Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 14/08/2020, à 07:52

Lek1

Re : Amule sur 20.04

abelthorne a écrit :

Ça, il faut voir du côté de tes fichiers de config. Est-ce que tu avais aMule installé précédemment et as toujours le dossier ~/.aMule ou c'est une nouvelle installation ? Si tu n'as rien, il faut aller dans Préférences → Serveurs, cliquer sur Liste et ajouter l'URL vers un server.met (ça se trouve assez facilement sur le web).

D'acc, c'est bon, trouver, merci.


"Ceux qui ne bougent pas ne sentent pas leurs chaînes." (Rosa Luxemburg)   
KDE Neon 18.04

Hors ligne

#52 Le 09/09/2020, à 19:55

Sfroumptch85

Re : Amule sur 20.04

abelthorne a écrit :

J'ai pu réinstaller amule en 20.04 sans devoir passer par le démon + amuleweb. J'ai téléchargé les paquets suivants en version eoan 64 bits sur packages.ubuntu.com :
- libwxgtk3.0-0v5
- amule-common (il est en all, pas amd64, c'est normal, ce sont juste des données)
- amule
puis les ai installés sans problèmes de dépendances particuliers :

sudo dpkg -i libwxgtk3.0-0v5_3.0.4+dfsg-12_amd64.deb
sudo dpkg -i amule-common_2.3.2-6_all.deb
sudo dpkg -i amule_2.3.2-6_amd64.deb
sudo apt-get install -f

Bonjour.
A priori, moi j'ai un problème de dépendances? une idée pour résoudre ça?

sudo dpkg -i libwxgtk3.0-0v5_3.0.4+dfsg-3_amd64.deb 
Sélection du paquet libwxgtk3.0-0v5:amd64 précédemment désélectionné.
(Lecture de la base de données... 177622 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libwxgtk3.0-0v5_3.0.4+dfsg-3_amd64.deb ...
Dépaquetage de libwxgtk3.0-0v5:amd64 (3.0.4+dfsg-3) ...
dpkg: des problèmes de dépendances empêchent la configuration de libwxgtk3.0-0v5:amd64 :
 libwxgtk3.0-0v5:amd64 dépend de libwxbase3.0-0v5 (>= 3.0.4+dfsg) ; cependant :
  Le paquet libwxbase3.0-0v5 n'est pas installé.

dpkg: erreur de traitement du paquet libwxgtk3.0-0v5:amd64 (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9) ...
Des erreurs ont été rencontrées pendant l'exécution :
 libwxgtk3.0-0v5:amd64

Hors ligne

#53 Le 09/09/2020, à 19:59

abelthorne

Re : Amule sur 20.04

Si tu fais un sudo apt-get install -f ça ne corrige pas le problème en installant libwxbase3.0-0v5 ?

Je ne l'avais pas précisé mais l'idée, c'est d'installer les trois paquets deb avec dpkg sans faire attention aux erreurs éventuelles, elles devraient être corrigées par la dernière commande.


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

En ligne

#54 Le 16/09/2020, à 19:43

Sfroumptch85

Re : Amule sur 20.04

Bonjour.
malheureusement, ça ne marche pas. les deb que j'ai trouvé sont pour bionic. je ne trouve pas ceux pour eoan

yohann@maison:~/Téléchargements$ sudo dpkg -i libwxgtk3.0-0v5_3.0.4+dfsg-3_amd64.deb 
[sudo] Mot de passe de yohann : 
(Lecture de la base de données... 183016 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de libwxgtk3.0-0v5_3.0.4+dfsg-3_amd64.deb ...
Dépaquetage de libwxgtk3.0-0v5:amd64 (3.0.4+dfsg-3) sur (3.0.4+dfsg-3) ...
Paramétrage de libwxgtk3.0-0v5:amd64 (3.0.4+dfsg-3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.31-0ubuntu9) ...
yohann@maison:~/Téléchargements$ sudo dpkg -i amule-common_2.3.2-2_all.deb 
(Lecture de la base de données... 183016 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de amule-common_2.3.2-2_all.deb ...
Dépaquetage de amule-common (1:2.3.2-2) sur (1:2.3.2-2) ...
Paramétrage de amule-common (1:2.3.2-2) ...
yohann@maison:~/Téléchargements$ sudo dpkg -i amule_2.3.2-2_amd64.deb 
Sélection du paquet amule précédemment désélectionné.
(Lecture de la base de données... 183016 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de amule_2.3.2-2_amd64.deb ...
Dépaquetage de amule (1:2.3.2-2) ...
dpkg: des problèmes de dépendances empêchent la configuration de amule :
 amule dépend de libboost-system1.65.1 ; cependant :
  Le paquet libboost-system1.65.1 n'est pas installé.
 amule dépend de libgeoip1 ; cependant :
  Le paquet libgeoip1 n'est pas installé.
 amule dépend de libupnp6 (>= 1:1.6.13) ; cependant :
  Le paquet libupnp6 n'est pas installé.

dpkg: erreur de traitement du paquet amule (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 amule
yohann@maison:~/Téléchargements$ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  amule
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 6561 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 183040 fichiers et répertoires déjà installés.)
Suppression de amule (1:2.3.2-2) ...
Traitement des actions différées (« triggers ») pour mime-support (3.64ubuntu1) ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.24-1ubuntu3) ...
yohann@maison:~/Téléchargements$ 

Dernière modification par Sfroumptch85 (Le 16/09/2020, à 19:44)

Hors ligne

#55 Le 16/09/2020, à 20:06

abelthorne

Re : Amule sur 20.04

Apparemment, les dépôts eoan (qui n'est plus supportée depuis juillet) ont fini par être supprimés de packages.ubuntu.com. Bizarrement, la distro n'est pas (encore ?) sur old-releases.ubuntu.com mais je ne crois pas qu'on puisse y télécharger des paquets manuellement de toute façon.

C'est peut-être possible de récupérer les paquets pour groovy (20.10) et de les installer en avance mais je n'ai pas essayé, je ne sais pas ce que ça donne au niveau des dépendances.

EDIT : c'est aussi peut-être possible d'installer libboost-system1.65.1 depuis les dépôts bionic pour installer la version bionic d'amule. Ça a l'air d'être la seule dépendance qui pose vraiment problème, elle n'a pas l'air d'avoir elle-même de dépendances trop spécifiques et les différentes versions de libboost ont l'air de pouvoir cohabiter. Mais là encore, je n'ai pas testé, c'est uniquement théorique.

EDIT 2 : je viens de faire un test de l'installation des paquets groovy sur une Xubuntu 20.04 en session live, r.à.s., ils s'installent et aMule se lance. Paquets installés (dans l'ordre) : libwxbase3.0-0v5, libwxgtk3.0-gtk3-0v5, amule-common, amule.
Reste à voir ce que ça donne sur une vraie installation avec beaucoup plus de paquets installés que sur une session live et des conflits potentiels. Si quelqu'un veut tester...

Dernière modification par abelthorne (Le 16/09/2020, à 23:40)


Installation de Steam (obsolète sauf 16.04) / Battle.net / Neverwinter Nights • Groupe Steam Ubuntu-fr : http://steamcommunity.com/groups/ubuntufr

En ligne