Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/09/2020, à 20:24

steph96

perte de connexion clé USB huawei

Bonjour,

je vous explique mon problème :
j'ai un ubuntu 20.04LTS serveur comme base pour faire fonctionner un homeassistant

j'ai acheté une clé USB HUAWEI E1552 pour la faire fonctionner avec gammu, dans le but d'envoyer des SMS avec home assistant
lorsque je branche ma clé USB
j'ai une détection de 3 ports /dev/ttyUSB0, /dev/ttyUSB1, /dev/ttyUSB2
>> pourquoi 3 ? je ne comprend pas trop la logique mais ce n'est pas le problème..
lorsque je la configure sur mon home assistant, dans le terminal, j'ai bien mes 3 ports USB virtuels et je peut configurer mon intégration SMS sur /dev/ttyUSB0
je fais un test et miracle, j'ai un SMS qui part (et en plus je le reçois)

je fais un 2e essai et la le message ne passe plus
après de nombreuses recherches je me suis rendu compte qu'en fait mon /dev/ttyUSB0 n'existait plus dans mon système hote ?
je me retrouve avec USB1, USB2 et USB3

si je fais un test direct a partir du gammu sur le système hote, j'ai exactement le même résultat
ce qui fait que je ne pense pas que cela vienne du home assistant mais bien de l'ubuntu hote

en fait, si je fais un dmesg, je me retrouve avec des 'reset' des ports USB aléatoires, une re-détection du matériel et réattribution des ports USB

[ 1964.682592] udevd[189]: starting version 3.2.9
[ 1964.692541] udevd[190]: starting eudev-3.2.9
[ 2201.620005] usb 1-6: USB disconnect, device number 5
[ 2201.623765] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 2201.624021] option 1-6:1.0: device disconnected
[ 2201.629592] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 2201.629837] option 1-6:1.1: device disconnected
[ 2201.631363] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[ 2201.631575] option 1-6:1.2: device disconnected
[ 2207.625058] usb 1-6: new high-speed USB device number 6 using ehci-pci
[ 2207.798488] usb 1-6: New USB device found, idVendor=12d1, idProduct=1001, bcdDevice= 0.00
[ 2207.798500] usb 1-6: New USB device strings: Mfr=2, Product=1, SerialNumber=3
[ 2207.798508] usb 1-6: Product: HUAWEI Mobile
[ 2207.798516] usb 1-6: Manufacturer: HUAWEI Technology
[ 2207.798524] usb 1-6: SerialNumber: 1234567890ABCDEF
[ 2207.804798] usb-storage 1-6:1.0: USB Mass Storage device detected
[ 2207.829362] option 1-6:1.0: GSM modem (1-port) converter detected
[ 2207.830505] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB0
[ 2207.831576] usb-storage 1-6:1.1: USB Mass Storage device detected
[ 2207.853299] option 1-6:1.1: GSM modem (1-port) converter detected
[ 2207.854148] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB2
[ 2207.854890] usb-storage 1-6:1.2: USB Mass Storage device detected
[ 2207.869376] option 1-6:1.2: GSM modem (1-port) converter detected
[ 2207.870503] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB3

voilà mon problème
comment forcer les ports USB pour au moins qu'ils gardent la même attribution après reset ?

une idée, une piste ?

Merci d'avance,
Stéphane

Hors ligne

#2 Le 14/09/2020, à 20:37

xubu1957

Re : perte de connexion clé USB huawei

Bonjour,

Ne faut-il pas se servir d'une commande :

sudo usb_modeswitch

?

> draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=216

> Clé wifi non reconnue par ubuntu 18.04lts [RESOLU]


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 14/09/2020, à 20:49

steph96

Re : perte de connexion clé USB huawei

d'après ce que tu m'envoi, c'est pour forcer la clé 'mass stroage' en 'modem'
mais ma clé est déjà bien détéctée en modem, j'ai bien mon pid à 1001

Bus 001 Device 006: ID 12d1:1001 Huawei Technologies Co., Ltd. E161/E169/E620/E800 HSDPA Modem

j'ai tenté le modeswitch mais semble sans effet...

Hors ligne

#4 Le 14/09/2020, à 21:29

xubu1957

Re : perte de connexion clé USB huawei


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 16/09/2020, à 06:50

steph96

Re : perte de connexion clé USB huawei

j'ai fait quelques manip en fonction des tutos,
j'ai bien cru que ça allait fonctionner,

j'ai tout redémarré et ça a fonctionné de 12h50 à 21h00
et la a nouveau plantage et déconnexion / reconnexion de ma clé USB
et encore changement d'attribution !

[78535.091615] udevd[189]: starting version 3.2.9
[78535.099386] udevd[190]: starting eudev-3.2.9
[78820.779367] udevd[189]: starting version 3.2.9
[78820.789866] udevd[190]: starting eudev-3.2.9
[79505.895602] usb 1-6: USB disconnect, device number 3
[79505.899417] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[79505.899797] option 1-6:1.0: device disconnected
[79505.906999] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[79505.907378] option 1-6:1.1: device disconnected
[79505.910458] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[79505.910616] option 1-6:1.2: device disconnected
[79511.398050] usb 1-6: new high-speed USB device number 5 using ehci-pci
[79511.567511] usb 1-6: New USB device found, idVendor=12d1, idProduct=1001, bcdDevice= 0.00
[79511.567523] usb 1-6: New USB device strings: Mfr=2, Product=1, SerialNumber=3
[79511.567531] usb 1-6: Product: HUAWEI Mobile
[79511.567539] usb 1-6: Manufacturer: HUAWEI Technology
[79511.567546] usb 1-6: SerialNumber: 1234567890ABCDEF
[79511.573592] usb-storage 1-6:1.0: USB Mass Storage device detected
[79511.590393] option 1-6:1.0: GSM modem (1-port) converter detected
[79511.591068] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB1
[79511.591723] usb-storage 1-6:1.1: USB Mass Storage device detected
[79511.614387] option 1-6:1.1: GSM modem (1-port) converter detected
[79511.615387] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB2
[79511.616340] usb-storage 1-6:1.2: USB Mass Storage device detected
[79511.646473] option 1-6:1.2: GSM modem (1-port) converter detected
[79511.647482] usb 1-6: GSM modem (1-port) converter now attached to ttyUSB3
[79511.648428] usb-storage 1-6:1.3: USB Mass Storage device detected
[79511.650903] scsi host4: usb-storage 1-6:1.3
[79511.652128] usb-storage 1-6:1.4: USB Mass Storage device detected
[79511.653957] scsi host5: usb-storage 1-6:1.4
[79512.674174] scsi 5:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
[79512.679132] scsi 4:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[79512.679866] sd 5:0:0:0: Attached scsi generic sg2 type 0
[79512.695965] sr 4:0:0:0: [sr0] scsi-1 drive
[79512.708254] sd 5:0:0:0: [sdc] Attached SCSI removable disk
[79512.720563] sr 4:0:0:0: Attached scsi CD-ROM sr0
[79512.722381] sr 4:0:0:0: Attached scsi generic sg3 type 5

dans le fil précédent, il n'y a pas vraiment de solution,
ça s'est mis a marcher sans trop savoir le pourquoi...
un peu comme j'ai eu hier !

Hors ligne

#6 Le 16/09/2020, à 07:25

xubu1957

Re : perte de connexion clé USB huawei

Bonjour,

Je lis :

Le 25/03/2020, Pilot6 a écrit :

Cela se produit avec certains modems et contrôleurs USB. Dans la plupart des cas, cela se produit parce que l'alimentation USB n'est pas suffisante pour un modem. Le problème n'est pas lié à Ubuntu. Cela se produit également sur Windows et Openwrt

dans > askubuntu.com/questions/1220027/problem-with-usb-modem


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 16/09/2020, à 20:48

steph96

Re : perte de connexion clé USB huawei

xubu1957 a écrit :

Bonjour,

Je lis :

Le 25/03/2020, Pilot6 a écrit :

Cela se produit avec certains modems et contrôleurs USB. Dans la plupart des cas, cela se produit parce que l'alimentation USB n'est pas suffisante pour un modem. Le problème n'est pas lié à Ubuntu. Cela se produit également sur Windows et Openwrt

dans > askubuntu.com/questions/1220027/problem-with-usb-modem

bonsoir,
il semble que mon problème soit effectivement lié a l'alimentation !
sur un port USB 'classique' j'ai un plantage après chaque SMS,
sur un port USB 'high current/fast charge' que j'ai sur ma carte mère, cela a tenu quelques heures sans plantage hier

depuis ce matin, j'ai essayé de mettre ma clé sur un hub USB 3.0 alimenté
et miracle, je n'ai pas eu de coupure depuis 9h ce matin, même en envoyant plein de SMS de test

alors je vais attendre quelques jours voir si tout est stable pour prononcer le 'miracle', mais c'est bien parti

mais je pense effectivement bien que ce soit tout bêtement un problème d'alimentation USB

alors je te remercie xubu1957 pour tes recherches et j'espère que ce post pourra servir a d'autres utilisateurs ...

Hors ligne

#8 Le 17/09/2020, à 20:20

steph96

Re : perte de connexion clé USB huawei

Bonsoir,

voilà les nouvelles,
un peu plus de 24h de fonctionnement parfait et ce soir à 17h,
encore planté !
alors comme il semble bien que ce soit l'alimentation,
je vais rester sur mon hub USB alimenté et je viens de changer l'alim d'origine par une 1,5A

la prochaine étape est de mettre en parallèle quelques condensateurs au plus proche de la clé USB pour avoir une réserve de courant lors des pics

Hors ligne

#9 Le 18/09/2020, à 18:24

steph96

Re : perte de connexion clé USB huawei

bien eh ben c'est raté
après 2 jours de pas trop mal,
j'en suis de nouveau a des plantages après quelques minutes avec toujours déconnexion, reconnexion et détection de nouveaux ports

n'est il pas possible de forcer les ports /dev/ttyUSB0 1 et 2 sur ma clé
pour que même si il y a déconnexion, elle se reconnecte toujours sur les même ?
j'utilise souvent des branchements USB émulant des com virtuels, ils se connectent toujours sur le même numéro

par exemple mon arduino est reconnu en /dev/ttyUSB0 sur mon PC, quand je débranche et rebranche, il est toujours sur le même !

Dernière modification par steph96 (Le 18/09/2020, à 18:33)

Hors ligne

#10 Le 18/09/2020, à 18:27

xubu1957

Re : perte de connexion clé USB huawei

Bonjour,

Montre :

lsusb | sort; echo; lsusb -t

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 18/09/2020, à 20:36

steph96

Re : perte de connexion clé USB huawei

voilà..
après reboot
avec ma bonne configuration

stephane@homeassistant:~$ lsusb | sort; echo; lsusb -t
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 004: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 005: ID 12d1:1001 Huawei Technologies Co., Ltd. E161/E169/E620/E800 HSDPA Modem
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0463:ffff MGE UPS Systems UPS
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 2, If 0, Class=Human Interface Device, Driver=usbfs, 1.5M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/8p, 480M
    |__ Port 5: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 4: Dev 5, If 0, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 5, If 1, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 5, If 2, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 5, If 3, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 4: Dev 5, If 4, Class=Mass Storage, Driver=usb-storage, 480M
    |__ Port 8: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M

Dernière modification par steph96 (Le 18/09/2020, à 20:37)

Hors ligne

#12 Le 18/09/2020, à 20:46

xubu1957

Re : perte de connexion clé USB huawei

Il faut des intervenants maîtrisant ce problème d'alimentation.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#13 Le 18/09/2020, à 20:51

steph96

Re : perte de connexion clé USB huawei

eh voilà après même pas 1/2h
planté encore !

stephane@homeassistant:~$ lsusb | sort; echo; lsusb -t
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 004: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 006: ID 12d1:1001 Huawei Technologies Co., Ltd. E161/E169/E620/E800 HSDPA Modem
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0463:ffff MGE UPS Systems UPS
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 2, If 0, Class=Human Interface Device, Driver=usbfs, 1.5M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/8p, 480M
    |__ Port 5: Dev 3, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 4: Dev 6, If 0, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 6, If 1, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 6, If 2, Class=Vendor Specific Class, Driver=option, 480M
        |__ Port 4: Dev 6, If 3, Class=Mass Storage, Driver=usb-storage, 480M
        |__ Port 4: Dev 6, If 4, Class=Mass Storage, Driver=usb-storage, 480M
    |__ Port 8: Dev 4, If 0, Class=Hub, Driver=hub/4p, 480M

tout a bien fonctionné pendant des heure depuis 2 jours et là plus rien !

Hors ligne

#14 Hier à 06:53

steph96

Re : perte de connexion clé USB huawei

bien,
rien de nouveau pour le moment mais il y a tout de même un phénomène qui m’interroge
> je branche ma clé, redémarre tout, elle fonctionne, elle est en USB0, 1, 2
> après quelques minutes ou heures, elle plante ! >> on va dire problème d'alimentation, elle est re-détectée en  USB1, 2, 3
> la, je la laisse branchée, sans rien toucher, et reviens après plusieurs jours, je refais un DMESG sur mon ordi >> rien de changé, pas de nouvelle coupure, pas de re-détection ?
> je change ma config homeassistant pour maintenant utiliser le ttyUSB1, la clé est détectée, je redémarre et la >> nouvelle coupure et re-détection
     elle est maintenant en USB0, 2 et 3 >> a chaque fois le port utilisé par homeassistant est mis de coté

alors c'est tout de même étonnant que les coupures, si elles sont au niveau de l'alimentation de la clé, ne soient qu'au moment où le homeassistant fait une lecture du niveau de signal

Hors ligne