Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 30/11/2008, à 21:23

Stemp

Webkit, Midori et Epiphany-webkit

L'équipe Webkit-team est heureuse de vous annoncer la sortie de la version 0.1.1 de midori et la version 38850 de Webkit disponible dans leur PPA.

16/03/2009 : WebKit v 1.1.3 disponible
23/03/2009 : Midori v 0.1.5 disponible dans le PPA Midori
29/03/2009 : Epiphany-webkit pour Jaunty est disponible
11/07/2009 : Epiphany-webkit disponible dans le PPA Epiphany Webkit

Pour ceux qui ne le savent pas encore, midori est un navigateur internet basé sur Webkit et est maintenant un projet officiel XFCE.

Amusez vous bien.

Liens :

Midori
WebKit
WebKitGtk+
Ubuntu webkit-team
Ubuntu Midori team
XFCE Midori en Français
XFCE Midori

Dernière modification par Stemp (Le 11/07/2009, à 16:58)


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#2 Le 01/12/2008, à 12:02

mavosaure

Re : Webkit, Midori et Epiphany-webkit

Question... j'ai installé y a quelques jours epiphany-webkit (rapide et léger mais pas fini) par les dépôts officiels...  (version2.24.1-0ubuntu1 pour Intrepid). J'ai vu que dans votre PPA il y avait aussi un epiphany-browser (2.22.3-1ubuntu2ppa1) et évidemment vous travaillez aussi avec Webkit... Quelles peuvent être les incidences?

M'enfin je pense que je vais tester tout à l'heure... un petit navigateur léger ça ferait pas de mal... surtout s'il est plus stable que les versions dispo d'epiphany-webkit ou kazehakaze...

PS : tu devrais ptet mettre un post sur le forum XFCE? tu aurais plus de chances de trouver des testeurs!

Dernière modification par mavosaure (Le 01/12/2008, à 12:03)


Xub'

Hors ligne

#3 Le 01/12/2008, à 12:06

spatz

Re : Webkit, Midori et Epiphany-webkit

Pas le temps en ce moment mais je testerai midori aux vacs de noël, je l'avait déjà testé auparavant mais je le trouvait beaucoup moins complet qu'epiphany ou kazehakase. Je suis toujours à la recherche d'un navigateur à la fois complet et léger pour mon vieux 700 Mhz, 256 Mo de RAM big_smile


PLOP ! Blogueur ! Râleur ! Agnostique ! Architecte ! Floodeur ! Gentil ! Chiant ! Fourbe ! Crâneur ! GNU/Windows/Linuxien ! Machiavélique ! Beau ! Républicain ! Intelligent ! Bosseur ! Très Prétentieux ! Scientifique ! Frimeur ! Étudiant !  De bonne foi ! Perverti ! Ubunteros ! Grand ! Sociable! Altruiste ! Provoc' ! Censé !

Hors ligne

#4 Le 01/12/2008, à 14:50

Stemp

Re : Webkit, Midori et Epiphany-webkit

@mavosaure : dans nos dépôts il s'agit d'une ancienne version pour Hardy donc ça n'a aucune incidence pour toi.
Pas bête pour le forum Xfce, mais je ne vais quand même pas spammer partout wink

@spatz : Midori a vraiment beaucoup changé, tu vas être surpris.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#5 Le 04/12/2008, à 22:29

MicheleP

Re : Webkit, Midori et Epiphany-webkit

Excellent c'est vraiment très très rapide !
C'est Midori qui fait ça ou Webkit ?

#6 Le 05/12/2008, à 00:04

Stemp

Re : Webkit, Midori et Epiphany-webkit

@MicheleP : Webkit est très rapide et midori est un navigateur très léger. Win-win ?

Dernière modification par Stemp (Le 05/12/2008, à 00:06)


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#7 Le 05/12/2008, à 11:07

mavosaure

Re : Webkit, Midori et Epiphany-webkit

Question pratique : si on veut rapporter des bugs,on fait ça où?
  * sur votre launchpad?
  * sur http://www.twotoasts.de/bugs/ ?

Et les problèmes de de traduction?
Aide > Adviser un problème... Robert, il connait pas adviser...


Xub'

Hors ligne

#8 Le 05/12/2008, à 14:13

Stemp

Re : Webkit, Midori et Epiphany-webkit

@Mavosaure : sur http://www.twotoasts.de/bugs/
Mais au lieu d'adviser le problème tu peux le corriger toi même et envoyer le patch lol


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#9 Le 05/12/2008, à 21:58

spatz

Re : Webkit, Midori et Epiphany-webkit

Je viens de l'installer et c'est vraiment une fusée, dès que je peux je l'installe sur mon vieux pc. big_smile


PLOP ! Blogueur ! Râleur ! Agnostique ! Architecte ! Floodeur ! Gentil ! Chiant ! Fourbe ! Crâneur ! GNU/Windows/Linuxien ! Machiavélique ! Beau ! Républicain ! Intelligent ! Bosseur ! Très Prétentieux ! Scientifique ! Frimeur ! Étudiant !  De bonne foi ! Perverti ! Ubunteros ! Grand ! Sociable! Altruiste ! Provoc' ! Censé !

Hors ligne

#10 Le 06/12/2008, à 00:08

helios91940

Re : Webkit, Midori et Epiphany-webkit

Mon avis est un peu plus mitigé...

Points positifs:
- démarrage très rapide
- passe le test acid3 à 100%

Points négatifs:
- Le moteur javascript est moins rapide que celui de Firefox (pourquoi ne pas intégrer V8 de chrome?)
- Certains chargements sont très longs en particulier quand plusieurs onglets sont ouverts
- Pas si léger que ca (89 mo pour un onglet)

Cependant Midori est encore en développement. Ca reste à mes yeux un projet très prometteur qui sera probablement une alternative à Firefox pour les petites config


There is no system but GNU, and Linux is one of its kernels.

Adhérez à l'APRIL!
http://www.april.org/adherer

Hors ligne

#11 Le 06/12/2008, à 13:06

Stemp

Re : Webkit, Midori et Epiphany-webkit

- Le moteur javascript est moins rapide que celui de Firefox (pourquoi ne pas intégrer V8 de chrome?)

Gné ?

Le moteur de javascript est au moins 2 fois plus rapide que celui de Firefox chez moi !

Test JavaScript SunSpider


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#12 Le 06/12/2008, à 13:43

helios91940

Re : Webkit, Midori et Epiphany-webkit

Stemp a écrit :

- Le moteur javascript est moins rapide que celui de Firefox (pourquoi ne pas intégrer V8 de chrome?)

Gné ?

Le moteur de javascript est au moins 2 fois plus rapide que celui de Firefox chez moi !

Test JavaScript SunSpider

Damned! Y a un problème chez moi alors hmm
Je verrai ca demain à tête reposée!

Dernière modification par helios91940 (Le 06/12/2008, à 13:44)


There is no system but GNU, and Linux is one of its kernels.

Adhérez à l'APRIL!
http://www.april.org/adherer

Hors ligne

#13 Le 06/12/2008, à 14:01

spatz

Re : Webkit, Midori et Epiphany-webkit

@Stemp :
1) Comment flash fonctionne sous Midori? Grâce à Firefox?
2) Comment configurer Midori comme avec about:config ou about:plugins dans firefox?
3) Peut modifier la variable USER AGENT sous Midori?
4) Pourquoi ne mémorise t'il pas la langue de google, par exemple sur google.fr en anglais chez moi?

Dernière modification par spatz (Le 06/12/2008, à 14:01)


PLOP ! Blogueur ! Râleur ! Agnostique ! Architecte ! Floodeur ! Gentil ! Chiant ! Fourbe ! Crâneur ! GNU/Windows/Linuxien ! Machiavélique ! Beau ! Républicain ! Intelligent ! Bosseur ! Très Prétentieux ! Scientifique ! Frimeur ! Étudiant !  De bonne foi ! Perverti ! Ubunteros ! Grand ! Sociable! Altruiste ! Provoc' ! Censé !

Hors ligne

#14 Le 06/12/2008, à 14:06

Stemp

Re : Webkit, Midori et Epiphany-webkit

1) il utilise effectivement le plugin mozilla
2) je ne crois pas que ce soit possible pour le moment
3) voir (3)
4) ça c'est étonnant, chez moi ça fonctionne.


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#15 Le 06/12/2008, à 14:10

spatz

Re : Webkit, Midori et Epiphany-webkit

Donc, on ne peut pas utiliser Midori sans Firefox ou équivalent d'installé. Que peut-on configurer dans Midori?


PLOP ! Blogueur ! Râleur ! Agnostique ! Architecte ! Floodeur ! Gentil ! Chiant ! Fourbe ! Crâneur ! GNU/Windows/Linuxien ! Machiavélique ! Beau ! Républicain ! Intelligent ! Bosseur ! Très Prétentieux ! Scientifique ! Frimeur ! Étudiant !  De bonne foi ! Perverti ! Ubunteros ! Grand ! Sociable! Altruiste ! Provoc' ! Censé !

Hors ligne

#16 Le 06/12/2008, à 15:04

Stemp

Re : Webkit, Midori et Epiphany-webkit

En fait je pense que tu peux installer le paquet flashplugin-nonfree sans firefox.

Pour le reste si tu cherches un gros navigateur, je te conseille de regarder plutôt en direction d'Epiphany-webkit.

N'oublions pas que midori n'est encore qu'en version 0.1.1 wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#17 Le 07/12/2008, à 19:34

DnS

Re : Webkit, Midori et Epiphany-webkit

Un des gros avantages de Midori , c'est lorsque Firefox à quelque peu du mal avec Flash : sous Midori je n'ai jamais de crash malgrè le fait qu'il utilise celui de Firefox ( bizarre non ? ^^ )


« Fais ce dernier pas en direction de la Force Obscure ! »

Hors ligne

#18 Le 18/12/2008, à 02:44

antistress

Re : Webkit, Midori et Epiphany-webkit

c'est tellement bien qu'on en veut tout de suite plus : la gestion des cookies et mots de passe, le classement de signets par étiquette...
je me demande si il y a ura à terme une fusion des projets midori/epiphany comme avec galeon car les deux sont très proches et les dev d'Epiphany ont toujours réclamé de l'aide...


Blogue : Libre et ouvert

Hors ligne

#19 Le 18/12/2008, à 02:49

antistress

Re : Webkit, Midori et Epiphany-webkit

et pour Java ?


Blogue : Libre et ouvert

Hors ligne

#20 Le 18/12/2008, à 10:44

mavosaure

Re : Webkit, Midori et Epiphany-webkit

Stemp a écrit :

- Le moteur javascript est moins rapide que celui de Firefox (pourquoi ne pas intégrer V8 de chrome?)

Gné ?

Le moteur de javascript est au moins 2 fois plus rapide que celui de Firefox chez moi !

Test JavaScript SunSpider

Je confirme ce que dit Stemp. Mais j'ai bien failli me planter en lisant les résultats comparer de Spider!:lol:

Par contre j'ai un problème à l'ouverture des pdf. Sous Firefox, j'utilise Mozzplugger 1.10.2 pour ouvrir le fichier à l'intérieur du navigateur, à l'aide de evince-gtk (suis sous Xub).

Sous Midori, il semble y avoir un soucis avec Mozzplugger : il charge l'interface d'evince mais n'arrive pas à ouvrir le fichier :  capture.

En lançant Midori dans un terminal, on a cet avertissement :

mav@mav-laptop:~$ midori
sh: acroread: not found

(midori:9411): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

note : le dernier avertissement est délivré à la fermeture de Midori. Pas d'avertissements pour Firefox.

De votre côté, pas de problème similaire?


Xub'

Hors ligne

#21 Le 18/12/2008, à 17:54

DnS

Re : Webkit, Midori et Epiphany-webkit

Je remonte ce topic car je viens de constater quelques choses avec mon site.

Webkit ( et donc Midori ) supporte les balises HTML 5 <video> et <audio> , malheureusement , malgré le tag " autoplay " , les vidéos ne démarrent pas.

Serait-ce dû à un non-support de OGG-Theora par Webkit ? ( apparemment c'est supporté mais les doc se réfèrent constamment aux MAC et donc à Quicktime )

Cette page est interressante http://webkit.org/blog/140/html5-media-support/


« Fais ce dernier pas en direction de la Force Obscure ! »

Hors ligne

#22 Le 20/12/2008, à 15:40

frenchy82

Re : Webkit, Midori et Epiphany-webkit

Bonjour,

Il faut reconnaitre que les videos flash (style youtube) sont beaucoup plus "regardables" avec midori sur mon viel ordi
Voila un projet a suivre de tres près smile

Hors ligne

#23 Le 02/01/2009, à 20:07

Кຼزດ

Re : Webkit, Midori et Epiphany-webkit

bon, je remonte le topic, parce que midori est quand même un navigateur qui promet pas mal wink
dommage que la version des dépôts soit autant obsolète roll


dou

Hors ligne

#24 Le 05/01/2009, à 01:03

antistress

Re : Webkit, Midori et Epiphany-webkit

par contre Swfdec + midori = plantage
(les deux en versions présentes dans les dépôts de Stemp)
vaut mieux utiliser le plugin flash non libre pour l'instant du point de vue stabilité


Blogue : Libre et ouvert

Hors ligne

#25 Le 06/01/2009, à 01:54

Stemp

Re : Webkit, Midori et Epiphany-webkit

@antistress : je présume que tu parles du swfdec des dépôts swfdec-team. C'est effectivement la version 0.9.2 instable. Il faudrait voir ce que ça donne avec la dernière version stable (0.8.4).


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

Haut de page ↑