Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 20/04/2005, à 14:02

Manu0086

Problème montage partition NTFS

Bonjour,

J'essaye de monter deux partitions NTFS.
Je les monte sans problème manuellement mais impossible d'accéder aux répertoires (que cela soit en root ou en tant qu'utilisateur) sad

"Impossible d'afficher le contenu de ce dossier."

Je les monte avec :

sudo mount /dev/sda5 /mnt/Divers -t ntfs -o umask=0222

Mes deux partitions NTFS se trouvent sur le même disque dur où se trouvent les deux partitions linux (ext3 et swap). De plus, il s'agit d'un disque dur SCSI.

Merci d'avance.

#2 Le 20/04/2005, à 15:28

Manu0086

Re : Problème montage partition NTFS

Oups petite rectification, il s'agit d'un disque dur SATA et non en SCSI...

#3 Le 20/04/2005, à 15:46

Stemp

Re : Problème montage partition NTFS

J'ai pas tout compris donc on recommence :

tu montes ta première partition en utilisant la commande : sudo mount /dev/sda5 /mnt/Divers -t ntfs -o umask=0222
tu montes ta deuxième comment ?

tu as bien créé les répertoires /mnt/Divers et /mnt/? (pour la 2ème) ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#4 Le 20/04/2005, à 16:53

Manu0086

Re : Problème montage partition NTFS

Pour la seconde partition, c'est biensûr la même ligne de commande (au nom près)

Oui les répertoires sont créés.

Bon pour simplifier, on peut dire qu'avec une seule partition car de toutes façons, je n'ai pas essayé la seconde.

Bref en allant sur /mnt/Divers, il me dit "Impossible d'afficher le contenu de ce dossier."

#5 Le 20/04/2005, à 20:45

Stemp

Re : Problème montage partition NTFS

Ooops j'avais pas vu ta réponse.

et en modifiant ton fichier /etc/fstab ?

/dev/sda5       /mnt/Divers      ntfs    umask=0222,nls=utf8      0       0


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#6 Le 20/04/2005, à 21:47

Manu0086

Re : Problème montage partition NTFS

C'est toujours pareil sad

Je commence à désespérer...

#7 Le 20/04/2005, à 22:00

Stemp

Re : Problème montage partition NTFS

Après la modification du fstab tu as bien executé la commande $ sudo mount -a  ou redémarré la machine ?


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#8 Le 20/04/2005, à 22:07

Manu0086

Re : Problème montage partition NTFS

Oui j'ai redémarré la machine.

Cette fois j'ai essayé de monter l'autre partition (en sd6), j'ai visualisé les dossiers à l'intérieur mais je ne pouvais rien faire d'autre, mon pc ramait un max, j'ai du remodifier le fstab sinon ça allait planter sous peu.

En passant sur le mode console, je pouvais y voir des erreurs et dans le fichier "messages des logs :

Apr 20 21:54:36 localhost kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Apr 20 21:54:36 localhost kernel: ata1: error=0x40 { UncorrectableError }
Apr 20 21:54:36 localhost kernel: SCSI error : <0 0 0 0> return code = 0x8000002
Apr 20 21:54:36 localhost kernel: Current sda: sense key Medium Error
Apr 20 21:54:36 localhost kernel: Additional sense: Unrecovered read error - auto reallocate failed
Apr 20 21:54:36 localhost kernel: end_request: I/O error, dev sda, sector 203721178

Un problème sur le disque dur visiblement sad

#9 Le 20/04/2005, à 22:28

Stemp

Re : Problème montage partition NTFS

Là je ne suis plus compétent, désolé, probablement un problème avec sata. Mais le bon côté des choses, c'est que ça a avancé smile

par contre essaie la commande : $ sudo fdisk -l
pour lister ta table de partition.
et : $ cat /proc/partitions


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#10 Le 20/04/2005, à 22:47

Manu0086

Re : Problème montage partition NTFS

Alors voici le détail pour y voir plus clair :

Disque /dev/sda: 160.0 Go, 160041885696 octets
255 têtes, 63 secteurs/piste, 19457 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        4589    36861111   83  Linux
/dev/sda2            4590       19456   119419177+   f  W95 Etendu (LBA)
/dev/sda5            5100       12278    57665286    7  HPFS/NTFS
/dev/sda6           12279       19456    57657253+   7  HPFS/NTFS
/dev/sda7            4590        5099     4096512   82  Linux swap / Solaris

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/hda: 30.7 Go, 30736613376 octets
255 têtes, 63 secteurs/piste, 3736 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/hda1   *           1        1275    10241406    c  W95 FAT32 (LBA)
/dev/hda2            1276        3736    19767982+   f  W95 Etendu (LBA)
/dev/hda5            1276        3736    19767951    b  W95 FAT32

et

major minor  #blocks  name

   8     0  156290904 sda
   8     1   36861111 sda1
   8     2          1 sda2
   8     5   57665286 sda5
   8     6   57657253 sda6
   8     7    4096512 sda7
   3     0   30016224 hda
   3     1   10241406 hda1
   3     2          1 hda2
   3     5   19767951 hda5
254     0   10241406 dm-0
254     1   19767951 dm-1
254     2   36861111 dm-2
254     3   57665286 dm-3
254     4   57657253 dm-4
254     5    4096512 dm-5

Si cela peut aider...

#11 Le 21/04/2005, à 15:33

Manu0086

Re : Problème montage partition NTFS

Up !

Haut de page ↑