Contenu | Rechercher | Menus

Annonce

Bientôt Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr dès maintenant

En cas de déconnexions intempestives, merci de vous connecter à partir de cette page en cochant la case « Me connecter automatiquement lors de mes prochaines visites ».

#1 Le 26/03/2006, à 13:30

MasterZ
Membre

Problème de compilation wxWdgets2.6.2

Bonjour,

Je n'e suis pas sûr que c'est la bonne section, mais je me lance :

J'ai un problème lorsque j'essaie de compiler wxWdgets2.6.2. Je dois le compiler à la main car j'ai besoin de le faire avec le GTK 1.2 afin de pouvoir compiler amule 2.1.1.

J'ai donc installé via synaptics :
libgtk1.2-dev
libgtk1.2
libgtk1.2-common
gcc 3.4

ensuite j'essaie ./configure sur les wxWdgets2.6.2 (j'ai testé différentes options :--with-gtk=1  ; --disable-gtk2 --with-gtk )
ce la se passe bien, mais j'obtiens cette erreur à chaque fois que je fais le make :

../src/generic/statusbr.cpp:325: internal compiler error: Segmentation fault
Please submit a full bug report,

a chaque fois que j'essaie, l'erreur survient sur des fichiers différents mais c'est toujours "internal compiler error: Segmentation fault" ...

J'ai essayé la compilation avec gcc 3.4 et gcc 4.0 ...

Quelqu'un peut-il m'aider ?
Merci,


MasterZ

Hors ligne

#2 Le 26/03/2006, à 17:45

thx1138
Membre

Re : Problème de compilation wxWdgets2.6.2

Si tu dis que ça arrive chaque fois sur un fichier différent, c'est peut-être dû au fait que tu fais de l'overclocking et qu'à un certain moment ton CPU chauffe trop, et Gcc perd les pédales.
Maintenant, ce n'est qu'une hypothèse ... Peut-être la mémoire aussi ...
Bref, c'est pas évident de trouver le problème.

PS : pourquoi vouloir compiler wxwidgets ? Il existe des paquets : http://packages.ubuntu.com/breezy/libs/libwxgtk2.6-0 et http://packages.ubuntu.com/dapper/libs/libwxgtk2.6-0


They did not know it was impossible, so they did it - Mark Twain

Hors ligne