Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 13/03/2006, à 15:00

LePoulpe303

[Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

Bonjour à tous,

J'ai essayé sans succès la plupart des tutos pour installer ma carte ati radeon 9600PRO.

Je bute sur un probleme qui ne vient peut etre pas des drivers , mais de la prise en charge de l'AGP ; j'ai essayé d'installer les drivers de NFORCE3 sans aucun résultat.

J'ai une carte mère ASUS (chipset NVIDIA)  avec un amd64 ; j'ai essayé les kernels i386 et k7 sans succès .

J'ai toujours les lignes suivantes dans dmesg :

...
[4294672.197000] NFORCE3-250: not 100% native mode: will probe irqs later
[4294672.197000] NFORCE3-250: BIOS didn't set cable bits correctly. Enabling workaround.
...
[4294694.061000] agpgart: Detected AGP bridge 0
[4294694.061000] agpgart: Setting up Nforce3 AGP.
---
[4294706.935000] [fglrx] Maximum main memory to use for locked dma buffers: 432 MBytes.
[4294706.935000] [fglrx:firegl_unlock] *ERROR* Process 7003 using kernel context 0

/var/log/xorg.0.log  contient lui :

(II) LoadModule: "fglrx"
...
(II) fglrx(0): AGP card detected
...
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): MonitorLayout is no longer supported.
(WW) fglrx(0): The hex number setting for DesktopSetup is deprecated,
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENODEV"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xe0c03000 at 0xb7b3b000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *

Donc si quelqu'un a quoi que ce soit à conseiller (excepté "achete une nvidia" ou "mets windows pour la 3d") je  suis preneur ; en desespoir je vais installer la version 64 bits d'ubuntu , mais sans conviction ....


Merci de votre attention

Dernière modification par LePoulpe303 (Le 23/03/2006, à 09:18)

Hors ligne

#2 Le 13/03/2006, à 17:13

milambert

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

essaye un peux de modifier le fichier "/etc/modules" en rajoutant "fglrx" avant les autres lignes non commentes.
Ca obligera le kernel 0 charger le module fglrx au démarage.

LePoulpe303 a écrit :

J'ai toujours les lignes suivantes dans dmesg :

...
[4294672.197000] NFORCE3-250: not 100% native mode: will probe irqs later
[4294672.197000] NFORCE3-250: BIOS didn't set cable bits correctly. Enabling workaround.
...

Pour ces lignes, c'est tout à fait normale, j'ai les avertissements anec une nforce2 (mb d'asus).


mouarf, ...

Hors ligne

#3 Le 13/03/2006, à 17:56

LePoulpe303

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

milambert a écrit :

essaye un peux de modifier le fichier "/etc/modules" en rajoutant "fglrx" avant les autres lignes non commentes.
Ca obligera le kernel 0 charger le module fglrx au démarage.

deja fait malheureusement :(

dans etc/modules j'ai


nvidia-agp
puis
fglrx


(j'ai egalement essayé   agpart + nvidia-agp + fglrx et bien sur agpart + fglrx)

Hors ligne

#4 Le 14/03/2006, à 11:30

milambert

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

peut etre une soulution en vue:

dans xorg.conf:
change l'option:

Option "UseInternalAGPGART"         "yes"

en

Option "UseInternalAGPGART"         "no"

vu ici:
http://www.redhat.com/archives/fedora-l … 05652.html

autre howto:
http://ubuntuforums.org/showthread.php? … fglrx+mtrr

peux tu poster ton xorg.conf?

Dernière modification par milambert (Le 14/03/2006, à 11:33)


mouarf, ...

Hors ligne

#5 Le 14/03/2006, à 11:55

LePoulpe303

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

J'ai essayé les 2 options sad

Hors ligne

#6 Le 14/03/2006, à 13:25

milambert

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

on veux bien ton xorg.cong.


mouarf, ...

Hors ligne

#7 Le 14/03/2006, à 13:30

LePoulpe303

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

le voili le voilou

(sachant que j'ai essayé des sections "device" plus simples sans plus de resultat)

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "Files"

        # paths to defoma fonts
    FontPath     "/usr/share/X11/fonts/misc"
    FontPath     "/usr/share/X11/fonts/cyrillic"
    FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath     "/usr/share/X11/fonts/Type1"
    FontPath     "/usr/share/X11/fonts/CID"
    FontPath     "/usr/share/X11/fonts/100dpi"
    FontPath     "/usr/share/X11/fonts/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
    Load  "GLcore"
    Load  "bitmap"
    Load  "ddc"
    Load  "dri"
#    Load    "extmod"
    SubSection "extmod"
        Option        "omit xfree86-dga"
    EndSubSection
    Load  "freetype"
    Load  "glx"
    Load  "int10"
    Load  "type1"
    Load  "vbe"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "fr"
    Option        "XkbVariant" "latin9"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
    Option        "CorePointer"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "ImPS/2"
    Option        "Emulate3Buttons" "true"
    Option        "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier   "L1915S"
    Option        "DPMS"
EndSection

Section "Device"
    Identifier  "ATI Technologies, Inc. Radeon 9600 (R300 AP)"
    Driver      "fglrx"
    VideoRam    262144
    # ### generic DRI settings ###
    # === disable PnP Monitor ===
    Option "NoDDC"
    Option "NoDDC1"
    Option "NoDDC2"
    # === disable/enable XAA/DRI ===
    Option "no_accel" "no"
    Option "no_dri" "no"
    # === misc DRI settings ===
    Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
    # ### FireGL DDX driver module specific settings ###
    # === Screen Management ===
    Option "DesktopSetup" "0x00000100"
    Option "MonitorLayout" "LVDS, AUTO"
    Option "IgnoreEDID" "false"
    Option "HSync2" "unspecified"
    Option "VRefresh2" "unspecified"
    Option "ScreenOverlap" "0"
    # === TV-out Management ===
    Option "NoTV" "yes"
    Option "TVStandard" "NTSC-M"
    Option "TVHSizeAdj" "0"
    Option "TVVSizeAdj" "0"
    Option "TVHPosAdj" "0"
    Option "TVVPosAdj" "0"
    Option "TVHStartAdj" "0"
    Option "TVColorAdj" "0"
    Option "GammaCorrectionI" "0x00000000"
    Option "GammaCorrectionII" "0x00000000"
    # === OpenGL specific profiles/settings ===
    Option "Capabilities" "0x00000000"
    # === Video Overlay for the Xv extension ===
    Option "VideoOverlay" "on"
    # === OpenGL Overlay ===
    # Note: When OpenGL Overlay is enabled, Video Overlay
    # will be disabled automatically
    Option "OpenGLOverlay" "off"
    # === Center Mode (Laptops only) ===
    Option "CenterMode" "on"
    # === Pseudo Color Visuals (8-bit visuals) ===
    Option "PseudoColorVisuals" "off"
    # === QBS Management ===
    Option "Stereo" "off"
    Option "StereoSyncEnable" "1"
    # === FSAA Management ===
    Option "FSAAEnable" "Yes"
    Option "FSAAScale" "1"
    Option "FSAADisableGamma" "no"
    Option "FSAACustomizeMSPos" "no"
    Option "FSAAMSPosX0" "0.000000"
    Option "FSAAMSPosY0" "0.000000"
    Option "FSAAMSPosX1" "0.000000"
    Option "FSAAMSPosY1" "0.000000"
    Option "FSAAMSPosX2" "0.000000"
    Option "FSAAMSPosY2" "0.000000"
    Option "FSAAMSPosX3" "0.000000"
    Option "FSAAMSPosY3" "0.000000"
    Option "FSAAMSPosX4" "0.000000"
    Option "FSAAMSPosY4" "0.000000"
    Option "FSAAMSPosX5" "0.000000"
    Option "FSAAMSPosY5" "0.000000"
    # === Misc Options ===
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "UseInternalAGPGART" "no"
    Option "ForceGenericCPU" "no"
    Option "KernelModuleParm" "agplock=0" # AGP locked user pages: disabled
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Device     "ATI Technologies, Inc. Radeon 9600 (R300 AP)"
    Monitor    "L1915S"
    DefaultDepth     24
    SubSection "Display"
        Depth     1
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     4
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     8
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     15
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     16
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "DRI"
    Mode         0666
EndSection

Dernière modification par LePoulpe303 (Le 14/03/2006, à 13:31)

Hors ligne

#8 Le 17/03/2006, à 19:27

milambert

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

J'ai trouver un lien qui donne une solution au probleme:
http://www.rage3d.com/board/showpost.ph … stcount=18

Ce probleme à été reporter sur le Launchpad: https://launchpad.net/distros/ubuntu/+s … +bug/24640


mouarf, ...

Hors ligne

#9 Le 17/03/2006, à 20:49

LePoulpe303

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

c'etait bien vu , malheureusement Saelynh sur irc m'avait deja signalé ca et mon MTRR est correct sad

merci en tout cas d'y avoir  pensé


Actuellement jeme tate a installer une version plus recente du kernel (je me sens pas vraiment les comptences mais j'ai pas le choix)

Hors ligne

#10 Le 17/03/2006, à 22:19

fabnorris

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

Je compatis, même carte, même combat ... sad

Hors ligne

#11 Le 22/03/2006, à 21:16

butnuu74

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

idem, dans le même cas
j'osais pas imaginer que ça puisse être si chaud sur ubuntu pour faire tourner une config assez standard big_smile

#12 Le 23/03/2006, à 09:18

LePoulpe303

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

bon les gars ,

apres avoir essayé dapper , sans plus de succès j'ai abandonné. (3 semaines rien que sur ca ca commence a faire long)


J'ai tout formaté et réinstallé w.nd.ws. J'installerai un ubuntu 64 en dual boot pour le fun.

Fin de l'aventure

Hors ligne

#13 Le 28/03/2006, à 18:56

buzz_l_eclair

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

Dans la release note d'ATI (drivers 8.23.7)

X Fails to Load on Systems with Linux Kernel Version 2.6.x

This information applies to the following system configurations:

    * Linux kernel version 2.6.x
    * Any ATI Linux driver 

A blank screen may appear momentarily when X starts to load. The following error message (or similar) may appear on the text console or in /var/log/XFree86.0.log:
(EE) fglrx(0): [agp] unable to acquire AGP, error ""xf86_ENODEV""xf86_ENODEV""

This is not a problem with the display driver.

Version 2.6 kernels require a second kernel module in addition to agpgart, which should be named similar to the manufacturer of your motherboard AGP chipset. This error message should occur if the other agp module is not loaded.

This issue can be worked around as follows:

   1. First make sure that agpgart is loading properly.
   2. To find out which AGP controller your motherboard uses, issue the following command: lspci | grep AGP
   3. To find a list of AGP related kernel modules installed on your machine, issue the following command and look for a module (*.ko file) that suits your AGP Controller: ls /lib/modules/`uname -r`/kernel/drivers/char/agp
   4. Use the modprobe command (as root) to load the module. For example: On a motherboard using a VIA® AGP Controller, you would load the via-agp.ko using modprobe as follows (notice that the trailing.ko is omitted): modprobe via-agp

Check the modprobe manpage for more information on loading kernel modules.

   5. To verify that the AGP module is already loaded, run lsmod as root. With the X server running and the connection established, the usage count of this module must be greater than zero. 

If you cannot find a suitable agp module for your motherboard, then you may want to upgrade to the latest version of the Linux kernel, or check your motherboard manufacturer's website for more information.

Hors ligne

#14 Le 28/03/2006, à 23:18

butnuu74

Re : [Abandonné] NFORCE 3 + amd64 + ATI Radeon 9600 PRO

humm... peut-être une issue pour notre problème
je revois ça demain car j'ai remis les drivers fglrx
enfin les modules, je les ai déjà il semblerait:

$ lsmod
agpgart                36784  2 nvidia_agp,amd64_agp

mad

Haut de page ↑