Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 13/03/2009, à 00:22

Ulver

Impossible de trouver le programme de lancement automatique

Bonsoir tout le monde !

Voila mon problème :
J'essaie de lancer le médiacenter neuf/SFR. Pour se faire, je dois lancer le programme en faisant un double-clic sur l'icône, je crois que jusqu'ici, tout le monde me suit.:o
Au lieu de me lancer le programme dans un terminal comme il avait l'habitude de le faire (j'ai déjà fait tourner ce programme avant de me taper une réinstallation complète du système), il m'ouvre le fichier dans un éditeur de texte.
Bon, qu'à cela ne tienne, je fais un clic droit sur l'icône et je lui dit de l'ouvrir avec l'invite d'exécution automatique.
Et là il me répond cette phrase énigmatique "Impossible de trouver le programme de lancement automatique.
Je précise qu'il me fait le même coup avec d'autres logiciels, comme Walldyn par exemple, qui fonctionnait très bien auparavant.
Je ne sais pas trop où chercher pour résoudre ce petit problème. Je peux juste rajouter que ces logiciels sont sur un disque dur interne différent du disque dur où est installé le système.

Voilà, merci à celui (ceux ?) qui voudront bien me donner un petit coup de main ! wink


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#2 Le 13/03/2009, à 00:38

szbab

Re : Impossible de trouver le programme de lancement automatique


les thèmes deBisigi

Hors ligne

#3 Le 13/03/2009, à 00:44

Ulver

Re : Impossible de trouver le programme de lancement automatique

Merci pour ton lien mais je l'avais déjà trouvé.
J'ai déjà installé tout ce qui est pré-requis, je sais comment leur mediacenter fonctionne, ça fait un peu plus d'un an que je l'utilise.
D'ailleurs, même si je n'avais pas installé apache, php5 et perl il pourrait tout de même me lancer le logiciel dans un terminal en me donnant des erreurs, ce qu'il ne fait absolument pas.:(


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#4 Le 13/03/2009, à 00:51

szbab

Re : Impossible de trouver le programme de lancement automatique

fait cd dans un terminal
puis glisse le dossier media dans le terminal pour lui donner le chemin fait entrée
tu doit te retrouver avec quelque chose comme ça
szbab@pcubuntu:~/mediacenter$
apres la commande

./mediacenter start

Dernière modification par szbab (Le 13/03/2009, à 00:52)


les thèmes deBisigi

Hors ligne

#5 Le 13/03/2009, à 02:16

Ulver

Re : Impossible de trouver le programme de lancement automatique

Merci pour ta réponse.
Je connaissais pas cette technique de faire glisser un répertoire pour avoir le chemin d'accès c'est super pratique, j'aurai appris un truc aujourd'hui !
Bon j'ai tenté ce que tu m'as dis, voici la réponse :
bash: ./mediacenter : /bin/bash : mauvais interpréteur: Permission non accordée
Ça te parle ?


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#6 Le 13/03/2009, à 11:55

szbab

Re : Impossible de trouver le programme de lancement automatique

tu as fait un espace entre les 2 ?
szbab@pcubuntu:~/mediacenter$ ./mediacenter start


les thèmes deBisigi

Hors ligne

#7 Le 13/03/2009, à 12:14

Ulver

Re : Impossible de trouver le programme de lancement automatique

Non non, pas du tout neutral


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#8 Le 14/03/2009, à 13:10

Ulver

Re : Impossible de trouver le programme de lancement automatique

Alors, je viens de faire un petit test :
Si je décompresse l'archive du mediacenter dans mon dossier home, et que je le lance en faisant un double clic sur l'icône, ça marche.
Ça doit donc venir de mon disque dur. Un problème de droit peut-être ?
Au cas où le problème viendrait de là, voici mon fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc    /proc    proc    defaults    0    0
#Entry for /dev/sda1 :
UUID=1491e990-154c-4d35-8ccf-f85363587055    /    ext3    relatime,errors=remount-ro    0    1
#Entry for /dev/sdb1 :
UUID=4785-10EF    /media/sdb1    vfat    rw,user,auto,utf8,umask=000,uid=1000,gid=1000    0    2
#Entry for /dev/sda5 :
UUID=0525c432-e0c2-46f2-aed6-0a68411153cd    none    swap    sw    0    0
/dev/scd0    /media/cdrom0    udf,iso9660    user,noauto,exec,utf8    0    0

Encore merci à ceux qui passent par là et qui ont une petite idée de ce qui se passe. smile


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#9 Le 14/03/2009, à 14:15

Sanael

Re : Impossible de trouver le programme de lancement automatique

Coucou.

S'il s'agit d'un problème de droit, donne nous le résultat de :

ls -l mediacenter

Pour celui que tu décompresses dans home, et celui que tu as décompressé ailleurs et qui ne marchait pas.


Muad'Dib il a les yeux bleus,
Les yeux bleus Muad'Dib il a.

Hors ligne

#10 Le 14/03/2009, à 14:20

Ulver

Re : Impossible de trouver le programme de lancement automatique

Merci de ton aide smile
Voici le résultat de la commande :

-rwxrwxrwx 1 david david 5060 2007-12-05 18:49 mediacenter

Edit : j'avais pas vu tout ton post désolé !
Donc pour celui qui ne fonctionne pas c'est celui que je viens de poster.
Pour celui qui fonctionne et qui est dans mon /home :

-rwxrwxr-x 1 david david 5060 2007-12-05 17:49 mediacenter

Dernière modification par Ulver (Le 14/03/2009, à 14:24)


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#11 Le 14/03/2009, à 14:49

Sanael

Re : Impossible de trouver le programme de lancement automatique

Ca vient pas de là, donc.

Bon, j'ai pas tout compris à ton problème, donc je vais essayer d'éclaircir.
Si tu lances le premier avec bash ou en double cliquant, ça veut pas.
Si tu lances le second avec bash : ça veut bien.
Si tu lances le second directement : ça veut bien. (ça ouvre un terminal ?)

C'est bien ça ?
Donc même si le problème n'a pas été élucidé, tu peux faire fonctionner le mediacenter correctement ?

Le souci ne vient pas du fait que tu ne peux pas le faire fonctionner en mode root et que, en voulant l'installer dans un répertoire système, tu l'as installé avec sudo ?


Muad'Dib il a les yeux bleus,
Les yeux bleus Muad'Dib il a.

Hors ligne

#12 Le 14/03/2009, à 15:07

Ulver

Re : Impossible de trouver le programme de lancement automatique

Alors attends, je récapitule, en essayant d'être clair.

Le mediacenter que j'essaie de faire fonctionner est sur mon deuxième disque dur. Quand je double clique sur l'icône, il m'ouvre le programme dans un éditeur de texte et quand j'essaie de le forcer à l'ouvrir avec l'invite de commande automatique, c'est là que j'ai le message "Impossible de trouver le programme de lancement automatique". Pourtant je ne l'ai pas installé en sudo.

Le second mediacenter que j'ai installé, je l'ai installé dans /home pour faire un test. Là, en double cliquant sur l'icône il se lance normalement dans un terminal. Donc celui-là fonctionne sans problème.

Entre temps, j'ai fait un autre test : j'ai décompressé l'archive du mediacenter de nouveau sur mon deuxième disque dur, à côté du premier, de la même façon que je l'avais fait dans le répertoire /home. Là aussi, il refuse de se lancer.

Donc il ressort que seul celui qui est installé dans le répertoire /home fonctionne. Les deux autres installé - de la même façon - sur mon deuxième disque dur, ne se lancent pas.

Alors, oui, le problème n'est pas élucidé, mais je peux utiliser mon mediacenter. Cela dit, j'aurai bien aimé comprendre le schmilblick wink

J'espère que c'est un peu plus clair smile

Cela dit, tu me dis que ce n'est pas un problème de droit, mais je vois qu'il y a une différence entre les deux réponses à la commande ls -l. Ça ne peut pas venir de là ? Je dis ça, je dis rien, hein... C'est la première fois que j'utilise cette commande hmm


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

#13 Le 14/03/2009, à 15:45

Sanael

Re : Impossible de trouver le programme de lancement automatique

Ah, je commence par t'expliquer ce qui est intéressant dans le résultat des commandes que je t'ai demandé.
D'abord, le "david" pour les deux fichiers montre que c'est bien david le propriétaire, pas de changement.
Ensuite, r signifie read, w signifie write, et x signifie execute.
Ils sont énumérés trois fois car les autorisations sont différentes pour le propriétaire, son groupe, et les autres.
On a donc :
Le propriétaire : lecture, écriture, execution
Les autres membres de son groupe : lecture, écriture, execution
Les autres utilisateurs (celui qui ne fonctionne pas) : lecture, écriture, execution
Les autres utilisateurs (celui qui fonctionne) : lecture, execution
Le problème ne vient donc pas de là, puisque tu es le propriétaire des fichiers et que tu as tous les droits.

Bon, alors le problème vient peut-être seulement d'un souci d'interface.
Essaie de renommer mediacenter en mediacenter.sh, qu'ubuntu le reconnaisse en script bash.
Si ça ne fonctionne pas, essaie de ne donner au fichier qui s'ouvre en mode lecture le droit d'execution uniquement :

sudo chmod 400 mediacenter

Muad'Dib il a les yeux bleus,
Les yeux bleus Muad'Dib il a.

Hors ligne

#14 Le 14/03/2009, à 15:59

Ulver

Re : Impossible de trouver le programme de lancement automatique

Merci d'avoir éclairé ma lanterne en décryptant la réponse de la commande ls -l !
Alors j'ai tenté ta manip' et le résultat est le même. J'ai renommé mediacenter en mediacenter.sh, toujours la même réponse de la part d'ubuntu : Impossible de trouver le programme de lancement automatique.
J'ai changé les droits du fichier, mais rien à faire, toujours la même erreur...:/
J'espère que tu es plein de ressource smile


Config : Ubuntu 9.10 64 bits
Mon site pro
Mon profil lastfm

Hors ligne

Haut de page ↑