Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 16/03/2009, à 18:36

Djinn008

Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

Bonjour tout le monde.

J'ai cherché un peu partout, mais je n'ai rien trouvé (entre autre car je ne sais pas trop sous quel mots faire ma recherche)
Je dois précisé que je suis débutant avec Linux (surtout à cause du fait que ce bug m'encourage à Booter sur Windows)

Ma Config:
Proc: Intel core 2 Quad Q6600
CM: ASUS P5K-E
CG: GForce 8600GT
RAM: 4Go Corsaire TWINTurbo (je crois)
Version d'Ubuntu: 8.10 64Bits
Version Gnome: 2.24.1

Problème (Pour faire simple):
Après un certain temps d'utilisation (5min - 20min) GNOME se fige!
Il m'est impossible de cliquer sur les menus du tableau de bord, mais étrangement, je peux toujours avoir accès au moniteur système que j'ai mis sur le tableau de bord.

Lorsque ce bug apparaît, je peux voir que dans la partie ressource de mon moniteur système mes processeurs s'affolent et ma RAM est utilisée à 70%
On peut d'ailleurs voir que c'est gnome-panel qui utilise toutes ces ressources.


J'avais déjà le même genre de problème avec une version antérieure d'Ubuntu, c'est pourquoi j'ai formaté, mais j'ai toujours le même problème avec ma version actuelle


Merci d'avance pour votre aide.

Dernière modification par Djinn008 (Le 16/03/2009, à 22:03)

Hors ligne

#2 Le 16/03/2009, à 21:07

brakbabord

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

A mon avis c'est un bug qui vient de la carte graphique. Comment as-tu installé les pilote? Via les dépôts?

Hors ligne

#3 Le 16/03/2009, à 21:11

Tom_L

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

Salut,

Si tu as accès au moniteur système, tu dois pouvoir jeter un oeil sur les processus et nous dire lequel prend toute la ram et le CPU.

Ca nous aiderai beaucoup à localiser le problème...


~~~~~~
Thomas.

Hors ligne

#4 Le 16/03/2009, à 22:02

Djinn008

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

Tom_L a écrit :

lequel prend toute la ram et le CPU.

C'est gnome-panel (voilà pourquoi j'incrimine GNOME)

Je vais éditer mon premier message pour le préciser!


Pour ce qui est de la carte graphique, je ne me souviens plus ce que j'ai fait la première fois, mais cette fois-ci, une infobulle est apparue sur le tableau de bord me disant que j'aurais de meilleurs résultats en utilisant les pilotes Nvidia
(désolé si je ne peux pas répondre plus précisément, en tout cas, je n'ai pas ouvert volontairement synaptique pour télécharger les drivers)

Hors ligne

#5 Le 16/03/2009, à 22:10

brakbabord

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

Oui donc ce sont les pilotes des dépôts. Ceux de Ubuntu 8.10 sont pourtant très bons.

Le Gnome-panel sont les barres en haut et en bas de ton bureau. Peut-être que tu y as mis trop de gadgets ou un truc qui bug?

Hors ligne

#6 Le 16/03/2009, à 22:17

Tom_L

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

En faisant une petite recherche je suis tombé la dessus (en anglais) :
http://muzso.hu/2009/02/27/gnome-panel-eating-up-cpu

En gros, le gars dit qu'en rajoutant une ligne pour tuer les processus pendant le démarrage résout le problème...
Tu peux peut-être essayer chez toi voir ce que ça donne.

Voilà la procédure à faire dans un terminal si tu veux essayer :
Pour sauvegarder ton fichier crontab :

sudo cp /etc/crontab /etc/crontab_bak

Pour editer le fichier :

sudo gedit /etc/crontab

Rajouter la ligne :

*/2 * * * * root pkill -P 1 gnome-panel

Sauvegarder, quitter et redemarrer...

S'il y a un soucis quelconque, pour restaurer le fichier d'origine :

sudo cp /etc/crontab_bak /etc/crontab

Dernière modification par Tom_L (Le 16/03/2009, à 22:19)


~~~~~~
Thomas.

Hors ligne

#7 Le 16/03/2009, à 23:39

Djinn008

Re : Plantage de GNOME (utilise 70% de ma RAM et 100% d'un CPU)

brakbabord a écrit :

Peut-être que tu y as mis trop de gadgets ou un truc qui bug?

Je n'ai rien ajouté mis à part un raccourcis pour un terminal et le moniteur. J'ai aussi déplacer la barre du bas sur la droite de l'écran (je ne vois pas pk ça ferait planter)



@Tom_L
J'ai été lire le site que tu indiques et je ne comprends pas très bien ce qu'il veut dire par processus rémanent.
Comment est-ce qu'il pourrait y avoir deux instances de gnome-panel active en même temps?
De plus, je ne comprends pas ce qu'il y a à tuer...


Mais je viens en effet de voir que j'ai le bug indiqué par le deuxième lien: https://bugs.launchpad.net/ubuntu/+sour … bug/187540

Gnome freeze quand j'ai 7-8 fenêtres ouvertes


C'est étrange que le bug ne soit pas un peu plus renseigné car apparemment il est systématique...
Je vais donc remettre ma barre en bas

(à moins que qq'un puisse m'expliquer comment appliqué le patch renseigné ici ... ... Merci d'avance ^^

Dernière modification par Djinn008 (Le 16/03/2009, à 23:40)

Hors ligne

Haut de page ↑