Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 14/04/2005, à 18:21

nemios

Ça rame grave !!!!

Salut!

J'osais pas trop poster pour ça mais je trouve ce problème de plus en plus bizarre: j'ai en effet remarqué que mon pc ramait un max; par exemple, si je suis en train de graver et que j'ouvre l'explorateur de fichiers, faut au moins attendre 10 secondes avant que ça s'ouvre effectivement. De même, si j'ai une ou deux applications qui marchent et que j'en ouvre une troisième, faut encore attendre.
Le plus étonnant est que maintenant, alors que je suis en train de taper ce post et que je n'ai ouvert aucune autre application, mon moniteur système m'indique que 100% du CPU est utilisé! hmm
Il me semble que c'est beaucoup... Dans les processus j'ai ceci:

gam_server utilise 89 % CPU
gnome-system-monitor utilise 7% CPU
firefox-bin utilise 3% CPU
wnck-applet utilise 1% CPU

Donc c'est ce "gam_server" qui pompe toutes les ressources... Mais à quoi sert-il et est-ce bien normal? Si oui, tant pis mais bon, mon pc a moins d'1 an donc bizarre qu'il rame et si non, que faire? J'ai dû sûrement louper un truc à configurer... hmm

Quelqu'un pourrait m'aider? roll

Hors ligne

#2 Le 14/04/2005, à 20:08

tigrou

Re : Ça rame grave !!!!

gam_server est un processus systeme charger de vérifier les changements sur le disque. C'est un remplacement à famd. ensuite pour qu'il prenne autant de ressources, soit des programmes sont en train de modifier des fichiers, soit c'est un bug.

Hors ligne

#3 Le 15/04/2005, à 14:24

nemios

Re : Ça rame grave !!!!

Hum... voilà qui n'est pas très réjouissant... Je vais essayer de m'y pencher un peu plus.
Merci pour l'info Tigrou.

Hors ligne

#4 Le 15/04/2005, à 17:16

Julian

Re : Ça rame grave !!!!

Parfois chez moi aussi (pas gam_server) y a un processus qui se met en branle, je sais pas pourquoi.

Ca me dérange pas plus que ça, puisque c'est très rare, et un coup de "tuer le processus" via le moniteur systeme et la machine reprend son calme.

Est-ce qu'en ayant fais ça, tout retourne correctement auquel cas c'est pas bien grave.

Maintenant si ça recommence à chaque fois je peux pas t'aider plus que ça wink


julian@jabber.fr

Hors ligne

#5 Le 16/04/2005, à 15:34

nemios

Re : Ça rame grave !!!!

Hum... hmm Tuer le processus...

Ça me paraît tout de même un peu dangereux si Gam est en train de manipuler des données sensibles. Je sais pas si ça risque pas de me bousiller une partie des mes données, du système d'exploitation ou même du disque dur. Si Gam est une sorte de Scandisk comme le dit Tirgou je préfère pas essayé. J'ai un copain qui a vu son disque dur griller (littéralement) lorsque son PC avait été débranché alors qu'il faisait un Scandisk.

Hors ligne

#6 Le 16/04/2005, à 16:02

Julian

Re : Ça rame grave !!!!

Mais dis moi nemios ça fais  bientôt 48h que tu as créé ton post, et ton pc est toujours en train de ramer yikes tongue oui / non...

T'as essayé de faire quelque chose?
Ca se remet à chaque boot?
Raconte nous ce qui se passe.

Perso, entre voir ma machine dans la rouge et chauffée pendant un long moment,et faire un terminer/tuer processus, pour moi y a pas photo.

Dernière modification par Julian (Le 16/04/2005, à 16:03)


julian@jabber.fr

Hors ligne

#7 Le 16/04/2005, à 16:33

tigrou

Re : Ça rame grave !!!!

gam_server n'est pas un scandisk, c'est un programme qui surveille les changements qui interviennent sur le disque dur pour en informer nautilus par exemple quand il affiche le répertoire en question.

à mon avis tu risques pas grand chose à le tuer au pire tu ne verras pas les changements en "temps réel" dans nautilus.

Hors ligne

#8 Le 18/04/2005, à 09:46

nemios

Re : Ça rame grave !!!!

Après une brève rencontre avec un utilisateur de Debian chevronné, qui a jetté un oeil à ma machine, il semblerait que ce soit dû non pas à gam_server mais plutôt que se soit lié à la carte vidéo.
Pour constater le bug je lui ai montré que, par exemple, le déplacement d'un bureau à l'autre pouvait parfois prendre plusieurs secondes avant que le nouveau bureau ne s'affiche.
hmm

Hors ligne

#9 Le 18/04/2005, à 10:26

Julian

Re : Ça rame grave !!!!

Ce que je pige pas, c'est que tu dis que gam_server prend 89% cpu et maintenant il est revenu à la normal ou pas. Qu'as tu essayer de faire?

Si tu mets "moniteur systeme" dans ta barre du bureau, il t'indique combien et à quel moment?
Qu'est ce qu'il te fait dire que c'est la carte vidéo, explique nous, histoire d'en apprendre un peu plus.

Dernière modification par Julian (Le 18/04/2005, à 10:28)


julian@jabber.fr

Hors ligne

#10 Le 18/04/2005, à 13:35

nemios

Re : Ça rame grave !!!!

C'est vrai que je suis un peu confus...

Gam_server prennait 89% du CPU quand j'en ai commencé à en avoir vraiment marre des ralentissements. En ouvrant le "moniteur système" j'ai donc constaté cela et ai cru que c'était gam_server le coupable. J'ai alors envoyé un post ici parce que je voulais pas toucher à des trucs qui me dépassent et préférais avoir votre avis.

Puis, hier soir, chez un ami, il y avait ce type, qui est un pro de la Debian, c'est lui qui m'a convaincu de me mettre à Linux et m'a conseillé Ubuntu... Le problème c'est que comme il est super calé, tout le monde le harcèle un peu en lui demandant des conseils, de résoudre les problèmes, etc.
Donc, en rusant, j'ai réussi à lui faire jetter un oeil sur Hoary, installée sur mon pc portable (que j'avais amené là à tout hazard). Il regarde, effectue des manips que j'ai pas compris et me dit:
"mais non ça rame pas, regarde, ton CPU n'est exploité qu'a 36%"
- ok, mais en passant d'un bureau à l'autre, ça rame, tu vois? et en bougeant la fenêtre, l'affichage est pas fluide, y'a des ralentissements...
- hum c'est vrai c'est pas normal, c'est sûrement la carte vidéo. Ton pc est vieux?
- non, je l'ai acheté cet été, c'est un Vaio PCG K115B, et en plus il a une ATI Radeon avec 128 Mo de mémoire partagée et 512 Mo de Mémoire vive...
Suite à ça remanip en console, je comprends qu'il vérifie des trucs, mais lequels ? Bref, après quelques vérifs donc, il est catégorique: "c'est pas lié à gam, mais à la carte vidéo"

Bon, suite à ça j'essaye d'en savoir un peu plus, regards lourds de l'assitance, pas disposée à entendre encore parler un jargon aussi incompréhensible... j'abandonne. De toutes façon, mon expert est fatigué, il doit rentrer et je comprends qu'il faut me débrouiller par mes propres moyens lorsqu'il me dit: "essaye de voir avec les gars d'Ubuntu, ils doivent savoir..."

Bref, me voilà encore moins avancé qu'avant ! sad

Hors ligne

#11 Le 20/04/2005, à 02:51

_Panta

Re : Ça rame grave !!!!

Bonjour,

j'ai également un probleme avec gam_server, process qui devient fou et monte au max des ressources et fini par planter la  bécane. Cela m'arrive pour la premiere fois ce soir, et puisque google est notre ami, je tombe sur ce topic :-)
J'ai cru remarquer que cela avait a voir avec une forte activité réseau (j'etais en train de recuperer 4 Go de mp3 entre la becane de mon fils et la mienne, tout en écoutant de la musique directement pris sur son HDD distant, et j'ai pu reproduire le bug. Si je demande plus d'une requete sur la même bécane du réseau, par exemple transfert d'un fichier et lecture d'un divX en même temps,  gam_server se mets en branle et deviens incontrolable. J'ai beau tuer le process, il revient 10 secondes apres.

Mandriva Linux 2005 LE x86_64 2.6.11-6mdk

#12 Le 22/04/2005, à 18:39

nemios

Re : Ça rame grave !!!!

Pour ma part j'ai remarqué que Gam_server s'affole dès que je fais un modification dans Système > Préférences > Thème

Hors ligne

#13 Le 24/04/2005, à 06:37

racoon97

Re : Ça rame grave !!!!

Moi j'ai aussi un probleme avec gam_server : j'ai insérér un DVD-R avec quelques  fichiers dedans et cela fais déja 15 minutes que ca tourne j'ai toujours pas la main !
On peut  pas  désactiver définitement ce truc ?


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#14 Le 25/04/2005, à 20:01

nemios

Re : Ça rame grave !!!!

En fait je m'apperçoit que par moment, une quantité tout à fait anormale de % CPU est utilisé. Exemple quand j'ouvre une page web:

nemios@ubuntu:~$ top

top - 20:54:31 up  4:19,  2 users,  load average: 0.68, 0.89, 0.87
Tasks:  78 total,   2 running,  76 sleeping,   0 stopped,   0 zombie
Cpu(s): 94.0% us,  6.0% sy,  0.0% ni,  0.0% id,  0.0% wa,  0.0% hi,  0.0% si
Mem:    451348k total,   415396k used,    35952k free,    26288k buffers
Swap:  1325320k total,     2048k used,  1323272k free,   196692k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 7969 nemios    18   0  124m  62m  20m R 79.7 14.2  37:08.84 firefox-bin
 6699 root      15   0  192m  49m 7940 S 13.9 11.2   6:29.48 Xorg
11717 nemios    15   0 30980  12m 8332 S  3.0  2.9   0:00.99 gnome-terminal
 7916 nemios    15   0 19100  10m 8020 S  1.3  2.3   0:20.61 wnck-applet
 7894 nemios    15   0 13884 8036 6476 S  0.7  1.8   0:17.79 metacity
 7857 nemios    15   0 19812 8644 6456 S  0.3  1.9   0:07.25 gnome-settings-
 7892 nemios    15   0  7736 2724 2160 S  0.3  0.6   0:02.55 gnome-smproxy
 7898 nemios    15   0 28928  12m 9332 S  0.3  2.8   0:06.89 gnome-panel
    1 root      16   0  1552  508  444 S  0.0  0.1   0:00.62 init
    2 root      34  19     0    0    0 S  0.0  0.0   0:00.00 ksoftirqd/0
    3 root       5 -10     0    0    0 S  0.0  0.0   0:00.63 events/0
    4 root      12 -10     0    0    0 S  0.0  0.0   0:00.05 khelper
   22 root       6 -10     0    0    0 S  0.0  0.0   0:00.00 kacpid
  115 root       5 -10     0    0    0 S  0.0  0.0   0:00.06 kblockd/0
  150 root      15   0     0    0    0 S  0.0  0.0   0:00.00 pdflush
  151 root      15   0     0    0    0 S  0.0  0.0   0:00.01 pdflush
  153 root      13 -10     0    0    0 S  0.0  0.0   0:00.00 aio/0

Chais pas pourquoi mais je me dit que c'est pas très normal, sous Windows je pouvais ouvrir une page web sans avoir besoin de rester à attendre que la page s'affiche, je pouvais lancer Winamp, ou ouvrir un fichier texte ou autre. Je pense pas que ça fasse non plus ça partout, donc où se situe le problème à votre avis?

Hors ligne

#15 Le 27/04/2005, à 16:53

racoon97

Re : Ça rame grave !!!!

C'est peut-être une page web avec un applet java ou un gros truc en Flash ? Tu peux toujours laisser l'URL pour que l'on puisse tester. Sinon as tu beaucoup d'extensions installées ?


Pas de logiciel de montage vidéo professionnel sous Linux ? Demandez à Sony son portage de Vegas Pro sous Linux... ou attendez Lightworks ;)

Hors ligne

#16 Le 27/04/2005, à 19:17

GAlain

Re : Ça rame grave !!!!

gam_server est connu pour poser des probs. il recoit via une API kernel foireuse des notifications lors de changements sur le systeme de fichier... tous changements meme mineurs... du coup, meme si gam_server trie les notification et ne les traite pas toutes quand il en recoit trop en meme temps, ca bouffe quand meme tout le µP.

une ancienne version de gam_server est connue pour entrer dans une boucle infinie. ce bug a ete regle -> update. mais ca ne regle pas le prob sus-mentionne et en +, la version de hoary n'est pas buggee

killall gam_server quand il s'affole. ca pose pas de prob, il ne fait pas d'ecriture sur le disque et redemarre immediatement apres

de plus, les drivers closed-source des cartes ATI sont connus pour etre pourris, et il me semble qu'Ubuntu les utilise.

mon diagnostique ici: gam_server bel et bien en cause, rien a faire ici sauf esperer que le prob sera regle a l'avenir.
qd ton expert debian est passe, gam_server etait calme puisque tu ne faisais pas de modif sur le disque. par contre, il a bien detecte le prob avec ATI

un outil que je ne saurais que trop conseiller pour detecter ce genre de probs: gkrellm.net
un p'tit moniteur systeme dont je ne pourrais plus me passer!
aptitude install gkrellm ;-)

a++

#17 Le 27/04/2005, à 19:28

nemios

Re : Ça rame grave !!!!

C'est l'ouverture de la page d'accueil de Wanadoo. Y'a plein d'autres pages ou ça me fait pareil, et quand j'ouvre un wiki c'est pire!

Je sais vraiment plus quoi faire, si j'étais logique je désinstallerais tout et remettrais Windows XP mais je préfère laisser le pc éteint plutôt que faire ça. Je voulais faire un rapport d'erreur mais je suis tombé sur un lien en anglais, j'ai rien compris et j'ai laissé tomber.

Maintenant j'ai tendance à penser que c'est une incompatibilité entre la Hoary et mon portable (Sony Vaio PCG-K115B) et que peut-être faut que je change de distribution, mais je veux pas retourner sous Windows! Ça j'en suis sûr.

Alors, je fais une dernière fois appel à vous, parce que là je suis à bout, je rame j'en peux plus, et j'ai l'impression que c'est foutu pour moi Ubuntu.

Que faire? S'il vous manque des infos, pas de problème, je regarde ce tropic toutes les heures, si vous posez une question j'y répondrais. S'il faut laisser tomber, ... ben... je me ferais une raison, par la force des choses...

Hors ligne

#18 Le 02/05/2005, à 20:35

Julien55

Re : Ça rame grave !!!!

Moi aussi j'ai un problème avec gam_server sur la Mandriva 2005 Limited Edition. Il me bouffe le CPU pour rien faire.
Quand je le kill, il revient aussi sec.
Y'a pas grand chose à faire, car beaucoup d'applications reposent sur lui.

Haut de page ↑