Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 27/04/2005, à 17:05

jpaul

PPRacer: Erreur

Bonjour, lorsque je lance ppracer (terminal) j'ai l'erreur suivante:

ppracer: error while loading shared libraries: libSDL_mixer-1.2.so.0: cannot open shared object file: No such file or directory

<Mon avatar n'est pas une grenouille><Windows ça pue; Mac c'est trop cher; Linux c'est trop compliqué*, xBSD ça sert à rien><Les modos, on vous aime><Hébergement Web gratos et sympah ;)>
* Mais ça rend beau
[Membre du club des beaux Ubunteros]

Hors ligne

#2 Le 27/04/2005, à 17:15

coffee

Re : PPRacer: Erreur

ln -s /usr/lib/libSDL_mixer-1.2.so.0.2.3 /usr/lib/libSDL_mixer-1.2.so.0


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#3 Le 28/04/2005, à 01:22

Sisssou

Re : PPRacer: Erreur

Je rencontre un problème similaire (mais pas similaire non plus vous allez comprendre) avec ce message d'erreur : "error while loading shared libraries". Sauf que c'est au lancement de Gnome qu'il y a occurrence dudit problème :

#########
gdm: error while loading shared librairies libexpat.so.1 Cannot open shared object file : Input/Output error
#########

J'ai bien essayé de réinstaller cette librairie (dpkg -i libexpat1-quivabien.deb), mais, je cite : "error processing libexpat... dpkg-deb : subprocess paste killed by signal"

Bref, ne s'agirait-il pas d'un lien _ symbolique _ à refaire, comme Coffee le montre ici de manière magistrale ? Je suppose que oui !

Mais vers quoi dois-je faire le lien ?
Quelqu'un avec une installation fonctionnelle pourrait-il me le dire ?

Merci beaucoup !

(Pour résumer j'espère que l'emplacement de mon post est judicieux....)

#4 Le 28/04/2005, à 10:19

sissou

Re : PPRacer: Erreur

Après quelques nouvelles recherches, je peux préciser à quoi sert cette librairie :

Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags

Bref c'est un parser.
Mais s'il faut réinstaller, il peut y avoir quelques difficultés :

Building expat

One of the problems with using expat is that isn't packaged as a library. Instead there are four separate object files that you have to link into your application. The Makefile that builds the sample applications in this article can be used as a template.

Qu'est-ce qu'il faut faire alors ?

J'avoue que ça me dépasse complètement là....

Est-ce qu'une solution telle que celle-ci pourrait résoudre mon problème :

host[/usr/lib]# su
host[/usr/lib]# cd /usr/lib
host[/usr/lib]# ln -s libexpat.so.0 libexpat.so.1

?

(Je ne suis pas devant ma machine avant ce soir, c'est la raison pour laquelle je ne fais que poser des questions sans tester, et autant éviter l'arrachage de cheveux ce soir....)

Dernière modification par sissou (Le 28/04/2005, à 10:34)

Hors ligne

Haut de page ↑