Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 05/04/2006, à 20:16

GuZnaK

/var/ , mise a jour et synaptic

Bonjour les gens, depuis cet après-midi jai ce problème :

Quand je clique sur le message des mises a jour dans le tableau de bord, rien ne se lance. Impossible de lancer Synaptic. J'essaye donc un sudo apt-get update puis apt-get upgrade, mais ce message d'erreur revient a chaque fois :

/var/run/sudo owned by uid 1000, should be uid 0

Je en sais pas quoi faire, et cela est assez derangeant car je ne peux ni faire de mise a jour, ni installer des nouveaux programmes.

Merci de votre aide !

GuZnaK.

Hors ligne

#2 Le 05/04/2006, à 20:36

m+rh-e

Re : /var/ , mise a jour et synaptic

n'aurais tu pas fait un (ou équivalent)

sudo chown $USER -R /var

un moyen de corriger le problème est de redemarrer ton système en mode single (restauration) et d'entrer

chown root -R /var/run/sudo

Dernière modification par m+rh-e (Le 05/04/2006, à 20:38)

Hors ligne

#3 Le 05/04/2006, à 20:39

GuZnaK

Re : /var/ , mise a jour et synaptic

C'est exactement ce que j'ai fais hmm
Merci pour ton aide, j'essaye ca de suite !

[EDIT]: Après avoir fait ceci, il m'était impossible d'accéder a ma session et ce message apparaissait :

Le rérertoire d'autorisation du serveur (daemon/ServAuthDir) est défini à /var/lib/gdm mais celui-ci n'existe pas. Veuillez corriger la configuration de gdm et redémarrer gdm.

J'ai pensé à faire sudo rm -r /var/lib/gdm puis sudo mkdir /var/lib/gdm mais le message apparaissait tout le temps.

Finalement, cela est résolu car j'ai formaté ma partition ubuntu et je viens de le réinstaller.

Dernière modification par GuZnaK (Le 06/04/2006, à 11:18)

Hors ligne

Haut de page ↑