Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 25/03/2006, à 18:54

setsix

[RESOLU] Caps lock ne fonctionne pas

Bonjour,

quand j'active le CAPS LOCK, cela ne fonctionne pas.
Si j'appuie sur la touche "1", j'ai alors "&" comme si je n'avais pas appuyé sur CAPS LOCK.

Dernière modification par setsix (Le 23/12/2006, à 02:14)

Hors ligne

#2 Le 25/03/2006, à 19:08

Donk

Re : [RESOLU] Caps lock ne fonctionne pas

C'est comme ca que ca marche, il faut appuyer sur la touche MAJ pour avoir accès aux chiffres

Hors ligne

#3 Le 31/03/2006, à 12:21

xploz

Re : [RESOLU] Caps lock ne fonctionne pas

Installer le paquet numlockx:

sudo apt-get install numlockx

Pour activer le numlock dés l"écran GDM, il suffit d"ajouter la ligne suivante au début du fichier /etc/gdm/Init/Default:

test -x /usr/bin/numlockx && /usr/bin/numlockx on

Pour activer le numlock dans toutes les consoles au prochain reboot : editer le fichier /etc/console-tools/config et enlever le # de la ligne commencant par #LEDS=+num à la fin du fichier Ou d"un coup d"un seul, en console :

sudo sed -i s/#LEDS=+num/LEDS=+num/g /etc/console-tools/config

Y'as pas de problêmes, y'a que des solutions.
http://wiki.ubuntu-fr.org/

Hors ligne

#4 Le 31/03/2006, à 12:59

mathesis

Re : [RESOLU] Caps lock ne fonctionne pas

Les premières machines à écrire ne le permettaient pas et c'est pour cela qu'on a fortement tendance à oublier qu'en français les majuscules sont accentuées. C'est à dire qu'il faut taper É È À Ç Î Â Ô Û Ù etc.

Comment comprends-tu "LE FILS LEGITIME" ?, "Le fils légitime" ou "Le fils légitimé" ? Ça n'est pas vraiment la même chose ..., d'où la nécessité de préciser les choses.

C'est le rôle de CAPSLOCK de permettre l'accentuation de ces caractères.

Pour avoir les chiffres il faut utiliser la touche MAJ. Sur un clavier normal, les chiffres du haut ne doivent être utilisés qu'ocasionnellement (dans un texte), d'où le recours à MAJ, sinon il y a le pavé numérique (tableur, calculs etc.). Par contre sur un portable tu n'as pas trop le choix.

Donc si tu fais une croix sur les majuscules accentuées (je suis un peu un puriste mais j'ai raison de le faire !) tu peux modifier le comportement de la touche CAPSLOCK dans je ne sais plus quelle option de Gnome ou de KDE.

Hors ligne

#5 Le 31/03/2006, à 14:26

dawar

Re : [RESOLU] Caps lock ne fonctionne pas

++ pour mathesis, oui les majuscules doivent être accentuées, magrès ce que l'on peux entendre dire. D'ou ce comportement de CAPS LOCK, qui comme son nom l'indique bloque en CAPITALES, et permet de faire des É À etc très facilement.


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#6 Le 31/03/2006, à 14:31

yeKcim

Re : [RESOLU] Caps lock ne fonctionne pas

Avec des explications aussi précises (auxquelles j'ajoute ce lien, pour que tu ais la preuve de ce que nous avençons ici) un [Résolu] dans le titre s'impose, non ?


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#7 Le 03/04/2006, à 19:47

st3f

Re : [RESOLU] Caps lock ne fonctionne pas

xploz a écrit :

Installer le paquet numlockx:

sudo apt-get install numlockx

Pour activer le numlock dés l"écran GDM, il suffit d"ajouter la ligne suivante au début du fichier /etc/gdm/Init/Default:

test -x /usr/bin/numlockx && /usr/bin/numlockx on

Pour activer le numlock dans toutes les consoles au prochain reboot : editer le fichier /etc/console-tools/config et enlever le # de la ligne commencant par #LEDS=+num à la fin du fichier Ou d"un coup d"un seul, en console :

sudo sed -i s/#LEDS=+num/LEDS=+num/g /etc/console-tools/config

-------------------------------
Re Bonjour,
1/ la commande "sudo apt-get install numlockx" fonctionne et installe les paquets
mais
2/"sudo sed -i s/#LEDS=+num/LEDS=+num/g /etc/console-tools/config"ne fonctionne pas cf resultat ci dessous.
st3f@ordi:~$ sudo sed -i s/#LEDS=+num/LEDS=+num/g /etc/console-tools/config
st3f@ordi:~$
aussi je me retrouve avec la touche "Fn" activée par defaut
s5 1e ta-e n6r+a3e+ent (si je tape normalement) ça donne cela
Que faire?


st3f@jabber.fr

Hors ligne

#8 Le 03/04/2006, à 23:09

mathesis

Re : [RESOLU] Caps lock ne fonctionne pas

Remarque : installer numlock ne te fera avoir que le Verr Num dès le démarrage. si c'est ce que tu souhaites avoir, alors je te conseille d'utiliser easyubuntu, ça te fait tout sans problème (et bien plus encore).

Hors ligne

#9 Le 04/04/2006, à 11:26

st3f

Re : [RESOLU] Caps lock ne fonctionne pas

J'ai installé Easyubuntu
Cela n'a pas réglé mon pb
Capslock ne fonctionne pas pour le touches du haut "multifonctions" (exemple touche 6 ou - ou |)
Avez vous une idée ?
Merci


st3f@jabber.fr

Hors ligne

#10 Le 04/04/2006, à 11:31

mathesis

Re : [RESOLU] Caps lock ne fonctionne pas

C'est ce que je disais : numlock (ce que tu tentais d'installer) est fait pour le pavé numérique.

Pour le Capslock, il marche à mon avis Capslock + 6 = "-" -> C'est normal, regarde mon premier poste. Si tu veux le 6 sans passer par le pavé numérique il faut faire Maj + 6.

Sinon tu modifies le comportement de Capslock (Système > Préférences > Clavier), tu devrais retomber sur le mauvais comportement par défaut de windows.

EDIT : le poste de xploz ne sert à rien pour le problème posé à l'origine si tu n'as pas de pavé numérique ou si tu ne veux pas l'utiliser.

Dernière modification par mathesis (Le 04/04/2006, à 11:32)

Hors ligne

#11 Le 06/04/2006, à 11:48

xploz

Re : [RESOLU] Caps lock ne fonctionne pas

oui excusez moi , un peu hors sujet sur ce coup là... tongue


Y'as pas de problêmes, y'a que des solutions.
http://wiki.ubuntu-fr.org/

Hors ligne

#12 Le 06/04/2006, à 20:43

st3f

Re : [RESOLU] Caps lock ne fonctionne pas

mathesis a écrit :

C'est ce que je disais : numlock (ce que tu tentais d'installer) est fait pour le pavé numérique.

Pour le Capslock, il marche à mon avis Capslock + 6 = "-" -> C'est normal, regarde mon premier poste. Si tu veux le 6 sans passer par le pavé numérique il faut faire Maj + 6.

Sinon tu modifies le comportement de Capslock (Système > Préférences > Clavier), tu devrais retomber sur le mauvais comportement par défaut de windows.

EDIT : le poste de xploz ne sert à rien pour le problème posé à l'origine si tu n'as pas de pavé numérique ou si tu ne veux pas l'utiliser.

---------------------------
Bon ben j'ai testé toutes les possibilités de "Système > Préférences > Clavier" pour capslock et rien à faire je n'arrive pas à avoir les chiffres de la seconde ligne une fois capslock verouillé...:mad:


st3f@jabber.fr

Hors ligne

#13 Le 06/04/2006, à 20:45

mathesis

Re : [RESOLU] Caps lock ne fonctionne pas

J'ai posté un rapport de bogue à ce sujet, je n'ai pas encore eu de retour, mais c'est bien comme ça qu'il faut procéder.

Sinon tu respectes la typographie française et tu apprends à taper au clavier :-)

Hors ligne

#14 Le 22/07/2008, à 08:38

rikyu

Re : [RESOLU] Caps lock ne fonctionne pas

il est habitué à windows en fait, car sur win c'est comme ça

Dernière modification par rikyu (Le 22/07/2008, à 08:38)


Pourquoi au resto chinois sous les assiettes il y a pas marqué "Made in china" ?

Hors ligne

#15 Le 02/11/2009, à 12:19

rocknroll00

Re : [RESOLU] Caps lock ne fonctionne pas

Bonjour,

Même probléme ici... c'est pas pour moi mais pour mes parents qui ont leurs petites habitudes sous windows (Caps locks enfoncé = chiffres). Malgrés les nombreuses options de configuration de la touche "Caps lock", aucune ne me permet de reproduire ce comportement...

Bon perso je m'en fou mais c'est possible que certaines personnes pensent que le clavier est cassé.. en particulier avec les mots de passe, mon pére n'aurait jamais trouvé tout seul qu'il faut appuyer sur Shift pour faire des chiffres et commencait à s'énerver tout seul sur son clavier ;-)

Hors ligne

#16 Le 20/05/2010, à 17:42

raphix

Re : [RESOLU] Caps lock ne fonctionne pas

hum, je comprends tout à fait la problématique des majuscules accentuées (je suis un puriste). En revanche, en puriste aussi, je ne comprends pas le passage en résolu d'un sujet non résolu...

On est tous d'accord pour dire que le comportement windowsien du clavier est naze. Ok. Mais la réponse : "tu respectes la typographie française et tu apprends à taper au clavier", c'est un peu violent et ça ne veut pas dire grand chose : un utilisateur français qui souhaite taper consécutivement 60 décimales de Pi (sur un portable sans pavé numérique) n'a pas, à mon avis, à maintenir appuyée la touche shift.
Autrement dit, dans un monde de liberté, disons que ce serait sympa de lui laisser le choix d'adopter le comportement buggé de windows...


Portable Asus A6KM Amd64 - Nvidia GeForce 7300.
Ubuntu Intrepid Ibex 32bit, ubuntero complet depuis début 2007. Fervent utilisateur de Logiciels Libres depuis ... que je touche aux ordis ou presque ('99)

Hors ligne

#17 Le 07/08/2010, à 14:50

superpc

Re : [RESOLU] Caps lock ne fonctionne pas

procédez comme suit:
1 -Système, Préférences puis clavier
2 -allez à l'onglet arrangement puis cliquez sur comportement de la touche verrouillage majuscule
3 - finalement sélectionnez "ver. maj. inverse Maj. qui affecte toutes les touches"

espérant que sa résoudre ta problème smile

Hors ligne

#18 Le 07/03/2013, à 15:51

DCUPLE

Re : [RESOLU] Caps lock ne fonctionne pas

Salut,

Voici ma petite contribution, si cela peut en aider quelques uns...

Je sélectionne deux claviers et bascule simplement de l'un à l'autre selon mes besoins :

- Français (variante obsolète)
- Cameroun multilingue (azerty)

(Tous les paramètres >> Agencement du clavier)
wink


L'Entraide, un facteur de l'évolution. MERCI

Hors ligne

#19 Le 08/03/2013, à 00:59

david96

Re : [RESOLU] Caps lock ne fonctionne pas

Pour ma part :
- Français (variante désuète : Azerty)
- Bépo (variante pour le Français)

wink

Hors ligne

#20 Le 13/12/2014, à 00:03

fouadessahlaoui

Re : [RESOLU] Caps lock ne fonctionne pas

big_smile big_smile la plus simple méthode  smile smile
J'ai créé un fichier /home/moi/.xmodmap-shiftlock avec la commande:

 $gedit /home/moi/.xmodmap-shiftlock

et qui ne contient que la ligne  suivante:

 keycode 0x42 =  Shift_Lock   NoSymbol   Shift_Lock

Ensuite, j'exécute la commande suivante dans le terminal:

 $xmodmap   /Home/moi/.xmodmap-shiftlock

Dernière modification par fouadessahlaoui (Le 13/12/2014, à 00:07)

Hors ligne

Haut de page ↑