Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 08/04/2006, à 15:47

Euskaral

gnome-app-install ne fonctionne plus

Bonjour,

Je suis actuellement obligé de lancer synaptic par la console (en mode avancé du coup), je n'arrive pas a le faire par le menu systeme>administration.
Lorsque je le fait par le menu, je tape le mot de passe su, et puis rien en se passe.
Par la console, je vois regulierement ce message d'erreur :

 (synaptic:15666): Gtk-CRITICAL **: gtk_accel_label_set_accel_closure: assertion `gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed

Donc je me dis que ce message est lié au probleme...

En vous remerciant de votre aide,


EDIT : titre

Dernière modification par Euskaral (Le 09/04/2006, à 13:29)

Hors ligne

#2 Le 08/04/2006, à 17:36

bapoumba

Re : gnome-app-install ne fonctionne plus

bonjour,
je ne pense pas que ce soit lié. J'ai le même type d'erreur. C'est lié au fait qu'une appli en gtk est lancée de la console.
Tes probs sont ailleurs.

As-tu vérifié quelle est la commande utilisée lorsque tu lances synaptic à partir du menu ?
(je ne sais plus où c'est, je le cherche. Si qqun a la réponse... wink)


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#3 Le 08/04/2006, à 20:17

bapoumba

Re : gnome-app-install ne fonctionne plus

donc voilà Euskaral, tu fais comme bobby le suggère :
http://forum.ubuntu-fr.org/viewtopic.php?id=35217

pour vérifier que ta commande de lancement de synaptic est correcte (bouton droit > propriétés > lanceur)
tu dois avoir gksudo /usr/sbin/synaptic smile


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#4 Le 09/04/2006, à 00:45

Euskaral

Re : gnome-app-install ne fonctionne plus

Merci pour ta reponse.

effectivement ça fonctionne mais en mode avancé.
En fait je voudrais pouvoir utiliser synaptic dans le mode "simple", chose qui ne se fait pas par la commande que tu m'as donné sad.

Pour mon lanceur, j'ai de base :

/usr/bin/gksudo /usr/bin/gnome-app-install

.

Bon c'est pas tres tres grave mais c'est agreable smile

Hors ligne

#5 Le 09/04/2006, à 12:47

Euskaral

Re : gnome-app-install ne fonctionne plus

bon j'ai tenté un

sudo apt-get remove --purge synaptic
sudo apt-get install synaptic

.
Le gestionnaire se lance bien a partir du raccourci, mais toujours pas de mode "simple".

Dernière modification par Euskaral (Le 09/04/2006, à 13:23)

Hors ligne

#6 Le 09/04/2006, à 13:20

Smarter

Re : gnome-app-install ne fonctionne plus

et en faisant la même chose mais avec gnome-app-install ?
Et en lançant gnome-app-install par la console?

Hors ligne

#7 Le 09/04/2006, à 13:27

Euskaral

Re : gnome-app-install ne fonctionne plus

Le raccourci vers synaptic aucun souci (donc en mode avancé).

Apres desinstallation et reinstalaltion de gnome-app-install, comme avant, pas de mode "simple" sad

par la console :

euskaral@ubuntu:~$ sudo gnome-app-install
Traceback (most recent call last):
  File "/usr/bin/gnome-app-install", line 41, in ?
    from AppInstall import AppInstall
  File "/usr/lib/gnome-app-install/AppInstall.py", line 30, in ?
    import gtkmozembed
ImportError: libgtkembedmoz.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
euskaral@ubuntu:~$

Dernière modification par Euskaral (Le 09/04/2006, à 13:28)

Hors ligne

#8 Le 09/04/2006, à 13:31

cep_

Re : gnome-app-install ne fonctionne plus

qu'est-ce que tu entends par mode simple et mode avancé ?

#9 Le 09/04/2006, à 13:39

Euskaral

Re : gnome-app-install ne fonctionne plus

le mode avancé est ce que tu obtiens en lançant synaptic.
Le mode simple avec gnome-app-install smile.
C'est ce que j'entend par là (je viens de faire la distinction entre ces deux applications)

Hors ligne

#10 Le 09/04/2006, à 14:43

cep_

Re : gnome-app-install ne fonctionne plus

Que donne :  locate libgtkembedmoz.so  ?

Il devrait y avoir :

/usr/lib/mozilla/libgtkembedmoz.so

Tu n'as pas d'autrs problèmes avec python ?

#11 Le 09/04/2006, à 14:45

cep_

Re : gnome-app-install ne fonctionne plus

Voir aussi si /usr/lib/gnome-app-install/AppInstall.py existe.

Si j'ai bien compris synaptic fonctionne par contre gnome-app-install ne marche pas.

Essaye de le réinstaller.

#12 Le 09/04/2006, à 14:55

Euskaral

Re : gnome-app-install ne fonctionne plus

cep_ a écrit :

Que donne :  locate libgtkembedmoz.so  ?

Il devrait y avoir :

/usr/lib/mozilla/libgtkembedmoz.so

Tu n'as pas d'autrs problèmes avec python ?

/usr/lib/firefox/libgtkembedmoz.so
Aucun autre probleme avec python

Hors ligne

#13 Le 09/04/2006, à 14:57

Euskaral

Re : gnome-app-install ne fonctionne plus

cep_ a écrit :

Voir aussi si /usr/lib/gnome-app-install/AppInstall.py existe.

euskaral@ubuntu:~$  locate AppInstall.py
/usr/lib/gnome-app-install/AppInstall.pyc
/usr/lib/gnome-app-install/AppInstall.py

Essaye de le réinstaller.

J'ai essayé de le reinstaller deja, mais rien de plus sad

Si j'ai bien compris synaptic fonctionne par contre gnome-app-install ne marche pas.

oui smile

Hors ligne

#14 Le 09/04/2006, à 15:57

cep_

Re : gnome-app-install ne fonctionne plus

Tu n'aurais pas modifié ton installation de firefox ?

Le problème pourait se situer entre python (/usr/lib/python2.4/site-packages/gtk-2.0/gtkmozembed.so) du pakage python2.4-gnome2-extras et firefox / mozilla.

Si un :

apt-get --reinstall install gnome-app-install

suivi éventuellement d'un

apt-get --reinstall install python2.4-gnome2-extras

ne règle rien, regarde en réinstallant firefox depuis apt-get --reinstall install firefox

Ou alors fais qq recherches s'il n'y a pas un bug remonté.

#15 Le 09/04/2006, à 16:00

cep_

Re : gnome-app-install ne fonctionne plus

Au fait, tu as essayé de faire :  gksudo gnome-app-install  ?

#16 Le 09/04/2006, à 18:41

Euskaral

Re : gnome-app-install ne fonctionne plus

cep_ a écrit :

Tu n'aurais pas modifié ton installation de firefox ?

hum si j'ai installé la 1.5 via les depots de dapper

Le problème pourait se situer entre python (/usr/lib/python2.4/site-packages/gtk-2.0/gtkmozembed.so) du pakage python2.4-gnome2-extras et firefox / mozilla.

Si un :

apt-get --reinstall install gnome-app-install

suivi éventuellement d'un

apt-get --reinstall install python2.4-gnome2-extras

ne règle rien, regarde en réinstallant firefox depuis apt-get --reinstall install firefox

Ou alors fais qq recherches s'il n'y a pas un bug remonté.

hum je peut reinstaller l'ancienne version de firefox s'il faut.
Mais bon dommage

Hors ligne

#17 Le 09/04/2006, à 18:41

Euskaral

Re : gnome-app-install ne fonctionne plus

cep_ a écrit :

Au fait, tu as essayé de faire :  gksudo gnome-app-install  ?

euskaral@ubuntu:~$ sudo gnome-app-install
Traceback (most recent call last):
  File "/usr/bin/gnome-app-install", line 41, in ?
    from AppInstall import AppInstall
  File "/usr/lib/gnome-app-install/AppInstall.py", line 30, in ?
    import gtkmozembed
ImportError: libgtkembedmoz.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou répertoire de ce type
euskaral@ubuntu:~$

Bon je pense donc que le probleme vient de firefox.
Je pense que je vais garder la version 1.5, et tant pis pour le mode simple de gnomme-app-install...


Merci a vous pour vos reponses, et votre aide smile

Dernière modification par Euskaral (Le 09/04/2006, à 18:43)

Hors ligne

#18 Le 09/04/2006, à 18:47

cep_

Re : gnome-app-install ne fonctionne plus

:~$ dpkg -S libgtkembedmoz.so
nvu: /usr/lib/nvu-1.0/libgtkembedmoz.so
firefox: /usr/lib/mozilla-firefox/libgtkembedmoz.so
mozilla-browser: /usr/lib/mozilla/libgtkembedmoz.so
mozilla-thunderbird: /usr/lib/mozilla-thunderbird/libgtkembedmoz.so

nvu est dans la liste. Regarde si le fait d'installer nvu ne résoudrait pas le problème.

#19 Le 09/04/2006, à 18:51

cep_

Re : gnome-app-install ne fonctionne plus

En complément :

gksudo gnome-app-install et non sudo ...

Donc ALT + F2 puis  gksudo gnome-app-install dans la fenêtre.

#20 Le 09/04/2006, à 18:53

Euskaral

Re : gnome-app-install ne fonctionne plus

Donc ALT + F2 puis  gksudo gnome-app-install dans la fenêtre.

dans la console :le resultat est le meme , c'est pur ça que j'ai copié collé mon message plus haut smile
dans la petite fenetre : rien ne se passe...

l'install de nvu ne m'a pas arrangé le shmimblick

Dernière modification par Euskaral (Le 09/04/2006, à 19:01)

Hors ligne

#21 Le 09/04/2006, à 20:29

bapoumba

Re : gnome-app-install ne fonctionne plus

salut,
c'est toujours un plaisir de te lire, cep wink


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#22 Le 09/04/2006, à 20:42

cep_

Re : gnome-app-install ne fonctionne plus

Coucou bapoumba,

J'avais vu ton autre poste smile

Haut de page ↑