Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 27/04/2009, à 13:03

olsman037

problème librairies : Stata 32bit sur jaunty 64bit

Bonjour à tous,

J'ai profité du passage à jaunty pour installer la version 64 bit (du bonheur!!), pas de souci pour réinstaller ma config... juste le logiciel stata, pour lequel je ne veux pas passer tout de suite à la version 64 bit (le passage à la licence 64 est gratuit, mais pas l'inverse, donc je veux attendre d'être sûr de rester en 64 bit)

J'ai fait comme ils disent sur la page ubuntu 64 http://doc.ubuntu-fr.org/ubuntu_64bits# … tu_64_bits, mais certains paquets sont "virtuels" (je sais pas trop ce que ça veut dire)

Après l'install, la version console fonctionne bien..

Pour la version graphique, il y avait un problème de libtiff.so.3, résolu en créant un lien appelé "libtiff.so.3" vers libtiff.so.4 dans le dossier lib32...

J'ai réessayé de lancer la version graphique, là il me demande libgtksourceview-1.0.so.0... le problème c'est qu'il n'est pas présent dans lib32... il n'est que dans lib64 (donc lib).. J'ai essayé en mettant un lien ou en copiant le fichier dans lib32 et il me dit qu'il y a un problème de classe, vu que c'est du 64...

En gros mes questions sont les suivantes :
    - est-ce que c'est normal que les paquets soient virtuels (linux32 et lib32asound2, problème de dépôt ??)
    - est-ce qu'il y a une solution (genre copier le fichier libgtksourceview-1.0.so.0 à partir d'un ordi en version 32 bit (celui de ma copine, mais qui est encore sous intrepid..) ??

Merci pour vos lumière

Dernière modification par olsman037 (Le 28/04/2009, à 10:16)


Sony Vaio VPC-SB1C5E, i7-2620M, 8Go, GPU AMD 6470M avec triple boot W7, Ubuntu 10.10 et Arch...
Galère les nouveaux sony sous linux!!!! (switch AMD/Intel, touchpad, ethernet,....)

Hors ligne

#2 Le 27/04/2009, à 21:08

brakbabord

Re : problème librairies : Stata 32bit sur jaunty 64bit

Paquet virtuel = Un paquet qui n'est pas utile en lui même, mais qui sert à installer plein d'autres logiciels comme dépendances.

Sinon je ne comprends pas trop de quoi tu parles quand tu dis "logiciel sata".

Hors ligne

#3 Le 28/04/2009, à 08:35

olsman037

Re : problème librairies : Stata 32bit sur jaunty 64bit

Euh... En fait je dis logiciel stata (comme statistique tongue)...
Si je te suis bien, les paquets virtuels je n'ai pas vraiment besoin de les installer...et c'est pour ça que ça ne s'installe pas ?

Bon sinon j'ai copié les librairies en questions dans lib32 (venant d'une installe intrepid 32bit), mais ça ne marche qu'en super user.. (sudo ./xstata) en normal il me dit qu'il manque libgtksourceview-1.0.so.0...

Après quelques recherches, j'ai vu le logiciel getlibs, qui est sensé permettre de récuperer les librairies manquantes.. le problème c'est qu'il me dit bien qu'il manque libgtksourceview-1.0.so.0 (quand je fais getlibs ./xstata), il fait semblant de les télécharger, de les installer, mais dès que j'essaye de le lancer ça n'a rien changé... et getlibs me redit qu'il manque libgtksourceview-1.0.so.0...

J'ai aussi testé de changer le propriétaire du dossier (usr/local/stata10), mais rien n'y fait...

Quelqu'un a une idée sur cette histoire de librairies qui manque en normal et pas en sudo ?


Sony Vaio VPC-SB1C5E, i7-2620M, 8Go, GPU AMD 6470M avec triple boot W7, Ubuntu 10.10 et Arch...
Galère les nouveaux sony sous linux!!!! (switch AMD/Intel, touchpad, ethernet,....)

Hors ligne

#4 Le 28/04/2009, à 13:54

olsman037

Re : problème librairies : Stata 32bit sur jaunty 64bit

Un petit up ?!?


Sony Vaio VPC-SB1C5E, i7-2620M, 8Go, GPU AMD 6470M avec triple boot W7, Ubuntu 10.10 et Arch...
Galère les nouveaux sony sous linux!!!! (switch AMD/Intel, touchpad, ethernet,....)

Hors ligne

#5 Le 10/05/2010, à 08:15

jeffhamel

Re : problème librairies : Stata 32bit sur jaunty 64bit

Salut. J'ai eu le même problème (sans doutes il a été réglé depuis le temps, mais bon... ça peut servir à d'autres)
simplement :

libgtksourceview-2.0.so.0 /usr/lib32/libgtksourceview-1.0.so.0

(ou bien, selon)

libgtksourceview-2.0.so.0 /usr/lib/libgtksourceview-1.0.so.0

Bon courage!

Hors ligne

Haut de page ↑