Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 16/05/2009, à 17:23

ren4rd

Bugs Blender 2.48 avec drivers Nvidia

Salut,

voilà j'ai un petit problème sous Ubuntu avec Blender 2.48a, en effet dés que je passe en mode Texture paint ou Weight paint les fenêtres 3D deviennent noire plus rien ne s'affiche dés que je pointe ma souris sur le header d'une fenêtre ou si je vais dans la Buttons Window.

Alors j'ai les drivers propriétaire de Nvidia 180.44 avec les paramètres suivant :

Xserver Xvideo Settings :

- Sync to Vblank : coché

OpenGL Settings :

- Sync to Vblank : coché
- Allow Flipping : coché
- Image Settings : High Quality

Antialiasing Settings :
- Override Application Settings sélectionné et 4x (4xMS) (même en changeant ça fait le même problème sauf quand je le désactive mais bonjour l'horreur tout est crénelé)

Anisotropic Filtering :
- Override Application Settings sélectionné et 4x (si je l'enlève ou le laisse comme ça ça ne change rien)

Texture quality :
- Texture Sharpening

J'ai testé avec les drivers 170.xx et c'est la même chose.

Pour ceux à qui ça fonctionne bien pourriez-vous m'aider à arranger ce problême ?

Dernière modification par ren4rd (Le 16/05/2009, à 17:24)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#2 Le 17/05/2009, à 12:09

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Alors d'abord je te remercie beaucoup de m'avoir répondu c'est très sympa de ta part.

Alors voici ce que je voulais dire, il y a quand même une grosse différence :

Donc ça c'est avec tes options, j'ai testé et évidemment pas de soucis tout marche car aucun éléments de config de la carte est activé, elle est par défaut et ça donne ça :

2f2b96d12c3b67ebdeacede3b6c17238.png

ET là avec les options que j'ai cité à mon précédent post cela donne ça :

1bb6c458e1b2e543a56a9e743f7175b8.png

Il y a quand même une grande différence de qualité d'image pas d'effet crénelé c'est nickel.

Alors sur un simple cube comme ça c'est pas trop dérangeant mais sur de grosses modélisations ça devient limite irritant pour les yeux cool

Et donc mon problème c'est que si je rentre dans les modes intéractifs de Blender c'est dire comme le sculpt mode, Texture paint, Weight paint ... et que je vais avec mon pointeur de souris sur les headers des 3D views ou si je vais sur la Buttons Window les 3D views deviennent noires et quand je reviens avec le pointeur de la souris sur les 3D views ca redevient normal.

Voilà besoin d'aide s'il vous plait, il y en a quand même bien un au moins chez qui ça fonctionne bien ?

Ah j'ai une 8800 GT 512 Mo, un Core²Duo E6600, 3Go de ram, HDD 250 Go si ça peux aider à la résolution de mon problème.

PS: Cela marchait parfaitement sous Windows, et là j'ai migré totalement sous ubuntu je suis dégouté que Blender ou les pilotes Nvidia ne fonctionne pas correctement avec un simple antialiasing et un anisotropique, je comprends pas pourquoi cela ne marche pas, aidez moi s'il vous plait roll

Dernière modification par ren4rd (Le 17/05/2009, à 12:12)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#3 Le 17/05/2009, à 18:37

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Alors sous windows c'est certain ça ne plante pas je l'ai testé déjà avec une version optimisée SSE3 et tout marchait parfaitement.

Bon ben espérons qu'une âme charitable et fort en linux puisse m'aider sinon bonjour le retour dans le passé si on ne peux pas utiliser ses paramètres graphiques pour Blender, aucun intérêt d'avoir une carte graphique poussée :s

C'est obligé que cela puisse fonctionner car sous Fedora si je me rappelle bien la Blender Foundation avait faire la Blender conf et avait présenter les évolutions du soft et l'affichage était nikel aucun crénelage c'était sublime.

Please Please qui c'est qui tate en linux et blender pour m'aider à résoudre mon problème ?? ou sinon si quelqu'un connait-il une distribution qui permet que cela fonctionne correctement sans bugs ?

Merci d'avance roll

PS: je me tate à passer sous Open Suse qui a l'air simple d'utilisation avec son DVD de 4,2Go elle a l'air très complète mais je ne voudrai pas tout réinstaller pour rien car Ubuntu pour le moment me comble mais étant donné que j'utilise principalement Blender ça va pas le faire si je ne trouve pas de solution.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#4 Le 17/05/2009, à 20:02

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

et tu as fait comment s'il te plait ?

Ah oue c'est super jolie et t'a tout les modules dedans ? tu peux tout faire ? Car je l'avais testé et il n'y avait rien dedans à part l'interface de base.

Merci d'avance et super ton aide wink

Edit : oula j'avais pas vu ton post pour la 2.49 je teste ca de suite je te dis si ca marche.

Dernière modification par ren4rd (Le 17/05/2009, à 20:08)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#5 Le 17/05/2009, à 20:17

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Pour la 2.49 RC3 c'est la même chose quand mon pointeur se trouve dans la 3D view c'est parfait et dés que le pointeur quitte la 3D view et que je vais sur un des menus du header ou dans la Button Windows ca redevient noir comme avec les autres versions.

Le problème persiste ...

Pour compiler la 2.5 tu as fait comment ? J''ai regardé les tutos sur la doc d'ubuntu et j'ai pu compiler les versions 2.49 RC3 mais ou c'est qu'on trouve les sources pour la 2.5 ? et comment fait-on après ?

Dernière modification par ren4rd (Le 17/05/2009, à 20:18)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#6 Le 17/05/2009, à 20:36

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Ben je la décompresse sur le bureau et je lance le blender et les drivers sont pas pris en compte sur la static 2.49RC3 c'est à dire c'est ultra crénelé.

Que faut-il faire pour l'installer celle-ci :
1/ la mettre dans le dossier de Blender qui est déjà installer ?
ou
2/ est ce que l'on peux la décompresser sur le bureau comme ca et la lancer directement comme ca

Car si c'est la deuxième solution c'est déjà fait et le résultat je l'ai écris 7 lignes plus haut.

snif je télécharge open suse et mandriva pour tester ces distribs au cas où cela marcherait.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#7 Le 17/05/2009, à 20:40

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Merci pour les sources de la 2.5, je vais également testé.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#8 Le 17/05/2009, à 21:11

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

ah mais si c'est résolue forcemment c'est comme si tu mettais les drivers par défaut c'est à dire créneler.

Mais ca ne résoud pas le problème de pouvoir profiter pleinement de sa carte graphique sous Blender.

Alors soit c'est car on ne maitrise pas linux à fond (c'est à mon avis probablement ça) soit si ce problème n'en st pas et que Blender est uniquement utilisable de la sorte sous linux ce qui là vraiment lui donne un très mauvais point mais je doute que ce soit ça.

De l'aide s'il vous plait


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#9 Le 18/05/2009, à 00:12

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

C'est la même chose que tu me demandes ?

J'ai donc testé avec Override Applications Settings (c'est ce que j'avais au départ) donc pareil.

Avec Enhance Application Settings ca remet les effets crénelés mais ça marche.

Oue donc toujours pas la solution, je suis sûr en plus que ça se trouve dans le nvidia-settings.rc mais quelle option arrangera ça ? très dur j'ai regardé la doc Nvidia et franchement très dur à comprendre certaines commandes.

Help qui aurait la solution pour arranger ce soucis avec Blender et Nvidia ayant le filtre anisotropique et antialiasing activé ?

EDIT: D'ailleurs je viens de trouver un lien là dessus sur un site anglais apparemment on est loin d'être les seuls bon ça date d'Août 2008 et ce problème est apparemment toujours présent ce qui est vraiment super embettant pour travailler dessus.

Voici lelien : http://www.nvnews.net/vbulletin/showthread.php?t=109531

Dernière modification par ren4rd (Le 18/05/2009, à 00:23)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#10 Le 18/05/2009, à 10:05

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Oui en effet, mais à la Blender conf à l'époque où je l'avais vu c'était la version 2.42 mise en avant et sous Fedora ça tournait nikel avec antialiasing.

Sinon mon lien c'est juste pour une réponse qui était celle-ci :

As far as settings goes, I know having forced anti-aliasing in nvidia-settings is a no-go because the blender 3D view become completely black and red when moving objects.

Moue comme tu dis cela doit être un problème qui vient plutôt des drivers Nvidia, je vais chercher comment mettre les derniers beta 185.18.08 parue le 05.05.2009.

Je te tiens au courant dés que j'ai réussi.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#11 Le 18/05/2009, à 10:49

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Tu penses que je risque quelque chose ?

Non mais t'a réussi en plus ouaaaah donc ce serait les séries 8 des Geforce qui poseraient problème.

Donc regarde le changelog des drivers beta 185.18.08 :

* Fixed stability problems with some GeForce 6200/7200/7300 GPUs on multi-core/SMP systems.
    * Improved recovery from certain types of errors.
    * Fixed a problem that caused DisplayPort monitors to never light up or lose sync intermittently on some Quadro GPUs.
    * Fixed a bug that caused some performance levels to be disabled on certain GeForce 9 series notebooks.
    * Fixed a problem that could result in temporary stalls when moving OpenGL application windows on GeForce 8 and later GPUs.
    * Fixed a bug that could interfere with the detection of display devices attached to secondary GPUs when first starting X after cold boots.
    * Fixed a bug that prevented VGA fonts from being saved/restored correctly on GeForce 8 and later GPUs.
    * Loaded the NVIDIA kernel module earlier in the X driver's initialization path to facilitate more graceful fallbacks if the kernel module cannot be loaded. Removed the LoadKernelModule X configuration option.
    * Fixed a bug that caused kernel crashes when attempting to initialize NvAGP on Linux/x86-64 kernels built with the CONFIG_GART_IOMMU kernel option.

Dernière modification par ren4rd (Le 18/05/2009, à 10:54)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#12 Le 18/05/2009, à 10:52

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

oui je l'ai lu juste après avoir posté


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#13 Le 18/05/2009, à 11:21

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Moue c'est clair bon ben tu avais raison après installation du nouveau drivers impossible de redémarrer  après un sudo dpkg-reconfigure xserver-xorg j'ai réussi à redémarrer mais dans le xorg.conf y a plus rien :s

Je vais chercher pour activer les drivers nvidia et remettre mes paramètres d'en temps.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#14 Le 18/05/2009, à 12:20

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Tout est arrangé :

6ca46f3119350f109a3ae12c1cef18de.png

Parcontre toujours pareil même bug avec Blender.

Donc je vais envoyer un rapport de bugs à Nvidia en espérant qu'ils le prennent en compte pour corriger ça dans les prochaines versions de leur driver.

Dernière modification par ren4rd (Le 18/05/2009, à 12:24)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#15 Le 19/05/2009, à 02:59

Gemnoc

Re : Bugs Blender 2.48 avec drivers Nvidia

Bien que la 6600 GT soit deux générations plus vieille que la 8500 GT, elle est dans une gamme supérieure (premier chiffre indique la génération, second chiffre la gamme - ce qui n'est plus vrai après la série 9).

La bande passante mémoire de la 6600 GT est supérieure à celle de la 8500 GT, à 16Gbits/s contre 12.8GBits/s. La 6600 GT a moins de mémoire, mais celle-ci a une fréquence de 1GHz contre 400MHz pour la 8500 GT.

Pas évident de faire la lecture de ces caractéristiques techniques, mais il semble bien que la 6600GT, même avec moins de mémoire graphique, soit plus performante que la 8500GT...

http://www.pantherproducts.co.uk/Product%20Reviews/Geforce%206600.shtml#Card%20comparison
http://www.nvidia.fr/page/geforce8.html

P.S. Au fait, j'ai une 8600 GTS 256Mo, j'ai Blender 2.48a installé, mais je ne comprends rien à ce logiciel. Trop habitué à l'interface des logiciels de CAO mécanique, je suppose! Si j'y arrive, je tenterai de voir si j'ai les mêmes problèmes de crénelage (ou de gel)...

Dernière modification par Gemnoc (Le 19/05/2009, à 03:06)


Pensez à consulter la documentation ! :-)

Hors ligne

#16 Le 19/05/2009, à 11:31

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Oui à première vu mais moi j'ai une 8800 GT 512 et la 6600 elle est loin derrière et c'est pas pour cela que la mienne est plus performante au final.

J'en ai une 6600 GT mais en AGP et ma carte mère y a que du pci express je suis vert :s

MA fois tant pis quand j'aurai besoin de ses fonctions je me débrouillerai autrement, enfin comme d'hab ca reste encore bidouillage sur bidouillage c'est dommage que je n'arrive jamais à un système fifi où tout marche correctement comme sur windows.

PS : vous ne connaissez pas une distribution qui gèrerai peut être ça mieux ? Ou est ce uniquement la faute aux drivers Nvidia ?


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#17 Le 19/05/2009, à 21:09

Gemnoc

Re : Bugs Blender 2.48 avec drivers Nvidia

En regardant rapidement dans Blender 2.48a, avec les mêmes réglages qu'indiqués à ton premier message, et les modes Texture paint et Weight paint, je n'ai pas d'écran noir (quoique j'y suis resté que moins de 5 minutes). Par contre, il me semble que je subis une importante perte de performance graphique. C'est-à-dire que la rotation me paraît moins fluide, également les menus s'affichent moins rapidement... Bizarre, ma carte graphique n'est pourtant pas une daube!

(j'ai les pilotes Nvidia 180.11)

Également, la rotation de la vue de la fenêtre 3D ne se fait plus correctement avec la molette de la souris enfoncée. J'amorce une rotation et ça se bloque immédiatement. Je dois m'y reprendre par plusieurs fois, et parfois j'arrive à faire pivoter le cube. Si je retourne en Object Mode, alors la rotation redevient fluide.

Je ne crois pas que ces problèmes soient dûs à la distribution Ubuntu, plutôt aux pilotes nvidia.

Si tu es à l'aise en anglais,  cette enfilade du forum anglophone d'Ubuntu concerne les pilotes de nvidia et les dernières versions sont toujours annoncées dans le premier message. Tu pourrais aussi y témoigner de tes problèmes, il semble y avoir beaucoup d'activité là-bas.


Pensez à consulter la documentation ! :-)

Hors ligne

#18 Le 20/05/2009, à 00:21

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Merci pour ta réponse, j'ai posté un message dans le forum que tu m'a passé.

Pour ton cas, c'est le cas des freeze dans la fenêtre 3D en fait soit c'est ce problème soit c'est celui que j'ai au choix si l'on souhaite activé l'AA.

Regarde par tu auras peut être une solution.


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#19 Le 20/05/2009, à 07:22

Gemnoc

Re : Bugs Blender 2.48 avec drivers Nvidia

@ ren4rd

J'ai désactivé l'AA et autres réglages, et j'ai encore ces freezes, incluant dans l'Object mode. Phoque, comme on dit par chez nous (lire ce qui est phonétiquement identique en anglais!)... hmm

D'autre part, j'ai visité ton site Blender Factory (mis dans mes liens!), et j'ai passé du temps à lire la page du site Blender sur les changements à l'UI dans la 2.5. Ça semble tellement majeur que je me demande si je ne vais pas attendre cette version avant de me lancer! Ça devrait sortir à l'automne si je comprends bien?


Pensez à consulter la documentation ! :-)

Hors ligne

#20 Le 20/05/2009, à 10:28

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

En effet dans ces eaux là tiens si tu es friand d'info sur la 2.5 voici un lien (en anglais) du site officiel, tu verras un peu les nouveautés à venir et franchement, ette version c'est un tournant majeur dans la vie de Blender, c'est du lourd du très lourd smile

Dernière modification par ren4rd (Le 20/05/2009, à 10:28)


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#21 Le 26/05/2009, à 08:10

damb

Re : Bugs Blender 2.48 avec drivers Nvidia

Bonjour,

Je viens de tester les réglages améliorant l'AA et l'affichage, en effet c'est un peu plus agréable, par contre c'est moins fluide et j'ai exactement le même problème...

Et donc mon problème c'est que si je rentre dans les modes intéractifs de Blender c'est dire comme le sculpt mode, Texture paint, Weight paint ... et que je vais avec mon pointeur de souris sur les headers des 3D views ou si je vais sur la Buttons Window les 3D views deviennent noires et quand je reviens avec le pointeur de la souris sur les 3D views ca redevient normal.

Idem concernant les blocages durant une rotation 3d...(9600gt+Driver 180.44...)

Quelqu'un aurait testé Blender la Version: 180.51 des drivers Nvidia

Hors ligne

#22 Le 26/05/2009, à 09:20

ren4rd

Re : Bugs Blender 2.48 avec drivers Nvidia

Concernant tes problème de fluidité vérifie en faisant un clic droit sur le Bureau et clic sur changer l'arrière plan.

Ensuite va dans l'onglet Effets Visuels et sélectionne Aucun.

Relance Blender et dis moi si c'est pas mieux. Avec ça je fais tourner Blender tranquilou avec Antialiasing à 8x (8xMS) et Filtre Anisotropique 4x.

Mais dés que j'active les Effets Visuels ça ralenti considérablement mon PC.

Ma config :

Core²Duo E6600 (2.6Ghz)
3Go de DDR2 (800 Mhz)
Nvidia Geforce 8800 GT 512Mo sur PCIe 16x


Blender Factory

Ma config :
Ubuntu jaunty, carte mère MSI neo P35F, Core²Duo E6600, Carte Nvidia 8800 GT 512, 3Go de ram PC6400

Hors ligne

#23 Le 26/05/2009, à 12:58

damb

Re : Bugs Blender 2.48 avec drivers Nvidia

En fait je n'utilise plus compiz, juste les effets composites intégrés dans gnome...
Je sens quand même une légère baisse de fluidité dès que l'AA est activé...mais pour des scènes simples c'est largement utilisable...

Hors ligne