Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#26 Le 01/03/2009, à 02:01

#hehedotcom\'isback

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

pas mieux osef_final.gif

Hors ligne

#27 Le 01/03/2009, à 02:06

ilcorseronero

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

parce que ... on a autre chose à faire

    (@)(@)


Solution à quasi tous vos problèmes: taper dans un terminal ce qu'il y a dans
la signature →  solution
solution
solution

Hors ligne

#28 Le 01/03/2009, à 02:18

#hehedotcom\'isback

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Au passage, la dernière version fonctionne parfaitement sous intrepid

cat /etc/lsb-release && uname -m
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"
x86_64

Hors ligne

#29 Le 01/03/2009, à 12:46

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

xy9 a écrit :

ça fait un moi que j essait tout pour installer java sur ubuntu 9.10 64 bit

C'est qu'à utiliser des versions qui ne sont pas encore sortie, même en alpha, ça risque de ne jamais marcher ...
Tu l'as trouvée où ton ubuntu 9.10 ?

xy9 a écrit :

pourquoi ça prend une page de commande pour installer java

Parce qu'il y a des personnes qui prennent le temps de détail toute l'installation, alors que ça aurait pu se résumer à :
- lancer le binaire téléchargé sur le site sun
- créer un lien dans /usr/lib/xulrunner-addons/plugins/ vers /usr/lib/java/jre1.6.0_12/lib/amd64/libnpjp2.so
- configurer Ubuntu pour qu'il utilise le java sun par défaut

Mais je suis sûr que l'on aurait des retours comme quoi :
- un newbie ne sait pas rendre executable un binaire
- un newbie ne sait pas lancer un binaire
- un newbie ne sait pas créer un lien sans passer par Nautilus
- un newbie ne sait pas faire en sorte que Ubuntu utilise java sun par défaut

Pour toutes ces raisons, et pour ne pas avoir un topic de 20 pages, Totem a eu la gentillesse de détailler l'installation point par point.

xy9 a écrit :

si ya personne qui connait une facon normale de l installer arrêter de mèler
tout le monde avec des recette compliqué,[...]

1. Nous n'obligeons personne à installer cette version de Java, tu peux faire avec OpenJDK si il te convient
2. Si tu veux vraiment le Java sun, demande à Sun de créer un .deb ou mettre à diposition un installateur en 1 clic.
3. Cette version de Java Sun est une beta, donc si tu ne sait pas ce que tu fais, abstiens-toi.

xy9 a écrit :

ja remarquer que sur les forum au lieu
d aider on fait des commentaires sans rapport

Je ne vois pas d'autre post de ta part sur ce topic, et je ne vois pas en quoi nous avons fait des commentaires sans rapport avec ton problème puisque tu n'as pas signalé que tu avais un problème.
1. Nous ne sommes pas devin
2. Si tu explique clairement ton problème, et à quelle étape du tutoriel ci-dessus tu bloques, tu as encore une maigre chance d'obtenir une réponse.
3. Nous ne sommes pas à tes ordres, et il se trouve que l'aide donnée est bénévole, donc ne tire pas trop vite sur l'ambulance.
4. Tu te pleins que l'explication est trop détaillée mais pour autant tu n'y arrives pas ... d'où peux bien venir le problème ?

xy9 a écrit :

comme quelqu un qui veut installer un antivirus on passe son temp a le traiter de crétin
lieu de donner des solutions qui existent

Se topic ne porte pas sur les antivirus, et personne n'a été traité de "crétin" hmm
Si tu parles d'une expérience personnelle, peut-être que ton comportement sur le forum a découragé les personnes qui souhaitaient t'aider. Ne reste donc que les autres utilisateurs dans ton genre : ceux qui critique sans faire avancer le schmilblik !

Et si au lieu de critiquer bassement ce topic, tu nous indiquait quels problèmes tu rencontre, et quel retour tu as eu lorsque tu as lancé les commandes du tutoriel ? Es-tu sûr que l'installation s'est bien déroulée ?

Dernière modification par draco31.fr (Le 01/03/2009, à 12:50)

Hors ligne

#30 Le 01/03/2009, à 15:09

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Vu que les versions changent assez régulièrement, je me suis écrit une petite ligne de commande pour télécharger "automatiquement" la dernière version :

wget $(wget -q http://download.java.net/jdk6/index.html -O - | grep -o -E '\"http.*jre.*linux-amd64-[0-9]{2}_.{3}_[0-9]{4}\.bin\"' | grep -o 'http.*\.bin') -c

Le but :
- parcourir la page http://download.java.net/jdk6/
- trouver l'url du dernier jre pour linux amd64 en .bin
- le télécharger dans le dossier courant

Pensez-vous que je peux écrire une telle commande dans le wiki pour expliquer comment récupérer (et installer avec le tuto du Totem) la dernière version amd64 du jre sun ?
Est-ce que ça ne fait pas trop "brute de décoffrage" ?

EDIT : La même chose en une fois avec sed :

wget $(wget -q http://download.java.net/jdk6/ -O - | sed -n 's/<a\ href="\(http.*jre.*linux-amd64.*[0-9]\{4\}\.bin\)".*/\1/p') -c

Dernière modification par draco31.fr (Le 01/03/2009, à 18:47)

Hors ligne

#31 Le 28/04/2009, à 01:47

Manu_95

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

Pensez-vous que je peux écrire une telle commande dans le wiki pour expliquer comment récupérer (et installer avec le tuto du Totem) la dernière version amd64 du jre sun ?
Est-ce que ça ne fait pas trop "brute de décoffrage" ?

Bonsoir.

Pour la commande je ne sais pas trop mais les contributeurs du wiki ne manqueront pas de corriger ou d'améliorer au besoin smile

Par contre le tuto de Totem doit être formalisé dans le wiki : cette méthode permet enfin - et faute de mieux en attendant des dépôts officiels - d'utiliser le java de Sun en 64 bits.

Testé sur Kubuntu 9.04/64 avec la lib 6.0_14 : cela fonctionne très bien sur le site des impôts smile Un grand merci à Totem !

Cordialement,


Manu.
(1) Desktop : Ubuntu 10.04  - desktop 64bits / Core 2 Duo E6420 @2.13 GHz - 6Go DDR2 - NVIDIA GeForce 8600GTS
(2) Netbook : Ubuntu 9.10 - UNR / Asus EeePC 1000H

Hors ligne

#32 Le 29/04/2009, à 08:37

Totem

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

çà fait plaisir wink

Je vais voir comment faire pour formaliser le tuto dans le wiki.

Dernière modification par Totem (Le 29/04/2009, à 08:47)


il n'existe que deux choses d'infinies, l'univers et la connerie humaine, mais pour l'univers je n'ai pas de certitude absolue

A. Einstein.

Hors ligne

#33 Le 13/05/2009, à 11:03

cgouttebroze

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Merci beaucoup Totem pour tes explications.

Ca a marché très bien pour moi !

Hors ligne

#34 Le 23/05/2009, à 14:13

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Manu_95 a écrit :

Par contre le tuto de Totem doit être formalisé dans le wiki : cette méthode permet enfin - et faute de mieux en attendant des dépôts officiels - d'utiliser le java de Sun en 64 bits.

Comme il n'est jamais trop tard, j'ai créé le tuto sur le wiki à cette adresse : tutoriel/comment_installer_sun_java6_plugin_64bits.
N'hésitez pas à l'améliorer ... il me manque notament la partie déclaration pour Konqueror.

Hors ligne

#35 Le 26/05/2009, à 22:29

malib

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

bon voilà j'ai enfin trouvé le post qui va bien, merci Totem pour ce tuto.
J'étais en train d'essayer de faire ma déclaration d'impôts et impossible sans la bonne machine virtuelle roll

Juste un précision : au lieu de faire le lien symbolique, autant utiliser le système des alternatives, xulrunner est livré avec un
xulrunner-1.9-javaplugin.so

Donc je n'ai pas utilisé cela :

Totem a écrit :

Apres ne reste plus qu'a faire un lien vers le repertoire plugins de votre firefox

ln -s /usr/lib/java/jre1.6.0_12/lib/amd64/libnpjp2.so /usr/lib/xulrunner-addons/plugins/.

Mais j'ai déclaré un nouveau lien alternatif pour xulrunner-1.9-javaplugin.so, ce qui donne :

$ sudo update-alternatives --install /etc/alternatives/xulrunner-1.9-javaplugin.so xulrunner-1.9-javaplugin.so /usr/lib/jvm/jre[VERSION]/lib/amd64/libnpjp2.so 1
$ sudo update-alternatives --config xulrunner-1.9-javaplugin.so

Je n'ai pas poussé plus loin, mais j'ai bien l'impression que pour bien utiliser sa nouvelle machine virtuelle il faudrait utiliser la manip des alternatives pour les liens suivants :

java
policytool
rmid
xulrunner-1.9-javaplugin.so
javaws
unpack200
servertool
tnameserv
jexec
pack200
rmiregistry

Petite précision : je suis sous Hardy, le paquet sun-java6-plugin n'est pas dispo.

Hors ligne

#36 Le 27/05/2009, à 13:46

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

malib a écrit :

Je n'ai pas poussé plus loin, mais j'ai bien l'impression que pour bien utiliser sa nouvelle machine virtuelle il faudrait utiliser la manip des alternatives pour les liens suivants :

java
policytool
rmid
xulrunner-1.9-javaplugin.so
javaws
unpack200
servertool
tnameserv
jexec
pack200
rmiregistry

Petite précision : je suis sous Hardy, le paquet sun-java6-plugin n'est pas dispo.

De mon côté, sous xubuntu Jaunty, j'ai les liens suivant dans /etc/alternatives qui pointent vers un dossier "java" :

draco@13:40:49 [0] <0>:/etc/alternatives$ file * | grep java
java:                         symbolic link to `/usr/lib/java/jre1.6.0_14/bin/java'
javaws:                       symbolic link to `/usr/lib/java/jre1.6.0_14/bin/javaws'
jexec:                        symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/lib/jexec'
jexec-binfmt:                 symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/lib/jar.binfmt'
keytool:                      symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/keytool'
keytool.1.gz:                 symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/keytool.1.gz'
orbd:                         symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/orbd'
orbd.1.gz:                    symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/orbd.1.gz'
pack200:                      symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/pack200'
pack200.1.gz:                 symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/pack200.1.gz'
pluginappletviewer:           symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/pluginappletviewer'
policytool:                   symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/policytool'
policytool.1.gz:              symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/policytool.1.gz'
rmid:                         symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/rmid'
rmid.1.gz:                    symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/rmid.1.gz'
rmiregistry:                  symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/rmiregistry'
rmiregistry.1.gz:             symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/rmiregistry.1.gz'
servertool:                   symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/servertool'
servertool.1.gz:              symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/servertool.1.gz'
tnameserv:                    symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/tnameserv'
tnameserv.1.gz:               symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/tnameserv.1.gz'
unpack200:                    symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/bin/unpack200'
unpack200.1.gz:               symbolic link to `/usr/lib/jvm/java-6-openjdk/jre/man/man1/unpack200.1.gz'

Ensuite je n'ai que l'alternative "xulrunner" pas de "xulrunner-1.9-javaplugin.so".
Et le lien déclaré est assez difficile à suivre mais ne pointe pas vers la librairie.

Je ne connais pas bien le fonctionnement de update-alternative, mais peut-on déclarer n'importe quel lien symbolique avec ?

Hors ligne

#37 Le 27/05/2009, à 20:57

Manu_95

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Bonsoir.

Pour info la version 6_013 est à présent disponible en 64 bits dans les dépôts ainsi que les plugins. Paquets Installés avec apt-get puis test sur http://java.com/fr/download/help/testvm.xml : ca marche !

Cordialement,


Manu.
(1) Desktop : Ubuntu 10.04  - desktop 64bits / Core 2 Duo E6420 @2.13 GHz - 6Go DDR2 - NVIDIA GeForce 8600GTS
(2) Netbook : Ubuntu 9.10 - UNR / Asus EeePC 1000H

Hors ligne

#38 Le 27/05/2009, à 21:26

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Manu_95 a écrit :

Bonsoir.

Pour info la version 6_013 est à présent disponible en 64 bits dans les dépôts ainsi que les plugins. Paquets Installés avec apt-get puis test sur http://java.com/fr/download/help/testvm.xml : ca marche !

Cordialement,

Je suppose que tu parle du paquet sun-java6-plugin ...
Si c'est le cas, j'en ai déjà parlé dans la page du wiki, mais le problème c'est qu'il n'est pas dispo sous Intrepid, voir pas dispo sous Hardy non plus (d'après les commentaires ci-dessus).

Hors ligne

#39 Le 27/05/2009, à 22:40

Manu_95

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

Je suppose que tu parle du paquet sun-java6-plugin ...
Si c'est le cas, j'en ai déjà parlé dans la page du wiki, mais le problème c'est qu'il n'est pas dispo sous Intrepid, voir pas dispo sous Hardy non plus (d'après les commentaires ci-dessus).

Effectivement j'ai un peu survolé le début du tuto roll désolé.

Et pour la dispo dans les dépôts tu as raison :
http://packages.ubuntu.com/search?suite=hardy&section=all&arch=any&searchon=names&keywords=sun-java6-plugin
http://packages.ubuntu.com/search?suite=intrepid&section=all&arch=any&searchon=names&keywords=sun-java6-plugin
http://packages.ubuntu.com/search?suite=jaunty&section=all&arch=any&searchon=names&keywords=sun-java6-plugin

Le tuto garde donc toute son utilité smile

Cordialement,


Manu.
(1) Desktop : Ubuntu 10.04  - desktop 64bits / Core 2 Duo E6420 @2.13 GHz - 6Go DDR2 - NVIDIA GeForce 8600GTS
(2) Netbook : Ubuntu 9.10 - UNR / Asus EeePC 1000H

Hors ligne

#40 Le 28/05/2009, à 12:54

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Je suis étonné de ne pas avoir eu plus de retour sur la création du tuto dans ce topic.
Sur la Mailing List du wiki , le tuto a été plutôt descendu en premier abord sad

@ Manu_95
Au final, je suppose que tu n'as pas installé la verion béta présentée ici.
Donc si jamais tu rencontre un problème sur un site, ça serait de nous en faire part ici même pour comparer avec ceux qui ont installé la version béta.

Hors ligne

#41 Le 28/05/2009, à 22:11

Manu_95

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

Je suis étonné de ne pas avoir eu plus de retour sur la création du tuto dans ce topic.
Sur la Mailing List du wiki , le tuto a été plutôt descendu en premier abord sad

Pour les retours sur la mailing list je viens de les parcourir rapidement. Je pense que le retour négatif est lié au fait que ton tuto a été interprété par certains comme "vous voulez java sur un Ubuntu 64 bits => voilà comment installer le java de sun qui est le seul plugin valable".

Une réaction un peu brutale je trouve car le tuto n'affiche pas cette prétention et propose simplement une astuce pour installer ce plugin - si l'utilisateur le souhaite ! Je ne vais pas renter dans le vieux débat des logiciels proprio - même partiellement - sur Linux. Mon opinion - qui n'engage que moi - est que la possibilité de faire fonctionner du proprio sous Linux favorise sa diffusion auprès du grand public. Le fait est que certains sites - peut être non-conformes aux standarts - ne fonctionne pas (encore) correctement avec les solutions java 100% libres.

Mais je m'écarte du sujet. Pour le tuto dans sa forme actuelle, je n'ai pas de remarques agressives à faire smile Simplement :
- un peu plus insister au début du tuto sur les solutions alternatives : un lien sur http://doc.ubuntu-fr.org/java (penser également à connecter ton tuto depuis cette page) et quelques mots suffiront amplement
- pour la vérification des plugins sous Konqueror je peux te filer un coup de main (je suis sous KDE) si tu veux ...
- "Indiquer le chemin de la librairie java au navigateur" => pour info le lien symbolique marche également pour konqueror (cf. ma réponse à la 2ème partie de ton message)

draco31.fr a écrit :

@ Manu_95
Au final, je suppose que tu n'as pas installé la verion béta présentée ici.
Donc si jamais tu rencontre un problème sur un site, ça serait de nous en faire part ici même pour comparer avec ceux qui ont installé la version béta.

Que nenni ! En fait j'ai commençé par la beta 1.6.14 qui ne m'a posé aucun problème (sauf pour la déclaration d'impôts mais cas très particulier ...). Cela fonctionne très bien sous Firefox et Konqueror.
Le paquet étant enfin dispo j'ai préféré une install en deb dans les règles de l'art et j'ai désinstallé la bêta. Pour le moment je ne remarque pas de différences mais si tu as une liste de sites réputés problématiques à me soumettre c'est avec plaisir que je testerai (enfin en fonction de mon planning).

Cordialement,


Manu.
(1) Desktop : Ubuntu 10.04  - desktop 64bits / Core 2 Duo E6420 @2.13 GHz - 6Go DDR2 - NVIDIA GeForce 8600GTS
(2) Netbook : Ubuntu 9.10 - UNR / Asus EeePC 1000H

Hors ligne

#42 Le 28/05/2009, à 23:07

malib

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

Je suis étonné de ne pas avoir eu plus de retour sur la création du tuto dans ce topic.
Sur la Mailing List du wiki , le tuto a été plutôt descendu en premier abord sad

Sympa !

Moi en tout cas, que ce soit ce topic on la version wiki que j'ai parcourue, je pense qu'elle est nécessaire.
En effet, pour faire la déclaration d'impôts cette année, il faut la JRE de Sun, sinon on a un beau message d'erreur qui vous dit que vous n'avez pas de JVM ! (alors que j'avais essayé avec icedtea-gcjwebplugin et icedtea-java7-plugin qui fonctionnaient parfaitement par ailleurs)

Donc merci pour le tuto et la version wiki.

Hors ligne

#43 Le 29/05/2009, à 20:43

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Manu_95 a écrit :

Mais je m'écarte du sujet. Pour le tuto dans sa forme actuelle, je n'ai pas de remarques agressives à faire smile Simplement :
- un peu plus insister au début du tuto sur les solutions alternatives : un lien sur http://doc.ubuntu-fr.org/java (penser également à connecter ton tuto depuis cette page) et quelques mots suffiront amplement
- pour la vérification des plugins sous Konqueror je peux te filer un coup de main (je suis sous KDE) si tu veux ...
- "Indiquer le chemin de la librairie java au navigateur" => pour info le lien symbolique marche également pour konqueror (cf. ma réponse à la 2ème partie de ton message)

J'ai déjà rattaché le tuto à la page java dans ce paragraphe : http://doc.ubuntu-fr.org/java#je_souhai … navigateur
Pour insister sur les versions alternatives, je veux bien votre coup de main, parce que à priori je suis pas bon à ce jeu là !! big_smile
Je suis parti du principe que l'utilisateur arrive sur le tuto via la page "java" de la doc, donc qu'il rencontre déjà des problèmes... mais un rappel ferait pas de mal, si c'est faisable sans trop surcharger la page.

Pour la vérification, je veux bien que tu m'indique si la page "about:plugins" fonctionne sous Konqueror.
Sous firefox pas de problème, mais sous Opera, la page en question n'affiche pas la partie Java, même après l'installation.
Donc là aussi, je ne sais pas comment vérifier qu'une JVM est déjà installée.

Pour le lien symbolique, ça veut dire que Konqueror utilise aussi xulrunner ?
Si c'est bien de ça dont tu parle, alors je rajouterai "Pour Firefox et Konqueror ..."

sudo ln -s /usr/lib/java/jre1.6*/lib/amd64/libnpjp2.so /usr/lib/xulrunner-addons/plugins/.

Par ailleurs, la page du wiki n'est pas verrouillée, donc n'hésitez pas à apporter votre petite touche perso !
(Au pire y a l'historique pour revenir en arrière !)

Hors ligne

#44 Le 02/06/2009, à 20:20

Manu_95

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

J'ai déjà rattaché le tuto à la page java dans ce paragraphe : http://doc.ubuntu-fr.org/java#je_souhai … navigateur

draco31.fr a écrit :

Pour insister sur les versions alternatives, je veux bien votre coup de main, parce que à priori je suis pas bon à ce jeu là !! big_smile
Je suis parti du principe que l'utilisateur arrive sur le tuto via la page "java" de la doc, donc qu'il rencontre déjà des problèmes... mais un rappel ferait pas de mal, si c'est faisable sans trop surcharger la page.

Je sens une pointe d'amertume lol Bon je vais voir si l'on peut insister un peu plus ...

draco31.fr a écrit :

Pour la vérification, je veux bien que tu m'indique si la page "about:plugins" fonctionne sous Konqueror.
Sous firefox pas de problème, mais sous Opera, la page en question n'affiche pas la partie Java, même après l'installation.
Donc là aussi, je ne sais pas comment vérifier qu'une JVM est déjà installée.

Oui, "about:plugins" fonctionne sous Konqueror mais la reconnaisance du module java n'est pas si triviale que ca. Par ailleurs, il faut en fait configurer un petit peu konqueror (je viens de m'en apercevoir). Je met la page à jour à ce sujet.

draco31.fr a écrit :

Pour le lien symbolique, ça veut dire que Konqueror utilise aussi xulrunner ?
Si c'est bien de ça dont tu parle, alors je rajouterai "Pour Firefox et Konqueror ..."

Comme je l'ai précisé plus haut je me suis un peu emballé : la démarche sous konqueror est un poil différente (mais très logique). Plutôt que de palabrer je vais directement mettre à jour la page.

EDIT : j'ai mis à jour la page mais j'ai un doute sur le chemin du binaire java désigné sous Konqueror (sr/lib/java/jre1.6*/bin/java) : peux tu le vérifier de ton côté STP ?

Cordialement,

Dernière modification par Manu_95 (Le 02/06/2009, à 20:56)


Manu.
(1) Desktop : Ubuntu 10.04  - desktop 64bits / Core 2 Duo E6420 @2.13 GHz - 6Go DDR2 - NVIDIA GeForce 8600GTS
(2) Netbook : Ubuntu 9.10 - UNR / Asus EeePC 1000H

Hors ligne

#45 Le 03/06/2009, à 20:42

Cémoidon

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

bonjour ,


Je viens d'installer java et j'ai choisi le paquet sun-java6-plugin de synaptic après avoir lu le tuto ( merci pour les explications claires )
Puis je me suis rendu sur la page de test de sun qui ne freeze pas chez moi même en descendant tout en bas de la page .
Tout n'est pas parfait pour autant , le Dancing Duke animé s'affiche de manière très saccadée et par intermittences dans un carré noir la plupart du temps , mais qui laisse parfois entrevoir des éléments d'un autre onglet du navigateur ( firefox 3.0.10)


capturevlv.png

Par curiosité j'ai affiché le même site avec une machine windows et l'affichage du Dancing Duke animé est fluide sur le fond blanc de la page sans cet encadrement noir  ( Internet explorer 8 )

dancingduke.png

Pensez vous qu'il y ait un moyen d'améliorer les choses  ? , faut il désinstaller le plugin nouvellement installé et tenter le beta 64 bits du tuto ?
Si oui la désinstall du plugin via synaptic ( qui ne désinstalle pas les dépendances ) suffit elle ?

Merci de vos réponses smile

[Edit]

Je me réponds en partie à moi même .
J'ai fait le premier essai ( celui de l'illustration ) avec les effets visuels sur ' extra '
en supprimant les effets visuels le carré noir disparait mais le dancing duke flashe , a des mouvements saccadés et disparait par moment .
Je n'ai ou n'avais jusqu'à ce moment pas de problème particulier avec mon circuit graphique ( Intel ICH8 )

Je précise que la machine windows est un vieux portable avec un pentium M et 512 Mo de RAM alors que la machine Linux bien plus récente est équipée d'un core2 avec 3 Go de ram . Ces deux machines utilisent le circuit graphique de la carte mère .

Dernière modification par TChatenet (Le 03/06/2009, à 20:53)

Hors ligne

#46 Le 04/06/2009, à 18:02

Cémoidon

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Bonsoir ,

Je m'interroge .
J'ai installé hier le plugin java et aujourd'hui mon affichage est hésitant .
Une application pourtant peu gourmande à priori comme free cell n'est plus affichée correctement , le déplacement des cartes est devenu haché .
Soupçonnant le plugin nouvellement installé je ferme firefox et miracle , tout fonctionne à nouveau normalement .
Je relance firefox et de nouveau l'affichage est haché voire incomplet .

Moralité : Le plugin java semble poser un problème à mon circuit graphique .
Cela vous parait il possible ?
Dois je chercher ailleurs ?

merci de vos réponses

Hors ligne

#47 Le 04/06/2009, à 18:51

Cémoidon

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Bon , j'ai supprimé java et tout fonctionne à nouveau normalement .

Quelqu'un peut il me dire à quoi sert java ?
J'ai vu que open office peut l'utiliser , mais à ce jour je n'avais pas java et open office fonctionne normalement .
j'ai vu que le site des impots utilisait un applet java , existe t il d'autres sites nécessitant ce plugin ? sur les sites que je fréquente habituellement il ne m'a pas semblé que cet applet soit nécessaire ?

merci de vos réponses

Hors ligne

#48 Le 04/06/2009, à 23:43

draco31.fr

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

Tout d'abord, ça nous aiderai si tu pouvais préciser ta version (Hardy, Intrepid ...) et ta variante (Ubuntu, Kubuntu ...).
Il y a peut-être un problème avec Compiz / Gnome + les applets java.

Sinon, Java (plugin) n'est lancé que si tu visite un page web avec un applet java intégré.
Donc lancer Firefox sans plus, ne devrait pas faire ramer le reste du PC (surtout si tu n'as qu'un onglet "google" d'ouvert !).
Après, selon ta version d'Ubuntu, il est possible que le plugin java passe par une émulation 32 bits, qui peux entrainer de serieux problèmes (lags, plantages ...).

Pour ce qui est de l'uilité de Java, il y en a plusieurs :
Certains logiciels sont en Java : il te faut absoluement un JRE (Java Runtime Environment) fonctionnel pour les lancer. Ce JRE peut être OpenJDK dans la plupart des cas ça ne pose pas problème.
Certains logiciels "font" du java : cas des fonctionnalités supplémenaires offertes par OpenOffice.
En gros, si le logiciel peut utiliser java c'est mieux, mais il sait faire sans.
Là encore, on parle d'un JRE installé.
Enfin, il y a les applet/plugin java, qui sont une sorte d'application java lancée depuis le net.
Pour ceux-là il faut un JRE d'installé et parfois des paquets en plus : java6-plugin par exemple.
Certains applets/plugins sont plus restrictifs que d'autres, et demandent donc d'avoir le JRE+plugin de Sun d'installé (i.e. ne fonctionnent pas avec OpenJDK).
Il semble que se soit le cas pour la page des impôts.

Cela dit, si tu peux voir l'intégralité des sites web, que tu ne rencontres pas de problème avec des plugins qui ne veulent pas tourner, c'est que ton installation de java est OK.
Tu n'as pas de raison d'installer le plugin java 64 bits béta.
En gros, si jamais tu avais besoin de la béta, tu le saurais parce que tu rencontrerais des problèmes flagrants.

Hors ligne

#49 Le 05/06/2009, à 05:10

Cémoidon

Re : Sun offre enfin le Java Plug-in 64-bit pour Linux

draco31.fr a écrit :

Tout d'abord, ça nous aiderai si tu pouvais préciser ta version (Hardy, Intrepid ...) et ta variante (Ubuntu, Kubuntu ...).
Il y a peut-être un problème avec Compiz / Gnome + les applets java.

Sinon, Java (plugin) n'est lancé que si tu visite un page web avec un applet java intégré.
Donc lancer Firefox sans plus, ne devrait pas faire ramer le reste du PC (surtout si tu n'as qu'un onglet "google" d'ouvert !).
Après, selon ta version d'Ubuntu, il est possible que le plugin java passe par une émulation 32 bits, qui peux entrainer de serieux problèmes (lags, plantages ...).

Pour ce qui est de l'uilité de Java, il y en a plusieurs :
Certains logiciels sont en Java : il te faut absoluement un JRE (Java Runtime Environment) fonctionnel pour les lancer. Ce JRE peut être OpenJDK dans la plupart des cas ça ne pose pas problème.
Certains logiciels "font" du java : cas des fonctionnalités supplémenaires offertes par OpenOffice.
En gros, si le logiciel peut utiliser java c'est mieux, mais il sait faire sans.
Là encore, on parle d'un JRE installé.
Enfin, il y a les applet/plugin java, qui sont une sorte d'application java lancée depuis le net.
Pour ceux-là il faut un JRE d'installé et parfois des paquets en plus : java6-plugin par exemple.
Certains applets/plugins sont plus restrictifs que d'autres, et demandent donc d'avoir le JRE+plugin de Sun d'installé (i.e. ne fonctionnent pas avec OpenJDK).
Il semble que se soit le cas pour la page des impôts.

Cela dit, si tu peux voir l'intégralité des sites web, que tu ne rencontres pas de problème avec des plugins qui ne veulent pas tourner, c'est que ton installation de java est OK.
Tu n'as pas de raison d'installer le plugin java 64 bits béta.
En gros, si jamais tu avais besoin de la béta, tu le saurais parce que tu rencontrerais des problèmes flagrants.

Merci de ta réponse .
J'utilise Ubuntu jaunty 64 bits (2.6.28-11-generic  ) installation standard régulièrement mis à jour .
par défaut je n'ai aucune installation de java sur mon système . du moins mon installation d'open office ne détecte pas de java dans outils - options - java , et il n'y a pas de plugin java dans firefox ( about:plugins).
Je ne m'en étais jamais rendu compte , peut être parce que j'ai une utilisation assez basique de mon ordi ( quelques tableurs , courriers et mails , quelques sites webs surtout d'actualités , rythmbox , f-spot et gnucash ).
En installant le plugin java 6 des dépots , synaptic m'avait aussi installé un bin et un jre .
Après cette installation java était détecté par open office et firefox , mais comme dit plus haut mon affichage en souffrait pourvu que firefox soit ouvert . J'avais effectivement laissée ouverte la page de test de la machine java de sun (http://java.com/fr/download/help/testvm.xml) qui est la seule page web que je connaisse utilisant java de manière certaine ( je n'ai pas essayé le site des impôts ) .
Comme dit plus haut l'affichage de cette page n'était pas parfait , mais s'améliorait pour peu que je supprime les effets visuels de l'affichage .
J'ai bien pensé à un problème de driver de circuit graphique , mais à priori mon installation n'en utilise pas et je n'ai pas trouvé sur le web de driver spécifique linux pour le circuit intel 82G965 , subsystem asustek computer device 81ea selon sysinfo .

Hors ligne

Haut de page ↑