Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#51 Le 06/05/2009, à 08:56

Bigfoot77210

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Je ne comprend pas bien les gens qui dise que c'est pareil avec une unité différente, vu qu'avec 3 giga de ram Ubuntu m'affiche bien 3 GIO, avec 2 giga de ram dans le PC il m'affiche 2 GIO, Pourquoi seulement avec 4 go de ram il afficherais 3,8 GIO ?

Ils appliquent un changement d'unité qui n'est valable (grosso-modo) que pour les disques durs. Mais certainement pas pour les barrettes de RAM.
C'est compréhensible, on se fait tellement entourlouper.

Dernière modification par Bigfoot77210 (Le 06/05/2009, à 08:57)


Faire des fautes de grammaire montre que l'on ne comprend pas ce que l'on écrit.
CPU: Athlon 5000+ 64X2 RAM: 2x1Go GPU: nVidia 8600GT Alim: 80Plus Bronze
Intrepid Ibex 8.10 32bits

Hors ligne

#52 Le 29/05/2009, à 18:00

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Je me permet de remonter le sujet :-\
3.8go au lieu de 4
le noyau server ne fonctionne pas, on dirai que X essaye de se lancer, ca affiche quelque chose d'étrange, puis figage complet, même les commande noyaux ne repondent plus.


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#53 Le 29/05/2009, à 18:41

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

loicm54 a écrit :

Je me permet de remonter le sujet :-\
3.8go au lieu de 4
le noyau server ne fonctionne pas, on dirai que X essaye de se lancer, ca affiche quelque chose d'étrange, puis figage complet, même les commande noyaux ne repondent plus.

Tu utilises les pilotes propriétaires habituellement ?
Si oui, ben change ton xorg.conf en remplaçant "fglrx" par "ati" et désinstalle puis réinstalle les Catalyst.
Si non, ben je sais pas ...

#54 Le 29/05/2009, à 18:44

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

le server a quoi de différent par rapport au géneric, ça ne risque pas de creer des problèmes ?


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#55 Le 29/05/2009, à 18:53

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

loicm54 a écrit :

le server a quoi de différent par rapport au géneric, ça ne risque pas de creer des problèmes ?

Absolument aucune idée, de toute façon il te donne déjà accès à tes 4Go de RAM pour le reste ça doit pas trop changer, c'est toujours le même code avec quelques options différentes lors de la compilation non

Non ça ne risque pas de créer de problèmes, ça faire comme passer de la version 2.6.28-9 à la 2.6.28-11, c'est juste les pilotes propriétaire qu'il faudra désinstaller et recompiler pour le nouveau noyau. Cela expliquerait pourquoi ton écran se fige au démarrage. smile

Dernière modification par Heliox (Le 29/05/2009, à 18:59)

#56 Le 30/05/2009, à 13:07

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

les pilotes proprio ont été installé via les depots, et un systeme dont je n'arrive plus a me rappeller le nom, est chargé de "recompiler" (?) ce drivers a chaques changements de noyau automatiquement.

edit: apparement il me manquai les header, (?) je re-test

Dernière modification par loicm54 (Le 30/05/2009, à 13:09)


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#57 Le 30/05/2009, à 19:14

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Pas mieu avec le kernel server, toujours 3.8gio :-\


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#58 Le 02/06/2009, à 09:13

Bigfoot77210

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Je suis surpris que l'on puisse autant se fatiguer pour récupérer 5% de RAM voire moins dans certains cas. Si 200Mo de RAM sont si importants, ajoute 2Go et installe une version ubuntu 64bits.
Là, si tu ne vois pas tes Go supplémentaires, le problème deviendra enfin intéressant et on pourra s'y prendre la tête avec plus de satisfaction.


Faire des fautes de grammaire montre que l'on ne comprend pas ce que l'on écrit.
CPU: Athlon 5000+ 64X2 RAM: 2x1Go GPU: nVidia 8600GT Alim: 80Plus Bronze
Intrepid Ibex 8.10 32bits

Hors ligne

#59 Le 02/06/2009, à 18:37

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

je suis sous 64bits hein !

et c'est pas plus pour le fait de recuperer ces 200mo qui me seront peu utile, mais plutot pour comprendre le pourquoi tu comment, car ca m'intrigue. Après bien sur, on peut se moquer de tout...


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#60 Le 02/06/2009, à 20:53

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Ça a doit être une sorte de cache que se réserve le noyau et dont le moniteur système ne s'en rend pas compte. hmm

C'est pas normal que 200Mo disparaissent tout seul lol

#61 Le 02/06/2009, à 23:17

RedLemon

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

quelqu'un a tester de desinstaler les drivers de la carte graphique propiétaire puis de regarder ci il y a bien 4go ?


« Je suis probablement l'inventeur de la combinaison Ctrl-Alt-Suppr, mais c'est Bill Gates qui l'a rendue célèbre ».
« I may have invented Control-Alt-Delete, but Bill Gates made it famous »
David Bradley
Mes wikis : http://doc.ubuntu-fr.org/utilisateurs/redlemon

Hors ligne

#62 Le 02/06/2009, à 23:25

Roggan

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Je donne juste une indication au passage :

Certaine carte mère avec carte graphique intégrée allouent une quantité de mémoire au GPU. Cette quantité peut être réglée dans le bios, mais elle est "prise" sur la quantité totale de mémoire. Personnellement ça à été la "source" de l'affichage de 3.8 au lieu de 4 Go de ram sous ubuntu 64bits. (Une fois une carte dédiée installée, l'affichage est passé à 4, vu que la carte mère n'allouait plus rien au chip graphique intégré).

Hors ligne

#63 Le 03/06/2009, à 00:14

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

sous win x64 en double doot, j'ai bien 4 Gio de reconnu et adressables
j'ai uniquement une carte dédié avec de la mémoire dédié !


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#64 Le 03/06/2009, à 10:12

Bigfoot77210

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Mais non, je ne me moque pas vraiment, je respecte la curiosité, d'autant que c'est mon boulot la curiosité.
Mais dans le cas où il s'agit de récupérer 200Mo sur 4GiO alors oui, il pourrait bien y avoir de la moquerie. Et là encore, je reste sceptique, il s'agit surtout de lassitude. D'autant que ça à l'air de varier d'un matériel à l'autre. Il suffit de voir ce que vient de dire Roggan.

Si ça se trouve, Win x64 fait une simple lecture de ce qu'indique le BIOS alors qu'Ubuntu détermine ce qui est réellement adressable. Finalement, qui peut savoir?
Il faudrait essayer une autre distribution linux pour voir si c'est pareil, et même dans ce cas, on ne sera pas vraiment fixé. Si la distrib ne fait que lire ce que dit le BIOS, nous ne serons pas avancé. Par contre, si elle nous affiche 3,8 GiO ou 3,*GiO de libre, ça peut être intéressant.

À voire. De mon côté, n'ayant pas 4GiO de RAM, ce n'est pas des expériences que je peux faire.


Faire des fautes de grammaire montre que l'on ne comprend pas ce que l'on écrit.
CPU: Athlon 5000+ 64X2 RAM: 2x1Go GPU: nVidia 8600GT Alim: 80Plus Bronze
Intrepid Ibex 8.10 32bits

Hors ligne

#65 Le 06/06/2009, à 13:04

zeoli

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Salut à tous,

moi je suis en 32 bit et du coup, j'ai 2,8 gb au lieu de 3,8. c'est normal mais y-a-t-il une solution pour récupérer ce giga ? j'ai essayé linux image server mais du coup, la carte graphique ne fonctionne plus.

Que faire ?

Patrick


La propriété privée nous a rendus si stupides et si bornés qu'un objet n'est nôtre que lorsque nous le possédons.

Hors ligne

#66 Le 06/06/2009, à 13:45

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

pour la carte graphique qui fonctionne c'est normal, faut réinstaller le pilote à chaque changement de noyau.

Donc retourne sur l'ancien noyau par défaut.
Puis dans gestionnaire de pilotes propriétaires
décoche la carte pour ta carte graphique, cela va désinstaller le pilote normalement.
Déconnecte-toi puis reconnecte-toi pour vérifier si tu obtiens un bureau "potable" (sans accélération graphique donc)
Ensuite, redémarre sur le noyau serveur sur lequel le bureau devrait apparaître correctement, de là il ne te reste plus qu'à réinstaller le pilote propriétaire de ta carte graphique (toujours depuis le gestionnaire de pilotes propriétaires)

Le problème vient du pilote qui est compilé pour ne marcher que sur un noyau précis (celui avec lequel il est compilé) et que le noyau serveur n'accepte pas, il faut donc réinstaller ce pilote avec ce nouveau noyau serveur.

Il me semble que c'est ça, chez moi ça a marché (même si j'ai pas 4Gigos de RAM), évidemment si j'ai faux, n'hésitez pas à me corriger smile

Dernière modification par Heliox (Le 06/06/2009, à 13:47)

#67 Le 06/06/2009, à 18:59

brakbabord

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

loicm54 a écrit :

sous win x64 en double doot, j'ai bien 4 Gio de reconnu et adressables
j'ai uniquement une carte dédié avec de la mémoire dédié !

Non, Windows reconnait 4Go et non pas 4Gio.
Ce n'est pas du chipotage, ces deux unités sont différentes.

4Go=3,8Gio à mon avis c'est ça l'explication.

Dernière modification par brakbabord (Le 06/06/2009, à 19:00)

Hors ligne

#68 Le 06/06/2009, à 19:11

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

+1

#69 Le 06/06/2009, à 22:34

brakbabord

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Pendant un moment j'avais calculé qu'entre Gio et Go il y avait 7% d'écart.

D'après mon calcul 4Go font donc 3,72Gio. Peut-être que le système arrondi à 3,8Gio, ou alors qu'il y a un peu plus de 4Go.

Hors ligne

#70 Le 07/06/2009, à 00:37

loicm54

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

ça a déja été dit, mais non !
les DD sont vendu réélement avec des capacité exprimés en Go

La ram elle, est vendu avec des unité exprimés en Gio, mais dites "Go" par abus de language.
Ca serai on ne peu plus débile de prendre des capacité non puissance de 2 pour la memoire, ça serai des bits du bus d'adressage de gachés...
d'ailleur quand on prend un barrette de 2 "go", tout systeme la presente en tant que barette de 2048 "mo"/"mio".

Heliox=> il n'y a plus jamais besoin de recompiler les pilotes a la main, même ceux provenant d'une install a partir du .run, tout se fait automatiquement.
concernant le soucis de zeoli, comme je l'ai dit plus haut, il manque juste les header du noyau server...

Dernière modification par loicm54 (Le 07/06/2009, à 01:24)


ubuntu 9,04 jaunty/ core2duo E8400@3.6Ghz / hd4850 Golden Sample

Hors ligne

#71 Le 07/06/2009, à 09:24

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

loicm54 a écrit :

Heliox=> il n'y a plus jamais besoin de recompiler les pilotes a la main, même ceux provenant d'une install a partir du .run, tout se fait automatiquement.
concernant le soucis de zeoli, comme je l'ai dit plus haut, il manque juste les header du noyau server...

Ah bon ... ben ça changé depuis l'époque pù on faisait encore tout manuellement cool
Faut que je me remette à jour neutral
(je commence le télélchargement tongue)

#72 Le 07/06/2009, à 13:16

zeoli

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Heliox a écrit :

pour la carte graphique qui fonctionne c'est normal, faut réinstaller le pilote à chaque changement de noyau.

Donc retourne sur l'ancien noyau par défaut.
Puis dans gestionnaire de pilotes propriétaires
décoche la carte pour ta carte graphique, cela va désinstaller le pilote normalement.
Déconnecte-toi puis reconnecte-toi pour vérifier si tu obtiens un bureau "potable" (sans accélération graphique donc)
Ensuite, redémarre sur le noyau serveur sur lequel le bureau devrait apparaître correctement, de là il ne te reste plus qu'à réinstaller le pilote propriétaire de ta carte graphique (toujours depuis le gestionnaire de pilotes propriétaires)

Le problème vient du pilote qui est compilé pour ne marcher que sur un noyau précis (celui avec lequel il est compilé) et que le noyau serveur n'accepte pas, il faut donc réinstaller ce pilote avec ce nouveau noyau serveur.

Il me semble que c'est ça, chez moi ça a marché (même si j'ai pas 4Gigos de RAM), évidemment si j'ai faux, n'hésitez pas à me corriger smile

ça marche pas.

en fait, je désinstalle le pilote nvidia, je me déconnecte, je me reconnecte sur le noyau serveur et là, j'ai bien les 4 gigas mais pas moyen d'installer le pilote, pire quand je relance, une erreur est affichée et j'ai plus de bureau du tout, je suis en mode console. je re=relance sur l'ancien noyau et là, surprise : le pilote est toujours installé.


Je suis un peu perdu


La propriété privée nous a rendus si stupides et si bornés qu'un objet n'est nôtre que lorsque nous le possédons.

Hors ligne

#73 Le 07/06/2009, à 13:29

brakbabord

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

Si si, pour le .run il faut le réinstaller à chaque mise à jour du noyau.

Par contre si tu utilises les pilotes des dépôts (via l'interface "Pilotes de périphériques") là tu n'as pas besoin. Avant les pilotes étaient mis à jour en même temps que le noyau, et maintenant ils sont recompilés via dkms (un truc qui automatise la recompilation).

Hors ligne

#74 Le 07/06/2009, à 13:37

Heliox

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

zeoli a écrit :

ça marche pas.

en fait, je désinstalle le pilote nvidia, je me déconnecte, je me reconnecte sur le noyau serveur et là, j'ai bien les 4 gigas mais pas moyen d'installer le pilote, pire quand je relance, une erreur est affichée et j'ai plus de bureau du tout, je suis en mode console. je re=relance sur l'ancien noyau et là, surprise : le pilote est toujours installé.


Je suis un peu perdu

Eh oui, bienvenue dans le bazar des pilotes sous linux neutral
Alors, ce que tu peux faire c'est éditer le fichier /etc/X11/xorg.conf :

gksu gedit /etc/X11/xorg.conf

Cherche la ligne :

    Driver        "nvidia"

et place un # au début de cette ligne, ça donne ça :

#    Driver        "nvidia"

Puis redémarre avec le noyau serveur, si ça marche, poste un message, si ça marche pas, poste quand même un message, et dis quels sont les problèmes big_smile

#75 Le 07/06/2009, à 14:09

zeoli

Re : [Ram] 3.8 Go détécté au lieu de 4 Go

désolé, ça ne marche toujours pas.



patrick


La propriété privée nous a rendus si stupides et si bornés qu'un objet n'est nôtre que lorsque nous le possédons.

Hors ligne

Haut de page ↑