Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 14/07/2009, à 20:07

Fred02840

Problèmes d'affichage sur un iMac G3 350 mHz

Bonjour,

J'ai installé la version "desktop" sur mon vieil iMac bleu (350 mHz, mange-disque), et tout fonctionne bien. Tout, à l'exception de l'affichage.
L'écran (15" CRT) est en 1024 x 768 (4:3), 75 Hz, ce qui me convient parfaitement. Par défaut, l'installation donne une résolution de 800 x 600.
Ce qui me chagrine, c'est l'affichage des couleurs : on se croirait avec une palette réduite à 10 couleurs, et c'est illisible.
J'ai ouvert /etc/X11/xorg.conf, et il y a très peu de détails :

Section "Device"
	Identifier	"Configured Video Device"
	BusID		"PCI:6:3:0"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Là, je sèche... Quelles sont vos suggestions, s'il vous plaît ?

Merci de votre aide,
Fred

Dernière modification par Fred02840 (Le 14/07/2009, à 20:08)


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

#2 Le 15/07/2009, à 08:16

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Salut wink

Quelle version d'Ubuntu ?
Il y a une doc pour la 6.06 : http://doc.ubuntu-fr.org/generalite/live_cd/imacg3
a+


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#3 Le 16/07/2009, à 14:21

Fred02840

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Bonjour,

Effectivement, je n'ai pas mis à jour les versions des ordinateurs et OS que j'utilise.
J'ai installé Jaunty sur mon iMac 350 mHz (je laisse le second, un 333 mHz, avec une version plus ancienne).

Je viens de regarder la documentation. Avec les autres versions utilisées avec mon 350 mHz, en effet, c'est la procédure que je respectais, au moins pour ce qui concerne la modification du fichier /etc/X11/xorg.conf (pour le reste, je n'en savais rien).
Mais avec le live-CD de Jaunty, il n'y a plus d'écran noir : cela peut être ressenti comme un progrès, mais il n'y a plus moyen d'afficher une console et de modifier les fichiers. J'ai essayé, mais en vain.

À bientôt,
Frédéric


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

#4 Le 16/07/2009, à 18:05

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Il faut que trouves la version d'ubuntu qui fonctionne le mieux. Malheureusement c'est pas forcément la dernière...
J'ai installé une xubuntu 6.06 sur un imacg3 333 160mo de ram. ça fonctionne bien mais ça reste un peu lent...


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#5 Le 16/07/2009, à 23:39

Fred02840

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Oui, bien sûr. J'ai commencé avec la 6.06, moi aussi, et ce n'était pas bien rapide. Mais j'ai vu quelques essais de changement du disque dur (rien à voir avec la apidité, bien sûr), de la carte-mère, etc., pour améliorer les choses.
Mais c'est une perspective que je n'ai pas : j'ai un PowerBook G4 qui fonctionne très bien (sauf en ce moment : le câble d'alimentation s'est cassé), avec Jaunty. L'iMac (les deux) servent à dépanner des copains, ou moi-même.
La Feisty donnait de bons résultats sur l'iMac 350 : je vais y repasser...

À bientôt,
Fr.

Dernière modification par Fred02840 (Le 16/07/2009, à 23:40)


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

#6 Le 17/07/2009, à 09:49

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Ubuntu 7.04 n'est plus maintenue depuis octobre 2008, non ?

Si tu as un système 7.04 d'installé depuis un moment, tu aurais plus simple à faire une copie de disque à disque depuis un pc via un live cédé.

Depuis un terminal :
sudo fdisk -l (pour connaitre le nom de tes disques, attention aux maitre-esclaves s'ils ont la même capacité !)
sudo dd if=/dev/hda of=/dev/hdb bs=1024 (à adapter selon le cas)
a+


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#7 Le 17/07/2009, à 13:10

Fred02840

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Mouais, ben, je l'ai détruite, la Feisty. Donc, je n'ai pas le choix : j'irai voir du côté de la 8.04 ou de la 8.10.
Je garde ta procédure en tête : ça pourrait servir. Merci.

À bientôt,
Fred


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

#8 Le 18/07/2009, à 22:11

gagoune

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Fred02840 a écrit :

Bonjour,

J'ai installé la version "desktop" sur mon vieil iMac bleu (350 mHz, mange-disque), et tout fonctionne bien. Tout, à l'exception de l'affichage.
L'écran (15" CRT) est en 1024 x 768 (4:3), 75 Hz, ce qui me convient parfaitement. Par défaut, l'installation donne une résolution de 800 x 600.

Salut Fred !

J'ai eu un problème similaire sur un iMac DV (400 MHz). En gros, par défaut, en 1024x768, l'iMac ne peut afficher en millions de couleurs, il faut se 'contenter' des milliers de couleurs. pour cela, il faut renseigner correctement ton /etc/X11/xorg.conf :
(je n'ai pas le xorg.conf de l'imac sur lequel je l'ai fait sous la main donc je tente de te redonner les infos dont je me souviens)

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI Technologies, Inc. Rage 128 PR/PRO (AGP TMDS)"
    Monitor        "iMac"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        32
        Modes        "800x600" "640x480"
    EndSubSection
EndSection

Mais du coup, je crois qu'il te faudra aussi modifier les sections "Device" et "Monitor" pour que ça soit opérationnel.

Tente toujours t affine si besoin est !

Si tu trouve la bonne combinaison, n'hésite pas à la poster ici !

Bon courage !

Dernière modification par gagoune (Le 18/07/2009, à 22:25)


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#9 Le 19/07/2009, à 09:46

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Il faut savoir que les versions ppc d'ubuntu n'existent plus officiellement depuis la 6.06 (passage du mac au processeur intel)
Ça se trouve que les dépôts sont encore maintenues par la communauté ppc, ça je ne jeux pas te le dire vu que je n'ai pas de machine ppc...

Pour en revenir aux anciennes versions d'ubuntu (cf mes précédents messages), je viens de tester un dépôt pour edgy sur x86, et ça fonctionne ! http://forum.ubuntu-fr.org/viewtopic.php?id=310944
(edgy n'est plus supporté officiellement depuis avril 2008, les dépôts par défaut sont introuvables : erreur 404)

A propos un mac mini ppc m'intéresserait, si quelqu'un en trouve un pas cher wink

A+

Dernière modification par mikedafunk (Le 27/07/2009, à 22:23)


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#10 Le 27/07/2009, à 11:20

gagoune

Re : Problèmes d'affichage sur un iMac G3 350 mHz

mikedafunk a écrit :

Je viens de tester pour edgy sur x86, ça fonctionne ! http://forum.ubuntu-fr.org/viewtopic.php?id=310944
A propos un mac mini ppc m'intéresserait, si quelqu'un en trouve un pas cher wink

Salut...

@Mikedafunk : Excuse-moi... mais je ne vois pas le rapport avec le sujet ! lol

A mon avis tu as dû vouloir le mettre dans un autre sujet plus généraliste sur les PPC ! wink

Fais gaffe, ça fait désordre ! tongue

@Fred02840 : Alors, toujours pas de nouvelle(s) de ton iMac G3 ?

A bientôt !


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#11 Le 27/07/2009, à 12:14

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Non, non, je ne me suis pas trompé. C'est ton message qui fait désordre wink

le rapport est que les anciennes versions d'ubuntu, même si elles ne sont plus supportées officiellement (plus de nouvelles maj de sécurité etc.) ont encore des dépôts actifs (contrairement à ce que je croyais). Et donc du coup il est possible de rajouter des programmes même sur une ancienne version (dapper, edgy, feisty, gutsy voire antérieur !)

Il suffit de modifier les sources (fichier sources.list), mais ça ne je ne peux pas la faire car je n'ai pas de ppc pour sous la main pour tester mais dès que j'ai l'occasion, je testerai avec xubuntu 6.06 ppc (la version desktop n'est plus supportée en théorie depuis juin 2009)

En même temps y a rien d'extraordinaire, un dépôt c'est environ 40Go, qu'est ce que c'est que 40go de nos jours wink

Dernière modification par mikedafunk (Le 27/07/2009, à 22:26)


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#12 Le 28/07/2009, à 13:18

gagoune

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Salut !

Je ne compte pas te faire entendre raison, juste que tu constate que le sujet parle de "Problèmes d'affichage sur un iMac G3 350 mHz" et que quand tu parles de "Je viens de tester pour edgy sur x86, ça fonctionne ! http://forum.ubuntu-fr.org/viewtopic.php?id=310944
A propos un mac mini ppc m'intéresserait, si quelqu'un en trouve un pas cher", je ne vois pas le rapport avec le-dit sujet. wink Sur ce, je considère ce point clôt.

Pour ce qui est des dépôts, c'est vrai qu'il ne sont pas légions... Je crois qu'une liste a été commencée sur le portail Mac, mais il faudrait le compléter, ça aiderait bien !! cool

@+


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#13 Le 28/07/2009, à 13:55

mikedafunk

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Ton dernier message était en effet indispensable et très constructif tongue 
Bon j'avoue que parfois mes idées ne sont pas très claires à l'écrit wink
Mais tu as quand même trouvé, le rapport était bien les dépôts, en particulier les anciens dépôts (tout type d'architecture confondue).

J'ai installé il y a longtemps xubuntu sur un imac g3 d'une de mes nièces : http://mikedafunk.over-blog.org/article-7364566.html.
Je testerai et posterai le résultat des dépôts ppc pour cette version dès que possible...

HS : je cherche un mac mini ppc pour pouvoir y installer AmigaOS4.

Dernière modification par mikedafunk (Le 28/07/2009, à 14:22)


Lubuntu 12.04 sur SSD 64go compaq mini / lubuntu 14.04 sur lenovo S10, tous deux avec 1go
Tu veux de l'aide physique ? Pense à la  liste des GUL ou aux parrains linux | http://mikedafunk.over-blog.org/

Hors ligne

#14 Le 30/07/2009, à 17:55

gagoune

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Salut...

On a toujours pas de nouvelles de Fred et de son iMac... ça sent les vacances lol

Je relance en tout cas pour le test de modification du xorg.conf qui avait permis de faire fonctionner l'iMac DV SE (400MHz) de mon père...

J'espère que ton iMac n'est pas passé par la fenêtre... hmm

@ bientôt... d'avoir des nouvelles de l'affichage... roll


«Chaque manipulation réalisée à l'aide de lignes de commande est un bug qu'il faut corriger» M. Shuttleworth
iBook DV 466MHz (palourde) 320Mo/--Go : (démonté)
iMac (alu : été 2007) 2GHz 20" 4Go/250Go : Snow Leopard
EEE-PC 4G (701) 900MHz 1Go/4Go : Lubuntu 12.04

Hors ligne

#15 Le 04/08/2009, à 16:52

Fred02840

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Merci Gagoune, pour cette réponse.

Je rentre en effet de vacances (bien joué !). J'ai tenté de modifier le fichier /etc/X11/xorg.conf par le tien (en tenant compte de ma carte graphique, bien sûr), mais ce cochon d'iMac n'en veut pas. Au reboot, il veut absolument SES paramètres et rien d'autre. J'ai modifié deux-trois choses dans le même fichier, avec la même réponse.

Je crois qu'il va falloir rétrograder à la dernière LTS (à moins que je trouve une autre solution du type "bidouillage"), et upgrader en douceur.

À bientôt,
Fred

Dernière modification par Fred02840 (Le 04/08/2009, à 16:55)


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

#16 Le 27/02/2010, à 13:50

texcor

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Me revoilou,

en espérant aider (ayant moi même trouver très peu de résultats positif sur internet),
je post la configuration qui fonctionne bien sur un imac ppc g3 350mhz (un Imac DV+),
il tourne sous Ubuntu 8.04.4 LTS (actuellement noyau 2.6.24-26-powerpc).

Voila le xorg:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"mac"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	BusID		"PCI:0:16:0"
	Option 		"UseFBDev" "false"
	Driver 		"r128"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
	HorizSync 	60-60
	VertRefresh 	75-117
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
EndSection

Alex

Hors ligne

#17 Le 27/02/2010, à 16:10

Fred02840

Re : Problèmes d'affichage sur un iMac G3 350 mHz

Bonjour Alex,

Merci pour cette proposition. Je laissais tomber mon vieil iMac depuis l'été, tellement c'était pénible de travailler avec un si mauvais rendu graphique. Ta solution m'incite à le reprendre.
Je te dirai ce qu'il en est dès que possible. À mon avis, l'ami Gagoune va sauter sur l'occasion et réagir plus promptement que moi.

À bientôt,
Frédéric


Frédéric
-----------------------
MacBook Pro (Snow Leopard et Ubuntu 12.04) ; presse-purée manuel ; moulinette à légumes ; une boîte de Gibolin

Hors ligne

Haut de page ↑