Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 19/07/2009, à 14:20

cyrus87

[Résolu] Clavier QWERTY à l'écran de connexion

Bonjour à tous,

Je rencontre un petit problème : mon clavier est en QWERTY au démarrage d'Ubuntu, au moment de taper le mot de passe du compte. Après connexion, celui-ci repasse en AZERTY.

Suite à plusieurs recherches sur le forum, il s'avère qu'il faille modifier la section "input device" dans le fichier xorg.conf.

Toutefois, cette section n'est pas présente dans mon fichier !

Voici son contenu :

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection

Merci beaucoup d'avance pour votre aide ! smile

Dernière modification par cyrus87 (Le 19/07/2009, à 20:57)


Have it your way.

Hors ligne

#2 Le 19/07/2009, à 15:08

wido

Re : [Résolu] Clavier QWERTY à l'écran de connexion

Bonjour,

cat /etc/hal/fdi/policy/10-keymap.fdi

et colle le résultat sur le forum.

quand tu trouveras ça:

      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string" />

remplace le par:

      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string" />

et pour éditer le fichier:

gksu gedit /etc/hal/fdi/policy/10-keymap.fdi

Dernière modification par wido (Le 19/07/2009, à 15:11)

Hors ligne

#3 Le 19/07/2009, à 15:45

cyrus87

Re : [Résolu] Clavier QWERTY à l'écran de connexion

Merci Wido pour ta réponse smile

Le fichier 10-keymap.fdi n'existe pas. sad
Dans le repertoire, il n'y a que le fichier preferences.fdi dont voici le contenu :

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<!--
  Some examples how to use hal fdi files for system preferences
  You can either uncomment the examples here or put them in a seperate .fdi
  file.
-->
<deviceinfo version="0.2">
<!--
  The following shows how to hint gnome-volume-manager and other programs
  that honor the storage.automount_enabled_hint to not mount non-removable
  media.
-->

  <device>
    <match key="storage.hotpluggable" bool="false">
      <match key="storage.removable" bool="false">
        <merge key="storage.automount_enabled_hint" type="bool">false</merge>
      </match>
    </match>
  </device>


</deviceinfo>


Have it your way.

Hors ligne

#4 Le 19/07/2009, à 17:25

wido

Re : [Résolu] Clavier QWERTY à l'écran de connexion

sudo cp /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi /etc/hal/fdi/policy

tu referas un test pour voir si le fichier 10-keymap.fdi est bien présent, si c'est le cas modifie comme j'ai indiqué.
redémarre ton pc , tu ne devrais plus y avoir de problème.

Hors ligne

#5 Le 19/07/2009, à 18:29

cyrus87

Re : [Résolu] Clavier QWERTY à l'écran de connexion

J'ai suivi à la lettre tes instructions et ça ne marche pas mieux sad


Have it your way.

Hors ligne

#6 Le 19/07/2009, à 18:54

idioteidiote

Re : [Résolu] Clavier QWERTY à l'écran de connexion

Bonjour,

J'ai un xorg.conf différent sur un de mes pc ayant un clavier qwertz (ch),
et j'ai du bidouiller pour ne pas rester en qwerty (usa):

pour un clavier français azerty, il devrait afficher ceci dans le xorg:

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option      "XkbModel" "pc105"
        Option      "XkbLayout" "fr"
EndSection

je n'ai pas mieux à proposer comme solution, à tester, et surtout après avoir fait un

cp /etc/X11/xorg.conf  /etc/X11/ancien_xorg.conf

au préalable, au cas où.

Dernière modification par idioteidiote (Le 19/07/2009, à 18:57)


Fan des Acer Aspire One et de PC anciens pour leur donner une deuxième vie avec Ubuntu.

Hors ligne

#7 Le 19/07/2009, à 19:35

cyrus87

Re : [Résolu] Clavier QWERTY à l'écran de connexion

J'ai ajouté ces quelques lignes dans le fichier xorg.conf.

Et ça ne fonctionne toujours pas :'(


Have it your way.

Hors ligne

#8 Le 19/07/2009, à 20:36

wido

Re : [Résolu] Clavier QWERTY à l'écran de connexion

ajoute ceci:

Section "ServerFlags"
     Option "AutoAddDevices" "False"
EndSection

Dernière modification par wido (Le 19/07/2009, à 20:37)

Hors ligne

#9 Le 19/07/2009, à 20:56

cyrus87

Re : [Résolu] Clavier QWERTY à l'écran de connexion

YEEEAHHH ça marche !
Bien joué !

Tout cela reste très mystérieux pour moi xDD

Merci beaucoup


Have it your way.

Hors ligne

#10 Le 19/07/2009, à 21:24

wido

Re : [Résolu] Clavier QWERTY à l'écran de connexion

La manipulation que je voulais faire était d'utiliser hal au lieu du serveur X (xorg) , l'avantage c'est qu'il est mieux géré et tu n'as pas besoin de redémarrer l'interface graphique pour que ce soit reconnu et ça laisse le serveur X pour le système graphique.

en ajoutant l'option "AutoAddDevices" "false" ça désactive la détection de hal au profit du serveur X.

l'avenir c'est que hal serait de plus en plus utilisé alors que le serveur X se spécialisera dans le graphique, tu verras ça dans les prochaines versions , et je rajouterai que depuis la version 1.5.3 de xorg-server la détection automatique (hal) est activée c'est pour cela qu'il faut rajouter cette option dans le xorg.conf.

Hors ligne

#11 Le 19/07/2009, à 22:17

cyrus87

Re : [Résolu] Clavier QWERTY à l'écran de connexion

Merci pour tes explications big_smile

Donc il faudra peut être que je retire la désactivation lors des prochaines mises à jour d'Ubuntu, en espérant que ce "bug" soit réglé...


Have it your way.

Hors ligne

#12 Le 20/07/2009, à 10:33

wido

Re : [Résolu] Clavier QWERTY à l'écran de connexion

le "bug" restera comme ça, après il faut se tenir au courant si canonical bosse sur ce "bug" smile

Hors ligne

#13 Le 11/05/2012, à 10:18

elpepe

Re : [Résolu] Clavier QWERTY à l'écran de connexion

Si d'autres tombent sur cette page pour ce problème, cf. http://forum.ubuntu-fr.org/viewtopic.ph … 1#p9213391

Hors ligne

Haut de page ↑