Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/05/2005, à 22:39

freepda

Probléme de compilateur ?

Désolé mais je suis novice....:P:P

J'essaye d'installer gtkpod, mais lorsque que dans le répertoire de l'archive j'execute la cmmande ./configure, il m'indique l'erreur suivante :  "no acceptable C compiler found in $PATH"

Pourquoi il n'est pas acceptable mon compiler ????  hmm:/

Merci pour votre aide !

Hors ligne

#2 Le 04/05/2005, à 22:50

tigrou

Re : Probléme de compilateur ?

Salut,

Avant d'essayer de compiler un programme, as tu regarder si il n'existait pas un paquet Ubuntu ? et visiblement gtkpod est disponible en paquet pour l'installer utilise synaptic ou alors en ligne de commande :

 sudo apt-get install gtkpod

c'est nettement plus simple que de compiler.

Si néanmoins tu veux vraiment compiler, il faut d'abord installer le nécessaire (compilateur, libs, ...) pour celà tu peux installer le paquet build-essential.

Dernière modification par tigrou (Le 04/05/2005, à 22:51)

Hors ligne

#3 Le 08/05/2005, à 12:01

manal

Re : Probléme de compilateur ?

Freepda a raison, mais cette erreur apparaitra pour n'importe quelle compilation.

C'est pas qu'il n'est pas "acceptable" ton compiler (compilateur en français), c'est surtout qu'il n'existe pas.
Il faut l'installer, donc un petit :

sudo apt-get install gcc

L'erreur disparaitra, mais dans le cas de gtkpod, il manquera des librairies de développement comme libgtk-2.0-dev

Bien que la gestion par paquets est de loin plus simple, tu as raison d'essayer de compiler des logiciels. Ca permet de se rappeller qu'il sont des lignes de code que l'on peut trifouiller à volonter.

Bon courage


Libère ton esprit, et ton cul suivra

Hors ligne

#4 Le 08/05/2005, à 12:25

freepda

Re : Probléme de compilateur ?

merci pour vos réponses, C'est vrais que la dernière fois que j'étais sous linux sa remonte à une dizaine d'années, et j'avais la "mauvaise" habitude (?) de tous recompiler pour installer les programmes.... On avait pas trop le choix à l'époque.

Je viens d'installer le package de Gtkpod... et tous fonctionne impec ! Merci !

Bon j'ai toujours un probléme de carte son qui n'est pas reconnu... mais je devrais finir par trouver !!!

Merci

Hors ligne

Haut de page ↑