Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 13/08/2009, à 15:45

Neros

[Jabber] Problème pour monter un serveur

Salut,

Je viens de monter mon serveur jabber sur mon domaine, mais...

Je me connecte sur mon compte (admin), là pas de problème, je rajoute un contact et là... rien.

Le contact ne reçoit pas la demande.

Gajim m'affiche : "remote-server-not-found"
Pidgin m'affiche : "not authorized"

Je ne vois pas quelle piste suivre...:/

Merci de votre aide wink

ps: j'ai cherché mais je ne tombe que sur quelque chose qui consiste à créer un ficher /etc/ejabberd/inetrc qui pointe sur /etc/resolv.conf, mais c'était déjà fait. D'ailleurs, ce dernier ne contient que "nameserver 192.168.1.1"  <--- normal ?
ps2: c'est sur ubuntu-server 9.04

Dernière modification par Neros (Le 13/08/2009, à 16:03)


Un gus dans le futur du passé.

neros.fr

Hors ligne

#2 Le 13/08/2009, à 17:28

Qid

Re : [Jabber] Problème pour monter un serveur

si si le nameserver est bon dans la mesure ou
tu as bien le net et c'est le routeur qui gere le dns


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#3 Le 13/08/2009, à 17:30

Neros

Re : [Jabber] Problème pour monter un serveur

Ha, ba du coup je n'ai pas la moindre idée de l'origine du problème...


Un gus dans le futur du passé.

neros.fr

Hors ligne

#4 Le 13/08/2009, à 17:35

Qid

Re : [Jabber] Problème pour monter un serveur

et moi je peu pas t'aider ...
par contre j'etais interessé par la démarche de me créer mon propre serveur
alors si tu me donne un coups de main pour faire ça de façon pas trop complexe
on poura comparer voir si j'arrive au meme résultat problématique que toi


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#5 Le 13/08/2009, à 17:41

Neros

Re : [Jabber] Problème pour monter un serveur

J'ai tout simplement suivi le tuto là :

http://wiki.jabberfr.org/Ejabberd

Attention, au moment de créer le compte, tu dois être en root (avec "su") donc tu dois d'abord lui donner un mot de passe avec :

sudo passwd root

Un gus dans le futur du passé.

neros.fr

Hors ligne

#6 Le 13/08/2009, à 17:44

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

Attention, au moment de créer le compte, tu dois être en root (avec "su")

genre ... la dessu je te crois pas ... enfin bon je vais feuilleter ça et je verais
pour passer à l'action (ou pas) ce soir


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#7 Le 13/08/2009, à 17:49

Neros

Re : [Jabber] Problème pour monter un serveur

Qid a écrit :
Neros a écrit :

Attention, au moment de créer le compte, tu dois être en root (avec "su")

genre ... la dessu je te crois pas ... enfin bon je vais feuilleter ça et je verais
pour passer à l'action (ou pas) ce soir

Hé ? C'est ironique ?

Non je t'assure, sinon tu as droit à une erreur du style

RPC failed on the node ejabberd@tonserveur: nodedown

Ha oui, et tu dois aussi installer le paquer "erlang", sinon marche pas.


Un gus dans le futur du passé.

neros.fr

Hors ligne

#8 Le 13/08/2009, à 17:52

Qid

Re : [Jabber] Problème pour monter un serveur

et "sudo -s" alors ?


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#9 Le 13/08/2009, à 18:01

Neros

Re : [Jabber] Problème pour monter un serveur

Qid a écrit :

et "sudo -s" alors ?

Je ne connaissais pas... et je remarque sur mon Arch, en faisait cette commande j'accède à Root sans que le mot de pass soit demandé...... hmm

Bon sinon, personne n'a une idée pour le problème ?


Un gus dans le futur du passé.

neros.fr

Hors ligne

#10 Le 13/08/2009, à 18:06

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :
Qid a écrit :

et "sudo -s" alors ?

Je ne connaissais pas... et je remarque sur mon Arch, en faisait cette commande j'accède à Root sans que le mot de pass soit demandé...... hmm

il devrait etre demandé si evidemment ...
bon bah je testerais ce soir de me monter
un serveur jabber avec le tuto que tu m'a filé
je te tiendrais au courant


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#11 Le 14/08/2009, à 02:48

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

tu as droit à une erreur du style

RPC failed on the node ejabberd@tonserveur: nodedown

Ha oui, et tu dois aussi installer le paquer "erlang", sinon marche pas.

pour erlang j'ia pas pu passer à coté
pour l'erreur j'ai effectivement eu le droit à un truc du genre mais bon c'etais louche

au final ...
primo > deja question con : t'a pensé aux ports et dans le firewall et dans le routeur
secondo > en fait ce qui semble merdouiller c'est justement le lien aux autre serv : notre serveur n'est que local
(d'ou ma premiere reflection mais sache que moi j'y ai pensé et ça change pas grand chose)
en fait c'est ton tuto qui manque légerement d'info ... sauf que j'ai pas trouvé grand chose sur google ...
on vera ça ensemble demain moi pour ce soir je laisse tomber


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#12 Le 14/08/2009, à 13:17

Qid

Re : [Jabber] Problème pour monter un serveur

ayant changer de méthode d'acces un autre point flou vient m'interpeller :
en faite hier soir j'ai tout fait à partir du serveur meme l'acces à l'interface web
(à partir de mon interface graphique de secoure et de firefox) bref ça marchait
la ce matin je suis sur mon pc principal et non plus sur le serveur ...
et donc ... notre serveur il a quoi comme adresse pour l'exterieur au juste ? ...
parce que d'apres moi c'est pour ça que ça coince


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#13 Le 14/08/2009, à 15:52

Neros

Re : [Jabber] Problème pour monter un serveur

primo > deja question con : t'a pensé aux ports et dans le firewall et dans le routeur

Oui, j'y ai pensé. wink

Second message, rien compris.


Un gus dans le futur du passé.

neros.fr

Hors ligne

#14 Le 14/08/2009, à 15:59

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

Second message, rien compris.

m'etonne pas trop j'ia changé de réflection en cours de route

en faite ce qui nous pose probleme d'apres ce que j'ai compris
c'est de se lier aux autres serveurs sauf que justement ...
comment ils nous identifient eux ? par ip ? par adresse (oui mais laquelle) ?

je me demande ça parce que ayant un serveur web deja operationnel
l'identification qui fait que je suis retrouvable par adresse c'est pas le pc qui l'a
d'autant plus que je suis pas en ipfixe ... et donc voila ... ducoups comment on fait avec ce truc ?


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#15 Le 14/08/2009, à 16:04

Neros

Re : [Jabber] Problème pour monter un serveur

Ba..... facile.... par ton ID Jabber :

le-compte-que-tu-as-enregistré@ton-domaine.truc


Un gus dans le futur du passé.

neros.fr

Hors ligne

#16 Le 14/08/2009, à 16:13

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

Ba..... facile.... par ton ID Jabber :

le-compte-que-tu-as-enregistré@ton-domaine.truc

bah wai mais de toutes évidence non il nous manque autre chose ...
(mon user est meme pas vu comme connecté d'ailleur alors qu'il l'est pour finch/pidgin)


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#17 Le 14/08/2009, à 22:38

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

Ba..... facile.... par ton ID Jabber :

le-compte-que-tu-as-enregistré@ton-domaine.truc

oui mais non ... et notre domaine ils le connaissent/l'identifie comment
sur le net on est identifié par une ip pas par un nom de domaine !
c'est à ça que je voulais en venir en fait


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#18 Le 15/08/2009, à 04:12

Qid

Re : [Jabber] Problème pour monter un serveur

Qid a écrit :
Neros a écrit :

Ba..... facile.... par ton ID Jabber :

le-compte-que-tu-as-enregistré@ton-domaine.truc

oui mais non ... et notre domaine ils le connaissent/l'identifie comment
sur le net on est identifié par une ip pas par un nom de domaine !
c'est à ça que je voulais en venir en fait

la c'est clairement ça qui pose probleme :
j'arrete pas de paraléliser le log et mes action
et à chaque tentative de connection d'un user j'ai :

monadresse -> proxy.jabber.org (remote server not found)

et pour cause : comme je le disais on est pas reconnu/identifiable :

http://pastoutafait.org/billets/installation-serveur-jabber-avec-ejabberd a écrit :

Avec cette configuration, il est nécessaire d'utiliser des enregistrements DNS de type SRV sur votre serveur DNS dans le fichier de zone de votre domaine, ainsi :

_xmpp-client._tcp.tondomaine. 86400 IN   SRV     20 0 5222  votredomaine.tld.
_xmpp-server._tcp.tondomaine. 86400 IN   SRV     20 0 5269 votredomaine.tld.

C'est facilement réalisable si vous hébergez votre propre serveur DNS, avec pourquoi pas BIND. Mais aussi chez votre hébergeur probablement, faites la demande.
Chez Gandi, c'est tout a fait possible.

Si vous n'avez pas la possibilité de mettre en place un enregistrement SRV, il est possible de contourner le problème en modifiant dans toutes les configurations "votredomaine.tld" par, ça n'est qu'un exemple, "im.votredomaine.tld", puis de faire pointer ce nom vers votre serveur. Évidemment les adresses Jabber seront alors de la forme "utilisateur@im.votredomaine.tld".
Voilà pour les modifications essentielles à réaliser.

enfin bon bref voila ... ducoups j'ai deporté mon envie de serveur jabber
sur le besoin d'avoir un serveur dns at home ... et alors la ...
c'est le flou on ne peu plus total meme avec un tuto ...

ducoups je crois que si tu ne me donne pas un coups de main je vais laisser tomber
en tous cas ce qui est deja sur c'est que je dégage bind9 ... sad


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#19 Le 15/08/2009, à 16:39

Qid

Re : [Jabber] Problème pour monter un serveur

on laisse tomber alors ou quoi ?


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#20 Le 15/08/2009, à 18:31

Neros

Re : [Jabber] Problème pour monter un serveur

Je vais trainer sur le forum et le salon de jabberFR pour trouver de l'aide, je te tiens au courant wink

Dernière modification par Neros (Le 15/08/2009, à 18:32)


Un gus dans le futur du passé.

neros.fr

Hors ligne

#21 Le 17/08/2009, à 13:54

Qid

Re : [Jabber] Problème pour monter un serveur

Qid a écrit :
http://pastoutafait.org/billets/installation-serveur-jabber-avec-ejabberd a écrit :

Avec cette configuration, il est nécessaire d'utiliser des enregistrements DNS de type SRV sur votre serveur DNS dans le fichier de zone de votre domaine, ainsi :

_xmpp-client._tcp.tondomaine. 86400 IN   SRV     20 0 5222  votredomaine.tld.
_xmpp-server._tcp.tondomaine. 86400 IN   SRV     20 0 5269 votredomaine.tld.

C'est facilement réalisable si vous hébergez votre propre serveur DNS, avec pourquoi pas BIND. Mais aussi chez votre hébergeur probablement, faites la demande.
Chez Gandi, c'est tout a fait possible.

Si vous n'avez pas la possibilité de mettre en place un enregistrement SRV, il est possible de contourner le problème en modifiant dans toutes les configurations "votredomaine.tld" par, ça n'est qu'un exemple, "im.votredomaine.tld", puis de faire pointer ce nom vers votre serveur. Évidemment les adresses Jabber seront alors de la forme "utilisateur@im.votredomaine.tld".
Voilà pour les modifications essentielles à réaliser.

bon au faite ... j'ai trouvé freedns qui semble pouvoir faire du DNS SRV gratuit
sauf que j'ai pas dutout su m'en servir ... si tu y arrive ce serait sympa que tu me donne un coups de main
parce que bon j'ai deja fait mon inscription sur ce site ... j'ai eu une adresse supplémentaire qui pointait sur mon serveur
mais pour le reste franchement j'ai pas tout bien compris


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#22 Le 20/08/2009, à 16:11

Qid

Re : [Jabber] Problème pour monter un serveur

Neros a écrit :

je te tiens au courant wink

t'en est ou ?


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#23 Le 20/08/2009, à 23:17

B@rtounet

Re : [Jabber] Problème pour monter un serveur

Yop,
J'ai installé mon serveur ejabber depuis un moment et j'ai eut aucun problème.
Je suis sur un dédié qui est aussi SOA pour mon domaine ca peut jouer...

Postez déjà les ejabberd.cfg ... qu'on puisse voir et les différents messages de logs.
Vos DNS sont bien configuré pour pointer sur le serveur jabber?

Dernière modification par B@rtounet (Le 20/08/2009, à 23:17)

Hors ligne

#24 Le 21/08/2009, à 00:16

Qid

Re : [Jabber] Problème pour monter un serveur

le probleme il est la justement c'est que le dns de dyndns ne saura pas gérerla redirection pour jabber (d'ou mon inscription sur freedns)
pour ce qui est de la config de ejabberd
je suis sur quelle est bonne puisque ça marche en local
(je peu pas la coller pour l'instant en plus donc bon)


"GNU/Linux c'est que du bonheur mais M$ Windows c'est pas la mort non plus"
1 portable Clevo W370ST : Ubuntu 13.10 & 14.04 (EXT2 : SSD) & W8.1 (HDD)
1 Zalman de 120Go et 1 MultiSysteme de 20Go prêts pour les install-party
2 tablettes ASUS : Android 4.2.2 & 4.1.1 non rootés | doc.ubuntu-fr/Qid

Hors ligne

#25 Le 21/08/2009, à 00:41

B@rtounet

Re : [Jabber] Problème pour monter un serveur

Pour ma part je n'ai pas utilisé d'enregistrement SRV dans la configuration DNS de mon serveur Jabber.

Hors ligne

Haut de page ↑