Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 22/05/2009, à 19:40

robulle

[Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bonjour à tous,

j'ai installé jaunty sur mon portable hp dv7-2030ef et je n'ai pas de son.
J'ai déjà fais quelques manips trouvées sur le forum mais sans succès:
- lancement de alsamixer en mode console (rien n'était en muet et j'ai tout mis à fond)
- ajout de options snd-hda-intel enable_msi=1 dans le fichier alsa-base.conf
- installation du paquet linux-backports-modules-jaunty-generic avec synaptic
Pour info la commande: lspci | grep -i audio renvoie
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
01:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]
Merci pour votre aide.

#2 Le 23/05/2009, à 18:02

robulle

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bon bah merci pour les réponses mais j'ai fini par trouver.

Alors ce tuto s'adresse à tout ceux qui n'ont pas de son avec leur portable HP pavillon DVx-xxxx.
Sur ces portables, il y a un caisson de basse. Le driver ALSA l'utilise au lieu des enceintes. C'est pour ça que le son ne sort pas ou qu'il est très faible. Dans ce tuto, on va récupérer le patch que ALSA a fourni pour corriger ce problème puis le compiler et l'installer.

Lancez un terminal (Applications/Accessoires/Terminal) et tapez les commandes suivantes (il faut une connexion à Internet). Attendez bien la fin de chaque commande avant de taper la suivante. Si ubuntu vous demande votre mot de passe, entrez le et continuez normalement.

cd Bureau
mkdir src
cd src
mkdir alsa
cd alsa
wget ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
tar -xvpf alsa-driver-snapshot.tar.gz
cd alsa-driver
./configure
sudo make
sudo make install-modules
sudo gedit /etc/modprobe.d/alsa-base.conf

Ajouter la ligne suivante à la fin du fichier quelque soit votre modèle (perso j'ai un dv7-2030)

options snd_hda_intel model=hp-dv5

Sauvegarder le fichier puis fermer gedit et le terminal puis rebooter.

Voila, chez moi ça a fonctionné.
A+

Source: https://help.ubuntu.com/community/Sound … x%20laptop

#3 Le 24/05/2009, à 11:53

Baricho

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Moi j'ai beau tout essayer, rien de changer toujours pas de son sad

#4 Le 12/06/2009, à 00:17

hurley

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Solution  miracle pour mon  dv6-1160

un grand merci!!!!!

Rectificatif, la sortie casque ne fonctionne pas.....

Dernière modification par hurley (Le 12/06/2009, à 11:12)


HP Pavilion dv6-1160 - Ubuntu 10.04 LTS "The Lucid Lynx"
"Windows sert à avoir IE; IE sert à télécharger firefox; Firefox sert à télécharger linux"

Hors ligne

#5 Le 04/07/2009, à 13:59

aladine

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Solution qui fonctionne aussi pour le HP dv7-2020ef, cependant là aussi la sortie casque ne fonctionne pas ... quelqu'un a une solution?


Être respecté n'est pas important, ce qui est important c'est d'être  respectable.

Hors ligne

#6 Le 04/07/2009, à 23:54

kironux

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Idem, sortie casque ne fonctionne pas chez moi, et le son grésille lors de l'extinction de la machine hmm

Par contre le reste fonctionne nativement, sauf l'icône pour couper le son, elle devient pas rouge (:P), mais c'est un détail futile sans importance (mais la "touche" fonctionne).

smile

Hors ligne

#7 Le 06/07/2009, à 12:07

aladine

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Oui, moi aussi l'icône devient pas rouge! J'avais pas remarqué....
Personne n'a de solution pour cette sortie casque ?


Être respecté n'est pas important, ce qui est important c'est d'être  respectable.

Hors ligne

#8 Le 18/07/2009, à 15:55

al_boon

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

deja mettez options snd_hda_intel model=hp-dv7 wink


viva ubuntu ^^ et deux personnes converties !!

ps: il est pas beau mon fils ? (cf mon avatar)

Hors ligne

#9 Le 21/07/2009, à 10:08

aladine

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

al_boon a écrit :

deja mettez options snd_hda_intel model=hp-dv7 wink

salut al_boon,
t'es sur de ça ? t'as essayés?

Sinon j'ai trouvé une solution pour la sortie casque, et tout se passe dans le mixer...

- clique droit sur l'icône du son
- ouvrir le contrôleur de volume
- préférence
- ajouter "Speaker" et "Import0 mux"
- Dans l'onglet lecture il faut baisser le speaker à fond (il gère la sortie son autre que le casque)

- et dans l'onglet enregistrement il faut lever Import0 Mux et activer le micro s'il est désactivé en cliquant dessus

Et normalement on a du son dans les 2 sorties casques.

ah oui, faire aussi un clique droit sur l'icône du son > préférences > choisir HDA ATI SB (Alsa mixer) et Volume général.

Voilà en espérant que ça marche chez vous aussi smile

Dernière modification par aladine (Le 21/07/2009, à 10:10)


Être respecté n'est pas important, ce qui est important c'est d'être  respectable.

Hors ligne

#10 Le 05/08/2009, à 13:36

saebasan67

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Eh bien finalement pour moi aussi cela a fini par fonctionner. yikes

Merci a vous, j'etais en train de pedaler dans la choucroute...
En plus j'ai achete le mien au Japon, alors entre les commandes a rallonges et les touches qui sont "pas a leur place", je vous raconte pas, je suis au bord de la crise de nerf pseudo epileptique. Mes doigts ne repondent plus a mes ordres...  big_smile

J'ajouterais juste un petit detail pour ceux qui galere encore, verifiez bien que vous avez bien tous les paquets de librairie alsa permettant la compilation des drivers.
Pour ce faire, ouvrir Synaptic, aller dans 'Systeme' -> 'Administration'  ->  'Gestionnaire de paquets synaptic'
Un fois de dedans, effectuer une recherche sur "alsa*", cocher tous les paquet relatif a alsa (sauf peut etre les alsa player qui ne seront pas d'un grand secour)
Enfin recommencer les precedantes etapes fourni par robulle, si la compilation prend un peu de temps et genere plein de fichiers avec l'extension .o  ,   vous etes sur la bonne voie... big_smile

P.S. @robulle ~>  Je ne comprend pas pourquoi toi tu avais deja tous les paquets libs d'installe des le depart et pas moi, cependant vraiment MERCI pour les infos wink

P.S.2  Si un admin passe par la ou si robulle reviens ici, il pourrait passer ce post en "Resolu"

Dernière modification par saebasan67 (Le 06/08/2009, à 07:38)


HP HDX Q9000 SSD 120Go

Hors ligne

#11 Le 20/08/2009, à 00:03

vond

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bonjour à tous,

La procédure de robulle a fonctionné pour moi aussi  sur un dv7-2120sf

j'ai ajouté la ligne suivante au fichier /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=hp-dv7

écrit avec des tirets et pas des tirets-bas, mais les deux fonctionnent


Merci à robulle

Dernière modification par vond (Le 21/08/2009, à 01:02)


Core 2 duo 1,8 Ghz Packard Bell nvidia GeForce 6600LE Precise
eeepc 1005 PX Seven, Precise

Hors ligne

#12 Le 26/08/2009, à 10:30

gillesdereves

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bonjour à tous,
J'ai le même problème qu'évoqué par robulle (ses messages du 22 et 23/05/2009).
La seule différence : mon pc est de marque MSI (modèle EX620).
Dans mon cas, puis-je suivre le conseil de robulle quand il propose d'ajouter la ligne suivante à la fin du fichier "options snd_hda_intel model=hp-dv5" ? Ou bien dois-je remplacer "hp-dv5" ? Et si oui, par quoi ?
Merci à tous

Hors ligne

#13 Le 26/08/2009, à 14:56

asnodj

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Moi j'arrive pas à compiler : :s

root@asno-laptop:~/Bureau/src/alsa/alsa-driver# make
if [ ! -d include/sound -a ! -L include/sound ]; then \
	  ln -sf ../alsa-kernel/include include/sound ; \
	fi
cp -puvf include/version.h include/sound/version.h
make dep
make[1]: entrant dans le répertoire « /home/asno/Bureau/src/alsa/alsa-driver »
if [ ! -d include/sound -a ! -L include/sound ]; then \
	  ln -sf ../alsa-kernel/include include/sound ; \
	fi
cp -puvf include/version.h include/sound/version.h
make[2]: entrant dans le répertoire « /home/asno/Bureau/src/alsa/alsa-driver/acore »
copying file alsa-kernel/core/info.c
/home/asno/Bureau/src/alsa/alsa-driver/utils/patch-alsa: 24: patch: not found
make[2]: *** [info.c] Erreur 1
make[2]: quittant le répertoire « /home/asno/Bureau/src/alsa/alsa-driver/acore »
make[1]: *** [dep] Erreur 1
make[1]: quittant le répertoire « /home/asno/Bureau/src/alsa/alsa-driver »
make: *** [include/sndversions.h] Erreur 2

On dirait que les sources ne sont pas complètes non ?!

Petite modif pour dire que j'ai un joli DV7-2120sf ! (mais je pense que cela ne devrait rien changer non!?)

Dernière modification par asnodj (Le 26/08/2009, à 15:00)

Hors ligne

#14 Le 26/08/2009, à 15:08

gillesdereves

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

j'ai peut-être trouvé la réponse à ma question ici : http://doc.ubuntu-fr.org/audio_intel_hda
j'essaie et je vous tiens au courant.
bye

Hors ligne

#15 Le 26/08/2009, à 15:53

asnodj

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Désolé j'avoue je n'avais pas tout lu. J'ai installé les paquets alsa* comme dit saebasan67 et ça marche.

Merci beaucoup à tous

Hors ligne

#16 Le 28/08/2009, à 20:54

Eric Buissonnet

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

La procédure de robulle a aussi été efficace avec un HP DV7-2040ef sous Jaunty jusque-là muet, et ce tel quel, c'est à dire avec les soulignés et dv5 comme modèle dans la ligne d'options.
J'ai du son aussi dans le casque.

Question : est-ce que la modification va résister à une mise à jour du système ?

Hors ligne

#17 Le 29/08/2009, à 15:17

Yohan64

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Super! Après avoir passé 2 heures à faire marcher mon wifi, j'me dis *go to jamendo:D*, et là, pas de son OO! Mais bon, la soluce en mettant dv5 à marcher sur mon hp dv6 1225sf, à part sur un point:
                   Quand je branche mon casque (nimporte quelle sortie), les hauts parleurs balancent quand même le son:/... Bref, je peux pas écouter la musique à fond sans déranger... Si quelqu'un sait d'où ça vient, qu'il éclaire ma lanterne.

Merci d'avance.


Un petit peu de pub pour le projet libre d'un ami:
son site de dessin et d'articles http://framabearn.tuxfamily.org/
le site de son projet Movim http://www.movim.eu/

Hors ligne

#18 Le 29/08/2009, à 15:58

Yohan64

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

J'ai trouvé... En fait, lorsque je branche mon casque, le canal "speaker" ne se met pas en mute, donc je dois le faire manuellement... Bah, c'est aussi bien comme ça, j'ai le choix entre les deux maintenant. smile Merci quand même et bonne continuation.


Un petit peu de pub pour le projet libre d'un ami:
son site de dessin et d'articles http://framabearn.tuxfamily.org/
le site de son projet Movim http://www.movim.eu/

Hors ligne

#19 Le 29/08/2009, à 21:16

gillesdereves

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bonjour à tous,
Voilà, ça marche ! Merci à robulle (voir ses messages plus haut). Sa solution est la bonne. J'ai enfin du son qui sort des haut-parleurs.
Pour ce qui concerne le fichier /etc/modprobe.d/alsa-base.conf, j'ai rajouté la ligne suivante :
options snd-hda-intel model=targa-dig
@+

Hors ligne

#20 Le 19/09/2009, à 22:36

Drusselnahg

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Bonsoir, j'ai appliqué le tutoriel, le son "à l'air" de marcher (je peux lire de la musqiue, j'ai le bruit  qui tue quand j'allume le pc) , mais des qu'un programme fait des appels autre qu'emmetre du son (detection des cannaux,etc) :  (alsamixer, winecfg), toutes les applications utilisant les syscall alsa sont bloquées et il est alors impossibles de les tuer (il s'en suit généralement un sync et un appui violent sur le bouton d'alimentation)

J'ai utilisé
model=hp-dv5  (de 5 a 7), mêmes symptomes.

J'ai un HP dv6-1227 sf fraichement acheté (et qui risque de retourner se faire échanger s'il continue comme ça !)

Quelqu'un a le même problème ?

Hors ligne

#21 Le 20/09/2009, à 08:46

al_boon

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

et bien il est vrai que j ai des probleme similaire, exemple, quand j utilise acidrip je n ai plus de son  o_O.
des que je le coupe le son reviens.
j espere que la nouvelle gestion du son sur ubuntu 9.10 réglera tous nos problèmes wink il doit y avoir une configuration automatique de l audio à plusieurs channels, enfin c est ce que j ai cru comprendre
encore un bon mois a attendre si quelqu'un est chaud à tester la version alpha : http://www.ubuntu.com/testing/karmic/alpha1 qu il nous poste son retour d utilisation wink


viva ubuntu ^^ et deux personnes converties !!

ps: il est pas beau mon fils ? (cf mon avatar)

Hors ligne

#22 Le 20/09/2009, à 14:11

Drusselnahg

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Moi, c'est carrément un problème du pilote alsa : je ne peux plus tuer mes programmes (même avec KILL -9 $pid), et donc, impossible d'éteindre correctement la machine (faudrait que j'active les magic keys ? ou que je me fabrique un module noyeau qui tue les process que j'ai envie ?)

Ah oui, et aussi, le bios de mon hp doit fumer je sais pas quoi : quand  on éteint le portable  "à l'arrache (a l'aide du bouton)" , il ne veut booter QUE sur un windows (il propose même pas les disques durs externes ni pxe)
Et comme j'ai installé ubuntu sur un disque dur externe, c'est assez génant.
Récapitulatif d'acheteur : garder la bébète ou changer de portable ?

Ha oui, et j'ai eu la surprise de la carte wifi également ; je l'ai éteinte par mégarde , et impossible de la ralumer. Or , j'ai éteint le pc violament.
résultat, plus de wifi, obligé d'éteindre le pc sans batterie, attendre l'éventuelle décharge des condensateurs&companie (1h) pour le ralummer ...

Hors ligne

#23 Le 21/09/2009, à 22:38

al_boon

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

Drusselnahg a écrit :

Moi, c'est carrément un problème du pilote alsa : je ne peux plus tuer mes programmes (même avec KILL -9 $pid), et donc, impossible d'éteindre correctement la machine (faudrait que j'active les magic keys ? ou que je me fabrique un module noyeau qui tue les process que j'ai envie ?)

Ah oui, et aussi, le bios de mon hp doit fumer je sais pas quoi : quand  on éteint le portable  "à l'arrache (a l'aide du bouton)" , il ne veut booter QUE sur un windows (il propose même pas les disques durs externes ni pxe)
Et comme j'ai installé ubuntu sur un disque dur externe, c'est assez génant.
Récapitulatif d'acheteur : garder la bébète ou changer de portable ?

Ha oui, et j'ai eu la surprise de la carte wifi également ; je l'ai éteinte par mégarde , et impossible de la ralumer. Or , j'ai éteint le pc violament.
résultat, plus de wifi, obligé d'éteindre le pc sans batterie, attendre l'éventuelle décharge des condensateurs&companie (1h) pour le ralummer ...

total respect, moi a ta place j aurai deja transformé le pc en barbecue.

quel est le model de ta machine ?

sinon pour tuer de sprocessus, utilise l applet Moniteur système 2.26.1 il te met un petit graphique dans la tableau de bord et quand tu cliques gauche sur le graphique ca t ouvre une fenetre moniteur system ou tu peux tuer ou terminer les processus (chez moi j ai tjs réussi a tuer les processus qui bloquaient de cette facon)


viva ubuntu ^^ et deux personnes converties !!

ps: il est pas beau mon fils ? (cf mon avatar)

Hors ligne

#24 Le 16/10/2009, à 21:05

casey39jura

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

bonjour,
j'ai un dv7-2060ef sous 9.04, j'ai essayé vos manips mais toujours pas de son, par contre il y a un mois lors d'une premiere installation de ubuntu sur ce meme portable, j'avais suivi votre méthode et ça avait marché... là quand je vais dans le gestionnaire de paquets synaptic et que je recherche "alsa" la liste est très courte par rapport à mon ancienne installation, je pense qu'il m'en manque... comment les retrouver? pouvez-vous m'aider?
par avance merci.
PS: je suis novice

Hors ligne

#25 Le 17/10/2009, à 07:02

al_boon

Re : [Résolu] Pas de son sur HP DV7-2030 avec Jaunty

casey39jura a écrit :

bonjour,
j'ai un dv7-2060ef sous 9.04, j'ai essayé vos manips mais toujours pas de son, par contre il y a un mois lors d'une premiere installation de ubuntu sur ce meme portable, j'avais suivi votre méthode et ça avait marché... là quand je vais dans le gestionnaire de paquets synaptic et que je recherche "alsa" la liste est très courte par rapport à mon ancienne installation, je pense qu'il m'en manque... comment les retrouver? pouvez-vous m'aider?
par avance merci.
PS: je suis novice

sois un peu patient, avec ubuntu 9.10 le son fonctionne par defaut sur mon dv7-1215ef en plus j ai bien l impression que le caisson fonctionne (je vais vérifier)


viva ubuntu ^^ et deux personnes converties !!

ps: il est pas beau mon fils ? (cf mon avatar)

Hors ligne

Haut de page ↑