Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 22/09/2009, à 13:27

sdblepas

Les fleches sous vim [Resolu]

Bonjour a tous

J'ai un probleme sous vim les fleches ne marche pas a chaque fois que je tape la fleche du haut ca pass en mode insertion et ca entre "A"
que faire pour les remettre ?
Merci

Dernière modification par sdblepas (Le 24/09/2009, à 10:32)

Hors ligne

#2 Le 22/09/2009, à 13:50

serged

Re : Les fleches sous vim [Resolu]

T'as pas dans ta home directory un fichier de style .vimrc ou répertoire .vim ? essaye de les effacer.


Linux-Mint Rebecca 64 (Cinnamon) sur ASUS F2A55/AMD A8-5600K APU

Hors ligne

#3 Le 22/09/2009, à 13:51

sdblepas

Re : Les fleches sous vim [Resolu]

effectiment j'ai .vimrc mais je m'en sert
1 set background=dark " we plan to use a dark background
  2 syntax on " syntax highlighting on
  3 set clipboard+=unnamed " share windows clipboard
  4 set noerrorbells " don't make noise
  5 set incsearch " BUT do highlight as you type you search phrase
  6 set novisualbell " don't blink
  7 set number " turn on line numbers
  8 set showcmd " show the command being typed
  9 set nocompatible
10 set noflash
11 set esckeys
12 set backspace=2
13 set history=500
14 set ignorecase
15 set showmode
16 set expandtab
17 set softtabstop=2
18 set shiftwidth=2
19 set autoindent
une autre solution

Hors ligne

#4 Le 22/09/2009, à 13:56

dominique.fournier

Re : Les fleches sous vim [Resolu]

tu ne serait pas en console a distance par hasard ? j'ai vu ce probleme depuis un putty vers un Linux : putty etait en iso et Linux en UTF et ca bugge,

Mettre le putty en UTF-8

Hors ligne

#5 Le 22/09/2009, à 14:00

sdblepas

Re : Les fleches sous vim [Resolu]

salut je suis effectivement en console distant mais utf-8 ca marche pas sad
Merci

Hors ligne

#6 Le 22/09/2009, à 14:07

dominique.fournier

Re : Les fleches sous vim [Resolu]

Depuis un Linux ou depuis autre chose ?

Peut-etre ton PC source est en ISO alors que le PC distant est en UTF ?
Regarde aussi le SSH si il a des codages dans /etc/ssh/ssh*_config

Hors ligne

#7 Le 22/09/2009, à 14:15

sdblepas

Re : Les fleches sous vim [Resolu]

j'etais sous putty je me suis connecte via ssh et ca marche
sous putty la translation est ISO-8859-8:1999 (Latin/Hebrew)
il faut changer quoi?
Merci

Hors ligne

#8 Le 22/09/2009, à 15:39

dominique.fournier

Re : Les fleches sous vim [Resolu]

Met ta langue en version UTF-8 pour etre compatible avec Linux.

Hors ligne

#9 Le 23/09/2009, à 05:37

sdblepas

Re : Les fleches sous vim [Resolu]

Merci

Hors ligne

#10 Le 23/09/2009, à 16:20

dominique.fournier

Re : Les fleches sous vim [Resolu]

Un petit resolu dans le titre ?

Hors ligne

Haut de page ↑