Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 03/05/2006, à 09:26

environ314

[Résolu] Pb de connexion ssh vers ma ubuntu

Bonjour,

J'ai installé le serveur de NX, suivant les conseils reçus dans le post http://forum.ubuntu-fr.org/viewtopic.ph … 88#p283088

Cela a fonctionné, mais cela ne fonctionne plus, et j'aimerais comprendre pourquoi !
Mon message (client) est un "connexion timeout".

Même un simpe
ssh (mon IP)
dans une console me renvois un "connexion timeout". Le pb n'est donc pas avec NX, mais ssh ... ?

J'imagine que j'ai dû toucher qqch à ma config ????

Pourtant, j'ai vérifié, le parefeu n'est pas actif.

D'ailleurs,
dans le KSystemLog, je vois qu'il y en a qui arrivent pourtant bien à essayer de me contacter !!! Un utilisateur teste depuis 2h plein de noms (et de mots de passe j'imagine), comme roger, chuck, leslie, chloe, guest, etc... via une commande sshd. ('Invalid user from xx.xxx.xxx.xxx')

Dans le log, il y a donc les tentatives de connexion de ces autres personnes, mais pas celles que je fais moi... C'est le monde à l'envers !

Donc je me demande vraiment où ca peut coincer... ! Que puis-je tester ? Je suis allé sur
https://www.grc.com/x/ne.dll?rh1dkyd2
et manifestement, mon port 22 est (le seul) ouvert


Merci pour vos conseils !

Dan.

Dernière modification par environ314 (Le 15/05/2006, à 00:16)

Hors ligne

#2 Le 03/05/2006, à 14:05

lgmdmdlsr

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Question : la machine où tourne le serveur est-elle derrière un routeur NAT ?

Hors ligne

#3 Le 03/05/2006, à 15:11

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Non, pas de routeur (une freebox, routeur desactivé, wifi)

Hors ligne

#4 Le 03/05/2006, à 16:15

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

sudo netstat -alpen --inet |grep 22
pour voir si le port 22 est bien en ecoute (par sshd)

Est ce que tu ping la machine ??
Est ce que tu peux faire un :
telnet TonServeur 22
Est ce que tu vois un truc écris OpenSSH ??

Est ce que tu peux monter une connexion en verbose avec
ssh -v login@tonSrv

Hors ligne

#5 Le 03/05/2006, à 16:16

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

En désespoir de cause, j'ai supprimé complêtement (enfin j'espère !) tout ce qui avait un rapport avec ca, et j'ai réinstallé.

Je n'arrive même plus à me connecter au serveur de test de nomachine :

NX> 203 NXSSH running with pid: 3281
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
ssh: connect to host testdrive.nomachine.com port 22: Connection refused

à moins qu'ils aient un pb chez eux.. ? Ca peut aussi arriver !

Ils proposent gentillement de tester avec un login+mdp à partir de la page http://www.nomachine.com/testdrive.php
J'en ai redemandé un, pour tester avec un autre login (car je suspecte que ma réinstallation ait généré de nouvelles clés d'autentification, qui pourraient interagir ?) mais je n'ai pas de réponse de leur part...


En revanche, je peux me connecter de chez moi vers chez moi par NX client et serveur...

EDIT : j'arrive à nouveau à me connecter chez eux, sans que je n'aie rien modifié chez moi.

Dernière modification par environ314 (Le 03/05/2006, à 16:43)

Hors ligne

#6 Le 03/05/2006, à 16:41

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Merci pour ton aide...

Uggy a écrit :

sudo netstat -alpen --inet |grep 22
pour voir si le port 22 est bien en ecoute (par sshd)

Edit : Je fais cela de chez moi :

sudo netstat -alpen --inet |grep 22
Password:
tcp        0      0 127.0.0.1:36237         127.0.0.1:22            ESTABLISHED109        320138     14515/ssh
tcp        1      0 xx.xxx.xxx.xxx:52251    yy.yyy.yy.yy:443        CLOSE_WAIT 1000       605420     311/firefox-bin
tcp        0      0 xx.xxx.xxx.xxx:42236    zz.zzz.zz.zz:1863       ESTABLISHED1000       597620     28152/kopete

Les essais suivants sont faits depuis un client chez nomachine, auquel j'accède par mon client.

Est ce que tu ping la machine ??

ping: sendmsg : Operation not permitted
De chez moi vers chez moi : cela fonctionne.

Est ce que tu peux faire un :
telnet TonServeur 22

telnet monserveur
Trying xx.xxx.xxx.xxx...
telnet: Unable to connect to remote host: Connection refused

De chez moi, vers chez moi, même problème !


Est ce que tu vois un truc écris OpenSSH ??

où cela ?

Est ce que tu peux monter une connexion en verbose avec
ssh -v login@tonSrv

(recopié à la main, j'espère ne pas recopier un chiffre de travers !)

OpenSSH_3.8pl, SSH Protocol 1.5/2.0, OpenSSL 0.9 [...]
debug1 : Reading configuraiton data /etc/ssh/ssh_config
debug1 : Applying options for *
debug1 : Connection to (mon seveur) port 22
debug1 : Connection to (mon seveur) port 22 : connection timed out
>
Display all 228 possiblilities ?

Dernière modification par environ314 (Le 03/05/2006, à 16:48)

Hors ligne

#7 Le 03/05/2006, à 17:09

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

sudo netstat -alpen --inet |grep 22
sur le serveur! pas coté client..
et si c'etait bien sur le serveur, ouvre ton fichier /etc/ssh/sshd_config
et met ListenAddress 0.0.0.0  puis un restart


telnet TonServeur 22
j'ai mis un 22... et pas toi...

Dernière modification par Uggy (Le 03/05/2006, à 17:11)

Hors ligne

#8 Le 03/05/2006, à 17:36

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Uggy a écrit :

sudo netstat -alpen --inet |grep 22
sur le serveur! pas coté client..
et si c'etait bien sur le serveur, ouvre ton fichier /etc/ssh/sshd_config
et met ListenAddress 0.0.0.0  puis un restart

Oui, c'était bien sur le serveur.

Ce fichier contient donc, en non commenté :

  # Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile	%h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes


# To change Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#AFSTokenPassing no
#KerberosTicketCleanup no

# Kerberos TGT Passing does only work with the AFS kaserver
#KerberosTgtPassing yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
KeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

telnet TonServeur 22
j'ai mis un 22... et pas toi...

Oui, en effet. Je corrige :
Chez moi :

telnet monserveur 22
Trying xx.xxx.xxx.xxx...
Connected to monserveur
Escape character is '^]'.
SSH-2.0-OpenSSH_4.1p1 Debian-7ubuntu4.1
^[
Connection closed by foreign host.

Depuis le client :

Trying... puis timed out.

Le comportement n'a pas évolué.

Dernière modification par environ314 (Le 03/05/2006, à 17:56)

Hors ligne

#9 Le 03/05/2006, à 18:01

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Je remarque que tu parles du sshd_config, alors que dans mon message précédent, il s'agissait de ssh_config
J'ai mis la même ligne dans le ssh_config, mais sans plus d'effets. Mais ce dernier fichier est quasiment vide...

Hors ligne

#10 Le 03/05/2006, à 18:07

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

hummm.. il y a un truc tres zarb...

Ton serveur n'est pas en écoute sur le port 22 d'apres le netstat transmis...
...mais la tu me dis qu'en faisant un telnet 22 tu as bien la banniere SSH-2.0-OpenSSH_4.1...

...Ce n'est pas possible...

Je ne sais pas ce que tu appelles "Chez toi" ou "le client"...
Je ne sais pas ce qu'est NX...

On a "clientSSH" qui cherche a se connecter a "ServeurSSH"
le netstat doit etre fait sur la machine "ServeurSSH"
le ssh -v ou le telnet 22 doivent etre fait sur la machine "clientSSH"
(ou clientSSH-1 et clientSSH-2)

Est ce que tu accedes au serveur depuis un client mais pas depuis un autre ???
Si oui... -> FireWall...

Hors ligne

#11 Le 03/05/2006, à 18:11

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

environ314 a écrit :

Je remarque que tu parles du sshd_config, alors que dans mon message précédent, il s'agissait de ssh_config
J'ai mis la même ligne dans le ssh_config, mais sans plus d'effets. Mais ce dernier fichier est quasiment vide...

oui je parle du sshd_config...
et c'est bien ce fichier que tu as mis...

Hors ligne

#12 Le 03/05/2006, à 18:18

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

BOn, je récapitule.
Quand j'écris "chez moi", c'est la machine sur laquelle je suis, sur laquelle il y a le serveur, sur la quelle je n'arrive pas à me connecter depuis ailleurs.

Le telnet 22  répond depuis la machine serveur. Mais PAS depuis l'ordinateur client.
Le ssh -v que tu me demandes de faire, n'aboutit pas non plus depuis le client.

C'est cohérent ?

Et le netstat a bien été effectué sur le serveur (chez moi quoi !)

Et dans les logs de connexion, je vois bien des étrangers tenter de rentrer sur mon système (sshd comme processus) Eux le voient bien !!!

Dernière modification par environ314 (Le 03/05/2006, à 18:22)

Hors ligne

#13 Le 03/05/2006, à 18:22

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

environ314 a écrit :

C'est cohérent ?

Maintenant oui....

Tu as un Firewall entre "l'ordinateur client" et "chez toi"
Si tu as des tentatives de connexions "chez toi" c'est que le Firewall est coté "l'ordinateur client"

Hors ligne

#14 Le 03/05/2006, à 18:24

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

ah, c'est peut-être ca. Moi je n'ai pas de firewall.
Comment je sais pour le client ?!

Hors ligne

#15 Le 03/05/2006, à 18:27

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

environ314 a écrit :

ah, c'est peut-être ca. Moi je n'ai pas de firewall.
Comment je sais pour le client ?!

Comment tu sais quoi ?? si il y a un FireWall coté client ??? La question ne se pose pas.. il y en a un wink

Je serais toi, j'essayerais de faire ecouter mon OpenSSH sur le port 80 ou 443 (mais faudrait couper apache dans ce cas!!) en se disant que ces ports ne sont pas filtrés dans le FireWall

je vais sur #ubuntu-fr si tu veux...

Hors ligne

#16 Le 03/05/2006, à 19:20

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Uggy, je résume depuis tout à l'heure :
en modifiant etc/ssh/sshd_config
et en règlant le port à 80 à la place de 22,

Je constate que les changements sont bien pris en compte en faisant, depuis mon serveur :
sudo netstat -alpen --inet |grep 443

J'ai des réponses, donc c'est bon smile

Ensuite,
j'arrive à avoir une réponse à un telnet monserveur 22 depuis le client,
mais un ssh en ligne de commande s'obstine à vouloir se connecter sur le port 22. J'ai bien tenter un -D 80, mais "seul root peut faire ca"

En revanche, mon application cliente NX de Nomachine me permet de régler le port (j'ai mis 80)
J'ai alors une info comme quoi ca cherche à identifier, mais que "Authentification failed for user ***"

Dans le fichier de config de mon serveur (etc/ssh/sshd_config, j'ai décommenté :

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

et j'ai relancé ssh avec
sudo /etc/init.d/ssh restart     

mais ca n'a rien changé. Et mon mot de passe est le bon !

Par ailleurs, lorsque je règle le port sur 80, l'autentification échoue également si je cherche à me connecter depuis le poste sur lequel le serveur est installé. D'un côté, ca communique plus (depuis le poste client), mais aucune autentification d'abouti (même en local)...

On fait quoi maintenant ?!

Des questions annexes : y a-t-il un danger à changer le port ? Si j'ai compris, c'est qu'on ne peut pas transmettre le mdp de manière cryptée. C'est ca ?
Il y a deux serveurs à lancer, chez moi :
avec le ssh :sudo /etc/init.d/ssh restart     
et pour le serveur NX : sudo nxserver --restart
Quels sont les fichiers de configuration de l'un et de l'autre ? Il y a peut-être à creuser de ce côté ?

Dernière modification par environ314 (Le 03/05/2006, à 19:49)

Hors ligne

#17 Le 04/05/2006, à 18:52

environ314

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

J'ai essayé "en vrai", physiquement quoi, depuis le poste client dont j'avais besoin. Tout ce passe bien !
Merci à vous pour votre aide, en particulier Uggy !

A dire vrai, je ne sais pas trop pourquoi un jour ca ne marchait pas, et puis maintenant ca marche. Je précise que j'ai pu le faire depuis un port 22

Je pense que ce qui a débloqué la chose est ListenAddress 0.0.0.0
Dans mes logs, j'ai un
"Accepted publicKay for nx from (adresse_client) port **** ssh2"
suivi d'un
"Accepted password for (utilisateur) from 127.0.0.1 port xxxxx ssh2"
Qu'est-ce que cela signifie ?

Hors ligne

#18 Le 14/05/2006, à 23:57

Uggy

Re : [Résolu] Pb de connexion ssh vers ma ubuntu

Désolé pour mon retour tardif...
Content que mon aide sur IRC est pu te dépanner...

maintenant ca marche

Si tu peux mettre en [Resolu] wink
A+

Hors ligne

Haut de page ↑