Contenu | Rechercher | Menus

Annonce

Les adresses laposte.net ne permettent pas de recevoir nos emails. Vous êtes invité à changer d'adresse dans vos paramètres de compte à votre prochaine connexion.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 20/10/2009, à 19:59

miniSeb

Problème d'alias... [résolu ^^]

Bonsoir !
Un petit problème d'alias :

J'ai créé un fichier .sh contenant :

#!/bin/bash
# script twitter
curl -u Mon_pseudo:Mon_MDP -d status="$1" http://twitter.com/statuses/update.xml

Quand je l'exécute avec :

./twitter.sh "Message à envoyer"

tout fonctionne correctement...

Par contre, j'ai voulu en faire un alias, en écrivant dans ~/.bashrc

alias twitter='curl -u Mon_pseudo:Mon_MDP -d status="$1" http://twitter.com/statuses/update.xml'

Et là, quand je fais :

twitter "Message à envoyer"

Ça ne fonctionne plus et je reçois ce message d'erreur :

<?xml version="1.0" encoding="UTF-8"?>
<hash>
  <request>/statuses/update.xml</request>
  <error>Client must provide a 'status' parameter with a value.</error>
</hash>
curl: (6) Couldn't resolve host 'Message à envoyer'

Quelqu'un aurait-il une solution pour moi?

J'ai l'impression de ne pas être très clair, mais j'avoue ne pas trouver de meilleur moyen pour expliquer pour le moment... S'il faut des infos supplémentaires, je suis là ^^

Merci d'avance à qui portera attention à mon problème smile

Dernière modification par miniSeb (Le 20/10/2009, à 20:10)

Hors ligne

#2 Le 20/10/2009, à 20:03

wido

Re : Problème d'alias... [résolu ^^]

Bonjour,
au lieu de mettre la commande directement, pourquoi tu ne pointes pas vers ton script et test si tu as la même chose?

Hors ligne

#3 Le 20/10/2009, à 20:10

miniSeb

Re : Problème d'alias... [résolu ^^]

Thanks !
Nickel Marcel et au poil Pascal ^^

Doué moi hmm

Bon ben résolu big_smile:D:D:D:D

Dernière modification par miniSeb (Le 20/10/2009, à 20:11)

Hors ligne

#4 Le 23/10/2009, à 22:08

nesthib

Re : Problème d'alias... [résolu ^^]

pour l'histoire, ton problème venait du fait que les alias ne prennent pas en charge d'arguments ($1), comme a dit wido le plus simple est de pointer vers ton script. Sinon tu peux déclarer une fonction dans ton .bashrc

function truc () {
    ma_commande $1 blabla
}

GUL Bordeaux : GirollServices libres : TdCT.org
Hide in your shell, scripts & astuces :  applications dans un tunnelsmart wgettrouver des pdfinstall. auto de paquetssauvegarde auto♥ awk
  ⃛ɹǝsn xnuᴉꞁ uʍop-ǝpᴉsdn

Hors ligne