Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 02/11/2009, à 18:57

pierre-antoine

Impossible d'avoir un "vrai" runlevel 3

Bonjour a tous,

mon probleme est que je n'arrive pas a booter sans mon gdm (je suis sous xfce mais il me semble que c'est gdm ?!). Pour activer mon runlevel 3 j'ai écrit un fichier inittab correct, et après reboot je retrouver encore ma session graphique. Je vérifi mon runlevel avec la commande runlevel et j'obtiens "N 3". Je vais donc voir les service et ne voi aucun lien sur gdm. J'en ajoute donc un a tout hasard :

cd /etc/rc3.d/
ln -s ../init.d/gdm K13gdm

Apres reboot j'ai encore ma session graphique sad. Il me semble que le chiffre 13 correspond a une priorité quelque part, j'essaye donc de renomer en K03gdm mais toujours la même chose.

Je n'ai pas essayer d'enlever l'exécution de  /etc/init.d/gdm car mon frère utilise par fois l'ordinateur et sans le startx il est perdu...

Une idée ?

Hors ligne

#2 Le 02/11/2009, à 19:26

twinsen93

Re : Impossible d'avoir un "vrai" runlevel 3

Bonjour,

Ubuntu n'utilise plus init mais upstart

J'ai pas compris comment ca fonctionne, mais une il n'y a plus de inittab. Il utilise les scripts de /etc/init.d mais je suis pas sur que les liens de rc?.d soient pris en compte, il y a un autre paramétrage dans /etc/event.d/ ou /etc/init/

Je sais pas si je t'aide beaucoup, mais bon...

Hors ligne

#3 Le 02/11/2009, à 19:40

pierre-antoine

Re : Impossible d'avoir un "vrai" runlevel 3

Je n'ai pas tout compris pour upstart moi non plus mais j'ai vu que le script /etc/event.d/rc-default appel telinit, et je croi que telinit va voir dans les rc?.d....non ?
De plus j'ai ce problème depuis que j'ai fais la mise a jours de 9.04 à 9.10 alors que sur 9.04 tout allais bien. Le changement vers upstart est-il juste sur la dernière version ?

Hors ligne

#4 Le 02/11/2009, à 19:49

twinsen93

Re : Impossible d'avoir un "vrai" runlevel 3

Non, upstart est la depuis quelque versions déja. Par contre, la nouveauté dans karmic c'est /etc/init/ qui remplace /etc/event.d/ (si j'ai bien compris).

Pour telinit, c'est censé changer de runlevel en appelant init, pas appeler les scripts directement (non ? oui ?)

Hors ligne

#5 Le 02/11/2009, à 20:08

pierre-antoine

Re : Impossible d'avoir un "vrai" runlevel 3

Iteressent, je suis aller voir le fichier /etc/init/gdm.conf. Ca a l'air d'etre le bon mais apres avoir modifier la ligne "stop on runlevel[016]" en "stop on runlevel[0136]" je n'ai toujours rien. Je continue de regarder. Merci twinsen93.

Hors ligne

#6 Le 02/11/2009, à 20:42

pierre-antoine

Re : Impossible d'avoir un "vrai" runlevel 3

ahhhhhh, le miracle c'est finalement produit, mais je pense que ma solution est beaucoup trop bourin pour etre la bonne....
J'ai commenté toute la fonction start du JOB. Je ne pense pas pouvoir y acceder avec un autre runlevel mais avec startx tout fonctionne.

Hors ligne

#7 Le 02/11/2009, à 21:05

zapple

Re : Impossible d'avoir un "vrai" runlevel 3

Tu peux montrer le fichier inittab que tu as crées ?

Dernière modification par zapple (Le 02/11/2009, à 21:05)

Hors ligne

#8 Le 03/11/2009, à 13:05

pierre-antoine

Re : Impossible d'avoir un "vrai" runlevel 3

Je ne suis pas chez moi pour le moment mais mon inittab ressemble a id:3:initdefault:
Ne pas oublier le dernier : a la fin sinon ça ne marche pas.

J'ai par contre découvert un autre probleme, je n'ai plus acces au réseau l'ors-ce que je boot, je dois pour pouvoir me connecter (wifi ou cable) faire un startx...Je ne comprend pas pourquoi....

Hors ligne

Haut de page ↑