Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/04/2008, à 22:31

Rocky77

[RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Bonjour,

J'aurais voulu savoir si quelqu'un avait reussi a faire fonctionner un imprimante Canon LBP-810 ou LBP-1120.

Le site de Canon propose des drivers en version 32bits donc si j'essaie de les installer sur Hardy 64 bits le systeme m'indique "Error Wrong Architecture i386"

Quelqu'un aurait-il trouvé une solution ?

Dernière modification par Rocky77 (Le 08/03/2009, à 13:15)

Hors ligne

#2 Le 26/04/2008, à 08:37

Celtiore

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Salut,
pas pour le moment, j'ai refais un script qui fonctionne avec 32bits, mais avec les sources des pilotes 1.60, je vais tenter la création de paquets dès que possible.

désolé

le lien pour 32b : http://blog.celtiore.fr/?p=14


http://blog.celtiore.fr <- Mon Blog
http://www.projetpos.fr <- Pour un Logiciel de Point de Vente Libre

Hors ligne

#3 Le 01/03/2009, à 22:00

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Je viens de decrouvrir un lien qui est pas mal :

https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/CanonPrinters/Canon_LBP_2900#Automatically%20Reporting%20and%20Correcting%20Errors

SAUF que je bloque a cette etape

~$ sudo /usr/sbin/ccpdadmin -p LBP-810 -o /dev/usb/lp0
/usr/sbin/ccpdadmin: error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory

j'ai regarde si le fichier libcups.so.2 existait et je le trouve bien dans /usr/lib et usr/lib64

Que faire !! Reponse : installer les libraires ia32-libs

EDIT : Des que j'ai un peu de temps et si quelqu'un est intéressé, j'expliquerai en détail

Dernière modification par Rocky77 (Le 08/03/2009, à 11:49)

Hors ligne

#4 Le 08/03/2009, à 11:48

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Mini tuto testé sur debian Lenny 64 bits, la methode doit etre identique pour ubuntu 8.04 ou 9.04 64 bits:

1 - Aller sur le site canon et telecharger la derniere version des pilotes linux pour la lbp-1120 :

2 - Decompresser l'archive et notament les repertoires cndrvcups-capt-1.80 et cndrvcups-common-1.80

3 - Compilation et installation du paquet cndrvcups-common-1.80

Si vous voulez eviter de compiler, n'hesitez pas à me demander les paquets deja compilés

  -  Aller dans le repertoire cndrvcups-common-1.80/debian, modifier le fichier control en remplacant "i386" par   amd64"
  - Installer (si non installé)
    * aclocal    (1.4.x or above)
    * automake    (1.4.x or above)
    * aclocal    (1.6.x)
    * automake    (1.6.x)
    * Gtk+        (1.2.x or above) -> libgtk2.0-dev
    * libcups   (1.1.17 or above) ->libcups2, libcups2-dev...
    * build-essential
    * gettext
    * gdebi
    * libxml2-dev
    * libtool
(je pense pas en avoir oublié. Si tel est le cas, il se peut que la compilation ci apres echoue)

- se mettre à la racine du dossier cndrvcups-common-1.80 et taper la commandes suivantes

user@debian64:~/CANON_UK/cndrvcups-common-1.80$ sudo dpkg-buildpackage
user@debian64:~/CANON_UK/cndrvcups-common-1.80$ cd ..
user@debian64:~/CANON_UK/$ sudo gdebi cndrvcups-common_1.80-1_amd64.deb

4 - Compilation et installation du paquet cndrvcups-capt-1.80
-  Aller dans le repertoire cndrvcups-capt-1.80/debian, modifier les fichiers
       
          * control en remplacant "i386" par  "amd64"
          * rules en remplacant “    dh_shlibdeps” par “#    dh_shlibdeps”

- se mettre à la racine du dossier cndrvcups-capt-1.80 et taper la commandes suivantes

user@debian64:~/CANON_UK/cndrvcups-capt-1.80$ sudo dpkg-buildpackage
user@debian64:~/CANON_UK/cndrvcups-capt-1.80$ cd ..
user@debian64:~/CANON_UK/$ sudo gdebi cndrvcups-capt_1.80-1_amd64.deb

5 - Installer les librairies ia32-libs et ia32-libs-gtk meme si je ne pense pas que ce dernier soit necessaire

6 - Modifier le fichier /etc/init.d/ccpd

#!/bin/sh
# ccpd startup script for Canon Printer Daemon for CUPS
# Modified for Debian GNU/Linux
# by Raphael Doursenaud <rdoursenaud@free.fr>.
DAEMON=/usr/sbin/ccpd
LOCKFILE=/var/lock/subsys/ccpd
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
NAME=ccpd
DESC="Canon Printer Daemon for CUPS"
test -f $DAEMON || exit 0
case $1 in
start)
echo -n "Starting $DESC: $NAME"
start-stop-daemon --start --quiet --exec $DAEMON
echo "."
;;
stop)
echo -n "Stopping $DESC: $NAME"
start-stop-daemon --stop --quiet --oknodo --exec $DAEMON
echo "."
;;
status)
echo "$DESC: $NAME:" `pidof $NAME`
;;
restart)
echo -n "Restarting $DESC: $NAME"
start-stop-daemon --stop --quiet --oknodo --exec $DAEMON
sleep 1
start-stop-daemon --start --quiet --exec $DAEMON
echo "."
;;
*)
echo "Usage: ccpd {start|stop|status}"
exit 1
;;
esac
exit 0

9 - Installation de l'imprimante

sudo /etc/init.d/cups restart
sudo /usr/sbin/lpadmin -p LBP-810 -m CNCUPSLBP1120CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
sudo /usr/sbin/ccpdadmin -p LBP-810 -o /dev/usb/lp0
sudo /etc/init.d/ccpd restart

Lors d'une impression, si ca demarre pas, faire :

sudo ccpd start

Sources :

http://ubuntuforums.org/showthread.php?p=6150677
https://help.ubuntu.com/community/Hardw … )%20Steps:


En esperant n'avoir rien oublié...

Dernière modification par Rocky77 (Le 27/03/2009, à 22:54)

Hors ligne

#5 Le 10/03/2009, à 22:32

bertrand_034

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Excuse moi mais je débute sur Linux alors moi j'ai canon IP4500 et il existe aussi des drivers Linux mais en 32 bits donc il faut les compiler comme tu le dit ? mais perso moi compiler cela doit être chaud pour moi car je n'ai jamais fait ceci alors un peu d'aide serait la bien venu comme tu le propose big_smile


www.universfreebox.com

Hors ligne

#6 Le 11/03/2009, à 14:19

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

je pense que ça peut etre une bonne solution. Regarde deja si, lorsque t'as téléchargé les drivers, t'as un repertoire appelé Debian. Si c'est le cas, d'abord lis le fichier README et ensuite tente de faire ce que j'ai indiqué. C'est pas dis que ca marche : mon imprimante utilise des drivers appelés CAPT alors que ton imprimante, elle, n'a pas l'air.

Hors ligne

#7 Le 04/04/2009, à 16:41

ingridL

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Étant donnée que je ne suis pas douée en informatique, j'apprécierais si quelqu'un pouvais me transmettre les paquets pour 64 bits 8.10 ubuntu intrepid concernant LBP1120 et LBP5000.

#8 Le 04/04/2009, à 17:38

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Je viens de le mettre en ligne. 

http://dl.free.fr/pzK8Rq3tz

Bon courage

Hors ligne

#9 Le 05/04/2009, à 21:30

Ingrid77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

il y a un problème avec le lien

Hors ligne

#10 Le 05/04/2009, à 23:13

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Moi j'ai cliqué dessus et il ya pas de problemes

Hors ligne

#11 Le 11/05/2009, à 07:59

cassoulet

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Bonjours Rocky77
J'ai aussi une LBP5000 et je suis  sur ubuntu  64 bits
J'essaie d'installer les fichiers que tu à mis sur free en cliquant sur "driver_canon_x86
j'obtiens 2 fichiers
cndrvcups-capt_1.80-1_amd64.deb et
cndrvcups-common_1.80-1_amd64.deb
en cliquant sur le premier j'ai   il manque le second
en cliquent sur le second j'ai:
des erreurs de traitement cndrvcups-common(--install)
problème de dépendances

Pourrait tu m'indiquer la marche a suivre
Merci

#12 Le 11/05/2009, à 15:58

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Il faut d'abord installer cndrvcups-common_1.80-1_amd64.deb ensuite cndrvcups-capt_1.80-1_amd64.deb. Il est important de respecter l'ordre.

Rappel : Ce sont les drivers pour LBP-810 et LBP-1120, donc c'est pas certain que ca marche avec la LBP5000

A+

Hors ligne

#13 Le 13/05/2009, à 11:31

cassoulet

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

bonjours
J'ai bien effectué les opérations, mais l'imprimante ne fonctionne pas

#14 Le 13/05/2009, à 19:41

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Peux tu me décrire ce que t'as fait exactement.  Est ce que t'as juste installé les 2 paquets que t'as telechargé ou a tu fais les etapes decrites apres l'install des paquets? As tu remplacé lbp800 par lbp5000? etc...
Sinon ca va m'etre difficile de t'aider

A+

Hors ligne

#15 Le 14/05/2009, à 16:30

cassoulet

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Effectivement.Excuse moi.
J'ai juste installé les 2 paquets

#16 Le 14/05/2009, à 16:32

cassoulet

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

J'ai cru comprendre qu'il y avait tout dans les paquets téléchargés
Mais j'ai peut être mal compris

#17 Le 14/05/2009, à 18:38

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Apres avoir installé les 2 paquets, il faut suivre la procedure à partir du point n°5.

Les 2 paquets que j'ai fourni, c'est juste pour eviter d'avoir à les compiler soi meme.

Hors ligne

#18 Le 15/05/2009, à 19:11

cassoulet

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Bonsoir
Désolé, j'ai pas bien compris ni trouvé les librairies ia32-libs  &  ia32-libs-gtk.
J'ai essayé à partir du point 6
en remplaceant  1120 par 5000.
Mon imprimante est bien reconnu.Marche arrêt est bien vu par le gestionnaire d'imprimante, mais je n'arrive pas à imprimer "Traitement en cours"
"file d'attente---> traitement encours, mais pas d'impression

#19 Le 18/05/2009, à 17:02

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

En allant sur Gestionnaire de paquet synaptics -> Rechercher et en tapant ia32, tu dois forcement les trouver si t'as une version ubuntu 64 bits.

Au point 9 tu as fait ceci ?

sudo /etc/init.d/cups restart
sudo /usr/sbin/lpadmin -p LBP-5000 -m CNCUPSLBP1120CAPTK.ppd -v ccp:/var/ccpd/fifo0 -E
sudo /usr/sbin/ccpdadmin -p LBP-5000 -o /dev/usb/lp0
sudo /etc/init.d/ccpd restart

Surtout ne pas oublier le sudo ccpd restart àpres avoir lancé l'impression, l'imprimante doit etre branchée en usb

Dernière modification par Rocky77 (Le 18/05/2009, à 17:03)

Hors ligne

#20 Le 07/11/2009, à 18:32

Rocky77

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

je remets en ligne mes drivers AMD64 :

http://dl.free.fr/getfile.pl?file=/YcycEAkA

Hors ligne

#21 Le 02/05/2010, à 22:33

zorbluc

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Bonsoir Rocky77
J'ai posté un message (http://forum.ubuntu-fr.org/viewtopic.php?id=392770) qui fait référence au lien que tu as laissé et qui contient les pilotes canon pour lbp1120 compilés pour une architecture en 64 bits.
Ils m'ont été personnellement très utile et je suis sûr qu'ils le seront à d'autres.
Merci encore.

Zorbluc

Hors ligne

#22 Le 13/05/2010, à 20:30

baballe

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Ben moi j'ai pas de chance, en 64bits, en suivant la méthode, ma 1120 n'est toujours pas détectée ... et à chaque install d'un périphérique c'est la même galère ...

Hors ligne

#23 Le 18/05/2010, à 21:05

zorbluc

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Bonsoir,

As-tu essayé la méthode que je donne à la fin de ce fil?
http://forum.ubuntu-fr.org/viewtopic.php?id=392770 ?

Hors ligne

#24 Le 05/01/2011, à 11:41

baballe

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

J'ai lancé le script en auto, reboot, et non : toujours au même point, imprimante détectée mais à chaque fois il faut sélectionner un pilote qui n'existe pas dans la liste ... je tourne en rond (depuis 7mois^)

[Edit] eh non, d'un coup ça s'est mis à fonctionner.
Bon, je change mon message pour installer canon lbp-1120 ubuntu 64bits fonctionne , huhu

Dernière modification par baballe (Le 05/01/2011, à 12:03)

Hors ligne

#25 Le 05/01/2011, à 16:20

baballe

Re : [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Hum, non en fait, le temps de redémarrer et l'imprimante et à nouveau non prise en charge ....

Hors ligne

  • Accueil
  • » Forum
  • » Archives
  • » [RESOLU]Driver Canon LBP-810/LBP-1120 pour ubuntu 8.04 ou 9.04 64bits

Haut de page ↑