Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 09/11/2009, à 16:42

fredthefrenchy

[RESOLU] pb avec ia32libs

Bonjour,

Lorsque je lance certains programmes j'ai des soucis du style, cannot open shared library ...

J'ai posté mes messages dans le forum multimedia car je pensais à un problème lié à des librairies multimedia.

Je pense plus maintenant à un problème avec ia32libs qui n'a pas réussi à s'installer lors de la migration Jaunty -> Karmic.
Voir mon post :

http://forum.ubuntu-fr.org/viewtopic.ph … 7#p3053317

le voici ici :

Depuis ma migration vers Karmic (que de problèmes d'ailleurs ...), j'ai ce message d'erreur :

./tsMuxerGUI: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Pourtant, j'ai bien cette librairie :

/usr/lib$ ls -ls libpng*
244 -rw-r--r-- 1 root root 244588 2009-06-04 20:35 libpng12.a
  0 lrwxrwxrwx 1 root root     18 2009-10-31 17:08 libpng12.so -> libpng12.so.0.37.0
  0 lrwxrwxrwx 1 root root     18 2009-10-31 17:08 libpng12.so.0 -> libpng12.so.0.37.0
160 -rw-r--r-- 1 root root 158640 2009-06-04 20:35 libpng12.so.0.37.0
  0 lrwxrwxrwx 1 root root     10 2009-10-31 17:08 libpng.a -> libpng12.a
  0 lrwxrwxrwx 1 root root     11 2009-10-31 17:08 libpng.so -> libpng12.so

idem pour tsMuxeR :

tsMuxeR
tsMuxeR: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory

ls -l /usr/lib/libfreetype*
-rw-r--r-- 1 root root 746742 2009-06-04 07:05 /usr/lib/libfreetype.a
-rw-r--r-- 1 root root    947 2009-06-04 07:05 /usr/lib/libfreetype.la
lrwxrwxrwx 1 root root     21 2009-10-31 17:08 /usr/lib/libfreetype.so -> libfreetype.so.6.3.20
lrwxrwxrwx 1 root root     21 2009-10-31 17:08 /usr/lib/libfreetype.so.6 -> libfreetype.so.6.3.20
-rw-r--r-- 1 root root 542936 2009-06-04 07:05 /usr/lib/libfreetype.so.6.3.20

Alors, je n'ai pas ia32libs d'installé.

J'ai voulu l'installer mais j'ai cela comme erreur :

ia32-libs:
 Dépend : lib32v4l-0 mais ne doit pas être installé

lib32v4l-0:
  Dépend : libv4l-0 (=0.6.0-1) mais 0.6.0.test-1~jjstemp1 doit être installé

libv4l-0 est installé


Que faire pour que je puisse installer ces librairies (ia32libs est un set de librairies il me semble).

D'avance, merci.

Dernière modification par fredthefrenchy (Le 09/11/2009, à 18:02)


CM MSI 990FXA-GD80 - AMD FX8150 8 x 3.6Ghz - G.SKILL KIT EXTREME3 2 X 4 GO PC17000 ARES CAS9 8192 Mo (2133 MHz), 9-11-10-28 - GeForce GTX560 1Go GDDR5 - Ubuntu 12.10 x86-64 dual boot avec W7 64bits

Hors ligne

#2 Le 09/11/2009, à 16:51

MacLane45

Re : [RESOLU] pb avec ia32libs

Je t'ai répondu dans l'autre post mais je te le remets ici à tout hasard.

Poste nous le résultat de cette commande passée dans un terminal : find / -name lib*v4l 2>/dev/null

@+

Hors ligne

#3 Le 09/11/2009, à 16:59

fredthefrenchy

Re : [RESOLU] pb avec ia32libs

mais en tapant : sudo apt-get install ia32-libs :

Les paquets suivants contiennent des dépendances non satisfaites :
  ia32-libs: Dépend: lib32v4l-0 mais ne sera pas installé
E: Paquets défectueux

sinon la commande :
find / -name lib*v4l 2>/dev/null

/usr/local/lib/libv4l
/usr/share/EasyCam2/drivers/ov534/v4l2-apps/lib/libv4l
/usr/share/doc/libpt-1.10.10-plugins-v4l
/usr/lib/libv4l

à priori, libv4l est installé mais pas lib32v4l. Il y a un pb avec apt !

Dernière modification par fredthefrenchy (Le 09/11/2009, à 17:14)


CM MSI 990FXA-GD80 - AMD FX8150 8 x 3.6Ghz - G.SKILL KIT EXTREME3 2 X 4 GO PC17000 ARES CAS9 8192 Mo (2133 MHz), 9-11-10-28 - GeForce GTX560 1Go GDDR5 - Ubuntu 12.10 x86-64 dual boot avec W7 64bits

Hors ligne

#4 Le 09/11/2009, à 17:23

MacLane45

Re : [RESOLU] pb avec ia32libs

Et en essayant de forcer l'installation du package ia32-libs ?

sudo apt-get -f install ia32-libs

Hors ligne

#5 Le 09/11/2009, à 17:35

fredthefrenchy

Re : [RESOLU] pb avec ia32libs

Exactement le même message :

sudo apt-get -f install ia32-libs
[sudo] password for segardf: 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  ia32-libs: Dépend: lib32v4l-0 mais ne sera pas installé
E: Paquets défectueux
segardf@media:~$ sudo apt-get -f install lib32v4l-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation : 

Les paquets suivants contiennent des dépendances non satisfaites :
  lib32v4l-0: Dépend: libv4l-0 (= 0.6.0-1) mais 0.6.0.test-1~jjstemp1 devra être installé
E: Paquets défectueux

Ce qui est interessant, c'est d'utiliser aptitude ...

sudo aptitude install -f ia32-libs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Les paquets suivants sont CASSÉS :
  lib32v4l-0 
Les NOUVEAUX paquets suivants vont être installés :
  ia32-libs lib32asound2{a} lib32ncurses5{a} lib32stdc++6{a} lib32z1{a} 
Les paquets suivants seront ENLEVÉS :
  aften{u} dvdisaster{u} dvdisaster-doc{u} dvdstyler-data{u} libfltk1.1{u} 
  libgavl1{u} libguicastcv-gl{u} libmlt-data{u} libmpeg3-1{u} 
  libmpeg3cv-gl{u} liboggz1{u} libogmrip1{u} libopenjpeg2{u} 
  libquicktime-doc{u} libquicktimecv-gl{u} libsox-fmt-mp3{u} 
  libsox-fmt-pulse{u} libweed0{u} libx264-76{u} lives-data{u} lsdvd{u} 
  ocrad{u} oggz-tools{u} ogmrip-dirac{u} ogmrip-oggz{u} ogmtools{u} 
  optlibx11-noxcb-6{u} optlibx11-noxcb-data{u} pv{u} vcdimager{u} 
  xmms2-plugin-airplay{u} xmms2-plugin-ao{u} xmms2-plugin-apefile{u} 
  xmms2-plugin-asf{u} xmms2-plugin-asx{u} xmms2-plugin-cdda{u} 
  xmms2-plugin-cue{u} xmms2-plugin-curl{u} xmms2-plugin-daap{u} 
  xmms2-plugin-faad{u} xmms2-plugin-flac{u} xmms2-plugin-flv{u} 
  xmms2-plugin-gme{u} xmms2-plugin-gvfs{u} xmms2-plugin-html{u} 
  xmms2-plugin-ices{u} xmms2-plugin-icymetaint{u} xmms2-plugin-jack{u} 
  xmms2-plugin-karaoke{u} xmms2-plugin-m3u{u} xmms2-plugin-mms{u} 
  xmms2-plugin-modplug{u} xmms2-plugin-mp4{u} xmms2-plugin-mpg123{u} 
  xmms2-plugin-musepack{u} xmms2-plugin-normalize{u} xmms2-plugin-ofa{u} 
  xmms2-plugin-oss{u} xmms2-plugin-pls{u} xmms2-plugin-rss{u} 
  xmms2-plugin-sid{u} xmms2-plugin-smb{u} xmms2-plugin-speex{u} 
  xmms2-plugin-tta{u} xmms2-plugin-vocoder{u} xmms2-plugin-wavpack{u} 
  xmms2-plugin-xml{u} xmms2-plugin-xspf{u} 
0 paquets mis à jour, 6 nouvellement installés, 68 à enlever et 4 non mis à jour.
Il est nécessaire de télécharger 30,3Mo d'archives. Après dépaquetage, 83,4Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  lib32v4l-0: Dépend: libv4l-0 (= 0.6.0-1) mais 0.6.0.test-1~jjstemp1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

Réinstaller à une version antérieure les paquets suivants :
libv4l-0 [0.6.0.test-1~jjstemp1 (now) -> 0.6.0-1 (karmic)]

Le score est de 20

Accepter cette solution ? [Y/n/q/?]

Humm ! Il me désinstalle beaucoup de chose mais ... je tente ...

RESULTAT :

Les paquets suivants vont être RÉINSTALLÉS à une VERSION ANTÉRIEURE :
  libv4l-0 
Les NOUVEAUX paquets suivants vont être installés :
  ia32-libs lib32asound2{a} lib32ncurses5{a} lib32stdc++6{a} lib32v4l-0{a} 
  lib32z1{a} 
Les paquets suivants seront ENLEVÉS :
  aften{u} dvdisaster{u} dvdisaster-doc{u} dvdstyler-data{u} libfltk1.1{u} 
  libgavl1{u} libguicastcv-gl{u} libmlt-data{u} libmpeg3-1{u} 
  libmpeg3cv-gl{u} liboggz1{u} libogmrip1{u} libopenjpeg2{u} 
  libquicktime-doc{u} libquicktimecv-gl{u} libsox-fmt-mp3{u} 
  libsox-fmt-pulse{u} libweed0{u} libx264-76{u} lives-data{u} lsdvd{u} 
  ocrad{u} oggz-tools{u} ogmrip-dirac{u} ogmrip-oggz{u} ogmtools{u} 
  optlibx11-noxcb-6{u} optlibx11-noxcb-data{u} pv{u} vcdimager{u} 
  xmms2-plugin-airplay{u} xmms2-plugin-ao{u} xmms2-plugin-apefile{u} 
  xmms2-plugin-asf{u} xmms2-plugin-asx{u} xmms2-plugin-cdda{u} 
  xmms2-plugin-cue{u} xmms2-plugin-curl{u} xmms2-plugin-daap{u} 
  xmms2-plugin-faad{u} xmms2-plugin-flac{u} xmms2-plugin-flv{u} 
  xmms2-plugin-gme{u} xmms2-plugin-gvfs{u} xmms2-plugin-html{u} 
  xmms2-plugin-ices{u} xmms2-plugin-icymetaint{u} xmms2-plugin-jack{u} 
  xmms2-plugin-karaoke{u} xmms2-plugin-m3u{u} xmms2-plugin-mms{u} 
  xmms2-plugin-modplug{u} xmms2-plugin-mp4{u} xmms2-plugin-mpg123{u} 
  xmms2-plugin-musepack{u} xmms2-plugin-normalize{u} xmms2-plugin-ofa{u} 
  xmms2-plugin-oss{u} xmms2-plugin-pls{u} xmms2-plugin-rss{u} 
  xmms2-plugin-sid{u} xmms2-plugin-smb{u} xmms2-plugin-speex{u} 
  xmms2-plugin-tta{u} xmms2-plugin-vocoder{u} xmms2-plugin-wavpack{u} 
  xmms2-plugin-xml{u} xmms2-plugin-xspf{u} 
0 paquets mis à jour, 6 nouvellement installés, 1 remis à une version antérieure, 68 à enlever et 4 non mis à jour.
Il est nécessaire de télécharger 30,4Mo d'archives. Après dépaquetage, 83,4Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Écriture de l'information d'état étendu... Fait
Prendre :1 http://archive.ubuntu.com karmic/main lib32z1 1:1.2.3.3.dfsg-13ubuntu3 [77,4kB]
Prendre :2 http://archive.ubuntu.com karmic/main lib32stdc++6 4.4.1-4ubuntu8 [347kB]
Prendre :3 http://archive.ubuntu.com karmic/main lib32asound2 1.0.20-3ubuntu6 [330kB]
Prendre :4 http://archive.ubuntu.com karmic/main lib32ncurses5 5.7+20090803-2ubuntu2 [186kB]
Prendre :5 http://archive.ubuntu.com karmic/main libv4l-0 0.6.0-1 [95,1kB]
Prendre :6 http://archive.ubuntu.com karmic/main lib32v4l-0 0.6.0-1 [73,7kB]
Prendre :7 http://archive.ubuntu.com karmic/universe ia32-libs 2.7ubuntu17 [29,2MB]
30,4Mo téléchargés en 58s (522ko/s)                                             
(Lecture de la base de données... 293392 fichiers et répertoires déjà installés.)
Suppression de aften ...
Suppression de dvdisaster ...
Suppression de dvdisaster-doc ...
Suppression de dvdstyler-data ...
Suppression de libfltk1.1 ...
Suppression de libgavl1 ...
Suppression de libguicastcv-gl ...
Suppression de libmlt-data ...
Suppression de libmpeg3-1 ...
Suppression de libquicktimecv-gl ...
Suppression de libmpeg3cv-gl ...
Suppression de ogmrip-oggz ...
Suppression de oggz-tools ...
Suppression de liboggz1 ...
Suppression de ogmrip-dirac ...
Suppression de libogmrip1 ...
Suppression de libopenjpeg2 ...
Suppression de libquicktime-doc ...
Suppression de libsox-fmt-mp3 ...
Suppression de libsox-fmt-pulse ...
Suppression de libweed0 ...
Suppression de libx264-76 ...
Suppression de lives-data ...
Suppression de lsdvd ...
Suppression de ocrad ...
Ignoring install-info called from maintainer script
The package ocrad should be rebuild with new debhelper to get trigger support
Suppression de ogmtools ...
Suppression de optlibx11-noxcb-6 ...
Suppression de optlibx11-noxcb-data ...
Suppression de pv ...
Suppression de vcdimager ...
Ignoring install-info called from maintainer script
The package vcdimager should be rebuild with new debhelper to get trigger support
Ignoring install-info called from maintainer script
The package vcdimager should be rebuild with new debhelper to get trigger support
Ignoring install-info called from maintainer script
The package vcdimager should be rebuild with new debhelper to get trigger support
Suppression de xmms2-plugin-airplay ...
Suppression de xmms2-plugin-ao ...
Suppression de xmms2-plugin-apefile ...
Suppression de xmms2-plugin-asf ...
Suppression de xmms2-plugin-asx ...
Suppression de xmms2-plugin-cdda ...
Suppression de xmms2-plugin-cue ...
Suppression de xmms2-plugin-icymetaint ...
Suppression de xmms2-plugin-curl ...
Suppression de xmms2-plugin-daap ...
Suppression de xmms2-plugin-faad ...
Suppression de xmms2-plugin-flac ...
Suppression de xmms2-plugin-flv ...
Suppression de xmms2-plugin-gme ...
Suppression de xmms2-plugin-gvfs ...
Suppression de xmms2-plugin-html ...
Suppression de xmms2-plugin-ices ...
Suppression de xmms2-plugin-jack ...
Suppression de xmms2-plugin-karaoke ...
Suppression de xmms2-plugin-m3u ...
Suppression de xmms2-plugin-mms ...
Suppression de xmms2-plugin-modplug ...
Suppression de xmms2-plugin-mp4 ...
Suppression de xmms2-plugin-mpg123 ...
Suppression de xmms2-plugin-musepack ...
Suppression de xmms2-plugin-normalize ...
Suppression de xmms2-plugin-ofa ...
Suppression de xmms2-plugin-oss ...
Suppression de xmms2-plugin-pls ...
Suppression de xmms2-plugin-rss ...
Suppression de xmms2-plugin-sid ...
Suppression de xmms2-plugin-smb ...
Suppression de xmms2-plugin-speex ...
Suppression de xmms2-plugin-tta ...
Suppression de xmms2-plugin-vocoder ...
Suppression de xmms2-plugin-wavpack ...
Suppression de xmms2-plugin-xspf ...
Suppression de xmms2-plugin-xml ...
Traitement des actions différées (« triggers ») pour « menu »...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
Traitement des actions différées (« triggers ») pour « install-info »...
install-info: avertissement: aucune entrée répertoire Info dans « /usr/share/info/menu.info.gz »
install-info: avertissement: aucune entrée répertoire Info dans « /usr/share/info/ispell.info.gz »
install-info: avertissement: aucune entrée répertoire Info dans « /usr/share/info/gmediaserver.info.gz »
Sélection du paquet lib32z1 précédemment désélectionné.
(Lecture de la base de données... 291434 fichiers et répertoires déjà installés.)
Dépaquetage de lib32z1 (à partir de .../lib32z1_1%3a1.2.3.3.dfsg-13ubuntu3_amd64.deb) ...
Sélection du paquet lib32stdc++6 précédemment désélectionné.
Dépaquetage de lib32stdc++6 (à partir de .../lib32stdc++6_4.4.1-4ubuntu8_amd64.deb) ...
Sélection du paquet lib32asound2 précédemment désélectionné.
Dépaquetage de lib32asound2 (à partir de .../lib32asound2_1.0.20-3ubuntu6_amd64.deb) ...
Sélection du paquet lib32ncurses5 précédemment désélectionné.
Dépaquetage de lib32ncurses5 (à partir de .../lib32ncurses5_5.7+20090803-2ubuntu2_amd64.deb) ...
dpkg : avertissement : dégradation (« downgrade ») de libv4l-0 depuis 0.6.0.test-1~jjstemp1 vers 0.6.0-1.
Préparation du remplacement de libv4l-0 0.6.0.test-1~jjstemp1 (en utilisant .../libv4l-0_0.6.0-1_amd64.deb) ...
Dépaquetage de la mise à jour de libv4l-0 ...
Sélection du paquet lib32v4l-0 précédemment désélectionné.
Dépaquetage de lib32v4l-0 (à partir de .../lib32v4l-0_0.6.0-1_amd64.deb) ...
Sélection du paquet ia32-libs précédemment désélectionné.
Dépaquetage de ia32-libs (à partir de .../ia32-libs_2.7ubuntu17_amd64.deb) ...
Paramétrage de lib32z1 (1:1.2.3.3.dfsg-13ubuntu3) ...

Paramétrage de lib32stdc++6 (4.4.1-4ubuntu8) ...

Paramétrage de lib32asound2 (1.0.20-3ubuntu6) ...

Paramétrage de lib32ncurses5 (5.7+20090803-2ubuntu2) ...

Paramétrage de libv4l-0 (0.6.0-1) ...

Paramétrage de lib32v4l-0 (0.6.0-1) ...

Paramétrage de ia32-libs (2.7ubuntu17) ...

Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
Lecture des listes de paquets... Fait             
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait

État actuel : 8150 nouveaux paquets [-3].

ET CA MARCHE ....

Il faut que je ré-installe maintenant ce qu'il m'a désinstallé.

merci.

Dernière modification par fredthefrenchy (Le 09/11/2009, à 17:56)


CM MSI 990FXA-GD80 - AMD FX8150 8 x 3.6Ghz - G.SKILL KIT EXTREME3 2 X 4 GO PC17000 ARES CAS9 8192 Mo (2133 MHz), 9-11-10-28 - GeForce GTX560 1Go GDDR5 - Ubuntu 12.10 x86-64 dual boot avec W7 64bits

Hors ligne

#6 Le 09/11/2009, à 18:00

MacLane45

Re : [RESOLU] pb avec ia32libs

De rien smile pense juste à mettre un petit résolu au titre de ton post.

@+

Hors ligne

#7 Le 09/11/2009, à 18:02

fredthefrenchy

Re : [RESOLU] pb avec ia32libs

Je sais, je le fais.

Juste un truc, on utilise toujours apt-get mais on devrait utiliser aptitude ; franchement il aide mieux et est plus compatible avec synaptic ...


CM MSI 990FXA-GD80 - AMD FX8150 8 x 3.6Ghz - G.SKILL KIT EXTREME3 2 X 4 GO PC17000 ARES CAS9 8192 Mo (2133 MHz), 9-11-10-28 - GeForce GTX560 1Go GDDR5 - Ubuntu 12.10 x86-64 dual boot avec W7 64bits

Hors ligne

Haut de page ↑