Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 09/11/2009, à 18:04

wod58

Problème montage de partition

Bonjour,

J'avais résolu ce problème très vite avec l'aide d'amis calés il y a quelques semaines, quand j'avais installé Jaunty, mais récemment (peut-être est-ce du à la m-à-j, je ne suis pas trop sur), ubuntu ne veut plus lancer ma partition Vista. Que ce soit au démarrage ou manuellement...

Quand j'essaye manuellement, je reçois ceci:

Impossible de monter Vista

Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sda2 on /media/Vista

J'ai tenté de chercher dans l'aide sur le montage de partition, mais sans succès... En effet, j'ai changé mon fstab, de la manière indiquée dans le tuto, et maintenant, je reçois :

Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://ntfs-3g.org/support.html#unprivileged

Et là, je calle complètement... (NTFS-3g est correctement installé)


Si quelqu'un trouve la solution... Il aura toute ma gratitude! smile

Hors ligne

#2 Le 09/11/2009, à 18:09

aemaeth2501

Re : Problème montage de partition

Utilises :

sudo mount /dev/sda2 /media/Vista

J'imagines que pour tester le fstab tu as fait

mount -a

?

Dans ce cas, même chose :

sudo mount -a

Hors ligne

#3 Le 09/11/2009, à 18:18

wod58

Re : Problème montage de partition

Je faisais déjà sudo mount, mais ceci dit, voici ce qu'il me rend à tes commandes:

laurent@laurent-laptop:~$ sudo mount /dev/sda2 /media/Vista
[sudo] password for laurent: 
fuse: failed to access mountpoint /media/Vista: Aucun fichier ou dossier de ce type
laurent@laurent-laptop:~$ mount -a
mount: seul l'usager ROOT peut faire cela
laurent@laurent-laptop:~$ sudo mount -a
fuse: failed to access mountpoint /media/Vista: Aucun fichier ou dossier de ce type

Hors ligne

#4 Le 09/11/2009, à 18:38

aemaeth2501

Re : Problème montage de partition

Il ne te reste plus qu'à créer le point de montage cool :

sudo mkdir /media/Vista

Hors ligne

#5 Le 10/11/2009, à 10:16

wod58

Re : Problème montage de partition

aemaeth2501 a écrit :

Il ne te reste plus qu'à créer le point de montage cool :

sudo mkdir /media/Vista

Pas de changement notable, mais il dit ceci :

laurent@laurent-laptop:~$ sudo mkdir /media/Vista
[sudo] password for laurent: 
laurent@laurent-laptop:~$ sudo mount /dev/sda2 /Media/Vista
fuse: failed to access mountpoint /Media/Vista: Aucun fichier ou dossier de ce type

Hors ligne

#6 Le 10/11/2009, à 14:32

aemaeth2501

Re : Problème montage de partition

/Media/Vista : attention, ca respecte la casse.
Il faut donc que tu tapes :

sudo mount /dev/sda2 /media/Vista

Tu peux me donner la ligne correspondante de ton fstab ?

Dernière modification par aemaeth2501 (Le 10/11/2009, à 14:33)

Hors ligne

#7 Le 15/11/2012, à 23:14

loransea

Re : Problème montage de partition

Bonjour, j'ai un soucis avec une partition sur l'un  de mes disques, j'arrive à la monter mais je ne peux pas y acceder ou bien je ne peux même pas la monter. J'ai changé mon fstab
"
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc              proc  nodev,noexec,nosuid         0  0 
# / was on /dev/sda7 during installation
UUID=8fd4ccfb-c79a-44a3-9efb-bbcb567763fd  /                  ext4  errors=remount-ro           0  1 
# /home was on /dev/sda6 during installation
UUID=35d3239e-93ec-4bba-9b74-99ffad8200ee  /home              ext4  defaults                    0  2 
# /media/Data_500Go was on /dev/sdb1 during installation
UUID=10A4548EA45477E4                      /media/Data_500Go  ntfs  defaults,umask=007,gid=46   0  0 
# /media/Data_95Go was on /dev/sda4 during installation
UUID=75FAF6C72AE14426                      /media/Data_95Go   ntfs  defaults,umask=007,gid=46   0  0 
# /media/WinXP was on /dev/sda1 during installation
UUID=C028ED2B28ED2160                      /media/WinXP       ntfs  defaults,umask=007,gid=46   0  0 
# swap was on /dev/sda5 during installation
UUID=73f8d507-8720-47ae-bf15-8b78b529d7d2  none               swap  sw                          0  0 
# dev/sdd1 label="stockage2" uuid="5BA696E100AB0239" TYPE="ntfs"
UUID=5BA696E100AB0239                    /media/stockage2   ntfs  defaults,umask=007,gid=46   0  0
# ligne remplacée /dev/sdd1                                  /media/stockage2   ntfs  defaults                    0  0 
# dev/sdd2 LABEL="Photostack" UUID="37CBC15E6A9F298B" TYPE="ntfs"
UUID=37CBC15E6A9F298B                    /media/Photostack  ntfs  defaults,umask=007,gid=46   0  0
# ligne remplacée /dev/sdd2                                  /media/Photostack  ntfs  defaults                    0  0 
# dev/sdd3 LABEL="Musique" UUID="4117D61148FD56A4" TYPE="ntfs"
UUID=4117D61148FD56A4                    /media/Musique     ntfs  rw,user,auto,gid=46,uid=1000,nls=iso8859,umask=002      0    0
# UUID=4117D61148FD56A4                    /media/Musique     ntfs  nls=iso8859-1,ro,umask=007  0  0
# ligne remplacée /dev/sdd3                                  /media/Musique     ntfs  nls=iso8859-1,ro,umask=000  0  0 
"
malheureusement, j'obtiens cela quandj'essaie d'accéder à la partition Musique
"Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://ntfs-3g.org/support.html#unprivileged"


e^(i·[pi])+1=0 donc...Dieu existe (citation attribuée à Euler)
Aimez vous les uns les autres... comme je vous ai aimés (citation attribuée à Jésus).
donc Dieu... serait le mathématicien au grand coeur.
Et moi "je doute donc...je suis" Descartes.

Hors ligne

#8 Le 15/11/2012, à 23:15

loransea

Re : Problème montage de partition

Bonjour, j'ai un soucis avec une partition sur l'un  de mes disques, j'arrive à la monter mais je ne peux pas y acceder ou bien je ne peux même pas la monter. J'ai changé mon fstab
"
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc              proc  nodev,noexec,nosuid         0  0 
# / was on /dev/sda7 during installation
UUID=8fd4ccfb-c79a-44a3-9efb-bbcb567763fd  /                  ext4  errors=remount-ro           0  1 
# /home was on /dev/sda6 during installation
UUID=35d3239e-93ec-4bba-9b74-99ffad8200ee  /home              ext4  defaults                    0  2 
# /media/Data_500Go was on /dev/sdb1 during installation
UUID=10A4548EA45477E4                      /media/Data_500Go  ntfs  defaults,umask=007,gid=46   0  0 
# /media/Data_95Go was on /dev/sda4 during installation
UUID=75FAF6C72AE14426                      /media/Data_95Go   ntfs  defaults,umask=007,gid=46   0  0 
# /media/WinXP was on /dev/sda1 during installation
UUID=C028ED2B28ED2160                      /media/WinXP       ntfs  defaults,umask=007,gid=46   0  0 
# swap was on /dev/sda5 during installation
UUID=73f8d507-8720-47ae-bf15-8b78b529d7d2  none               swap  sw                          0  0 
# dev/sdd1 label="stockage2" uuid="5BA696E100AB0239" TYPE="ntfs"
UUID=5BA696E100AB0239                    /media/stockage2   ntfs  defaults,umask=007,gid=46   0  0
# ligne remplacée /dev/sdd1                                  /media/stockage2   ntfs  defaults                    0  0 
# dev/sdd2 LABEL="Photostack" UUID="37CBC15E6A9F298B" TYPE="ntfs"
UUID=37CBC15E6A9F298B                    /media/Photostack  ntfs  defaults,umask=007,gid=46   0  0
# ligne remplacée /dev/sdd2                                  /media/Photostack  ntfs  defaults                    0  0 
# dev/sdd3 LABEL="Musique" UUID="4117D61148FD56A4" TYPE="ntfs"
UUID=4117D61148FD56A4                    /media/Musique     ntfs  rw,user,auto,gid=46,uid=1000,nls=iso8859,umask=002      0    0
# UUID=4117D61148FD56A4                    /media/Musique     ntfs  nls=iso8859-1,ro,umask=007  0  0
# ligne remplacée /dev/sdd3                                  /media/Musique     ntfs  nls=iso8859-1,ro,umask=000  0  0 
"
malheureusement, j'obtiens cela quandj'essaie d'accéder à la partition Musique
"Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://ntfs-3g.org/support.html#unprivileged"

J'ai laissé en commentaire mes commandes précédentes la plus ancienne en bas...mais aucune n'a fonctionné sauf la plus vielle au début
# ligne remplacée /dev/sdd3                                  /media/Musique     ntfs  nls=iso8859-1,ro,umask=000  0  0
mais qui ne voulait plus me monter Musique ensuite (de quoi, mystère). Musique elle même partition d'un disque physique dont les deux autres partition /media/Stockage2 et /media/Photostack montent normalement grrr).
Quand je mets les mêmes valeurs aux options des trois partitions, j'obtiens un message d'erreur seulement pour /media/Musique su /dev/sdd3, soit
Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdd3 on /media/Musique


Quelqu'un a-t-il une idée de ce qu'il faut modifier dans le fstab pour que je puisse écouter ma musique à nouveau ? et m'explique svp ce qu'est l'eternal FUSE library ? Merci de votre aide,cdlt.

Dernière modification par loransea (Le 15/11/2012, à 23:33)


e^(i·[pi])+1=0 donc...Dieu existe (citation attribuée à Euler)
Aimez vous les uns les autres... comme je vous ai aimés (citation attribuée à Jésus).
donc Dieu... serait le mathématicien au grand coeur.
Et moi "je doute donc...je suis" Descartes.

Hors ligne

#9 Le 15/11/2012, à 23:51

compte supprimé

Re : Problème montage de partition

Le plus simple, pour monter une partition ntfs est de faire ça :

UUID=4117D61148FD56A4 /media/Musique ntfs-3g defaults 0 0

(en admettant bien sûr que l'uuid est correcte et que le point de montage existe)
Et à tout hasard, avant de la monter :

sudo chown loransea:loransea /media/Musique

Histoire que tu sois le propriétaire du répertoire, pour pouvoir écrire dedans...

Dernière modification par faustus (Le 15/11/2012, à 23:55)

#10 Le 18/11/2012, à 21:13

loransea

Re : Problème montage de partition

@faustus,
genial tout baigne dans une atmosphère musicale... fausse, lol
Un grand merci smile


e^(i·[pi])+1=0 donc...Dieu existe (citation attribuée à Euler)
Aimez vous les uns les autres... comme je vous ai aimés (citation attribuée à Jésus).
donc Dieu... serait le mathématicien au grand coeur.
Et moi "je doute donc...je suis" Descartes.

Hors ligne

Haut de page ↑