Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 24/01/2005, à 23:30

Le Furet

Impossible d'installer CG VIA S3G Unichrome

Bonjour,

j'ai un mirifique portable ACER 1363WLMi, avec un chipset graphique intégré VIA S3G Unichrome Pro.

Et mon affichage rame lamentablement. De plus, ma carte graphique n'apparaît pas avec un dmesg, je ne sais pas si c'est normal.

Tout ça me laisse penser que mon pilote graphique n'est pas optimisé pour ma carte (m'étonnerait pas que ce soit le VESA, mais je ne sais pas comment on fait pour vérifier).

Je précise que je suis grand débutant sous Linux, mais pas demeuré quand même. Si vous m'expliquez, je comprends, mais allez lentement par pitié, je débarque juste de mon Windows.

Ma version est une Hoary, et je dois dire que plus je la pratique, mieux je comprends certains mécanismes et plus ça me plaît, mais parfois, seul, je patauge un peu.

Merci à qui pourra m'aider.

Hors ligne

#2 Le 24/01/2005, à 23:41

newportable

Re : Impossible d'installer CG VIA S3G Unichrome

La tu me fous les boules gamin, t'es pire que moi... Tu débarque du côté obscure de la force et tu prend une hoary, t'es sucidaire ou quoi. Avant toute chose revient en warty et reposte après. Une hoary faut avoir du temps libre et aucune données qui craint...

Hors ligne

#3 Le 24/01/2005, à 23:51

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

J'ai eu une Warty. J'avais le même pb de carte graphique, en pire, vu que sous la Warty, je ne parvenais pas à avoir la résolution 1280*800 (la plus adaptée à mon écran). Ca marche sous la Hoary.

De plus, après divers messages sur divers forums en diverses langues, j'ai cru comprendre que le seul espoir de faire tourner ma carte était d'utiliser Xorg, et qu'on trouvait Xorg sur la Hoary et pas sur la Warty.

Donc, dans tous les cas, je reste sous Hoary smile

Hors ligne

#4 Le 24/01/2005, à 23:55

newportable

Re : Impossible d'installer CG VIA S3G Unichrome

ben bonne chance quand même. Sinon pour ton pb pas de réponses, désolé...

Hors ligne

#5 Le 24/01/2005, à 23:56

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

Merci d'avoir essayé.

Personne dans le coin n'a de portable Acer avec cg VIA intégrée ?

Hors ligne

#6 Le 25/01/2005, à 02:37

coffee

Re : Impossible d'installer CG VIA S3G Unichrome

nop mais je chercherai du coté des drivers unichrome
http://unichrome.sourceforge.net/


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#7 Le 25/01/2005, à 09:34

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

Le problème est là :

An X driver suited for X.org and Xfree86. It provides support for VIA CLE266 and KM400/KN400. K8M800 and PM800/CN400 support is still limited.

Et bien sûr, ma carte, c'est la K8M800 (je crois, c'est pas non plus très bien documenté).

Sur viaarena.com, il y a un pilote Linux pour ça, mais pour Fedora, Red Hat et Mandrake. Pas pour Ubuntu ni même Debian.

J'ai essayé de l'installer en suivant les instructions, j'ai ça :

# ./vinstall
-------- install start --------
install VIA/S3G UniChrome familly graphic driver!
cp: ne peut évaluer `//k7/XServer/via_v4l_drv.o': Aucun fichier ou répertoire de ce type
cp: ne peut évaluer `/lib/modules/2.6.9-1-386/kernel/drivers/media/video/videodev.o': Aucun fichier ou répertoire de ce type
cp: ne peut évaluer `//k7/XServer/videodev.o': Aucun fichier ou répertoire de ce type
cp: ne peut évaluer `//k7/XServer/via_drv.o': Aucun fichier ou répertoire de ce type
cp: ne peut évaluer `//k7/XServer/via.o': Aucun fichier ou répertoire de ce type
cp: ne peut évaluer `//k7/XServer/via_dri.so': Aucun fichier ou répertoire de ce type
sed: impossible de lire /etc/rc.d/rc.local: Aucun fichier ou répertoire de ce type
cp: ne peut créer le fichier régulier `/etc/rc.d/rc.local': Aucun fichier ou répertoire de ce type
sed: impossible de lire /etc/rc.d/rc.local: Aucun fichier ou répertoire de ce type
cp: ne peut créer le fichier régulier `/etc/rc.d/rc.local': Aucun fichier ou répertoire de ce type
sed: impossible de lire /etc/rc.d/rc.local: Aucun fichier ou répertoire de ce type
cp: ne peut créer le fichier régulier `/etc/rc.d/rc.local': Aucun fichier ou répertoire de ce type
FATAL: Module via_v4l_drv not found.
insmod: can't read '/lib/modules/2.6.9-1-386/kernel/drivers/char/drm/via.o': No such file or directory
-------- vinstall end --------

Hors ligne

#8 Le 25/01/2005, à 10:22

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

J'ai tenté de télécharger la version 26 du pilote du lien donné par coffee (fichier .o avec la mention Debian), je l'ai copié à la place de via_drv.o dans usr/X11R6/lib/modules/drivers, puis j'ai modifié le fichier xorg.conf en remplaçant "vesa" par "via_drv".

Ca n'a pas marché. Mais il est vraisemblable que j'ai râté une étape (je n'ai trouvé aucun tuto clair et j'ai fait au feeling)

Hors ligne

#9 Le 25/01/2005, à 13:15

coffee

Re : Impossible d'installer CG VIA S3G Unichrome

lspci tu donnera + d'info sur ta carte

et pour ton pb euh j'y vois trp de pb pour pouvoir y repondre


//k7/XServer/via_v4l_drv.o <-- il est pas bien placé, une merde avec une variable d'environnement style $PWD

/etc/rc.d/rc.local ya pas sous debian

donc je ne saurai trop te dire comment l'install


doc d'install: http://sourceforge.net/docman/display_doc.php?docid=21910&group_id=102048

Dernière modification par coffee (Le 25/01/2005, à 13:19)


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#10 Le 29/01/2005, à 14:05

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

lspci répond :

0000:01:00.0 VGA compatible controller: VIA Technologies, Inc.: Unknown device 3108 (rev 01)

ce qui n'augure rien de bon. Mais les différentes infos glanées sur le net confirment que c'est un K8M800.

La documentation commence par :

Make sure you have a build tree of XFree 4.4 or later, which has been built once so all object files etc. are there. The top build directory will hereafter be called "<build>", and it is containing the subdirectory xc.

Je n'ai pas trouvé ledit répertoire. Comment fais-je pour savoir quelle est ma version de XFree ?

Hors ligne

#11 Le 29/01/2005, à 22:18

coffee

Re : Impossible d'installer CG VIA S3G Unichrome

c une 4.3 ....

EDIT: ou sous hoary c X;org ce qui n'est pas XFree

Dernière modification par coffee (Le 29/01/2005, à 22:19)


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#12 Le 31/01/2005, à 00:31

Le Furet

Re : Impossible d'installer CG VIA S3G Unichrome

Xorg n'est pas XFree 4.4 ? Flute...

Hors ligne

#13 Le 10/02/2005, à 19:05

mougla

Re : Impossible d'installer CG VIA S3G Unichrome

XFree et xorg sont deux implémentations différentes de X Window, comme debian et Mandrake sont deux implémentations différentes de Linux (en gros quoi).

La version du serveur est dans /var/log/XFree86.0.log (pour Xfree) ou /var/log/Xorg.0.log (pour Xorg).

En fait j'ai un Acer 1362WLMi, et j'ai en gros le même problème que toi.
Je suis sous une debian sarge.

D'ailleurs, pour changer le driver dans le fichier de conf de X, faut mettre Driver "via" et pas "via_drv", les drivers disponibles sont visibles dans /usr/X11R6/lib/modules/drivers/.
Mais j'obtient uniquement un écran noir, et je suis obligé de redémarrer avec Ctrl+Alt+Backspace (pourquoi ça redémarre avec ces touches, d'ailleurs ??).

Pour l'instant j'utilise le driver vesa, qui marche avec mon écran 15,4 pouces à conditions de mettre ça pour le configurer (dans /etc/X11/XF86Config-4):

Section "Monitor"
        Identifier "PTS031D"
        VendorName "Unknown"
        ModelName  "Unknown"
        HorizSync 30 - 70
        VertRefresh 50 - 160
        #Refresh Rate 60Hz
        ModeLine "1280x800" 68.9 1280 1344 1368 1408 800 803 806 816
        Option          "DPMS"
EndSection

En ce moment j'essaye d'installer Xorg, mais visiblement ça marche pas mieux.

Haut de page ↑