Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#76 Le 15/11/2009, à 20:12

sudni

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bonsoir, je viens de recompiler pour Karmic la version 2.1 et toujours le meme probleme : pas de suavegarde et ce quelque soit le format utiliser (VOB,FLV,...) et pour la preview la son en fond ne joue pas! Si quelqu'un a une idée ...
Merci d'avance.
Paul.
(sudni@altern.org)

Hors ligne

#77 Le 16/11/2009, à 02:23

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

ne mets pas ton email en clair dans tes posts tu vas te faire spammer. On peut te contacter via ta page utilisateur du forum.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#78 Le 16/11/2009, à 20:46

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

sigo a écrit :

super comme logiciel.

je l'ai compilé à partir du depot svn.
je n'arrive pas à avoir des transitions en lancant le programme "normalment" (ALT + F2). par contre en le lancant dans un terminal depuis l'endroit ou je l'ai compilé, pas de soucis. il doit donc y avoir des fichiers qui n'ont pas bougé mais lesquels?

c'est pas grave comme problème mais c'est quand meme un peut dérangeant donc si quelqu'un comprend mon soucis, je suis preneur.

ps: j'ai compilé car j'avais le meme problème avec le paquet sur getdeb.

Bonjour,

J'ai le même problème que toi  concernant les transitions mais par contre je te dis merci car je n'avais pas remarqué qu'elles y étaient en lançant via le terminal dans le répertoire où la compilation s'est faite.
On aura peut être la solution pour le lancer "normalement" mais je n'ai toujours pas trouvé.

Pour ceux qui demande si la version du dépot ne suffit pas (la 1.5.3), il y a une grande différence par rapport à la 2.1. En effet (sauf erreur de ma part), avec la 1.5.3, on ne peut pas zoomer, mettre de texte sur les diapos, les mp3 ne sont pas gérés.

Merci au dev.

Edit: ça y est j'ai trouvé mais je n'ai aucun mérite, c'est marqué dans le readme. Voilà ce qu'il faut faire:

Avant de compiler, il faut aller modifier une ligne dans le répertoire "src" du fichier "support.c"
Il faut transformer
#define PLUGINS_INSTALLED 0
en
#define PLUGINS_INSTALLED 1

sauver votre fichier ainsi modifié et compiler
./configure
make
sudo make install

lancer par "alt F2" et là, les transitions apparaissent enfin.

Dernière modification par dalas (Le 16/11/2009, à 22:21)

Hors ligne

#79 Le 22/11/2009, à 11:52

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bonjour, à tous.

Je ne sais pas si cela est dû à un bug mais pour moi, Imagination 2.1 n'ouvre plus une présentation sauvegardée.
Depuis aujourd'hui, je ne peux plus ouvrir mes sauvegardes de présentation.
Quelqu'un a-t-il rencontré le même problème?

Dernière modification par dalas (Le 22/11/2009, à 12:05)

Hors ligne

#80 Le 22/11/2009, à 14:27

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Regarde dans l'aide d'Imagination, c'est indiqué que les présentations sauvegardees avec une ancienne version d'Imagination (je ne sais plus le numero) ne seront plus prises en charge.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#81 Le 22/11/2009, à 15:25

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

YannUbuntu a écrit :

Regarde dans l'aide d'Imagination, c'est indiqué que les présentations sauvegardees avec une ancienne version d'Imagination (je ne sais plus le numero) ne seront plus prises en charge.

Merci pour ta réponse mais le problème ne vient pas de là.
J'ai bien compilé la dernière version et les sauvegardes viennent de cette version et pas d'une version antérieure.

Edit: Alors là, je ne comprends plus.

J'ai fait une nouvelle présentation avec deux photos et l'ai sauvegardé pour voir si je pouvais la récupérer. Là, pas de problème, ça marche.
J'essaye dans la foulée, d'ouvrir les autres présentations et là elles s'ouvrent aussi ???

Si ça recommence, je referais cette manip (à moins que l'on ne trouve une solution à ce problème). Je garde ma petite présentation "dépannage" et je l'ouvrirai plus tard pour voir si je rencontre encore ce problème.

Edit du 23/11/2009:
Aujourd'hui, j'essaie d'ouvrir les deux présentations faites hier et elles ne s'ouvrent pas.
Je reteste la manip d'hier (création présentation, sauvegarde, fermeture puis ouvrir).
Cette présentation s'ouvre sans problème par contre là, cette fois, impossible d'ouvrir celles d'hier ???

En regardant les fichiers créés (fichier txt), ils commencent tous par :

#Imagination 2.0 Slideshow Project - http://imagination.sf.net

[slideshow settings]
video format=576
background color=0;0;0;
distort images=true
number of slides= X (X étant le nombre de photos contenus dans le diaporama).

Edit du 29/11/2009:
Aujourd'hui, j'essaie d'ouvrir mes trois sauvegardes (je n'arrivais pas à les ouvrir depuis mon dernier message) et là je réussi, elles s'ouvrent.
Si quelqu'un écrivant bien l'anglais pouvait  faire part au développeur de "l'instabilité" d'ouverture des sauvegardes (pouvoir ouvrir ses sauvegardes est très très aléatoire).

Dernière modification par dalas (Le 29/11/2009, à 16:16)

Hors ligne

#82 Le 30/11/2009, à 20:25

barthp

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bonjour,

J'ai installé Imagination avec succès avec les dernières mise à jour de GetDeb. Et ça a l'air de fonctionner.

Mais et j'ignore si c'est lié; je ne sais pas lire de fichier au format AVI alors que sur un autre PC sans imagination, ça focntionne sans problème.

Totem me dit :
Aucun paquet n’a été trouvé avec les greffons requis.
Les greffons requis sont :

Décodeur XVID MPEG-4

VLC me dit :
Pas de décodeur approprié pour le format:
VLC ne supporte probablement pas le format audio ou vidéo « XVID ». Malheureusement il n’y a rien à faire.

MPlayer (en console !!!) me dit :

mplayer: error while loading shared libraries: libfaad.so.0: cannot open shared object file: No such file or directory

Avez-vous une petite idée pour résoudre cela?

D'avance merci.

barthp

Hors ligne

#83 Le 30/11/2009, à 21:49

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

barthp a écrit :

Bonjour,

J'ai installé Imagination... avec succès avec les dernières mise à jour de GetDeb. Et ça a l'air de fonctionner.

Mais et j'ignore si c'est lié; je ne sais pas lire de fichier au format AVI alors que sur un autre PC sans imagination, ça focntionne sans problème.

Totem me dit :
Aucun paquet n’a été trouvé avec les greffons requis.
Les greffons requis sont :

Décodeur XVID MPEG-4

VLC me dit :
Pas de décodeur approprié pour le format:
VLC ne supporte probablement pas le format audio ou vidéo « XVID ». Malheureusement il n’y a rien à faire.

MPlayer (en console !!!) me dit :

mplayer: error while loading shared libraries: libfaad.so.0: cannot open shared object file: No such file or directory

Avez-vous une petite idée pour résoudre cela?

D'avance merci.

barthp

Bonjour,

As tu installé "mencoder" via synaptic. Il contient un codec xvid et cela pourrait peut être résoudre ton problème. Où sinon, pour mplayer, essaie d'installer le paquet libfaad.0 (toujours via synaptic)

Dernière modification par dalas (Le 30/11/2009, à 21:52)

Hors ligne

#84 Le 30/11/2009, à 23:14

barthp

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Merci pour ta réponse.

Ils sont déjà installés. Je les ai réinstallé mais sans amélioration.

D'autres idées?

Merci d'avance.

Barthp

Hors ligne

#85 Le 30/11/2009, à 23:27

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Trouvé sur un autre post et apparemment son problème est résolu.

Regardes ici:
http://forum.ubuntu-fr.org/viewtopic.php?id=314962

ci-après quelques suggestions, mille excuses si tu les as déjà testées.

1)  installer les codecs pour gstreamer ( Applications-Ajouter/Supprimer-taper gstreamer dans le moteurde recherche)
2)  installer w32codecs ou w64codecs récupérables sur           http://www.mplayer.hu.
3)  installer libdvdcss2  avec synaptic

En espérant que ça marche aussi pour toi.

Dernière modification par dalas (Le 30/11/2009, à 23:28)

Hors ligne

#86 Le 01/12/2009, à 22:10

barthp

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Merci à Dalas pour les info, mais ça n'a pas fonctionné.

En désespoir de cause, j'ai désinstallé complètement mplayer et libfaad à la suite de quoi j'ai réinstallé mplayer et là, miracle, ça fonctionne...

ouf...

barthp

Hors ligne

#87 Le 06/12/2009, à 21:55

winux12

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bonsoir,
je viens de découvrir ce soft dans LPE, installer avec synpatic, mais voilà je rencontre un problème lors de l'importation de photos, 9/10 le logiciel se gele m'obligeant a forcer à quitter

merci de quelques conseils


La LIBERTE n'a pas de prix ...Ubuntu 12.04 - Gnome-Shell - Asus K52F-SSD 240Go-8Go Ram
TuxLibre - ARU2L
Adhérent à l'APRIL
1 Photo - 1 Jour

Hors ligne

#88 Le 18/12/2009, à 03:48

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

bonjour
Un utilisateur d'Imagination sur 9.04 à dépanner svp : http://forum.ubuntu-fr.org/viewtopic.php?pid=3143158


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#89 Le 18/12/2009, à 15:46

laurentb

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Salut,

je viens de tester la version 1.5 du paquet officiel Ubuntu universe, ça tourne très bien.

J'ai fait une page de doc ici : http://www.lprod.org/wiki/doku.php/video:imagination

avec un tuto de base et une vidéo de démo big_smile. La suite d'ici quelques jours.

J'aurais voulu tester la version 2.1, ou 2.0, mais la compilation plante ici sous Karmic UBS 32bits.

Il y a une doc ou un paquet à tester ?

Merci d'avance,

Laurent,
lprod.org


Laurent Bellegarde, professeur de SVT, 64 Bayonne, France
GNU/Linux a l'ecole : www.abuledu.org
lprod.org, Montage audio et vidéo libre
Lugs : www.euskalug.org, www.abul.org

Hors ligne

#90 Le 19/12/2009, à 15:56

cenwen

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Salut laurent
Vite fait car je suis à la bourre ces jours-ci, tu trouveras le paquet chez Getdeb, tu suis la procédure pour installer le dépot puis tu fais comme d'habitude, (sudo apt-get update && sudo apt-get install imagination). Tu as aussi la version par svn, il me semble que j'ai donné la procédure dans un précédant post la version est plus évoluée (>3.0.) et le manuel d'aide est en français.Bon je retourne à mon manuel si je veux être pret dans les délais, il m'en reste 40% à traduire.:P On se verra bientot dans la mailing.:lol:


Le jour où j'ai découvert le libre, j'ai su que je ne reviendrais jamais en arrière.
The OpenShot Team : http://www.openshotvideo.com/
Mon blog perso sur le multimédia et OpenShot : http://linuxevolution.wordpress.com/
Google+ : https://plus.google.com/u/0/111472725110173916234/posts

Hors ligne

#91 Le 19/12/2009, à 19:23

sam7

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

cool ... dispo sur getdeb !

Hors ligne

#92 Le 20/12/2009, à 08:11

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

salut
pour memoire, tout ceci se trouve deja dans la Doc: http://doc.ubuntu-fr.org/imagination

@cenwen: tu peux demander un coup de main / relecture a la mailing-list des traducteurs http://doc.ubuntu-fr.org/groupetraducteur

Dernière modification par YannUbuntu (Le 20/12/2009, à 08:14)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#93 Le 20/12/2009, à 13:37

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Bonjour,

Juste un petit passage pour voir si je suis le seul à avoir ce problème.
Comme déjà signalé plus haut , j'ai toujours des problèmes pour ouvrir mes sauvegardes de présentation.

Je précise qu'elles sont bien faites avec la dernière version d'imagination 2.1.

Le souci est le suivant: parfois j'arrive à les ouvrir et d'autrefois non. Et c'est souvent le non qui remporte.

Est ce que cela pourrait venir d'une mauvaise compilation de la source ou est ce un bug ?

Malgré mes recherches sur le Net, je n'ai rien trouvé.

EDIT: J'ai trouvé d'où vient le problème (j'aurais dû y penser plus tôt) et voilà la solution.
Voilà pourquoi ça ne marchait pas systématiquement:

Mes photos utilisées pour mes diaporamas se trouvent stockées sur un deuxième disque dur qui ne se monte pas automatiquement au démarrage de linux. S'il n'est pas monté, il est tout à fait logique qu'imagination ne trouve pas les photos.
La solution est donc de monter mon disque et là, c'est du 100% pour ouvrir mes sauvegardes.

C'était un problème bête mais pas insurmontable.

Dernière modification par dalas (Le 20/12/2009, à 13:53)

Hors ligne

#94 Le 20/12/2009, à 23:58

alain59144

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

bonsoir,
j'ai le même problème les diaporamas ne s'ouvrent pas; version 2-0b.1
je n'arrive pas à iinstaller le 2.1 je suis sous jaunty (suis revenu à jaunty cause probleme son).
a moins que la 2.1 ne fonctionne qu'avec karmic
je cherche un .deb pour la 2.1 mais à première vue il n'y en a pas
à l'installation j'ai :

No package 'gtk+-2.0' found
No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

comment faire si cela est possible


On a déjà assez de soucis avec ce qui arrive, ne nous prenons pas la tête avec ce qui aurait pu arriver....
ubuntu depuis 2010..j'avance doucement dans la connaissance du système, j'utilise Gimp VLC Openshot EKD Audacity KDEnLive MediaMobilConverter (pour Linux)...

Hors ligne

#95 Le 21/12/2009, à 10:28

dalas

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

alain59144
    Hier à 22:58

bonsoir,
j'ai le même problème les diaporamas ne s'ouvrent pas; version 2-0b.1
je n'arrive pas à iinstaller le 2.1 je suis sous jaunty (suis revenu à jaunty cause probleme son).
a moins que la 2.1 ne fonctionne qu'avec karmic
je cherche un .deb pour la 2.1 mais à première vue il n'y en a pas
à l'installation j'ai :
Code:

No package 'gtk+-2.0' found
No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

comment faire si cela est possible

Bonjour,

Essaies ça (je suis sous Karmic mais ça doit marcher pour Jaunty) pour compiler. Certains paquets sont déjà installés par Karmic mais je te conseille de vérifier les paquets un par un.


YannUbuntu a écrit :

Le dev d'Imagination qui utilise Xubuntu m'avait conseillé d'installer les paquets docbook-xsl, libsox-dev or libgtk2.0-dev. L'autre dev (qui utilise une autre distribution) m'a parlé des paquets automake, autoconf, libtool, libgtk2.0-dev,
libsox, xsltproc et ffmpeg. Je ne sais pas si ils existent toujours sous karmic ?

Dernière modification par dalas (Le 21/12/2009, à 10:30)

Hors ligne

#96 Le 21/12/2009, à 12:43

laurentb

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Salut,

effectivement, le paquet 2.0 ne peut pas s'installer sur Karmic.

Le paquet 2.1 seul en tentative d'installation demande une dépendance sur lib-sox non résolue et la seule solution pour faire l'installation est de rajouter le dépôt PPA de get deb dans sa karmic.

La 2.1 s'est installée ici.

Je commence mes tests, et si c'est concluant, je vais demander un upload sur le paquet officiel.

Laurent
lprod.org


Laurent Bellegarde, professeur de SVT, 64 Bayonne, France
GNU/Linux a l'ecole : www.abuledu.org
lprod.org, Montage audio et vidéo libre
Lugs : www.euskalug.org, www.abul.org

Hors ligne

#97 Le 21/12/2009, à 12:45

alain59144

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

Pour l'ouverture d'un diapo déjà créé, c'est tout bête, il faut d'abord sauvegarder le script avec "enregistrer" et c'est ce fichier créé que l'on peut re-ouvrir par la suite, pas le fichier exporté.  roll:rolleyes:

mais vous parlez tous de karmic et pas de jaunty, je voulais savoir si la version 2.1 fonctionne sous jaunty.
si je trouve comment l'installer.

Dernière modification par alain59144 (Le 21/12/2009, à 12:50)


On a déjà assez de soucis avec ce qui arrive, ne nous prenons pas la tête avec ce qui aurait pu arriver....
ubuntu depuis 2010..j'avance doucement dans la connaissance du système, j'utilise Gimp VLC Openshot EKD Audacity KDEnLive MediaMobilConverter (pour Linux)...

Hors ligne

#98 Le 21/12/2009, à 15:13

YannUbuntu

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

@laurent: merci pour ton tuto "Imagination: diaporama simple" .  Un point à corriger: tu écris "une fonction automatique qui pourrait régler d'un seul coup la durée de chaque diapositive n'est pas encore disponible", or si tu sélectionnes toutes les diapos (CTRL+A ou à la souris) tu peux régler d'un seul coup la durée de toutes les diapos. smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#99 Le 21/12/2009, à 21:59

cenwen

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

@YannUbuntu
Aie. Trop tard, je ne viens que de le voir, de toutes façons je l'avais déjà traduit, c'était surtout pour un contrôle de relecture (et dieu sait que j'en ai fait des fautes et des oublis aussi tongue)
J'aurai du y penser avant mais tout se passe si vite. Là je suis en train de reverifier avant de le valider. Merci quand même.;)


Le jour où j'ai découvert le libre, j'ai su que je ne reviendrais jamais en arrière.
The OpenShot Team : http://www.openshotvideo.com/
Mon blog perso sur le multimédia et OpenShot : http://linuxevolution.wordpress.com/
Google+ : https://plus.google.com/u/0/111472725110173916234/posts

Hors ligne

#100 Le 09/01/2010, à 23:58

bierenard

Re : [Nouveau]Logiciel "Imagination" pour créer un Slideshow

[Résolu]
Bonsoir,

Malgré plusieurs essais de versions différentes, je n'ai aucun fichier exporté dans aucun format de sortie :-(

Dernière tentative avec : Karmic (9.10) - imagination 2.1 (paquet sur GetDeb)
Ligne imagination générée :

ffmpeg -f image2pipe -vcodec ppm -r 30,00 -b 384k -s 320x240 -i pipe: -f flac -i /tmp/img_audio_fifo -f flv -vcodec flv -acodec libmp3lame -ab 56000 -ar 22050 -ac 1 -y "/tmp/imagination/video.flv"

Mais pas le moindre fichier "video.flv" dans mon répertoire imagination :-(

----------------------------------------------------------- oOo ---------------------------------------------------------

[Solution] :

Le problème venait d'un mauvais fonctionnement de "ffmpeg" dans la version 9.10 (peut être lié aux 2 upgrades successifs effectués pour passer de Intrepid à Jaunty puis à Kacmic ?)
"ffmpeg" lancé seul donnait le message suivant :
"libx264.so.57: cannot open shared object file: No such file or directory"

D'où l'idée de repartir de zéro en retirant le paquet "ffmpeg" de la 9.10 et de le ré-installer à partir des sources.
J'ai suivi l'excellent tutoriel (en anglais) suivant :  "http://ubuntuforums.org/showthread.php?t=786095"
pour recompiler et installer "ffmpeg" et "x264" à partir des sources du "svn".
À la sortie : Impeccable ! Imagination 2.1 génère tous les formats (sauf le "ogv") avec du son en MP3

Bye

Dernière modification par bierenard (Le 10/01/2010, à 17:13)

Hors ligne

Haut de page ↑