Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 08/05/2005, à 17:41

Ratur

[Résolu] Freeze de firefox et X avec certains sites

Bonjour à tous

Voila, j'ai un probleme assez dérangeant entre ma machine et mozilla-firefox.
Ma config d'abord : c'est une Epia M-9000, avec un CPU via C3 à 933mhz. 256Mo de ram DDR, geforce 2 MX PCI, et le reste ne doit pas etre important. C'est pas un foudre de guerre, mais ça suffit largement pour la bureautique.

Mon problème est le suivant : Quand je demande à firefox d'afficher un site trop lourd, le PC freeze irrémédiablement. C'est à dire que je ne peux plus bouger que la souris, le reste ne répond plus. Je ne peux meme plus acceder à la console. Tout ce qu'il me reste à faire, c'est rebooter. Et ça m'arrive plusieurs fois par jour sad.
Celà arrive, par exemple, quand je visite un site où il y a bcp d'images, d'animations flash, etc (genre ebay) ou bien quand il y a trop d'onglets ouverts.

J'utilise ubuntu hoary, firefox 1.03, et xfce 4

Je précise que, avant, j'utilisais gentoo, et je n'avais jamais eu de problème de ce type.

S'il vous plait aidez moi smile
Vous n'imaginez pas à quel point j'ai l'air ridicule, quand je vente la stabilité de linux devant mes potes, et puis qu'ils le voient freezer devant leurs yeux big_smile

Dernière modification par Ratur (Le 29/05/2005, à 16:45)

Hors ligne

#2 Le 15/05/2005, à 23:03

Ratur

Re : [Résolu] Freeze de firefox et X avec certains sites

UP

Le problème est toujours présent.
Et il survient même sur des sites anodins genre
http://people.via.ecp.fr/~alexis/formation-linux/shell.html

Hors ligne

#3 Le 16/05/2005, à 13:10

ZeBob

Re : [Résolu] Freeze de firefox et X avec certains sites

http://www.chezmoicamarche.org/

Et en désinstallant complètement Firefox puis en le réinstallant ? En essayant avec un autre navigateur ?

Hors ligne

#4 Le 16/05/2005, à 13:36

αjet

Re : [Résolu] Freeze de firefox et X avec certains sites

salut,

En ce qui me concerne, j'ai vire libflash-mozplugin, comme conseille dans certains posts et depuis firefox ne freeze plus.

Par contre, seul firefox plantait dans mon cas.

@+
alex


a.k.a. alex63

Hors ligne

#5 Le 29/05/2005, à 16:46

Ratur

Re : [Résolu] Freeze de firefox et X avec certains sites

Réponse trouvée sur le forum ubuntu anglais :
http://ubuntuforums.org/showthread.php?t=28345&highlight=firefox+freeze

en gros il faut virer dans xorg.conf
RenderAccel "true"

Maintenant mon PC est ultra stable cool (certains jours, il m'arrivait de rebooter 10 fois big_smile )

Hors ligne

#6 Le 04/06/2005, à 21:16

Omnisilver

Re : [Résolu] Freeze de firefox et X avec certains sites

J'ai le même problème (ati radeaon 9200 SE je crois) et je ne trouve pas de RenderAccel dans /etc/X11/xorg.conf !

Que faire ? Créer un RenderAccel "false" ou autre chose ?

Voici mon log :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
#    Load    "extmod"
    SubSection "extmod"
    Option    "omit xfree86-dga"
    EndSubSection
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"hp f1723"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
	Monitor		"hp f1723"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Pour le moment je suis obligé de rebooter plusieurs fois par jour, c'est pire que sous Windows, c'est horrible sad

Hors ligne

#7 Le 05/06/2005, à 21:35

Omnisilver

Re : [Résolu] Freeze de firefox et X avec certains sites

Up ... j'en suis à mon 4 ème hard reboot de la soirée sad

J'ai rajouté une ligne à la section device de mon xorg.conf mais ça n'a rien changé hmm

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
        Option	        "RenderAccel" "false"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
EndSection

Un coup de main svp ! Si je désinstalle le driver de ma carte ATI ça règlera mon problème ? Je préfère ne pas pouvoir jouer à planter toutes les 10 minutes ...

Hors ligne

Haut de page ↑