Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash vient d'être divulguée, il est recommandé de mettre à jour son système (plus de détails)

*** 28 sept. nouvelle mise à jour (4.2-2ubuntu2.5 ou 4.3-7ubuntu1.4) *** pour mettre à jour, lancez dans un terminal :
sudo apt-get update ; sudo apt-get upgrade bash

#1 Le 16/05/2005, à 18:51

Ph.denis

Ma session ne démarre plus!!! IMPORTANT

Bonjour à tous,
j'étais sur mon ordi puis la batterie c'est décharée donc l'ordi s'est fermé d'un seul coups. Et mnt qd je veux redémarrer par ma session (car j'arrive à démarer avec la session "root")  ça ne marche pas. Même qd je passe par la console et que je tape "startx" et je sais pas voir quel fichier m'empêche de démarer en mode graphique car je ne sais pas monter avec un curseur dans ma console.

AVEZ vous une idée pour que je puisse démarer???

merci

#2 Le 16/05/2005, à 18:57

PierreR

Re : Ma session ne démarre plus!!! IMPORTANT

Et la session de secours de Gnome (dans le menu session de GDM) ?

Hors ligne

#3 Le 16/05/2005, à 19:22

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

j'ai pas celà au démarrage pcq j'ai Kubuntu en faites


Vous avez un solution?

#4 Le 16/05/2005, à 19:31

Gzyg

Re : Ma session ne démarre plus!!! IMPORTANT

startx &

au cas où ... c'est le & qui est important . Je démarre comme ça depuis que j'ai perdu gdm  ...
(il me semble que c'est une histoire de nombre de consoles ouvertes en graphiques ?)

Hors ligne

#5 Le 16/05/2005, à 19:38

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

merci de ta réponse avec startx &  mais celà ne fonctionne pas!

#6 Le 16/05/2005, à 19:51

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

Avez vous une autre idée?

je sais lire ce message

"waiting for X server to shut down Synaptics DeviceOff called"

#7 Le 16/05/2005, à 19:57

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Vérifier les suid et uid et Xauthority

Hors ligne

#8 Le 16/05/2005, à 20:01

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

cep a écrit :

Vérifier les suid et uid et Xauthority

Je suis assez nouveau et je ne sais pas trop m'y prendre pour vérifier ça?? tu sai m'en dire plus stp

#9 Le 16/05/2005, à 21:32

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Ph.denis a écrit :

Je suis assez nouveau et je ne sais pas trop m'y prendre pour vérifier ça?? tu sai m'en dire plus stp

Ok. On va essayer de simplifier au maximum.
Par exemple, dans ton /home/ il y a le fichier caché .Xauthority qui renferme des clés et cookies.
Pour voir les droits, avec ton explorateur de fichier, clique droit et propriétés puis permissions.
Ce fichier doit appartenir à ton user, donc Groupe du fichier User et Propriétaire en lecture et écriture, donc = rw = 600.
Ou, en console :
ls -l /home/user/.Xauthority
et tu devrais avoir : rw......1 user  user etc. etc.

Maintenant tu pourrais aussi renommer ou supprimer .Xauthority
Pour le supprimer en console :
rm .Xauthority une fois positionné dans le home de ton user
puis touch .Xauthority pour créer un nouveau fichier
Ensuite, comme il aura été crée par root, lui redonner les droits rw à ton user et le mettre dans le groupe de ton user comme l'était le précédent .Xauthority

Si cela ne suffit pas, il faudra compliquer un peu.

Bonne continuation.
Cep

Hors ligne

#10 Le 16/05/2005, à 21:42

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Ph.denis a écrit :

Avez vous une autre idée?

je sais lire ce message

"waiting for X server to shut down Synaptics DeviceOff called"

Je n'avais pas vu ce message qui a du arriver pendant que je rédigeais mon premier poste.

Tu as quel noyau ?

Hors ligne

#11 Le 16/05/2005, à 22:30

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

kernel=2-6.10-5-386

J'ai fais ce que tu m'as indiqué ça ne marche toujours pas....(merci de ton aide!!)

#12 Le 16/05/2005, à 22:36

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Après avoir rebooté ?

Bon, si ça ne fonctionne toujours pas, voir aussi les droits sur le fichier .kde de ton home et, éventuellement le supprimer. Tu perdras tes réglages. Voir aussi s'il n'y a pas un fichier lock

Au fait, le home n'est pas sur une partition séparée ?

Dernière modification par cep (Le 16/05/2005, à 23:02)

Hors ligne

#13 Le 17/05/2005, à 09:03

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

non c'est pas une partition séparée.

Mais quitte à faire ta solution autant que je crée un nouvel utilisateur et que je transfert tout le répéertoire /home  même avec les fichiers cachés comme ça j'aurais toujours les rgélages,non?

#14 Le 17/05/2005, à 09:22

cep

Re : Ma session ne démarre plus!!! IMPORTANT

A priori, X n'est pas cassé, le système de fichiers non plus.
Donc, il faut trouver où est le cadenas qui empêche l'user de démarrer sa session.
Tu as éliminé le .Xauthority, et tu ne parles pas d'un autre fichier .Lock dans le /home.
Donc on peut penser que .kde fiche la pagaille. Le fait de le supprimer n'est pas vraiment grave, tu perdras seulement tes réglages, personalisation de fond d'écran, etc. Rien d'irréversible.
Donc, tu regardes, comme tu as fait pour .Xauthority, les permissions, puis tu supprimes ce fichier et tu le recrées par touch.
Le fait de créer un autre user va te compliquer la tâche (sudo, etc. ) et si tu recopies le home tu déplaces le problème.
Lorsque tu auras réglé ce problème, il faudra peut-être aussi explorer la cause de ce problème. En effet ton message "waiting for X server to shut down Synaptics DeviceOff called" pourrait laisser supposer qu'il y a un bug dans la gestion de la charge... A voir.
Bonne continuation.
Cep

P.S. Je parle bien sûr du .kde qui est dans le dossier personnel dans /home
donc, /home/user/.kde

Dernière modification par cep (Le 17/05/2005, à 09:24)

Hors ligne

#15 Le 17/05/2005, à 09:40

laurent

Re : Ma session ne démarre plus!!! IMPORTANT

Il y a aussi le fichier .X0-lock ou un truc du genre dans /tmp. J'avais eu le prob mais il y a un bout de temps...

Si tu essayais d'effacer le contenu de /tmp, pour voir? (ça fait pas de mal, c'est des fichiers temporaires...)

puis faire startx


Laurent, petit belge explorant la banquise

Hors ligne

#16 Le 17/05/2005, à 11:09

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Indépendament du fichier .X0-lock, attention à la suppression de fichiers dans /tmp/. Il vaut mieux s'abstenir de supprimer les fichiers récents.

Tu pourrais aussi explorer plus en détail les fichiers de log, en particulier dans /var/log/Xorg.0.log et dans /var/log/kdm

Hors ligne

#17 Le 17/05/2005, à 11:11

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

Alors j'ai supprimer .kde(c'est une répertoire donc pas avec rm  mais rm -rf) puis je le recrée (mkdir .kde) j'ai redémarré toujours le même prob.

Et pour ta solution laurent je l'ai fait aussi et rien à faire...

ON VA Y ARRIVER les ga!

#18 Le 17/05/2005, à 11:19

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Ph.denis a écrit :

Alors j'ai supprimer .kde(c'est une répertoire donc pas avec rm  mais rm -rf)...

oui, bien sûr.

Ben, tu pourrais redémarrer en recovery et tenter une réparation.
Documente-toi avant, car tu devras adapter à ton installation.
Donc fsck /dev/hdx...
A adapter à ton installation et à ton système de fichier.

Dernière modification par cep (Le 17/05/2005, à 11:33)

Hors ligne

#19 Le 17/05/2005, à 12:10

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

bon j'ai formaté ça me faisait chi*** lol

ET ENCORE UN GRD MERCI LES MECS SURTT CEP!


http://www.student.montefiore.ulg.ac.be/~denisp/

Hors ligne

#20 Le 17/05/2005, à 12:16

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Ph.denis a écrit :

bon j'ai formaté ça me faisait chi*** lol

Dommage, on aurait pu s'amuser en allant plus loin big_smile

Bonne suite

Cep

Hors ligne

#21 Le 17/05/2005, à 18:13

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

Voialj'ai tout formaté! lol

Dis tu ne sais pas ce que je pourrais faire car j'ai un un autre disk qui ne contient pas l'installation de linux dessus mais des donnés à moi! Et j'aimerais qu'au démarage il me le démarre au lieu de faire à chaque démarrage "mount -t ext 3 /dev/ ....." . Je sais que je dois modfier un fichier mais je suis plus trop lequel merci!


(me suis inscrit car j'adore ce site!)


http://www.student.montefiore.ulg.ac.be/~denisp/

Hors ligne

#22 Le 17/05/2005, à 18:27

cep

Re : Ma session ne démarre plus!!! IMPORTANT

Ph.denis a écrit :

'au démarage il me le démarre au lieu de faire à chaque démarrage "mount -t ext 3 /dev/ ....." . J

Effectivement, il faut modifier fstab dans /etc/
et la ligne qui concerne ton disque et ta partition windows (fat32) doit ressembler à cela :

/dev/hdxx      /mnt/rep_crée pour     vfat    user,auto,gid=100,umask=002   0    0

Tu trouveras des explications ici :
http://www.ubuntulinux.org/wiki/FrMonta … ionWindows

et ici aussi :
http://lea-linux.org/admin/admin_fs/fstab.html

Dernière modification par cep (Le 17/05/2005, à 21:22)

Hors ligne

#23 Le 17/05/2005, à 22:20

Ph.denis

Re : Ma session ne démarre plus!!! IMPORTANT

merci!


http://www.student.montefiore.ulg.ac.be/~denisp/

Hors ligne

Haut de page ↑