Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 13/01/2010, à 17:27

zebuntu

horloge système avance trop vite. date/time jamais à l'heure :S

Hello,

Sous ubuntu 9.10 karmic 64bit depuis qq temps (impossible de mettre un debian dans ce #@#@ pc), je viens de remarquer un truc que j'avais jamais eu avant : l'horloge système/générale/qui-sert-à-tout (dont la datation des fichiers) prend de l'avance/va trop vite. Elle prend 1/2sec toutes les 10secs environ : un

$ while true
do
	ntpdate <ntpserver>
	sleep 10
done

dans un shell me retourne :

...
13 Jan 16:06:40 ntpdate[31013]: step time server <ntpserver> offset -0.520941 sec
13 Jan 16:06:50 ntpdate[31020]: step time server <ntpserver> offset -0.520251 sec
13 Jan 16:07:00 ntpdate[31026]: step time server <ntpserver> offset -0.522974 sec
13 Jan 16:07:10 ntpdate[31034]: step time server <ntpserver> offset -0.537297 sec
13 Jan 16:07:20 ntpdate[31039]: step time server <ntpserver> offset -0.512136 sec
13 Jan 16:07:32 ntpdate[31046]: step time server <ntpserver> offset -0.522410 sec
...

script que je suis obligé de laisser tourner dans un shell, tout le temps, sinon le temps fait nawak :\
il va sans dire que j'ai déjà essayé avec plein d'autres serveurs ntp (même microsoft.com), c'est pareil. C'est normal que ce soit pareil, le pb vient pas des serveurs ntp, mais de mon temps qui file trop vite. Je ne suis pas non plus en train de voyager dans l'espace à la vitesse de la lumière, hein wink

voilà, c'est sans commentaire supplémentaire.

matos: asrock p55 pro (i5-750) 4go ram, nvidia gts-250

J'ai fait une recherche dans les forums mais
- recherche rapide: ça me renvoie toujours sur une liste google (et y'a pas ce que je cherche dedans),
- formulaire de recherche: ça me renvoie toujours sur l'accueil forum
donc <new post>

Dernière modification par zebuntu (Le 13/01/2010, à 17:31)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#2 Le 13/01/2010, à 17:44

Yann

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Bizarre, je crois que ca arive avec certains CPUs a fréquence variable. Installe ntpd? Ca résoudra pas le pourquoi, mais ca t'ajusteras le temps de manière plus propre...


Et pourtant moi, jsuis pas du genre délicat,
Dans un coin de la musse, j'ai posé mon matelas
- Paulo Anarkao

Hors ligne

#3 Le 13/01/2010, à 18:06

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

salut Yann,

J'ai déjà essayé ntpd, ça ne change rien, même problème d'horloge qui file un rien trop vite.
(J'ai meme essayé avec openntpd, mais lui se plante à la post-install, donc on oublie)
Si c'est un pb de proc, j'vois pas ce que je peux faire de mieux que ça.


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#4 Le 13/01/2010, à 18:20

Yann

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Euh ntpd c est censé *vraiment* mettre a jour l horloge... Il te la mettra pas a jour toutes les 5 secondes, mais regulierement, ca doit pouvoir se configurer...


Et pourtant moi, jsuis pas du genre délicat,
Dans un coin de la musse, j'ai posé mon matelas
- Paulo Anarkao

Hors ligne

#5 Le 13/01/2010, à 19:12

Le Galéanthrope

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink


Miaou ! ー Nyamiou Le Galéanthrope

Hors ligne

#6 Le 13/01/2010, à 19:23

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

re,

$  sudo aptitude install ntp ntp-doc
...
Les NOUVEAUX paquets suivants vont être installés :
  ntp ntp-doc 
...
Paramétrage de ntp (1:4.2.4p6+dfsg-1ubuntu5.1) ...
 * Starting NTP server ntpd                          [ OK ]
...

(install ok)

$ /etc/init.d/ntp status
 * NTP server is not running.
$ service ntp status restart (ou même force-reload)
 * Stopping NTP server ntpd                          [ OK ]
 * Starting NTP server ntpd                          [ OK ]
$ /etc/init.d/ntp status
 * NTP server is not running.

gni !?


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#7 Le 13/01/2010, à 19:23

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Le Galéanthrope a écrit :

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink

Le pc est neuf (4 mois), et sous sale-os y'a pas ce pb (ni en 32, ni en 64)


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#8 Le 13/01/2010, à 19:43

Michel38

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Bonsoir,
Décommente les 2 lignes à la fin juste au-dessus des serveurs que tu as choisi:

sudo gedit /etc/ntp.conf

restart ton ntp

sudo /etc/init.d/ntp restart

vérifie

sudo /etc/init.d/ntp status

... tu verras çà va beaucoup mieux wink


Every day is a school day ... Your Ubuntu User number is # 572
Portable ASUS Dual Core T2130 de chez Iventive - 1.86 GHz - RAM:2 Go - DD 160 Go - Hardy Heron 8.04.4 LTS - Noyau 2.6.24.24 Generic - LiveBox Sagem 4 Mo
Mon Blog http://mdoucet.wordpress.com/

Hors ligne

#9 Le 13/01/2010, à 20:02

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Michel38 a écrit :

Bonsoir,
Décommente les 2 lignes à la fin juste au-dessus des serveurs que tu as choisi:

sudo gedit /etc/ntp.conf

...

je pige pas où tu veux dire là !?

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift


# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
server ntp.ubuntu.com


# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#10 Le 13/01/2010, à 21:35

Michel38

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Re,

#disable auth
#broadcastclient

Ces 2 lignes-la, ensuite tu choisis qq serveurs dans l'applet de l'heure par "Régler la date et l'heure" > déverrouiller > rester synchronisé avec les serveurs sur internet > choisir des serveurs proches de ton lieu d'habitation.

Dernière modification par Michel38 (Le 13/01/2010, à 21:36)


Every day is a school day ... Your Ubuntu User number is # 572
Portable ASUS Dual Core T2130 de chez Iventive - 1.86 GHz - RAM:2 Go - DD 160 Go - Hardy Heron 8.04.4 LTS - Noyau 2.6.24.24 Generic - LiveBox Sagem 4 Mo
Mon Blog http://mdoucet.wordpress.com/

Hors ligne

#11 Le 13/01/2010, à 22:28

Le Galéanthrope

Re : horloge système avance trop vite. date/time jamais à l'heure :S

zebuntu a écrit :
Le Galéanthrope a écrit :

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink

Le pc est neuf (4 mois), et sous sale-os y'a pas ce pb (ni en 32, ni en 64)

L'horloge système n'est pas géré par l'OS, elle est hardware (avec un quartz). Donc je ne voit pas comment c'est possible qu'elle décale sous Linux et pas sous Windows.


Miaou ! ー Nyamiou Le Galéanthrope

Hors ligne

#12 Le 13/01/2010, à 22:39

tukuyomi

Re : horloge système avance trop vite. date/time jamais à l'heure :S

zebuntu a écrit :
Le Galéanthrope a écrit :

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink

Le pc est neuf (4 mois), et sous sale-os y'a pas ce pb (ni en 32, ni en 64)

Si tu restes dans le BIOS un moment, et que tu regardes l'heure filer, ça avance "normalement"?

Hors ligne

#13 Le 14/01/2010, à 01:13

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Michel38 a écrit :

Re,

#disable auth
#broadcastclient

Ces 2 lignes-la...

Ok.
(Modifs...)
Alors

$ service ntp restart
 * Stopping NTP server ntpd        [ OK ]
 * Starting NTP server ntpd        [ OK ]
$ service ntp status
 * NTP server is not running.

Flûte !
Bon, re, différemment

$ service ntp force-reload
 * Stopping NTP server ntpd        [ OK ]
 * Starting NTP server ntpd        [ OK ]
$ service ntp status
 * NTP server is running.

Ha. J'aime mieux.
Hop.
Plus qu'à laisser tourner comme ça un temps, et regarder si ça fonctionne correctement.

Michel38 a écrit :

... ensuite tu choisis qq serveurs dans l'applet de l'heure par "Régler la date et l'heure" > déverrouiller > rester synchronisé avec les serveurs sur internet > choisir des serveurs proches de ton lieu d'habitation.

Ben, c'est pas fichu comme ça dans la 9.10, pas de sélection de serveurs dans les Préférences de l'applet (gnome). Il faut les ajouter dans /etc/ntp.conf (partie server <ntpserver>, vers le début du fichier). Puis refaire un ntp restart (voire un ntp force-reload).


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#14 Le 14/01/2010, à 01:15

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

tukuyomi a écrit :
zebuntu a écrit :
Le Galéanthrope a écrit :

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink

Le pc est neuf (4 mois), et sous sale-os y'a pas ce pb (ni en 32, ni en 64)

Si tu restes dans le BIOS un moment, et que tu regardes l'heure filer, ça avance "normalement"?

Là, pas possible, ch'ui en prod. Mais je garde cette note de coté (pour le prochain boot, par ex).


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#15 Le 14/01/2010, à 01:19

zebuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Le Galéanthrope a écrit :
zebuntu a écrit :
Le Galéanthrope a écrit :

Et si tu changer la pile sur la carte mère, il y a des grande chance pour que ça résolve ton problème. wink

Le pc est neuf (4 mois), et sous sale-os y'a pas ce pb (ni en 32, ni en 64)

L'horloge système n'est pas géré par l'OS, elle est hardware (avec un quartz).

Ha oui, bien noté là.

Donc je ne voit pas comment c'est possible qu'elle décale sous Linux et pas sous Windows.

Moi non plus, encore un truc à vérifier (j'ai peut être tout simplement pas remarqué si ça le faisait aussi sous win).


http://zebulon.biniou.net    #biniou@irc.freenode.net

Hors ligne

#16 Le 23/05/2010, à 16:05

arturpio

Re : horloge système avance trop vite. date/time jamais à l'heure :S

chez moi c'est la meme chose....

j'ai un i7, carte mere Gigabyte, chipset Intel.

l'heure de l'horloge de la carte mère est bonne. je peux entrer dans le BIOS, la changer et vérifier des jours après - elle est à l'heure.

mais sous Ubuntu, l'heure système avance "à toute allure". une bonne 1/2h toutes les heures!

j'ai installé NTP, ca ne change rien, l'heure devient fausse.
j'ai désinstallé NTP, je changé le paramètre d'heure pour la fixer "à la main", elle avance toujours.

il arrive même que le PC se plante ("freeze" système total) quand je change l'heure dans la fenêtre "Administration/date, heure" à la main, et que je clique sur l'icône de synchronisation d'horloge (à droite de la ligne d'heure).

visiblement le logiciel a du mal à accéder l'horloge de la carte mère. c'est donc un problème de compatibilité, reconnaissance du chipset ou un truc comme ca.

j'ai observe ca sous Karmic (9.10), qui fonctionnait bien jusqu'à une certaine date (janvier, justement, je crois). maintenant je suis sous Lucid (10.04) et le problème persiste.

j'insiste sur le fait que l'heure du BIOS est bonne - décalée de 2 heures (pour heure Paris). ce n'est que l'heure système qui est fausse.

au secours! ca fausse tout (mails, conversation dans le messengers etc)!

Hors ligne

#17 Le 03/06/2010, à 00:51

arturpio

Re : horloge système avance trop vite. date/time jamais à l'heure :S

donc: le problème est diagnostiqué (chez moi...) et - "résolu" (partiellement...).

Rappel: l'horloge système (Ubuntu) accélérait, très vite, bien que l'horloge de la carte mère restait à l'heure. NTP installé ne corrigeait pas le problème.

J'ai une carte mère Gigabyte EX58 UD3R, pour processeur Intel i7.

Dans le BIOS de cette carte on peut choisir certains options d'accélération du travail du processeur (modes "Turbo" etc.)

En fait, il faut laisser le BIOS de la carte mère dans la configuration "standard", sans enclencher les options d'optimisation ou accélération du travail de processeur. SI la carte mère est configurée avec les paramètres "standard", l"heure Ubuntu reste parfaitement correcte. Si on laisse le BIOS changer la vitesse de travail de processeur, l'heure commence a accélérer très vite...

Donc: visiblement, le système d'horloge système Ubuntu est quelque part lié à la vitesse d'horloge du processeur et ne sait pas tenir compte de vitesse variable possible avec les processeurs de type i7.

En laissant donc les vitesses "standard", on a l'heure système correcte. Question seulement: combien de puissance de calcul on perd...? Dans les statistiques, je vois un certain fléchissement de la courbe de travail de BOINC. Ce processeur (i7) est tellement puissant qu'il ne sert à rien d'autre que ca: BOINC. Rien d'autre ne peut lui donner assez du travail.... smile

Hors ligne

#18 Le 16/11/2010, à 23:36

LvR.ubuntu

Re : horloge système avance trop vite. date/time jamais à l'heure :S

Hello

content de voir que d'autre ont ce pb. Sous ubuntu (10.10), l'horloge n'est jamais à l'heure. Carte mère neuve, ca fonctionne bien sous windows, bref ... meme pb que vous.

carte mère Gigabyte GA-770TA-UD3 et cpu

Si qqun à la solution (a pars changer des options du bios) ...

Hors ligne

  • Accueil
  • » Forum
  • » Archives
  • » horloge système avance trop vite. date/time jamais à l'heure :S

Haut de page ↑