Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/01/2010, à 12:28

Slystone

[deux petits grains de sable encore] version 64 bits non compatible

Bonjour

Alors voilà, tout est un peu dans le topic. J'ai fait récemment l'acquisition d'un netbook sous processeur AMD (MV-40), normalement compatible avec les instructions 64 bits.
La veRrsion 32 bits fonctionne sans aucun problème, j'en suis très content. Par contre la tentative d'install de la version 64 bits s'est soldée par un échec. Je me suis retrouvé avec un curseur clignotant après le grub, et pas d'accès au mode recovery (pas d'accès au système possible avant ou après). J'ai ensuite essayé de téléchargé une nouvelle image depuis un autre post pour réinstaller, et là je n'ai même pas réussi à créer une clé bootable (j'ai essayé avec l'outil d'Ubuntu, en ligne de commande, avec Pendrive, Unetbootin)... sans résultat quand je réussissais tout de suite avec la version normale (j'ai lu la doc et essayé plusieurs méthodes).
Là je crois que j'ai abandonné avec le 64 bits pour l'instant (j'ai tout de même passé plusieurs heures en vain), mais j'aurais tout de même été curieux de connaître les raisons de cet échec (je précise qu'il n'y a rien de trollesque). Est-ce que je n'ai tout simplement pas eu de chance ? :| Ou est-ce que certains composants pourraient empêcher l'installation d'Ubuntu 64 bits (besoin de drivers 32 bits) ? Merci pour vos explications si vous en avez.

Dernière modification par Slystone (Le 24/01/2010, à 17:40)


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#2 Le 23/01/2010, à 13:14

darkevolution

Re : [deux petits grains de sable encore] version 64 bits non compatible

Bah, mis à part la carte mère et le proc, je sais pas quel matos pourrait bloquer mais ce serait intéressant de le savoir effectivement...


Schedio: Logiciel de gestion modulable de scripts (dont Gestion/Lancement/Restriction planifiée de logiciels).
http://forum.ubuntu-fr.org/viewtopic.php?id=383356
Apportez vos idées à la version 3 !

Hors ligne

#3 Le 23/01/2010, à 15:03

brakbabord

Re : [deux petits grains de sable encore] version 64 bits non compatible

Il faudrait essayer avec une autre distrib pour voir.

Hors ligne

#4 Le 23/01/2010, à 15:41

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

Oui Brakbabord, c'est une bonne idée. J'étais plus motivé, mais je vais finalement y rejeter un petit coup d'oeil avec une Fedora KDE (bon support de matos il paraît).
Pour le problème de la clé, ils en parlent sur le forum ubuntu.com (c'est exactement ce qui m'est arrivé) : http://ubuntuforums.org/showthread.php?t=1385273&highlight=usb+startup+disk+karmic

Pour l'install j'essaye ça tout à l'heure, j'aurai peut-être plus de succès (ou au moins plus de grains à moudre).


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#5 Le 23/01/2010, à 16:46

brakbabord

Re : [deux petits grains de sable encore] version 64 bits non compatible

Fedora propose un outil pour créér une clé bootable: https://fedorahosted.org/liveusb-creator/

Par contre il ne fonctionne que sur Windows.
On peut le mettre sur Linux mais il indique toujours des erreurs md5 sans même vérifier, alors que j'ai pourtant installé tous les paquets python+md5.

Mais sous Windows aucun problème.

Hors ligne

#6 Le 23/01/2010, à 20:37

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

Ah zut, c'est dommage je n'ai pas Windows.  hmm Merci quand même.
Et pour installer en dual-boot avec une autre distri, il n'y a pas une soluce ? Parce-que s'il n'y a pas moyen de faire une clé usb bootable, il doit bien y avoir moyen de bricoler quand même, non ?


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#7 Le 23/01/2010, à 21:23

brakbabord

Re : [deux petits grains de sable encore] version 64 bits non compatible

http://products.amd.com/en-us/NotebookCPUDetail.aspx?id=513

En effet ce proc est sensé être compatible 64bits...
De toutes façons sur un netbook je sais pas si il y a un avantage à utiliser le 64bits. Au contraire mieux vaut rester en 32bits et économiser ta ram.

Hors ligne

#8 Le 23/01/2010, à 22:08

Link31

Re : [deux petits grains de sable encore] version 64 bits non compatible

Normalement, tu as un message d'erreur très clair si tu tentes de lancer un noyau 64 bits sur un processeur qui ne supporte que le 32 bits. Ça doit être un autre composant qui pose problème. Essaie de démarrer en enlevant le paramètre "quiet" de la ligne de commande du noyau si il est présent.

Sur Grub 1 : touche "e" sur la ligne dans Grub, puis touche "e" sur la ligne du noyau, enlève "quiet", appuie sur "entrée" puis sur "b". Sur Grub 2, je ne sais pas tongue

Hors ligne

#9 Le 23/01/2010, à 22:25

valAa

Re : [deux petits grains de sable encore] version 64 bits non compatible

Sur Grub 2 (de mémoire), touche "e" sur la ligne du grub, tu cherches la ligne contenant

quiet splash

et tu enlèves le

quiet

Puis <Ctrl><x> pour booter.
et si tu enlèves le "splash" également, tu auras encore plus de détail (mais pas de zouli splash screen, faut savoir ce qu'on veut)

Dernière modification par valAa (Le 23/01/2010, à 22:26)

Hors ligne

#10 Le 23/01/2010, à 22:29

na kraïou

Re : [deux petits grains de sable encore] version 64 bits non compatible

Salut,

Slystone a écrit :

Par contre la tentative d'install de la version 64 bits s'est soldée par un échec. Je me suis retrouvé avec un curseur clignotant après le grub, et pas d'accès au mode recovery (pas d'accès au système possible avant ou après).

T'as pris la version live-cd ? T'as réussi à être en session live quand même, avant ? Ça doit pas être dû au 64 bits.

Sinon, tu préfères laisser ce topic dans le café, ou que je le bouge dans une section de support ? C'est un petit peu du support quand même.

Dernière modification par Р☢w ! ✰ :mad: ✰ (эй !) (Le 23/01/2010, à 22:30)


Triste !
Intégriste ! Historieux ! Comploteur ! Connard ! Fourbe ! Linuxeux ! Machiavélique ! Moche ! Branleur ! Grognon ! Prétentieux ! Frimeur ! /b/tard ! Futile ! Étudiant ! Médiéviste ! Perfide ! Debianeux ! Futur maître du monde ! Petit (quasi nanos gigantium humeris insidentes) ! Égoïste ! Nawakiste ! Mauvaise langue ! 34709 ! На краю ! Arrogant ! Suffisant !

Hors ligne

#11 Le 23/01/2010, à 23:21

Gage

Re : [deux petits grains de sable encore] version 64 bits non compatible

Pour créer une clé USB bootable, si ta clé USB est reconnue comme /dev/sdb :

dd if=MonimageFedora.iso of=/dev/sdb

Ils ont adopté la technique Archlinux, et je trouve ça tout à fait pertinent.


Ça, ce sont les sources. Le mouton que tu veux est dedans.
Merci, c'est tout à fait comme ça que je le voulais ! Crois-tu qu'il faille beaucoup de ressources à ce mouton ? Parce que ma config est toute petite...
Ça devrait aller. Tu peux te compiler un petit mouton.
Pas si petit que ça. Tiens ! il s'est mis en veille...

Hors ligne

#12 Le 24/01/2010, à 01:34

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

@ Gage : oui finalement cette bonne vielle ligne de commande est encore ce qui se fait de mieux, c'est ce que j'ai choisi, je suis en train d'essayer de me dépatouiller de l'install de Fedora 12 (je laisse Ubuntu à côté).

@ la 'tite : oui tu as raison, j'abuse un peu de faire ce topic dans le café (je ne pensais pas persister au début).

@ Valaa et Link : merci pour ces réponses, je les retiens pour la prochaine fois (j'ai écrasé).

@ Brakbabord : au risque de relancer le débat sur 32bits vs 64 bits, comme je suis équipé je me dis que j'aurais bien tort de ne pâs en profiter. Des admins ici encouragent fortement la migration ne serait-ce que pour encourager le dév des applis compatibles. N'y a t-il vraiment pas de gain significatif (même à long terme) ?


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#13 Le 24/01/2010, à 01:48

brakbabord

Re : [deux petits grains de sable encore] version 64 bits non compatible

Je sais et d'ordinaire je suis le premier à l'encourager.

Essaie de désactiver l'acpi au boot.
Il faut rajouter acpi=off ou noapic

Hors ligne

#14 Le 24/01/2010, à 02:10

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

Ouf ! C'est bon finalement, Constantine tourne comme un charme. Merci à tous

Dernière modification par Slystone (Le 24/01/2010, à 17:52)


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#15 Le 24/01/2010, à 17:53

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

je rencontre deux derniers petits problèmes.

1) Fedora marquait "not enough free space pendant l'install alors que 80Go étaient libre. Pas grave, j'ai sauvegardé et viré des partitions, et Fedora a finalement bien voulu s'installer sur le reste d'espace libre.
Le problème c'est que le lvm n'est pas géré par Gparted. Je comprend bien qu'il faut avant tout réduire les partitions à l'intérieur du lvm, puis réduire le lvm lui-même. Quelle manip me conseilleriez-vous svp ?

2) Je rencontre un souci avec os-probe de retour sous Ubuntu. Celui-ci était sensé repérer les grubs des autres OS quand update-grub n'y arrivait pas, mais je n'ai pas plus de succès.
Bon pour ça je vais faire une modif barbare du grub.cfg en rajoutant ça :

menuentry "Grub 2 sur /dev/sda7" {
set root=(hd0,x)
configfile /boot/grub/menu.lst
}

avec plusieurs exemples pour chaque x possible, logiquement ça devrait marcher... tongue

Edit : il faut peut-être que j'ouvre de nouveaux topics pour plus de clarté ?

Dernière modification par Slystone (Le 25/01/2010, à 00:17)


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#16 Le 24/01/2010, à 22:16

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

Bon alors j'ai un problème de grub. Après quelques tatonnements j'ai réussi à afficher le menu de grub, éditer 40_custom pour chainload, rajouté plusieurs entrées pour lui faire trouver le menu.lst de Fedora (j'ai bien vérifié qu'il existe), rendu 40_custom exécutable, updaté grub (sudo update-grub et là c'est le drame, je reçois ce message :
invalid signature
C'est pourtant la bonne partition, j'ai eu le réflexe d'appuyer sur e pour changer manuellement dans le menu de boot l'entrée, et j'ai changé root de 0,0 à 0,6 sans résultat, je suis sûr que 0,4 est le bon paramètre (la partition de boot est sur sda3, elle vient après la partition Ubuntu qui répond à 0,3)...
Bref, je suis bloqué et j'ai besoin encore de votre précieuse aide.

Edit : je donne des détails :

sudo fdisk -l

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        3187    25599546   83  Linux
/dev/sda2           29698       30401     5654880    5  Extended
/dev/sda3   *        3188        3213      204800   83  Linux
/dev/sda4            3213       29697   212736775   8e  Linux LVM
/dev/sda5           29698       30401     5654848+  82  Linux swap / Solaris

Partition table entries are not in disk order

sudo gedit /etc/grub.d/40_custom:

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Grub 1 de Fedora 12" {
set root=(hd0,3)
chainloader +1
}
menuentry "Grub 1 de Fedora 12" {
set root=(hd0,4)
chainloader +1
}

sudo gedit /boot/grub/grub.cfg:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s /boot/grub/grubenv ]; then
  have_grubenv=true
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  saved_entry=${prev_saved_entry}
  save_env saved_entry
  prev_saved_entry=
  save_env prev_saved_entry
fi
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set ffba7f9e-adce-4dce-a89f-e25eeac7dcdc
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-14-generic" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
	set quiet=1
	insmod ext2
	set root=(hd0,1)
	search --no-floppy --fs-uuid --set ffba7f9e-adce-4dce-a89f-e25eeac7dcdc
	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=ffba7f9e-adce-4dce-a89f-e25eeac7dcdc ro   quiet splash
	initrd	/boot/initrd.img-2.6.31-14-generic
}
menuentry "Ubuntu, Linux 2.6.31-14-generic (recovery mode)" {
        recordfail=1
        if [ -n ${have_grubenv} ]; then save_env recordfail; fi
	insmod ext2
	set root=(hd0,1)
	search --no-floppy --fs-uuid --set ffba7f9e-adce-4dce-a89f-e25eeac7dcdc
	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=ffba7f9e-adce-4dce-a89f-e25eeac7dcdc ro single 
	initrd	/boot/initrd.img-2.6.31-14-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	linux16	/boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	linux16	/boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Grub 1 de Fedora 12" {
set root=(hd0,3)
chainloader +1
}
menuentry "Grub 1 de Fedora 12" {
set root=(hd0,4)
chainloader +1
}
### END /etc/grub.d/40_custom ###

Le menu de Fedora que je veux appeler par grub2
sudo gedit /media/464a2aa8-d553-4abb-9180-66294db38cd8/grub/menu.lst

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_p3nguinlaptop-lv_root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31.12-174.2.3.fc12.x86_64)
    root (hd0,2)
    kernel /vmlinuz-2.6.31.12-174.2.3.fc12.x86_64 ro root=/dev/mapper/vg_p3nguinlaptop-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=fr-pc rhgb quiet
    initrd /initramfs-2.6.31.12-174.2.3.fc12.x86_64.img
title Fedora (2.6.31.5-127.fc12.x86_64)
    root (hd0,2)
    kernel /vmlinuz-2.6.31.5-127.fc12.x86_64 ro root=/dev/mapper/vg_p3nguinlaptop-lv_root noiswmd LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=fr-pc rhgb quiet
    initrd /initramfs-2.6.31.5-127.fc12.x86_64.img

Dernière modification par Slystone (Le 24/01/2010, à 22:43)


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

#17 Le 25/01/2010, à 18:47

Slystone

Re : [deux petits grains de sable encore] version 64 bits non compatible

Petit up, pretty please


« Rigid, the skeleton of habit alone upholds the human frame. » - Virginia Woolf.
Mon petit blog avec mes tutos, mes trads, et mes humeurs (commentaires bienvenus).

En ligne

  • Accueil
  • » Forum
  • » Archives
  • » [deux petits grains de sable encore] version 64 bits non compatible

Haut de page ↑