Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 19/12/2006, à 13:49

2fast4u

[résolu] Paquet défectueux, problème de sources.list ?

Bonjour,

Je tente une install de hugin sur mon Amd64 en suivant le tutos et au moment de l'installation de libgtk2.0-dev on me dit que je demande l'impossible mad

 sudo apt-get install libgtk2.0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  libgtk2.0-dev: Dépend: libgtk2.0-0 (= 2.8.17-1ubuntu5) mais 2.8.20-0ubuntu1 devra être installé
                 Dépend: libglib2.0-dev (>= 2.8.5) mais ne sera pas installé
                 Dépend: libpango1.0-dev (>= 1.10.0-2) mais ne sera pas installé
                 Dépend: libatk1.0-dev (>= 1.6.1-2) mais ne sera pas installé
                 Dépend: libcairo2-dev mais ne sera pas installé
E: Paquets défectueux

j'ai bien libgtk2.0-0 d'installé en version 2.8.20-0ubuntu1 d'après synaptique, le menu réinstallé est grisé

mon sources.list

# The above lines were generated automatically by EasyUbuntu 3.02 Release
# The rest of your sources.list follows
deb http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper main restricted
## Major bug fix updates produced after the final release of the
## distribution.
deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fr.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper universe
## Uncomment the following two lines to add software from the 'backports'
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe
## XGL et Compiz
deb http://ubuntu.moshen.de/ dapper all
## PLF
deb http://packages.freecontrib.org/ubuntu/plf/ dapper free non-free
deb-src http://packages.freecontrib.org/ubuntu/plf/ dapper free non-free

que puis-je faire pour règler ça ?

Dernière modification par 2fast4u (Le 19/12/2006, à 16:01)

Hors ligne

#2 Le 19/12/2006, à 14:16

yugo

Re : [résolu] Paquet défectueux, problème de sources.list ?

Essaye d'utiliser aptitude

sudo aptitude install hugin

regarde bien les solutions qu'il te propose, c'est pas toujours ce qu'on veut..


Dans la vie il y a 3 sortes d'imbéciles: ceux qui doutent de tout et ceux qui doutent de rien

Hors ligne

#3 Le 19/12/2006, à 15:17

2fast4u

Re : [résolu] Paquet défectueux, problème de sources.list ?

hugin semble pas être dans les dépots sad

Hors ligne

#4 Le 19/12/2006, à 15:22

yugo

Re : [résolu] Paquet défectueux, problème de sources.list ?

Je comprends pas, d'après ton premier post, apt-get trouve hugin mais n'arrive pas à installer une de ces dépendances. C'est pas ça?


Dans la vie il y a 3 sortes d'imbéciles: ceux qui doutent de tout et ceux qui doutent de rien

Hors ligne

#5 Le 19/12/2006, à 15:40

2fast4u

Re : [résolu] Paquet défectueux, problème de sources.list ?

non non,
dans la doc d'install il faut télécharger enblend, hugin et quelques dépendences, libgtk2.0-dev est une des librairies nécessaire pour compiler hugin, c'est ça que je n'arrive pas a installer.

Hors ligne

#6 Le 19/12/2006, à 15:55

yugo

Re : [résolu] Paquet défectueux, problème de sources.list ?

Ok par ce que je suis sous edgy et il est dans les dépots.
alors:

sudo aptitude install libgtk2.0-dev

Dans la vie il y a 3 sortes d'imbéciles: ceux qui doutent de tout et ceux qui doutent de rien

Hors ligne

#7 Le 19/12/2006, à 16:00

2fast4u

Re : [résolu] Paquet défectueux, problème de sources.list ?

J'ai eu quelques avertissements comme quoi j'installais des versions antérieur, mais c'est passé wink
Merci pour ton aide

Dernière modification par 2fast4u (Le 19/12/2006, à 16:00)

Hors ligne

#8 Le 26/01/2010, à 19:43

zaouia

Re : [résolu] Paquet défectueux, problème de sources.list ?

Bonjour,
Je suis sur Intrepid mis à jour. Je n'arrive pas à installer hplip-gui. Il s'affiche que j'ai des paquets défectueux marqués "gardés en l'état" mais que mon hplip est la dernière version.
quelqu'un peut-il m'aider. Merci
zaouia

Hors ligne

Haut de page ↑