Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#101 Le 31/01/2010, à 19:06

Joj

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Aucune idée cracolinux, je crois que le plus simple est tout simplement d'essayer, mais fais quand même une copie de sauvegarde de ton xorg.conf... un accident est si vite arrivé roll

Pour ma part, lors de l'install (console en tant que sudo, puis interface graphique), j'ai laissé toutes les options par défaut et ça pète. A toi de voir si tu t'y risques.

Hors ligne

#102 Le 31/01/2010, à 23:20

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

J'aimerais bien faire une sauvegarde de ce fichier, mais comme dit plus haut, ce fichier est inexistant chez moi...et je voudrais bien savoir pourquoi!

Si quelqu'un sait ça...;)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#103 Le 01/02/2010, à 14:32

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bon, j'ai tenté le coup quand même (sans sauvegarde du xorg.conf qui est toujours inexistant!!)

Voilà ce que le terminal me renvoi:

*****:~/Téléchargements$ sudo sh ati-driver-installer-10-1-x86.x86_64.run -
-buildpkg Ubuntu/karmic
Created directory fglrx-install.9cAwQA
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.69................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Generating package: Ubuntu/karmic
Resolving build dependencies...
Continuing package build
Package build failed!
Package build utility output:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value: 
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.690-0ubuntu1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
 debian/rules build
dpkg-buildpackage: host architecture i386
test -x debian/rules
mkdir -p "."
#Create important strings
for i in 10fglrx \
			 dkms.conf \
			 xorg-driver-fglrx.install \
			 xorg-driver-fglrx-dev.install \
			 fglrx-kernel-source.install \
			 fglrx-amdcccle.install \
			 libamdxvba1.install \
			 overrides/fglrx-kernel-source; do \
		sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
			-e "s|#XMODDIR32#||" \
			-e "s|#DRIDIR32#|usr/lib32|"   \
			-e "s|#LIBDIR#|lib|"       \
			-e "s|#DRIDIR#|usr/lib|"       \
			-e "s|#CVERSION#|8.690|"   \
			-e "s|#XARCH#|x740|"   \
			-e "s|#ARCH#|x86|"   \
			debian/$i.in > debian/$i;      \
	done
# remove exec bit on everything
find arch \
		etc \
		lib \
		module \
		usr \
		x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
		arch/x86/usr/X11R6/bin \
		usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
		x740/usr/X11R6/lib/modules/drivers/fglrx_drv.so > \
		debian/modaliases/fglrx-modules.alias.override
 debian/rules binary
test -x debian/rules
dh_testroot
dh_clean -k 
dh_installdirs -A 
mkdir -p "."
#Create important strings
for i in 10fglrx \
			 dkms.conf \
			 xorg-driver-fglrx.install \
			 xorg-driver-fglrx-dev.install \
			 fglrx-kernel-source.install \
			 fglrx-amdcccle.install \
			 libamdxvba1.install \
			 overrides/fglrx-kernel-source; do \
		sed -e "s|#XMODDIR#|usr/lib/xorg/modules|"     \
			-e "s|#XMODDIR32#||" \
			-e "s|#DRIDIR32#|usr/lib32|"   \
			-e "s|#LIBDIR#|lib|"       \
			-e "s|#DRIDIR#|usr/lib|"       \
			-e "s|#CVERSION#|8.690|"   \
			-e "s|#XARCH#|x740|"   \
			-e "s|#ARCH#|x86|"   \
			debian/$i.in > debian/$i;      \
	done
# remove exec bit on everything
find arch \
		etc \
		lib \
		module \
		usr \
		x740     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86/usr/sbin \
		arch/x86/usr/X11R6/bin \
		usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
		x740/usr/X11R6/lib/modules/drivers/fglrx_drv.so > \
		debian/modaliases/fglrx-modules.alias.override
dh_installdirs -pxorg-driver-fglrx 
dh_installdirs -pxorg-driver-fglrx-dev 
dh_installdirs -pfglrx-kernel-source 
dh_installdirs -pfglrx-amdcccle 
dh_installdirs -pfglrx-modaliases 
dh_installdirs -plibamdxvba1 
dh_installdocs -pxorg-driver-fglrx   
dh_installexamples -pxorg-driver-fglrx 
dh_installman -pxorg-driver-fglrx  
dh_installinfo -pxorg-driver-fglrx  
dh_installmenu -pxorg-driver-fglrx 
dh_installcron -pxorg-driver-fglrx 
dh_installinit -pxorg-driver-fglrx   
dh_installdebconf -pxorg-driver-fglrx 
dh_installemacsen -pxorg-driver-fglrx   
dh_installcatalogs -pxorg-driver-fglrx 
dh_installpam -pxorg-driver-fglrx 
dh_installlogrotate -pxorg-driver-fglrx 
dh_installlogcheck -pxorg-driver-fglrx 
dh_installchangelogs -pxorg-driver-fglrx   
dh_installudev -pxorg-driver-fglrx 
dh_lintian -pxorg-driver-fglrx 
dh_install -pxorg-driver-fglrx  
dh_link -pxorg-driver-fglrx  
dh_installmime -pxorg-driver-fglrx 
dh_installdocs -pxorg-driver-fglrx usr/share/doc/fglrx/* --exclude ATI_LICENSE.TXT
dh_installinit -pxorg-driver-fglrx --name="atieventsd" --no-start --update-rcd-params="defaults 31"
for i in \
			debian/xorg-driver-fglrx/usr/bin/atiode \
			debian/xorg-driver-fglrx/usr/sbin/amdnotifyui \
			debian/xorg-driver-fglrx/usr/lib/dri/fglrx_dri.so \
			debian/xorg-driver-fglrx/usr/lib/libGL.so.* \
			; do execstack -q $i; execstack -c $i; done
- debian/xorg-driver-fglrx/usr/bin/atiode
- debian/xorg-driver-fglrx/usr/sbin/amdnotifyui
- debian/xorg-driver-fglrx/usr/lib/dri/fglrx_dri.so
- debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2
dh_installdocs -pxorg-driver-fglrx-dev   
dh_installexamples -pxorg-driver-fglrx-dev 
dh_installman -pxorg-driver-fglrx-dev  
dh_installinfo -pxorg-driver-fglrx-dev  
dh_installmenu -pxorg-driver-fglrx-dev 
dh_installcron -pxorg-driver-fglrx-dev 
dh_installinit -pxorg-driver-fglrx-dev   
dh_installdebconf -pxorg-driver-fglrx-dev 
dh_installemacsen -pxorg-driver-fglrx-dev   
dh_installcatalogs -pxorg-driver-fglrx-dev 
dh_installpam -pxorg-driver-fglrx-dev 
dh_installlogrotate -pxorg-driver-fglrx-dev 
dh_installlogcheck -pxorg-driver-fglrx-dev 
dh_installchangelogs -pxorg-driver-fglrx-dev   
dh_installudev -pxorg-driver-fglrx-dev 
dh_lintian -pxorg-driver-fglrx-dev 
dh_install -pxorg-driver-fglrx-dev  
dh_link -pxorg-driver-fglrx-dev  
dh_installmime -pxorg-driver-fglrx-dev 
dh_installdocs -pfglrx-kernel-source   
dh_installexamples -pfglrx-kernel-source 
dh_installman -pfglrx-kernel-source  
dh_installinfo -pfglrx-kernel-source  
dh_installmenu -pfglrx-kernel-source 
dh_installcron -pfglrx-kernel-source 
dh_installinit -pfglrx-kernel-source   
dh_installdebconf -pfglrx-kernel-source 
dh_installemacsen -pfglrx-kernel-source   
dh_installcatalogs -pfglrx-kernel-source 
dh_installpam -pfglrx-kernel-source 
dh_installlogrotate -pfglrx-kernel-source 
dh_installlogcheck -pfglrx-kernel-source 
dh_installchangelogs -pfglrx-kernel-source   
dh_installudev -pfglrx-kernel-source 
dh_lintian -pfglrx-kernel-source 
dh_install -pfglrx-kernel-source  
dh_link -pfglrx-kernel-source  
dh_installmime -pfglrx-kernel-source 
dh_installdocs -pfglrx-amdcccle   
dh_installexamples -pfglrx-amdcccle 
dh_installman -pfglrx-amdcccle  
dh_installinfo -pfglrx-amdcccle  
dh_installmenu -pfglrx-amdcccle 
dh_installcron -pfglrx-amdcccle 
dh_installinit -pfglrx-amdcccle   
dh_installdebconf -pfglrx-amdcccle 
dh_installemacsen -pfglrx-amdcccle   
dh_installcatalogs -pfglrx-amdcccle 
dh_installpam -pfglrx-amdcccle 
dh_installlogrotate -pfglrx-amdcccle 
dh_installlogcheck -pfglrx-amdcccle 
dh_installchangelogs -pfglrx-amdcccle   
dh_installudev -pfglrx-amdcccle 
dh_lintian -pfglrx-amdcccle 
dh_install -pfglrx-amdcccle  
dh_link -pfglrx-amdcccle  
dh_installmime -pfglrx-amdcccle 
execstack -c debian/fglrx-amdcccle/usr/bin/amdcccle
dh_installdocs -pfglrx-modaliases   
dh_installexamples -pfglrx-modaliases 
dh_installman -pfglrx-modaliases  
dh_installinfo -pfglrx-modaliases  
dh_installmenu -pfglrx-modaliases 
dh_installcron -pfglrx-modaliases 
dh_installinit -pfglrx-modaliases   
dh_installdebconf -pfglrx-modaliases 
dh_installemacsen -pfglrx-modaliases   
dh_installcatalogs -pfglrx-modaliases 
dh_installpam -pfglrx-modaliases 
dh_installlogrotate -pfglrx-modaliases 
dh_installlogcheck -pfglrx-modaliases 
dh_installchangelogs -pfglrx-modaliases   
dh_installudev -pfglrx-modaliases 
dh_lintian -pfglrx-modaliases 
dh_install -pfglrx-modaliases  
dh_link -pfglrx-modaliases  
dh_installmime -pfglrx-modaliases 
dh_installdocs -plibamdxvba1   
dh_installexamples -plibamdxvba1 
dh_installman -plibamdxvba1  
dh_installinfo -plibamdxvba1  
dh_installmenu -plibamdxvba1 
dh_installcron -plibamdxvba1 
dh_installinit -plibamdxvba1   
dh_installdebconf -plibamdxvba1 
dh_installemacsen -plibamdxvba1   
dh_installcatalogs -plibamdxvba1 
dh_installpam -plibamdxvba1 
dh_installlogrotate -plibamdxvba1 
dh_installlogcheck -plibamdxvba1 
dh_installchangelogs -plibamdxvba1   
dh_installudev -plibamdxvba1 
dh_lintian -plibamdxvba1 
dh_install -plibamdxvba1  
dh_link -plibamdxvba1  
dh_installmime -plibamdxvba1 
dh_strip -pxorg-driver-fglrx  
dh_compress -pxorg-driver-fglrx  
dh_fixperms -pxorg-driver-fglrx  
dh_makeshlibs -pxorg-driver-fglrx  
dh_strip -pxorg-driver-fglrx-dev  
dh_compress -pxorg-driver-fglrx-dev  
dh_fixperms -pxorg-driver-fglrx-dev  
dh_makeshlibs -pxorg-driver-fglrx-dev  
dh_strip -pfglrx-kernel-source  
dh_compress -pfglrx-kernel-source  
dh_fixperms -pfglrx-kernel-source  
dh_makeshlibs -pfglrx-kernel-source  
dh_strip -pfglrx-amdcccle  
dh_compress -pfglrx-amdcccle  
dh_fixperms -pfglrx-amdcccle  
dh_makeshlibs -pfglrx-amdcccle  
dh_strip -pfglrx-modaliases  
dh_compress -pfglrx-modaliases  
dh_fixperms -pfglrx-modaliases  
dh_makeshlibs -pfglrx-modaliases  
dh_strip -plibamdxvba1  
dh_compress -plibamdxvba1  
dh_fixperms -plibamdxvba1  
dh_makeshlibs -plibamdxvba1  
dh_installdeb -pxorg-driver-fglrx 
dh_perl -pxorg-driver-fglrx 
dh_shlibdeps -pxorg-driver-fglrx   "-Xlib32" 
dpkg-shlibdeps: warning: debian/xorg-driver-fglrx/usr/sbin/atieventsd contains an unresolvable reference to symbol XauFileName: it's probably a plugin.
dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XRead used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XReply used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XFlush used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/xorg-driver-fglrx/usr/lib/libfglrx_dm.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol dlopen used by debian/xorg-driver-fglrx/usr/lib/libXvBAW.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol dlsym used by debian/xorg-driver-fglrx/usr/lib/libXvBAW.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol dlerror used by debian/xorg-driver-fglrx/usr/lib/libXvBAW.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XGetGeometry used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XReadPad used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XFree used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XSetErrorHandler used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XGetErrorDatabaseText used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XMaxRequestSize used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XCreateGC used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XFreeFontInfo used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XEHeadOfExtensionList used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XSend used by debian/xorg-driver-fglrx/usr/lib/libGL.so.1.2 found in none of the libraries.
dpkg-shlibdeps: warning: 18 other similar warnings have been skipped (use -v to see them all).
dpkg-shlibdeps: error: couldn't find library libatiuki.so.1 needed by debian/xorg-driver-fglrx/usr/lib/xorg/modules/linux/libfglrxdrm.so (ELF format: 'elf32-i386'; RPATH: '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: dpkg-shlibdeps returned exit code 2
make: *** [binary-predeb-IMPL/xorg-driver-fglrx] Error 1
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.9cAwQA
******:~/Téléchargements$

Si quelqu'un peut m'aider à trouver la/les librairie(s) qui pose(nt) problème (absente ou autre)...ben moi, je serais super content et le gars, ben se sera mon pote!!

Dernière modification par cracolinux (Le 01/02/2010, à 14:36)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#104 Le 01/02/2010, à 15:02

Joj

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Désolé, j'arrive un peu après la bataille.

Bien que novice sous Linux, je ne pense pas possible que tu n'aies pas de fichier de config du serveur graphique : tu n'aurais alors pas d'interface graphique du tout, et ça se remarque tout de suite...

Pour les librairies, cela dépasse largement mes compétences.

Sinon, pour éditer ce fameux fichier :

sudo gedit /etc/X11/xorg.conf

Pour en faire une sauvegarde (même si c'est un peu tard) :

sudo cp /etc/X11/xorg.conf  /etc/X11/xorg.conf.save

Et pour remettre la version initiale en cas d' "écran noir", le contraire :

sudo cp /etc/X11/xorg.conf.save  /etc/X11/xorg.conf

Et à part ça, j'ai cru comprendre que ça ne marche pas mieux ?

Hors ligne

#105 Le 01/02/2010, à 15:03

Joj

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

cracolinux a écrit :

Si quelqu'un peut m'aider à trouver la/les librairie(s) qui pose(nt) problème (absente ou autre)...ben moi, je serais super content et le gars, ben se sera mon pote!!

Mais on peut être potes quand même smile

Hors ligne

#106 Le 01/02/2010, à 15:45

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Pas de soucis, on est pote!

Quand je lance l'édition de xorg.conf avec la commande que tu donnes, gedit m'ouvre un fichier vide, je pense même qu'il le crée [edit : c'est même sûr] ...

De partout, j'entends parler de ce fichier, mais je n'en ai pas..

Tiens un question, est il possible que x ne sois pas le gestionnaire graphique sur mon PC ?

Dernière modification par cracolinux (Le 01/02/2010, à 16:08)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#107 Le 01/02/2010, à 20:27

Joj

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Alors là, ça dépasse mes compétences (et de très loin), il faut demander aux cracks.
Perso, je n'aurais pas cru cela possible, mais il faut bien se rendre à l'évidence...

Hors ligne

#108 Le 01/02/2010, à 20:55

zzero79

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Heps,

Si j'ai bien lu sous Karmic il n'y a pas de fichier xorg.conf
Il y a une config de base qui est utilisée, avec driver installé lors de l'install de Karmic si j'ai bien suivi. Tu peux toutefois spécifier une config désirée en éditant un fichier xorg.conf
En gros si il est présent,, c'est ton fichier xorg.conf qui sera utilisé, sinon c'est la config crée lors de ton installation de karmic, avec les drivers ati ou radeon j'imagine.

Qu'on me corrige si je me gourre, je débarque un peu aussi et je suis à la recherche moi-même d'une solution pour ma radeon 9200SE (premier boot j'avais les effets et depuis je ne les ai plus, et je n'arrive pas à trouver quel driver est utilisé de ati ou radeon...)

Hors ligne

#109 Le 01/02/2010, à 21:05

Joj

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Je confirme que je tourne bien sous karmic et que xorg.conf existe et n'est pas vide (je vous épargne le contenu).
Peut-être cela vient-il de ce que j'ai fait une mise à niveau depuis jaunty et pas une install ex nihilo ?

Dernière modification par Joj (Le 01/02/2010, à 21:05)

Hors ligne

#110 Le 01/02/2010, à 21:13

zzero79

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Joj a écrit :

Je confirme que je tourne bien sous karmic et que xorg.conf existe et n'est pas vide (je vous épargne le contenu).
Peut-être cela vient-il de ce que j'ai fait une mise à niveau depuis jaunty et pas une install ex nihilo ?

j'imagine que c'est effectivement "à cause" d'une nouvelle installation ... en tout cas pour ma part c'est une nouvelle installation.

Je vais essayer un fichier xorg.conf un de ces jours, disons que pour le moment aucun soucis graphique mais j'ai pas droit aux beaux effets :-)

Hors ligne

#111 Le 02/02/2010, à 01:14

Poun64

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Salut toul'monde smile !

Je crois me souvenir effectivement que sous une 1ère installation Karmic et sans demande particulière, Ubuntu ne crée pas de fichier xorg.conf.

Mon installation à moi en crée un automatiquement, parce que je dois lancer le LiveCD en mode graphique sans échec (utilisation du pilote VESA).

Ça me donne un xorg.conf de ce type :

Section "Device"
	Identifier 	"Configured Video Device"
	Driver		"vesa"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier  	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Si vous voulez créer un xorg.conf neutre, utilisez-le en commentant avec "#" la ligne imposant le driver graphique. Ça donne :
# Driver        "vesa"
... ou supprimez-la.

smile

Dernière modification par Poun64 (Le 02/02/2010, à 01:21)


L'expérience est une chandelle qui n'éclaire que celui qui la porte.
=======================================================================
Ubuntu 12.04.2 LTS - Gigabyte GA H77M - Intel Core I7 3770K / Ivy Bridge - 4 cœurs - 3,5 Ghz - 8 Go de RAM
Ubuntu 12.04.3 LTS - ASRock N68C-GS FX - AMD Phenom X4 Quad-Core 9500 - 2,2 Ghz - GeForce 8600 GT - 4 Go de RAM

Hors ligne

#112 Le 02/02/2010, à 11:11

manchois

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bonjour,
J'ai ce même problème pas de fichier xorg.conf avec karmic il ne prend pas les fichiers des pilotes propriétaires donc un défilement des images nul et pas de compiz .J'ai tout essayé les pilotes libres et tous les pilotes ATI . je n'ai pas trouvé de solution pour l'instant je suis donc revenu à 9.04 j'attends avec impatience qu'un crack nous la trouve.
@+


Config: carte mère  ASROK 980DE avec AMD 8320FX, memoire 4GO, carte graphique AMD EAH5450,2 dd WD160go sata,1 Maxtor 120go ide, moniteur LG 1930sq. Ubuntu 14.04
Laptop HP pavillion G6 carte graphique  radeon hd 7670m  DD 750 go ubuntu 14.04

Hors ligne

#113 Le 02/02/2010, à 11:32

malbo

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Par défaut dans Ubuntu 9.10 , il n'y a pas de fichier xorg.conf dans /etc/X11. Il est possible de créer vous-même ce fichier xorg.conf afin d'imposer au gestionnaire d'affichage de prendre en compte des paramètres particuliers qui seront à définir dans  xorg.conf. Déjà pour vous entrainer, vous pouvez en créer un et y coller ça (c'est le xorg.conf du live CD quand on démarre avec l'affichage minimaliste (toucheF4) :

Section "Device"
    Identifier    "Configured Video Device"
    Driver        "vesa"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
EndSection

Edit : pour créer ce fichier, je vous conseille de le faire en mode graphique : dans un terminal, vous tapez :
sudo nautilus
Le navigateur s'ouvre alors avec pouvoir d'administrateur et vous pouvez faire des conneries (donc gaffe, terrain miné) mais aussi créer le fameux fichier xorg.conf dans /etc/X11 en parcourant Système de fichiers > etc > X11
clic droit (dans X11) créer un document, l'appeler xorg.conf, l'ouvrir avec gedit, copier dedans ce que j'ai mis plus haut, enregistrer, fermer , puis sortir du Terminal en tapant exit en valider par la touche Entrée.
Pour pouvoir contrôler ce qui se passe, avant de redémarrer le PC, vous allez dans Système > Administration > Visionneur de journaux système, vous sélectionnez la première ligne Xorg.0.log et vous trouverez vers la fin de nombreuses lignes qui commencent par le nom du pilote que vous êtes en train d'utiliser (chez moi, c'est RADEON(0) car j'utilise le pilote libre pour ma carte Radeon ). Vous redémarrez le PC et vous allez fouiller dans le même journal Xorg.0.log, vous trouverez à présent le pilote VESA (je viens de le faire et je trouve des lignes qui contiennent la mention "VESA(0)" et bien sûr l'affichage est minimaliste - on dirait du Windows 95, hein? - mais il fonctionne sur tous les PC du monde. Enfin, je crois).
Bon, assez déconné, et comment on fait pour revenir à la gestion automatique de l'affichage ? Et bien ça commence comme plus haut :
sudo nautilus
naviguer jusqu'au fichier xorg.conf et le supprimer. Sortir du terminal par exit. Au redémarrage du PC, vous retrouverez votre affichage (merdique?) d'avant.

Epilogue : maintenant que vous avez compris le principe et que vous savez créer un fichier xorg.conf, il vous reste à définir les paramètres qui sont bons pour votre affichage (on n'écrit pas n'importe quoi, n'importe comment la-dedans). Pour ça, je fais confiance aux experts qui sauront vous guider. Moi, je ne sais que dépanner, pas faire les réglages fins.
A toutes fins utiles, il y a d'excellents conseils dans ce post pour les problèmes de non reconnaissance de l'écran (il faut alors définir la résolution adaptée à son moniteur):
http://forum.ubuntu-fr.org/viewtopic.php?pid=2259389#p2259389

Dernière modification par malbo (Le 02/02/2010, à 12:13)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#114 Le 02/02/2010, à 12:26

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bonjour les copains!

Bon, ben on avance! big_smile
Si j'en crois les infos que donne malbo et le #95 (page 4) de Poun64...je devrais reussir quelque chose pour ma radeon 9600 ??

Dieu aurait il entendu mon appel???:lol:
Je vais voir ça de près et je donnerais des infos.
Merci à tous.

(je confirme que mon Karmic est une installation "neuve")

Et je renvois à cet excellent lien pour ceux qui on des problèmes suite à des tentatives d'installation des pilotes proprio (qui semblent vraiment ignorer nos vieilleries)
ZZero79 pourra être intéressé :
https://wiki.ubuntu.com/X/Troubleshooti … deonDriver


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#115 Le 02/02/2010, à 12:43

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Avant de me lancer, j'ai une question pour Poun64 :

Comment tu fais pour savoir quoi coller ici (issu de ton #95) :

BusID        "PCI:1:5:0"             ### A priori pas nécessaire chez moi, mon bus est bien reconnu

Je veux dire : Pourquoi PCI:1:5:0 et pas PCI:2:4:2 par exemple ?
et où puis-je trouver l'info sur ma machine ?

Merci!

Dernière modification par cracolinux (Le 02/02/2010, à 12:44)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#116 Le 02/02/2010, à 13:00

MC_911

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

en tapant un petit lspci dans ton terminal, non ?

Dernière modification par MC_911 (Le 02/02/2010, à 13:02)

Hors ligne

#117 Le 02/02/2010, à 13:04

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Salut MC!

***@***:~$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 40)
00:14.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev 80)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600]
01:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)

Voilà ce que j'obtiens, dois-je en conclure que ma ligne sera :
PCI:1:0:0 ??
ou bien
PCI:1:0:1 peut être, aie aie, là je sais pas quelle ligne choisir entre les deux, si une des deux s'avère être la bonne!!

Remarque : je peux peut être ignorer cette ligne dans mon future xorg.conf ?

Dernière modification par cracolinux (Le 02/02/2010, à 13:08)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#118 Le 02/02/2010, à 13:16

MC_911

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

alors là ... sais pas lol
en cherchant sur le net, j'ai vu qu'une commande bien pratique, c'est lshw ... ça te détaille toute l'archi de ta machine.

Sinon, pour moi le hwinfo --gfxcard suffit : il me dit que ma carte video est en PCI 2:0:1 (et son contôleur/bus en 2:0:0)

[edit] en regardant les résultats du lshw et du hwinfo côte à côte ... ben le "physical id" du lshw correspond à l'identification de l'emplacement de la carte sur le bus PCI. Et ça correspond bien au code en tête de ligne dans le lsdev.

Donc pour toi, je dirais (mais sans garantie, hein !?) que c'est 1:0:1

Dernière modification par MC_911 (Le 02/02/2010, à 13:21)

Hors ligne

#119 Le 02/02/2010, à 13:27

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Sympa ces commandes!!
Voici ces que j'obtiens..

hwinfo --gfxcard
18: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_4150
  Unique ID: VCu0.M35Fvi6T4o7
  Parent ID: vSkL.K3WJKbXW3V7
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "C.P PowerColor R96A-C3N"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x4150 "RV350 AP"
  SubVendor: pci 0x148c "C.P. Technology Co. Ltd"
  SubDevice: pci 0x2064 "PowerColor R96A-C3N"
  Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
  I/O Ports: 0xc000-0xcfff (rw)
  Memory Range: 0xe5000000-0xe500ffff (rw,non-prefetchable)
  Memory Range: 0xe4000000-0xe401ffff (ro,prefetchable,disabled)
  IRQ: 11 (31729 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d00004150sv0000148Csd00002064bc03sc00i00"
  Driver Info #0:
    XFree86 v4 Server Module: radeon
  Driver Info #1:
    XFree86 v4 Server Module: radeon
    3D Support: yes
    Extensions: dri
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

19: PCI 100.1: 0380 Display controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1002_4170
  Unique ID: NXNs.NzIXo_OOZTB
  Parent ID: vSkL.K3WJKbXW3V7
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.1
  SysFS BusID: 0000:01:00.1
  Hardware Class: graphics card
  Model: "ATI RV350 AP [Radeon 9600] (Secondary)"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x4170 "RV350 AP [Radeon 9600] (Secondary)"
  SubVendor: pci 0x148c "C.P. Technology Co. Ltd"
  SubDevice: pci 0x2065 
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable,disabled)
  Memory Range: 0xe5010000-0xe501ffff (rw,non-prefetchable,disabled)
  Module Alias: "pci:v00001002d00004170sv0000148Csd00002065bc03sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #10 (PCI bridge)

Primary display adapter: #18

La question que je me pose, c'est :
Quelle est la différence entre VGA compatible controller et Display controller ??

A priori, je dirais que le display controller l'emporte et que donc ma ligne serais : PCI:1:0:1, mais bon...

Dernière modification par cracolinux (Le 02/02/2010, à 13:29)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#120 Le 02/02/2010, à 13:34

MC_911

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Si j'en crois ta dernière ligne ... c'est ton #18 le "primary adapter"
J'ai la même chose :

mc@duchnok:~$ hwinfo --gfxcard
08: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_2a42
  Unique ID: _Znp.X_f4FFi_8HA
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Mobile 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2a42 "Mobile 4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x7015 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0x90000000-0x903fffff (rw,non-prefetchable)
  Memory Range: 0x80000000-0x8fffffff (rw,prefetchable)
  I/O Ports: 0x70f0-0x70f7 (rw)
  IRQ: 31 (20969136 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00002A42sv0000103Csd00007015bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

09: PCI 02.1: 0380 Display controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_2a43
  Unique ID: ruGf.2R1j85+eQuF
  SysFS ID: /devices/pci0000:00/0000:00:02.1
  SysFS BusID: 0000:00:02.1
  Hardware Class: graphics card
  Model: "Intel Mobile 4 Series Chipset Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x2a43 "Mobile 4 Series Chipset Integrated Graphics Controller"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x7015 
  Revision: 0x07
  Memory Range: 0x90400000-0x904fffff (rw,non-prefetchable)
  Module Alias: "pci:v00008086d00002A43sv0000103Csd00007015bc03sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #8

donc du coup, ton id PCI serait 1:0:0

à croiser avec les infos que tu recueilleras dans ta log, consultable comme expliqué plus haut par malbo

malbo a écrit :

Pour pouvoir contrôler ce qui se passe, avant de redémarrer le PC, vous allez dans Système > Administration > Visionneur de journaux système,

Dernière modification par MC_911 (Le 02/02/2010, à 13:40)

Hors ligne

#121 Le 02/02/2010, à 14:15

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Oh!! , MC...;)

Je tiens au courant de l'évolution

Dernière modification par cracolinux (Le 02/02/2010, à 14:16)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#122 Le 02/02/2010, à 16:08

Koryushin

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Bonjour a tous, je suis tout nouveaux sur Ubuntu  - environ 1 mois tongue  -  (pendant mon BTS y a un petit bout de temps j'étais sur mandrake big_smile et je dois avouer que je suis assez content de revenir sur linux)

J'espère ne pas me tromper de section; je vraiment était déçu après avoir tester les drivers catalyst 9.10 et 9.12. Je possède une carte ati HD4870 qui fonctionnait très bien sur l'os de billou. Bref j'ai testé openaren et nexuiz qui au passage son de très bons jeux mais par moment j'avais des micro lags de 3 ou 4 secondes.

Après lecture de la doc : http://doc.ubuntu-fr.org/radeonhd j'ai décidé d'installer le pilote radeonHD en suivant le lien vers le tutoriel présent sur cette page. https://help.ubuntu.com/community/RadeonHD. Première impression tout va bien tout s'installe correctement du coup je suis en kernel 2.6.32.7. en voulant terminer le tutoriel bah pas de xorg.conf sad ( et oui j'ai fait des bêtises et j'ai du réinstaller tongue )

En lisant ce fil j'ai compris que c'est normal.  alors ma question puis-je utiliser le xorg.conf de la doc radeonHD pour continuer le tutoriel ? ( en l'adaptant a ma config )

Hors ligne

#123 Le 02/02/2010, à 18:44

cracolinux

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Ca y est, c'est fait :
-Création du fichier xorg.conf
-Modification des valeurs pour mon PC
-Alt+SysRq+k (redemarrage de xorg)

Bon, première chose : glxgears me donne de meilleur score avec une moyenne
de 9500 frames /5sec contre 8000 avant....héhé!

La "fiberlamp" des économiseurs d'écran est par contre toujours aussi tarte et lente qu'avant, mais elle n'a pas empirée.

Je m'empresse d'installer un jeux 3D et j'édite ce message pour donner le résultat.. tongue

[EDIT] bon, pour les jeux 3D, aucuns changements, je vais tenter quelques modifications...

Dernière modification par cracolinux (Le 02/02/2010, à 18:55)


Pixup : postez vos images vite et bien
« Ne devenez jamais pessimiste. Un pessimiste a plus souvent raison qu'un optimiste, mais l'optimiste s'amuse plus — et aucun des deux ne peut arrêter la marche du monde. » R.Heinlein

Hors ligne

#124 Le 02/02/2010, à 19:35

MC_911

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

Ah ben c'est déjà cool que ca marche !
Pour les jeux, peux pazaider ... j'en n'ai jamais installé sous tux ...

Hors ligne

#125 Le 02/02/2010, à 19:43

zzero79

Re : [IMPORTANT] Vieilles cartes ATI et pilote proprio

cracolinux a écrit :

Et je renvois à cet excellent lien pour ceux qui on des problèmes suite à des tentatives d'installation des pilotes proprio (qui semblent vraiment ignorer nos vieilleries)
ZZero79 pourra être intéressé :
https://wiki.ubuntu.com/X/Troubleshooti … deonDriver

Merci bien, je garde sous la main, mais je n'ai pas installé les pilotes proprio pour ma part.
Je testerai donc avec un fichier xorg.conf tout neuf mais pour le moment je me soucie pas trop de mon affichage, je n'ai aucun problème majeur et ne jouant pas bin je peux me satisfaire de pas avoir un beau cube qui tourne pour le moment smile
le principal est de migrer mes habitudes "logicielles" vers du libre ... pas toujours évident du premier coup ;-)

Hors ligne

Haut de page ↑