Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/02/2010, à 00:02

elfix

Problème de « locale »

Bonjour,

J'ai sans doute dû faire une fausse manipulation mais depuis peu, lorsque je tape certaines commandes (comme apt-get entre autre), j'ai ce message d'erreur qui s'affiche (que je n'ai jamais vu) :

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = "fr_FR",
        LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Je me suis un peu renseigné en recherchant sur internet les personnes qui avaient le même problème, mais le mien perdure. J'ai bien entendu fait les dpkg-reconfigure locales et ai modifié /etc/environment ainsi que créé /etc/locale.gen, mais rien à y faire. J'ai entendu parler d'un paquet nommé « localeconf » qui aurait pu m'aider à régler ce problème, mais il m'est introuvable.

Merci d'avance pour vos réponses.

PS : je précise également qu'il m'est impossible de taper des lettres accentuées dans la console (et d'en voir).

Dernière modification par elfix (Le 21/02/2010, à 00:04)

Hors ligne

#2 Le 22/03/2010, à 01:21

david96

Re : Problème de « locale »

Je ne sais pas si tu as réglé le blème, mais au cas où, que te donnes la commande :

setxkbmap -print

edit : un lien qui pourrait, peut-être t'intéresser > http://pagesperso-orange.fr/cspoires/linux/terminal.html#clavierfr

Dernière modification par david96 (Le 22/03/2010, à 01:33)

Hors ligne

Haut de page ↑