Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 27/05/2005, à 13:59

Doppler

[Résolu] Un Grub qui a du mal avec XP...

Bien le bonjour à vous tous !
D'abord merci pour toutes vos conversations qui m'ont permit d'arriver jusqu'ici, Ubuntu est un régal et vos aides sont vraiment des plus utiles.
Après avoir passé pas mal de caps je me trouve face à un problème qui commence à sérieusement me...

Voilà, au lancement de windows XP (dont je me passerait bien mais bon mes logiciels pros ne fonctionnant que sous win je n'ai pas le choix...) Grub me fait systématiquement aboutir à ce message:


Booting 'microsoft windows XP professionnel

Root (hd1,O)
filesystem type unknown, partion type 0x7
Savedefault
makeactive
chain loader +1

Et offcourse impossible de lancer XP

Pour info j'ai d'abord installé XP sur un disque qui est maintenant en esclave de mon second disque sur lequel j'ai ensuite installé Ubuntu. Il fonctionnait très bien avant de mettre Ub'


Si vous avez des idées pour me sortir de ce mauvais pas je serai des plus heureux, merci pour mes neurones tongue wink

Dernière modification par Doppler (Le 27/05/2005, à 16:29)

Hors ligne

#2 Le 27/05/2005, à 14:04

Stemp

Re : [Résolu] Un Grub qui a du mal avec XP...

'jour

$ sudo /sbin/sfdisk -d /dev/hda
$ sudo /sbin/sfdisk -d /dev/hdb

pour voir un peu plus clair


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#3 Le 27/05/2005, à 14:15

Doppler

Re : [Résolu] Un Grub qui a du mal avec XP...

'jour 'jour

bash: $: command not found

hum... c'est bien dans le terminal superutilisateur n'est ce pas ?

Hors ligne

#4 Le 27/05/2005, à 14:41

Reef

Re : [Résolu] Un Grub qui a du mal avec XP...

Essaye la solution suivante ça a marché chez moi :

http://forum.ubuntu-fr.org/viewtopic.php?id=616

Hors ligne

#5 Le 27/05/2005, à 14:48

Stemp

Re : [Résolu] Un Grub qui a du mal avec XP...

Doppler : le $ indique juste une console en mode utilisateur normal


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#6 Le 27/05/2005, à 14:58

samsan

Re : [Résolu] Un Grub qui a du mal avec XP...

J'ai réussi à le lancer depuis Grub en éditant la ligne de commande
root (hd1,0) par l'id de mon lecteur (hd0,0)
Ensuite j'ai fixé définitivement en éditant le fichier grub. Il suffit mettre l'id de ton lecteur.

Ceci dit c'est juste une piste, j'ai deux durs et pas sûr d'avoir eu la même erreur...

+++
Samsan.

Dernière modification par samsan (Le 27/05/2005, à 15:09)

Hors ligne

#7 Le 27/05/2005, à 15:16

Doppler

Re : [Résolu] Un Grub qui a du mal avec XP...

Minçouille... Désolé les gars chuis un pur newbee et à part que  $ indique juste une console en mode utilisateur normal (merci Stemp ^) j'ai rien capté d'autre...

Vous parlez de modifications, mais comment les fait on...

Désolé de mon manque de savoir... neutral

PS grâce à ta commande Stemp j'obtiens:

# table de partitions de /dev/hda
unit: sectors

/dev/hda1 : start=       63, size= 75135942, Id=83, bootable
/dev/hda2 : start= 75136005, size=  3020220, Id= 5
/dev/hda3 : start=        0, size=        0, Id= 0
/dev/hda4 : start=        0, size=        0, Id= 0
/dev/hda5 : start= 75136068, size=  3020157, Id=82
doppler@blablabla:~$ sudo /sbin/sfdisk -d /dev/hdb

puis...

/dev/hdb1 : start=       63, size= 61432497, Id= 7, bootable
/dev/hdb2 : start= 61432560, size=251128080, Id= f
/dev/hdb3 : start=        0, size=        0, Id= 0
/dev/hdb4 : start=        0, size=        0, Id= 0
/dev/hdb5 : start= 61432623, size=251128017, Id= e
doppler@blablablaencore:~$

mais hum hum... chuis toujours pas plus éclaircit....

Dernière modification par Doppler (Le 27/05/2005, à 15:19)

Hors ligne

#8 Le 27/05/2005, à 15:35

cep

Re : [Résolu] Un Grub qui a du mal avec XP...

Doppler a écrit :

Pour info j'ai d'abord installé XP sur un disque qui est maintenant en esclave de mon second disque sur lequel j'ai ensuite installé Ubuntu. Il fonctionnait très bien avant de mettre Ub'

Je ne sais pas ou est ton boot.ini mais as-tu essayé le paramètre map et rootnoverify ?

map to_drive from_drive     Commande
Fait correspondre le disque from_drive au disque to_drive. Cette opération est nécessaire pour le chargement chaîné de certains systèmes d'exploitation, comme DOS, si un tel OS n'est pas sur le premier disque. Voici un exemple:

grub> map (hd0) (hd1)
grub> map (hd1) (hd0)

rootnoverify device [hdbias]     Commande
Cette commande est similaire à root (voir root), mais elle n'essaie pas de monter la partition. C'est utile pour un OS qui se trouve en dehors de la zone lisible par GRUB, mais il est toujours préférable de définir le périphérique racine correct. Notez que les éléments mentionnés dans root, obtenus au montage ne fonctionneront pas correctement

Hors ligne

#9 Le 27/05/2005, à 16:04

Doppler

Re : [Résolu] Un Grub qui a du mal avec XP...

cep a écrit :

Je ne sais pas ou est ton boot.ini mais as-tu essayé le paramètre map et rootnoverify ?

heu... non je n'ai pas essayé... je ne savais même pas qu'ils existaient... marf

Merci pour ton aide, je vais...hum... voir si je trouve comment on fait...

Hors ligne

#10 Le 27/05/2005, à 16:14

cep

Re : [Résolu] Un Grub qui a du mal avec XP...

L'idée est d'adapter cela :
title Windows Xp
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
savedefault
makeactive
chainloader +1

Hors ligne

#11 Le 27/05/2005, à 16:28

Doppler

Re : [Résolu] Un Grub qui a du mal avec XP...

Cool ça marche !!!

Merci infiniment pour votre patience !

Merci ! big_smile



Alors si y'a un utilisateur aussi novice et banane que moi qui passe dans les parages je résume...

On ouvre le Terminal (Applications/Outils système/Terminal)

On tape la commande : sudo gedit /boot/grub/menu.lst

On donne son password

La fenêtre gedit s'ouvre avec menu.lst dedans

Tout en bas on trouve :
title        Microsoft Windows XP Professionnel
root        (hd1,0)
savedefault
makeactive
chainloader    +1

on remplace à partir de root (hd1,0)...
par :
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
savedefault
makeactive
chainloader +1

Et ça roule, enfin ici ^^



Merci encore les gens !

Hors ligne

#12 Le 29/05/2005, à 16:51

Electr0niK

Re : [Résolu] Un Grub qui a du mal avec XP...

salut à tous, c drôle Doppler, j'suis dans le meme cas que toi.
Bon, meme si g plus trop besoin d'XP j'vais essayer ca smile

Hors ligne

#13 Le 29/05/2005, à 17:51

Electr0niK

Re : [Résolu] Un Grub qui a du mal avec XP...

merci ca marche super smile

Hors ligne

Haut de page ↑