Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#26 Le 21/07/2010, à 17:42

jeanamesage

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Au cas ou cela peut aider quelqu'un:
J'ai eu ce problème lors du passage de Karmic à Lucid, sur un PC un peu ancien sur lequel j'ai XP en dual boot avec ubuntu.
Après la mise à jour, j'ai eu le fameux message d'erreur avec grub. Mais j'avais toujours le choix de lancer grub (qui me donnait ce message d'erreur) ou de démarrer windows XP toujours accessible.
Je suis revenu aux indication d'installation initiale de windowx XP et ubuntu en dual boot dans la doc standard.
Avec un live CD d'ubuntu (lucid), j'ai simplement régénéré grub.bs que j'ai copié sur une clef usb. J'ai vérifié en démarrant sous windows que  le fichier boot.ini contient toujours l'ajout fait lors de l'installation initiale (C:\grub.bs="Exécuter GRUB").
Ensuite j'ai écrasé dans "C" (sous windows) l'ancien fichier grub par le nouveau .
au redémarrage suivant, tout a fonctionné normalement.


Dell XPS L502X, ubuntu 14.04 / Win7 dual boot, et HP ENVY dv7 Ubuntu 14.04

Pourquoi existe-t-il quelque chose plutôt que rien?

Hors ligne

#27 Le 23/07/2010, à 17:41

jbyvosges

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Bonjour.
J'ai galéré plusieurs fois avant de réparer mon système : je n'avais pas vu que la commande fixboot n'existe pas sur Seven et qu'il fallait utiliser Bootrec \fixboot.

Mais : à chaque fois qu'il y a une mise à jour du grub, le boot Windows est écrasé. En ce qui me concerne, ça fait la troisième fois. Ceci est évidemment du à l'erreur d'installation initiale signalée par Hundredfire au premier post : j'ai grub installé sur /dev/sda

Y-a-t-il un moyen de réparer définitivement cette erreur ? Si oui, quelqu'un pourrait-il donner la marche à suivre bien détaillée ?

Merci


hp Pavilion ELite 020fr - Intel® Core™ i7 860 - 12Go RAM - Ubuntu 14.04
Mes sites : http://www.jbyorchid.fr
http://www.dolman.fr
http://www.sfola.fr

Hors ligne

#28 Le 07/08/2010, à 15:15

jbyvosges

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Personne n'a la solution ?


hp Pavilion ELite 020fr - Intel® Core™ i7 860 - 12Go RAM - Ubuntu 14.04
Mes sites : http://www.jbyorchid.fr
http://www.dolman.fr
http://www.sfola.fr

Hors ligne

#29 Le 07/08/2010, à 20:59

urustu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Je n'ai pas de double-boot ni Windows.


HP Pavilion 17-e027sf | CPU AMD A4-5000 alias Kabini | Graphique Radeon HD 8330 | Wifi Realtek RTL8188EE > Ubuntu Precise 12.04.4 LTS | Trusty 14.04 LTS | Fedora 20 | Mint 17
Samsung 300E7A nVidia Optimus > Ubuntu Precise 12.04 LTS

Hors ligne

#30 Le 18/08/2010, à 17:05

eggregor

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Salut,
Je lis tout çà un peu tard, mais pour avoir connu le même ennui sur une machine en dual-boot Debian Squeeze et Debian SID, j'ai réparé sans difficulté en téléchargeant Super_grub_disk depuis ce serveur, puis gravure et démarrage machine sur le cd-rom.

http://prdownload.berlios.de/supergrub/super_grub_disk_hybrid-1.98s1.iso

Depuis le cd rom j'ai sélectionné la première ligne de menu et l'écran d'identification de la Squeeze est apparu, Après ouverture, j'ai fait une dist-upgrade en réinstallant grub sur le disque entier comme cela était proposé. ( chez moi /dev/hda ), et non sur la partition de Squeeze.

Pour autant au redémarrage je n'avais toujours pas de possibilité de lancement de SId.

J'ai donc fait un reboot sur le Cd et cette fois j'ai choisi de faire une install de grub comme le propose de mémoire la deuxième ligne du menu du CD-rom.

Un checking s'est lancé et au final SID a démarré.

J'ai refait une dist-upgrade sur Sid, et en redémarrant j'ai bien l'ouverture de grub avec  tous les choix de kernel installés.

C'est de travail de petite main mais çà marche et c'est simple.

Si tu essaies, raconte nous le résultat ?

Hors ligne

#31 Le 25/08/2010, à 23:43

cpolos

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Bonsoir à tous,

Ca fait la deuxième fois que je tente de faire la mise à jour ubuntu 10.4 à partir de 9.10 en dual boot windows 7.
La première fois j'ai chosi à la fin de la mise à jour 10.4 l'option 'garder les mêmes config' (pour grub -pc)
Et la deuxième, 'installer les nouveaux (...)' enfin la première option proposé.

Et pour les deux j'ai au redémarrage "No module name found".
J'ai tenté plusieurs choses, "Bootrec/fixboot" depuis un CD windows 7:sans succès.

Je ne sais plus quoi faire à part jeter le cd d'ubuntu par la fenetre.


Merci par avance pour votre aide! smile

Hors ligne

#32 Le 26/08/2010, à 00:07

cpolos

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

img0741l.jpg

Hors ligne

#33 Le 26/08/2010, à 13:58

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

cpolos a écrit :

Et pour les deux j'ai au redémarrage "No module name found".
J'ai tenté plusieurs choses, "Bootrec/fixboot" depuis un CD windows 7:sans succès.

Je ne sais plus quoi faire à part jeter le cd d'ubuntu par la fenetre.

Garde le pour restaurer ton GRUB!

http://doc.ubuntu-fr.org/grub-pc#reinstallerrestaurer_grub_2


Xub'

Hors ligne

#34 Le 26/08/2010, à 19:32

cpolos

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Grace à cette opération j'ai pu récupérer mon grub!

Cependant une fois que je choisis Windows 7 et que je redémarre ma session j'ai à nouveau: "No module name found Press any key..."

Je sais pas quoi faire.

Hors ligne

#35 Le 31/08/2010, à 11:40

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

J'ai le même soucis, le bug a déjà été reporté plusieurs fois.
Tu as un portable HP ou Dell? Un logiciel de sauvegarde écrase GRUB à chaque fois que tu démarres sous Windows Seven. Avec une restauration nécessaire de GRUB (en te reportant à la doc, cf. lien ci-dessus) après chaque boot sous Windows (pas de problème après un boot sous Ubuntu).
A priori le moyen le plus simple est d'identifier le logiciel en cause et de le désinstaller.


Xub'

Hors ligne

#36 Le 31/08/2010, à 13:53

cpolos

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

C'est exactement ça! J'ai un Dell studio 1558 tout neuf!
Je vais éssayer de me renseigner sur ça.
Merci beaucoup!

Hors ligne

#37 Le 01/09/2010, à 08:52

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Comme c'est bizarre... moi aussi lol

https://bugs.launchpad.net/debian/+source/grub2/+bug/551721

Et dans la série, presque pareils :
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/482757
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/441941

Anthony Hook a écrit :

I may have solved my problems on this Dell One 19. I removed:

Dell DataSafe Local Backup
Dell DataSafe Local Backup - Support Software

From Windows and I will be sure to notify if this reoccurs.

Bug 482757 #17


Xub'

Hors ligne

#38 Le 02/09/2010, à 18:04

cpolos

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

J'ai installé via Wubi et ça marche trés bien, je vais m'en contenter, j'ai trop utilisé le cd live d'ubuntu pour le moment.

Cependant, tu pense que si on enlève Dell Datesafe local backup on peut avoir un dual boot?

Merci pour ton aide.

Hors ligne

#39 Le 08/09/2010, à 10:25

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

cpolos a écrit :

Cependant, tu pense que si on enlève Dell Datesafe local backup on peut avoir un dual boot?

A défaut de désinstaller ces logiciels (DataSafe & co) j'avais essayé d'empêcher leur démarrage automatique (vis msconfig). Ils n'ont pas l'air d'être inscrits dans les services (services.msc). Au final, je reste sur le même problème : à chaque démarrage sous Windows, une partie du GRUB est écrasée et je suis obligé de le restaurer via live USB avec les 3 ligne de code ci-dessus.

Deux types de solutions définitives semblent donc toujours possible
- désinstaller Dell DataSafe (cf. ubuntuforums.org)
- remplacer grub2 par un autre bootloader : BURG, dérivé lui-même de GRUB2 (cf bug#551721).

cpolos a écrit :

J'ai installé via Wubi et ça marche trés bien, je vais m'en contenter, j'ai trop utilisé le cd live d'ubuntu pour le moment.

Attention, Wubi est loin de valoir une installation "en dur" sur une partition dédiée, même si son usage est beaucoup plus confortable qu'un live.


Xub'

Hors ligne

#40 Le 10/09/2010, à 03:25

YannUbuntu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Hundredfire a écrit :

Cela est dû à une petite "bourde" des développeurs qui ont donné des indications confuses à l'installation de GRUB.

Bonjour. Cette "bourde" a-t-elle été corrigée dans Ubuntu 10.04.1 ? 
si non, existe-t-il un rapport de bug ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#41 Le 10/09/2010, à 10:10

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Pour ce que j'ai compris compris ce n'est pas lié à une bourde des programmateurs... ce serait trop simple d'expliquer ça comme ça!

Il y a plusieurs paramètres, pour ce que j'ai compris :
  * d'une part des applications Windows qui écrivent dans le MBR - ça ce n'est pas gérable sauf désinstallation
  * d'autre part la taille de GRUB dans le MBR ("stage1"). Cette taille a augmenté avec le passage de GRUB1 à GRUB2, ce qui le rend plus sensible à l'a réécriture par des programmes tiers.

Voici un des endroits où j'ai trouvé cette explication détaillée (via un lien sur sur le sjet d'ubuntuforums.org):
http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:Windows_Writes_To_MBR


La même explication à propos de l'utilisation de BURG (pas concluant pour mi, pour l'instant) qui permettrait de contourner le pb en conservant GRUB2+BURG, voir ici :
http://code.google.com/p/burg/wiki/Troubleshooting


Xub'

Hors ligne

#42 Le 10/09/2010, à 13:22

mavosaure

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

YannUbuntu a écrit :

Bonjour. Cette "bourde" a-t-elle été corrigée dans Ubuntu 10.04.1 ? 
si non, existe-t-il un rapport de bug ?

En fait de ce que j'ai pu voir ce bug a été reporté de multiple fois depuis l'arrivée de GRUB2, avec des variantes sur le message d'erreur de GRUB, et avec des vraintes ur le logiciel provocant l'écrasement, sans révolution majeure jusqu'ici :

* Bug #551721 sous Lucid et Squeeze
* Bug #482757 sous Karmic
* Bug #441941 de Karmic à Maverick

Note: le dernier bug est le plus "actif" et suivi. Les 2 autres pourraient probablement être inscrits comme comme doublons (la distinction tient au message d'erreur qui diffère).


Xub'

Hors ligne

#43 Le 20/09/2010, à 22:18

chfab31400

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Bonsoir,

Je possède un IBMT43 avec Windows XP pro / ubuntu 8.04 en multiboot grace à GRUB.
Je viens de mettre à jour ubuntu via le gestionnaire vers la version 10.04 et à priori tout s'est bien passé mis à part que je crains que le fichier menu.lst n'a pas bien été mis à jour.
Lorsque je redémarre le PC, le titre de la version d'ubuntu est restée la même (8.04) et impossible de démarrer ubuntu.
Je pense que les adresses du kernel ne sont plus valables.
Pouvez-vous me donner les commandes à modifier dans le grub ?

J'ai essayé de chercher des fichiers types menu.lst mais n'ayant pas accès à la partition Ubuntu, je ne sais pas la modifier.
J'ai essayé avec une knoppix mais impossible car les fichiers ne sont qu'en lecture !

Merci

Hors ligne

#44 Le 21/09/2010, à 03:53

YannUbuntu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Bonjour
pour mettre GRUB a jour, il suffit de suivre ce tuto : http://doc.ubuntu-fr.org/grub-pc#reinstallerrestaurer_grub_2


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#45 Le 21/09/2010, à 13:53

chfab31400

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

D'accord, merci du tuyau.

En balayant le tuto pour GRUB2, je vois qu'il me faut une version d'ubuntu sur:
- un cd (téléchargement + iso)
- une clé USB (tuto avec4 méthodes qui nécessitent d'accèder à Ubuntu ou tout autre système linux)

Dans tous les cas, ça nécessite le téléchargement de l'iso + des lignes de codes types Linux  --> impossible car mon PC est bloqué (impossible de démarrer Ubuntu

N'y-a-t-il pas plus simple avec la clé usb (fichier iso surlequel booter au démarrage ?)

Est-il possible de modifier les lignes de commandes dans le grub au démarrage ?
lien kernel + nom de la version de Ubuntu pour pointer la bonne version quitte à la modifier ensuite dans menu.lst ?

merci

Hors ligne

#46 Le 21/09/2010, à 14:34

YannUbuntu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

A mon avis il te faut soit un live-CD soit un live-USB, pas moyen de modifier GRUB sans cela.

Si ton Windows XP se lance toujours, tu peux graver ton live-CD Ubuntu a partir de windows.
Tu peux aussi te créer un live-USB avec Unetbootin. Sinon, fais-le depuis un autre ordinateur, ou achete-toi un magazine avec un CD.

(d'ailleurs tu devrais toujours garder un live-CD ou live-USB avec toi, ca pourra te re-servir)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#47 Le 21/09/2010, à 19:43

chfab31400

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

oui en effet.
Je vais faire ça avec windows.
J'ai un CD mais c'est la version 8.04 !

Merci

Hors ligne

#48 Le 22/09/2010, à 03:12

YannUbuntu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

oui, grave un CD ubuntu 10.04 via Windows.

Le cd ubuntu 8.04 ne contient que GRUB 1 (legacy), il ne permet pas d'installer Grub2.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#49 Le 22/09/2010, à 10:41

tan-ki

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

[modifié pour ne pas faire doublon :]

S'il vous plaît, est-ce que quelqu'un pourrait me conseiller une solution pour retrouver l'accès à ma partition linux après une erreur 15, que j'ai eue à la suite d'une mise à niveau grub legacy -> grub 2 ?

Cf nouvelle discussion : Vista/Lucid[jaunty;karmic], grub legacy à grub 2, error 15.

Dernière modification par tan-ki (Le 22/09/2010, à 11:59)


It is the eye which makes the horizon ~ Ralph Waldo Emerson

Hors ligne

#50 Le 22/09/2010, à 11:40

YannUbuntu

Re : [Solution]Problème GRUB/démarrage Windows après upgrade vers 10.04

Bonjour tan-ki,

je pense que tu ferais mieux de créer une nouvelle discussion (et nous donner le lien ici), tu auras plus de réponses.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

Haut de page ↑