Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/10/2010, à 19:06

xanalie

[son] pas de son sur la prise casque

Bonjour,

Voila, je suis nouvelle sous linux. J'ai installé ubuntu sur mon portable (dell M101z). Tout marche pour le mieux sauf le son. Sur les haut-parleurs, il n'y a pas de soucis mais quand je branche mes écouteurs dans la prise son, les haut-parleurs ne produisent plus de son mais il n'y en a pas non plus dans mes écouteurs. Les écouteurs ne sont pas hs, je les ai testé sur mon lecteur mp3.


J'ai un peu cherché sur le forum mais apparement, tout devrait fonctionner avec mon modèle de pc.

Quelqu'un peut-il m'aider ?
Quelles sont les informations que je dois donner?

merci d'avance

Hors ligne

#2 Le 02/10/2010, à 21:50

vinclm

Re : [son] pas de son sur la prise casque

Bonjour,

J'ai un problème analogue sur un Acer Aspire 4820, problème pas encore résolu en ce qui me concerne.
Ceci dit ton problème est peut-être plus simple :
Dans le menu Système -> Préférences -> Son : dans l'onglet Sortie, tu as peut-être la possibilité de sélectionner les HP internes ou la sortie casque.
Vérifies aussi les niveaux sonores des différents réglages proposés.

Hors ligne

#3 Le 02/10/2010, à 22:58

xanalie

Re : [son] pas de son sur la prise casque

J'ai vérifié les sorties mais je peux juste choisir entre les haut-parleurs internes et la sortie hdmi. Pas de sortie casque.Merci quand même pour le conseil

Hors ligne

#4 Le 07/10/2010, à 15:53

xanalie

Re : [son] pas de son sur la prise casque

pas de solution ?

Hors ligne

#5 Le 07/10/2010, à 19:13

Corentin38

Re : [son] pas de son sur la prise casque

Voyons ce qu'on peut faire ...

quel sont les résultats des commandes :

lspci | grep -i audio
cat /proc/asound/card0/codec#* | grep "Codec"

Corentin
Ubuntu 5.10 --> Ubuntu 12.10

Hors ligne

#6 Le 07/10/2010, à 20:40

xanalie

Re : [son] pas de son sur la prise casque

Voilà

lspci | grep -i audio :

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA) (rev 40)
01:05.1 Audio device: ATI Technologies Inc RS880 Audio Device [Radeon HD 4200]

cat /proc/asound/card0/codec#* | grep "Codec" :

Codec: Realtek ALC269


Alors docteur, c'est grave ? big_smile

Dernière modification par xanalie (Le 07/10/2010, à 20:40)

Hors ligne

#7 Le 11/10/2010, à 18:41

xanalie

Re : [son] pas de son sur la prise casque

up

Hors ligne

#8 Le 23/10/2010, à 14:47

xanalie

Re : [son] pas de son sur la prise casque

personne n'a une idée de solution ?? sad

Hors ligne

#9 Le 23/10/2010, à 15:17

maman

Re : [son] pas de son sur la prise casque

salut,
as-tu essayé de voir du côté d'alsamixer?
En console, tu tapes

alsamixer

Tu vas avoir un truc du genre:
1282417651.jpg
tu te déplaces avec les flèches sur headphone et tu montes le son avec la flèche "up".

Quel est la marque et le modèle de ton PC?

@+


90% of teens today would die if Facebook was completely destroyed. If you are one of the 10% that would be laughing, copy and paste this to your signature.

Hors ligne

#10 Le 23/10/2010, à 18:05

xanalie

Re : [son] pas de son sur la prise casque

j'ai essayé mais je n'ai même pas le headphone dans le mixer, juste master, speaker, pcm, front mic boost, mic boost et beep.

J'ai un dell inspiron M101z

Hors ligne

#11 Le 24/10/2010, à 14:37

Thenardier

Re : [son] pas de son sur la prise casque

Salut xanalie, j'ai eu le même problème que toi et je viens de le résoudre.
Il suffit d'éditer alsa-base.conf
sudo vim /etc/modprobe.d/alsa-base.conf
et de rajouter à la dernière ligne:
options snd-hda-intel model=dell

Save & Reboot, et ça marche smile
Mais ça n'a pas résolu le problème de micro sad
je vais chercher encore ....


j'ai toujours raison, sauf quand j'ai tort ...

Hors ligne

#12 Le 24/10/2010, à 17:13

Thenardier

Re : [son] pas de son sur la prise casque

Je me réponds à moi-même smile
Je viens de faire marcher le micro.
Après la manip indiquée il faut resélectionner le bon profile dans les préférences audio.
J'ai mis à jour la page http://doc.ubuntu-fr.org/dell_inspiron_m101z avec toutes les trouvailles que j'ai faites depuis que j'ai mon m101z, c'est à dire depuis 5 jours.


j'ai toujours raison, sauf quand j'ai tort ...

Hors ligne

#13 Le 24/10/2010, à 22:38

xanalie

Re : [son] pas de son sur la prise casque

je ne comprend pas sad j'ai fait la même manip et ça ne marche pas.

Voici une copie de mon fichier asla-base config au cas où :

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
options snd-hda-intel model=dell

Hors ligne

#14 Le 25/10/2010, à 12:40

Thenardier

Re : [son] pas de son sur la prise casque

Je suis nouveau moi aussi sur Linux, donc je ne peux pas te donner de garanties sur la qualité de mon aide.

Bon en tout cas, la manip que j'ai décrite a fait marcher mon casque direct, donc il y a 2 possibilités:
- j'ai fait tellement de manips avant qu'il y en a peut-être une qui est indispensable
- au contraire, tu en as fait une qu'il ne fallait pas faire
Mais dans les 2 cas, quelle est la manip en question ?

La seule chose que je peux faire, pour essayer d'avancer, est de comparer nos 2 configs.
- une question bête: est-ce que tu as testé les écouteurs sur ton m101z avec windows 7 ? (histoire de vérifier que le matériel est ok)
- tu as installé 10.04 LTS ou 10.10 ? (j'ai installé 10.04 LTS)
- je ne connais pas assez l'archtitecture hard, à priori ce n'est pas lié mais on ne sait jamais, est-ce que tu as installé les drivers ATI propriétaires ? (moi, oui)
- quelque part dans ton post, j'ai vu que tu as détecté le codec Realtek ALC269, moi j'ai ALC259, soit c'est une faute de copier/coller, soit on n'a pas le même hard, et là, ça va se compliquer hmm
- après avoir vu http://playingwithsid.blogspot.com/2010 … buntu.html, j'avais fait ceci:
sudo apt-get update
sudo apt-get install linux-backports-modules-alsa-lucid-generic

ça n'avait pas suffit mais peut-être que c'est une étape indispensable
- on a le même alsa-base.conf
- dans les préférences audio, j'ai
--- onglet Hardware, device 'Internal Audio': Analog Surround 4.0 Output + Analog Stereo Input
--- onglet Output, device 'Internal Audio Analog Surround 4.0': connecteur Analog Speaker
--- onglet Applications: je vois ALSA plug-in [plugin-container] non muté

Sinon, il va falloir se comparer tous les fichiers de conf ...


j'ai toujours raison, sauf quand j'ai tort ...

Hors ligne

Haut de page ↑