Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/02/2009, à 16:33

xabilon

Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Bonjour

Ce sujet a pour but de répertorier les problèmes les plus fréquemment rencontrés lors de l'utilisation des différents gestionnaires de paquets fournis sur Ubuntu et ses différentes déclinaisons (Kubuntu, Xubuntu, Edubuntu ...) :
Synaptic : logiciel graphique Gtk (Ubuntu, Xubuntu, Edubuntu)
Adept : logiciel graphique Qt (Kubuntu)
apt-get : interface en ligne de commande
aptitude : interface en ligne de commande / semi-graphique

Commencez par ces pages de documentation :
* Comment installer un logiciel
* Comment installer un paquet
* Questions fréquemment posées sur APT
* Problèmes fréquents du gestionnaire de paquets

FAUT-IL UTILISER SYNAPTIC/ADEPT, APT-GET OU APTITUDE ?

Il est conseillé d'utiliser les interfaces graphiques disponibles, pour plus de simplicité.

Pour une gestion en ligne de commande, apt-get est le plus simple
Aptitude présente une gestion différente et améliorée des dépendances, et est plus évolué que apt-get (permet de gérer plusieurs versions des paquets, propose des solutions en cas de conflits entre paquets ...).

Il est généralement recommandé de ne pas utiliser alternativement l'un et l'autre, les tableaux des dépendances créés par les deux logiciels pouvant se retrouver faussés.

Debian recommande officiellement l'utilisation d'Aptitude, notamment en cas d'utilisation évoluée du gestionnaire de paquets (pinning, etc ...).
Il n'y a aucune recommandation officielle dans le cas d'Ubuntu. Les dépôts, leur rôle et fonctionnement n'étant pas les mêmes, il est conseillé de réserver l'usage d'Aptitude aux utilisateurs déjà expérimentés.

J'AI UN MESSAGE D'ERREUR  :

       - Dpkg was interrupted ...

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. 
E: _cache->open() failed, please report.

Solution : Ouvrez un Terminal ou une Konsole, et tapez la commande suivante :

sudo dpkg --configure -a

.

       - Signatures non vérifiées ...

W: GPG error: **adresse d'un dépôt** Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY **XXXXXXXXXXXXXX**

Les dépôts utilisent des clés publiques pour authentifier leur contenu. Si vous avez ajouté un dépôt non officiel (Medibuntu, PPA.aunchpad ...) à votre liste de canaux logiciels, il vous faut l'authentifier.
Solution :Consultez le site du dépôt en question, ou la documentation Ubuntu, afin de pouvoir récupérer la clé et l'installer.
À noter que cette erreur n'est qu'un avertissement ; elle ne vous empêchera pas de continuer l'installation de vos paquets.




N'hésitez pas à poster ci-bas les questions que vous rencontrez le plus souvent à propos de APT, avec leurs messages d'erreur, ainsi que leurs solutions (solutions simples, ou alors liens vers tutos si plus compliqué).
Ils seront ajoutés à ce message

AUCUN PROBLÈME NE SERA TRAITÉ SUR CE TOPIC, CRÉEZ VOTRE PROPRE DISCUSSION POUR CEUX-CI.
TOUT MESSAGE DE DEMANDE D'AIDE SERA SUPPRIMÉ


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#2 Le 02/02/2009, à 18:20

pipou24

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Salut,

la page de doc : http://doc.ubuntu-fr.org/probleme_apt recense déjà pas mal de problèmes liés au gestionnaires de paquets.

Et dernièrement, on a rencontré ce cas de figure : http://forum.ubuntu-fr.org/viewtopic.php?id=287712
certes pas très courant, mais bon.


Non geek et fier de l'être. ㋡

Hors ligne

#3 Le 02/02/2009, à 19:21

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Ah té, j'l'avions pas vue, celle-là !
Ce qui prouve qu'elle n'est peut-être pas si facile à trouver ...

Je la rajoute illico dans l'en-tête du forum

Les problèmes répertoriés ici serviront aussi à étoffer la page de doc, mais on va laisser de côté les soucis pas courants, afin de ne pas trop surcharger.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#4 Le 10/04/2009, à 19:34

lecoqhardi

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Bonsoir,
Merci pour cette petite mise au point qui était sans doute nécessaire. Il est également vrai que ce n'est pas toujours simple de trouver une info simple sur la différence entre apt-get et aptitude, par exemple. Le coqhardi.

Hors ligne

#5 Le 22/07/2009, à 23:46

Goulou99

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Voilà, je vous transmet une contribution au site.

En espérant que le format proposé remplira les attentes concernant les problèmes liés à synaptic.

Cas # 1 :

Message d'erreur:

dpkg: erreur d'analyse syntaxique, dans le fichier" /var/lib/dpkg/available" p

Solution (dans un terminal):

sudo dpkg --clear-avail
sudo apt-get update
sudo dpkg-reconfigure -a

Source:

http://forum.ubuntu-fr.org/viewtopic.php?id=331309

Remarque:

Ne fonctionne pas toujours mais peut cacher des problèmes plus profonds au niveau de la partition ou du disque.

Cas # 2

Message d'erreur:

E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/archive.canonical.com_ubuntu_dists_jaunty_partner_binary-i386_Packages
E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.'

Solution (dans un terminal):

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update
sudo apt-get upgrade

Source:

http://forum.ubuntu-fr.org/viewtopic.php?id=332525

Remarque:

Fonctionne

Cas # 3

Problème:

Paquet qui refuse de se désinstaller et qui empêche le bon fonctionnement de synaptic.

Solution (dans un terminal):

sudo dpkg --force-all --purge paquet-problématique
sudo dpkg --configure -a

Source:

http://forum.ubuntu-fr.org/viewtopic.php?id=332706

Remarque:

Ne fonctionne pas toujours car il peut rester des problèmes de dépendances.


Cas # 4

Message d'erreur:

E: Impossible d'ouvrir le fichier verrou /var/cache/apt/archives/lock - open (2 Aucun fichier ou dossier de ce type)
E: Impossible de verrouiller le répertoire de téléchargement

ou

E: Impossible de verrouiller /var/lib/dpkg/lock - open (11 Ressource temporairement non disponible)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/), est-il utilisé par un autre processus ?

Solution (dans un terminal):

cd /var/lib/dpkg
sudo mv info info_old
sudo mkdir info
sudo apt-get update
sudo apt-get -f install
sudo mv info_old info

Sources:

http://forum.ubuntu-fr.org/viewtopic.php?id=332124
http://forum.ubuntu-fr.org/viewtopic.php?id=339105

Remarque:

Fonctionne


Cas #5

Message d'erreur:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/dpkg/status, E:Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.'


Solution (dans un terminal):

Le fichier status étant corrompu, il faut d'abord s'assurer de la présence d'un backup de status dans le système:

find /var/lib/dpkg/status-old

Si le terminal renvoie la ligne
/var/lib/dpkg/status-old
sans rien d'autres comme un message d'erreur c'est que le fichier existe. Donc vous pouvez procéder au lancement des lignes suivantes:

sudo rm /var/lib/dpkg/status
sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/status /var/lib/dpkg/status-old

Source:

http://forum.ubuntu-fr.org/viewtopic.php?id=338138


Commentaire:

Fonctionne, sauf qu'il faut être prudent  car le fichier status est essentiel au fonctionnement de la débian.

Dernière modification par Goulou99 (Le 31/08/2009, à 02:43)

Hors ligne

#6 Le 23/07/2009, à 00:34

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Salut

Tu sais, tu peux aussi modifier tes messages. Ça sera plus clair wink


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#7 Le 23/07/2009, à 01:45

Goulou99

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Merci

Hors ligne

#8 Le 30/07/2009, à 21:34

mydjey

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Un lien intéressant:
http://doc.ubuntu-fr.org/installation_n … e_logiciel <-- installation non standard de logiciel.

http://doc.ubuntu-fr.org/tutoriel/comme … _internet? <-- installer des paquets sans internet.

Dernière modification par mydjey (Le 16/12/2010, à 09:30)


Mon site : http://mydjey.eu/

Hors ligne

#9 Le 18/02/2010, à 02:32

abelcaine

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

voila jai ca ki s affiche ds synaptic W: Duplicate sources.list entry http://security.ubuntu.com karmic-security/restricted Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_karmic-security_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com karmic-security/main Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_karmic-security_main_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com karmic-security/universe Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_karmic-security_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://ppa.launchpad.net karmic/main Packages (/var/lib/apt/lists/ppa.launchpad.net_ubuntu-mozilla-daily_ppa_ubuntu_dists_karmic_main_binary-i386_Packages) please help me

Hors ligne

#10 Le 18/02/2010, à 03:02

ilcorseronero

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

xabilon a écrit :

Il est généralement recommandé de ne pas utiliser alternativement l'un et l'autre, les tableaux des dépendances créés par les deux logiciels pouvant se retrouver faussés.

et c'est debian qui fait ça wow.
J'ai cru un moment à cette théorie, anéfé.


Solution à quasi tous vos problèmes: taper dans un terminal ce qu'il y a dans
la signature →  solution
solution
solution

Hors ligne

#11 Le 18/02/2010, à 03:42

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Ce n'est plus le cas, désormais smile

@abelcaine : tu as lu le titre de ce sujet ? Poste ton problème dans la section "Installation de logiciels"


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#12 Le 02/03/2010, à 14:32

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Tous les gestionnaires de paquets/mises à jour ne sont que des interfaces à APT : Synaptic, apt-get, aptitude ...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#13 Le 02/03/2010, à 14:34

Pix64

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Mince j'ai supprimé mon message après avoir trouvé la réponse dans la doc pour éviter de polluer ce topic.
Merci pour ta réponse ultra rapide, du coup je viens d'apprendre une chose.

aptitude est donc une interface (surcouche) pour apt ? Si oui pourquoi l'utilisation des 2 peut créer des conflits de dépendance vue que aptitude se base sur l'arbre d'apt ?

Dernière modification par Pix64 (Le 02/03/2010, à 14:36)

Hors ligne

#14 Le 03/03/2010, à 02:12

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

C'est le marquage des paquets qui pouvait créer des conflits : aptitude différencie les paquets installés volontairement de ceux installés automatiquement.
Désormais apt-get fait de même


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#15 Le 15/12/2010, à 23:57

Pit38f

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

xabilon a écrit :

Bonjour

Ce sujet a pour but de répertorier les problèmes les plus fréquemment rencontrés lors de l'utilisation des différents gestionnaires de paquets fournis sur Ubuntu et ses différentes déclinaisons (Kubuntu, Xubuntu, Edubuntu ...) :
Synaptic : logiciel graphique Gtk (Ubuntu, Xubuntu, Edubuntu)
Adept : logiciel graphique Qt (Kubuntu)
apt-get : interface en ligne de commande
aptitude : interface en ligne de commande / semi-graphique

Commencez par ces pages de documentation :
* Comment installer un logiciel
* Comment installer un paquet
* Questions fréquemment posées sur APT
* Problèmes fréquents du gestionnaire de paquets

FAUT-IL UTILISER SYNAPTIC/ADEPT, APT-GET OU APTITUDE ?

Il est conseillé d'utiliser les interfaces graphiques disponibles, pour plus de simplicité.

Pour une gestion en ligne de commande, apt-get est le plus simple
Aptitude présente une gestion différente et améliorée des dépendances, et est plus évolué que apt-get (permet de gérer plusieurs versions des paquets, propose des solutions en cas de conflits entre paquets ...).

Il est généralement recommandé de ne pas utiliser alternativement l'un et l'autre, les tableaux des dépendances créés par les deux logiciels pouvant se retrouver faussés.

Debian recommande officiellement l'utilisation d'Aptitude, notamment en cas d'utilisation évoluée du gestionnaire de paquets (pinning, etc ...).
Il n'y a aucune recommandation officielle dans le cas d'Ubuntu. Les dépôts, leur rôle et fonctionnement n'étant pas les mêmes, il est conseillé de réserver l'usage d'Aptitude aux utilisateurs déjà expérimentés.

Suggestion : compléter ce post en parlant de la Logithèque Ubuntu intégrée dans Ubuntu (en tous cas dans celle que je viens d'installer : 10.10) et situer les autres par rapport à cette interface graphique.


L'information seul bien dont la valeur augmente quand on le partage.

Hors ligne

#16 Le 27/01/2011, à 14:49

darkking

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

merci big_smile

Hors ligne

#17 Le 15/01/2012, à 10:50

cyrilohuertas

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Bonjour,
Je suis nouveau ici, et nouveau avec Ubuntu .... smile
J ai installé Ubuntu, je l'utilise pas mal, et je dois avoué, je kiff smile
Je souhaite installé open ssh pour me connecter a distance via putty par exemple.
Mais voila se que j obtiens :

cyrilo@cyrilo-desktop:~$ sudo apt-get install openssh-server
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
openssh-server : Dépend: openssh-client (= 1:5.3p1-3ubuntu7) mais 1:5.8p1-7ubuntu1 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
cyrilo@cyrilo-desktop:~$

Avez vous une idée, cela fait une semaine que je tourne en rond a chercher partout !!!
Merci d avance

Hors ligne

#18 Le 15/01/2012, à 16:40

xabilon

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Salut

... tu as lu le titre du sujet ? Crée ta propre discussion pour ton problème.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#19 Le 14/02/2012, à 10:26

lutetius

Re : Questions fréquemment posées /!\ ne postez pas vos problèmes ici

Bonjour,

je dois installer Dropbox pour un travail que j'ai à faire...
J'utilise actuellement Ubuntu 10.04 LTS
Il faut que je choisisse le téléchargement en version 64 bits ou 32 bits...
        Ubuntu (.deb)           64-bit           32-bit

Je ne sais pas laquelle choisir !

Ni comment l'installer, car on me propose aussi de passer par une ligne de commande à copier :

Install Dropbox via command line

The Dropbox daemon works fine on all 32-bit and 64-bit Linux servers. To install, run the following command in your Linux terminal.

32-bit:

cd ~ && wget -O - http://www.dropbox.com/download?plat=lnx.x86 | tar xzf -
       

64-bit:

cd ~ && wget -O - http://www.dropbox.com/download?plat=lnx.x86_64 | tar xzf -
       

Next, run the Dropbox daemon from the newly created .dropbox-dist folder.

~/.dropbox-dist/dropboxd
       

If you're running Dropbox on your server for the first time, you'll be asked to copy and paste a link in a working browser to create a new account or add your server to an existing account. Once you do, your Dropbox folder will be created in your home directory. Download this CLI script to control Dropbox from the command line. For easy access, put a symlink to the script anywhere in your PATH.

Merci pour votre aide...

Hors ligne

Haut de page ↑