Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 17/04/2011, à 05:11

Lilou

mettre à jour Gnome 3 - Ubuntu 10.04

salut
comment mettre à jour Gnome vers la version 3 sur Ubuntu 10.04 ?
J'ai trouvé cette page sur le forum http://live.gnome.org/GnomeShell#building
mais je n'ai pas compris ce que ça raconte.
Merci de votre aide.

Hors ligne

#2 Le 18/04/2011, à 01:33

AlexandreP

Re : mettre à jour Gnome 3 - Ubuntu 10.04

Et comme pour tous les autres logiciels de toutes les versions d'Ubuntu: une fois qu'Ubuntu est sortie en version stable, les versions des logiciels qui la composent sont gelées. Les seules mises à jour proposées sont des correctifs de sécurité. Les versions stables d'Ubuntu ne proposent pas des nouvelles versions des logiciels.

Si tu veux avoir GNOME 3 (incluant GNOME Shell et tous les autres composants de GNOME) dans Ubuntu 10.04 LTS, il va falloir que tu le compiles depuis le code source de GNOME.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#3 Le 18/04/2011, à 18:56

Trïdun

Re : mettre à jour Gnome 3 - Ubuntu 10.04

Voici , un petit lien pour l'avoir testé c'est du tonnerre , mais il y a des conditions :

- Avoir le pilote propriétaire , et l'accéleration 3D
- Avoir une connexion à haut-débit
- Se lever très tôt la compilation prend très très longtemps § + de 4h chez moi , mais je ne suis pas une référence. §

http://doc.ubuntu-fr.org/gnome-shell

Hors ligne

#4 Le 26/04/2011, à 22:48

Lilou

Re : mettre à jour Gnome 3 - Ubuntu 10.04

salut et merci pour vos réponses mais maintenant le server x ne démarre plus. J'ai voulu réinstaller les pilotes propriétaires de ma carte et maintenant Ubuntu ne démarre qu'en mode console.
J'ai essayé des manips trouvées sur les forums mais rien ne marche donc je vais attendre la version 11.04, faire une nouvelle install et essayer gnome shell si possible.

Hors ligne

#5 Le 19/05/2011, à 12:04

siick

Re : mettre à jour Gnome 3 - Ubuntu 10.04

Trïdun a écrit :

- Se lever très tôt la compilation prend très très longtemps § + de 4h chez moi , mais je ne suis pas une référence. §

http://doc.ubuntu-fr.org/gnome-shell

Tant mieux... j'aimerais tellement qu'il compile pendant 4h chez moi lol
Sérieusement, j'ai suivi le tuto de la doc, mais dès le début ça commence mal....

Aller plus loin...
Installation depuis GIT
Pour les utilisateurs plus avancés, il est possible de compiler assez simplement GNOME Shell. Le code source du projet sera téléchargé depuis un serveur GIT et sera automatiquement compilé à l'aide du compilateur Jhbuild.

Avant de compiler GNOME Shell, commencez par installer ses dépendances. Dans un terminal, exécutez la commande suivante (sur une seule ligne) :

sudo apt-get install curl jhbuild libjasper-dev libdconf0 libtiff4-dev libgstreamer0.10-dev libcroco3-dev xserver-xephyr xulrunner-dev python-dev mesa-utils mesa-common-dev libreadline5-dev libgl1-mesa-dev libwnck-dev librsvg2-dev libgnome-desktop-dev libgnome-menu-dev libffi-dev libgtk2.0-dev libgconf2-dev libdbus-glib-1-dev gtk-doc-tools gnome-common git-core flex bison automake build-essential icon-naming-utils autopoint libcanberra-dev libpulse-dev libvorbis-dev gnome-settings-daemon-dev libxklavier-dev libpam0g-dev libtasn1-3-bin libupower-glib-dev libgnome-keyring-dev

Parfait! Mais le hic c'est que sur Ubuntu 10.04, on a le droit à ça

siick@siick-desktop:~$ sudo apt-get install curl jhbuild libjasper-dev libdconf0 libtiff4-dev libgstreamer0.10-dev libcroco3-dev xserver-xephyr xulrunner-dev python-dev mesa-utils mesa-common-dev libreadline5-dev libgl1-mesa-dev libwnck-dev librsvg2-dev libgnome-desktop-dev libgnome-menu-dev libffi-dev libgtk2.0-dev libgconf2-dev libdbus-glib-1-dev gtk-doc-tools gnome-common git-core flex bison automake build-essential icon-naming-utils autopoint libcanberra-dev libpulse-dev libvorbis-dev gnome-settings-daemon-dev libxklavier-dev libpam0g-dev libtasn1-3-bin libupower-glib-dev libgnome-keyring-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
curl est déjà la plus récente version disponible.
E: Impossible de trouver le paquet libdconf0

Ce paquet existe mais pour Maverick... Et quand je veux l'installer (depuis package.ubuntu.com), j'ai le droit à un problème de dépendance...Logique..
Pourtant la doc précise bien que c'est pour la version 10.04 hmm

Par compilation (Ubuntu 10.04 LTS et ultérieures)
Compiler GNOME Shell vous promet d'utiliser la toute dernière version de GNOME Shell, l'expérience utilisateur la plus à jour. C'est aussi la méthode qui vous assure le moins de conflit dans votre système Ubuntu. Rapportez-vous à la section Installation depuis GIT.

Donc j'ai besoin d'aide.... J'aimerai bien l'installer quand même:cool:
Merci d'avance.

Dernière modification par siick (Le 19/05/2011, à 12:07)

Hors ligne

#6 Le 29/05/2011, à 14:22

sylvain972

Re : mettre à jour Gnome 3 - Ubuntu 10.04

J'ai le même problème sur 10.04.2 : Impossible de trouver le paquet libdconf0

Quelqu'un a t il une solution ?

Hors ligne

#7 Le 29/05/2011, à 17:58

siick

Re : mettre à jour Gnome 3 - Ubuntu 10.04

C'est normal, c'est impossible en fait sur 10.04, après moult recherches, il faut savoir abdiquer... lol.
Il faudrait peut-être changer la doc non?

Hors ligne

#8 Le 14/06/2011, à 23:20

01101011

Re : mettre à jour Gnome 3 - Ubuntu 10.04

Je confirme, j'ai ce soucis aussi.

J'ai essayé de voir sur le canal irc #ubuntu et on m'a signalé que c'était à la fois une manipulation dangereuse et que le résultat pouvait être instable. Donc si une solution existe elle est à prendre avec beaucoup de pincette.

Je vais me renseigner pour la documentation.

Haut de page ↑