Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 29/01/2005, à 15:12

PrEdAt0r

[Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

bonjour j'essaye de faire la mise a jour de firefox 0.9.3 vers la 1.0 , en suivant ce que vous avez dis c a d rajouter le lien en depot (en cherchant sur le forum wink) , il me trouve bien firefox 1.0 , mais je le met a jour et voila ce qu'il me dit :

Preconfiguring packages ...
(Lecture de la base de données... 78015 fichiers et répertoires déjà installés.)Préparation du remplacement de mozilla-firefox 0.99+1.0PR.1+revertedto0.9.3-0ubuntu3 (en utilisant .../mozilla-firefox_1.0-2ubuntu4-warty99_i386.deb) ...
rm: ne peut enlever `/usr/lib/mozilla-firefox/defaults/pref': est un répertoire
dpkg : erreur de traitement de /var/cache/apt/archives/mozilla-firefox_1.0-2ubuntu4-warty99_i386.deb (--unpack) :
le sous-processus pre-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/mozilla-firefox_1.0-2ubuntu4-warty99_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


aidez moi svp je ne sais pas quoi faire sad
ps : mon architecture est i386 et quoi qui se passe je suis toujours sous la 0.9.3 de firefox

Dernière modification par PrEdAt0r (Le 02/02/2005, à 20:51)

Hors ligne

#2 Le 29/01/2005, à 22:01

coffee

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

quand tu cherches dans synaptic, qu'as tu d'installer en rapport à firefox?


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#3 Le 30/01/2005, à 00:35

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

j'ai firefox 0.9.3 + les locales 0.9.3 fr c'est tout sad je comprend pas aidez moi :'(

Hors ligne

#4 Le 30/01/2005, à 03:19

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Tente d'enlever la version que tu as de firefox (la 0.9.3) si ca ne passe copie / colle le message d'erreur...


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#5 Le 30/01/2005, à 11:19

Cougar

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Supprime les paquets en cache, dans les préférences de Synaptic.
Et retélécharge le.


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#6 Le 30/01/2005, à 15:35

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

ok mais on fait comment pour supprimer les paquets en cache ? ensuite ok j'essais

Hors ligne

#7 Le 30/01/2005, à 17:55

Cougar

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Bah dans les préférences de Synaptic, il y a un bouton pour smile


Jabber: cougar (arobase) jabber.nuxo.net

Hors ligne

#8 Le 30/01/2005, à 17:56

coffee

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

dans les preferences de synaptic


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#9 Le 30/01/2005, à 20:53

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

je l'ai fais mais çà donne toujours le même message d'erreur (1er message de ce topic) aidez moi svp sad:( je sais plus quoi faire...

Hors ligne

#10 Le 31/01/2005, à 02:37

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Je ne connais pas assez synaptic...

Que renvoit sudo apt-get install -f   ?


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#11 Le 01/02/2005, à 14:50

koni68

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

C'est censé faire quoi sudo apt-get install -f ?

Hors ligne

#12 Le 01/02/2005, à 16:51

coffee

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

trouvé dans le man apt-get

       install
              La commande install est suivie par un  ou  plusieurs  paquets  à
              installer.  Chaque paquet est un nom de paquet ; ce n'est pas un
              nom de  fichier  pleinement  déterminé  (par  exemple,  dans  un
              système  Debian  GNU/Linux,  on  indiquera  libc6   et  non  pas
              libc6_1.9.6-2.deb). Tous les paquets requis par le(s)  paquet(s)
              que l'on veut installer sont aussi récupérés et installés. On se
              sert du fichier /etc/apt/sources.list pour localiser les paquets
              désirés.   Quand  un  trait  d'union  est  accolé  (sans  espace
              intermédiaire) au nom d'un paquet déjà installé, ce  paquet  est
              supprimé.  De  même on peut ajouter un signe « + » pour désigner
              un paquet à installer.  Cette dernière fonctionnalité peut  être
              utilisée  pour  annuler  les  décisions prises par le système de
              résolution des conflits d'apt-get.

              On peut choisir d'installer une version particulière d'un paquet
              en  faisant  suivre son nom par un signe égal et par la version.
              Cette version sera localisée et l'installation sera demandée. On
              peut  aussi  choisir  une  distribution  particulière en faisant
              suivre le nom du paquet par une barre oblique et par le  nom  de
              la distribution ou de l'archive (stable, testing, unstable).

              Avec  ces  possibilités  de choisir la version, de vieilles ver-
              sions d'un paquet peuvent être installées. Il faut faire  atten-
              tion.

              Enfin,  le  mécanisme  de  apt_preferences(5)  permet  de  créer
              d'autres règles pour l'installation des paquets.

              Quand aucun paquet ne correspond à l'expression donnée en  argu-
              ment et que cette expression contient l'un des caractères « . »,
              « ?  »  ou  «  *  »,  on  considère  que  c'est  une  expression
              rationnelle POSIX et elle est appliquée à tous les paquets de la
              base de données. Tout paquet correspondant est installé (ou sup-
              primé).  Notez  que la comparaison est effectuée par sous-chaîne
              et « lo » correspond aussi bien à « how-lo » qu'à « lowest ». Si
              vous  ne  le  voulez  pas,  ancrez l'expression par un caractère
              « ^ » ou un  caractère « $ », ou bien créez une expression  plus
              précise.
-f

       --fix-broken
              Correction  ;  essaye de réparer un système dont les dépendances
              sont  défectueuses.  Cette  option,  utilisée  avec  install  ou
              remove,  peut  omettre tout paquet de façon à permettre à APT de
              déduire  une  solution  viable.   Chaque  paquet  spécifié  doit
              complètement  corriger le problème. Cette option est quelquefois
              nécessaire lorsque l'on exécute APT pour la première fois ;  APT
              lui-même  interdit les dépendances défectueuses dans un système.
              Il est possible que la structure  de  dépendances  d'un  système
              soit  tellement  corrompue  qu'elle  requiert  une  intervention
              manuelle (ce qui veut dire la plupart  du  temps  utiliser  dse-
              lect(8)  ou  dpkg  --remove pour éliminer les paquets en cause).
              L'utilisation de cette option conjointement avec  -m  peut  pro-
              duire une erreur dans certaines situations.  Élément de configu-
              ration : APT::Get::Fix-Broken.

Donc en théorie ça répare les paquets cassés


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#13 Le 02/02/2005, à 13:25

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

ok merci je test ca cette aprem je vous tien au courant wink

Hors ligne

#14 Le 02/02/2005, à 13:30

nikola

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

signature de coffee a écrit :

sudo rm -rf /

big_smile Oué en même temps c'est radical ^^

NB : Cette cascade est effectuée par un professionnel : ne tentez en aucun cas de l'imiter tongue


Venez prendre un café :)

Hors ligne

#15 Le 02/02/2005, à 17:04

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

alors je l'ai fait et il me dit , 0 mise a jour , 0 nouvellement installés , 0 mise a jour et 2 a mettre a jour ! ( dont firefox )
mais çà ne marche pas sad vous avez une autre solution ?

Hors ligne

#16 Le 02/02/2005, à 17:08

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Que renvoit sudo apt-get install -f   ?

Bon ...

A mon avis tu as recuperé un fichier .deb avec Firefox dessus mais le systeme a pas reussi à gerer les dependances, et te bloque :

Enlever les firefox, avec synaptic, au pire enleve aussi les plugins; tes favoris resteront inchangés.
Puis un coup de sudo apt-get -f install afin qu'il t'annonce qu'aucun fichier n'est cassé, ou à mettre à jour.

Si tu veux le faire à la ligne de commande :
sudo apt-get remove mozilla-firefox[TAB] le tab pour qu'il complete la version à en levr en s'appuyant sur celle installée.

Enfin ajoute les backports sur ta machine pour avoir firefox en 1.0 en procedant comme indiqué là :
http://www.biologeek.com/journal/index.php/2005/01/09/27-installer-firefox-10-et-thunderbird-10-en-francais-sous-ubuntu

Dernière modification par Ju (Le 02/02/2005, à 17:10)


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#17 Le 02/02/2005, à 17:17

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

heeeu ok mais je me suis justement servi de ce lien pour rajouter les backports sad ! donc c'est surtout pour cela que je comprend pas !! bon je test quand même je vous tien au courant wink

Hors ligne

#18 Le 02/02/2005, à 17:32

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

bon bin j'ai essayer comme tu m'a dis et cela reviens au même qu'au debut sad ... ma ubuntu marche super bien sauf pour cette mise a jour de firefox 1.0 c'est quand même faut le dire SUPER dommage , surtout que 0.9.3 c'est lourd , svp vous avez une autre solution je sais plus quoi faire sad

Hors ligne

#19 Le 02/02/2005, à 17:43

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Est ce que tu peux faire un copier coller du resultat de sudo apt-get install -f ?

C'est vraiment dommage que tu sois bloqué en 0.9.3 surtout que ton souci doit pouvoir se resoudre facilement.


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#20 Le 02/02/2005, à 17:47

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

voila le resultat :

romain@ubuntu:~ $ sudo apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.

help me please sad

Hors ligne

#21 Le 02/02/2005, à 17:58

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

et ? sudo apt-get install -Vf

Ce que je comprends : L'idee c'est qu'un paquet plante à l'installation (dependances, etc.) il faut enlever ce paquet, un coup de apt-get update (au cas ou ta liste n'est pas à jour, tu as bien le depot backport installé ?) et installer le paquet que tu veux : mozilla-firefox


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#22 Le 02/02/2005, à 18:55

nikola

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Pour moi c'est un problème de dépôt. Il faut que les dépôts warty-backports soient activés. Au pire, activer les universe juste pour firefox et les recommenter ensuite.


Venez prendre un café :)

Hors ligne

#23 Le 02/02/2005, à 19:36

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

sudo apt-get install -Vf donne exactement la même chose que sudo apt-get install -f sad je ne sais pas quoi faire ... et oui ne vous inquieté pas j'ai bien le backports en main universe de mis , j'ai même en warty-backports-staging  main universe enfin bon j'ai bien l'url que tout le monde a pour faire l'update de firefox 1.0 mais ca ne marche pas sad:( .... help me sad:(

Hors ligne

#24 Le 02/02/2005, à 19:44

Ju.

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Au temps pour moi ...

C'est  rageant qu'il ne montre pas les paquets qu'il n'arrive pas à mettre à jour.

Donne le resultat de
cat /etc/apt/sources.list

et

apt-get remove -f  mozilla-firefox


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#25 Le 02/02/2005, à 19:51

PrEdAt0r

Re : [Install firefox 1.0]je fais tout se qui faut mais marche pas [Résolu]

Voici mon source.list :

## Uncomment the following two lines to fetch updated software from the network
deb http://archive.ubuntu.com/ubuntu/ warty main restricted
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://archive.ubuntu.com/ubuntu/ warty universe   
# deb-src http://archive.ubuntu.com/ubuntu/ warty universe   

deb http://security.ubuntu.com/ubuntu/ warty-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ warty-security main restricted 
deb http://ftp.sun.ac.za/ftp/mirrorsites/ubuntu.com/ warty main restricted


deb http://ubuntu-bp.sourceforge.net/ubuntu/ warty-backports main universe





deb http://ubuntu-bp.sourceforge.net/ubuntu/ warty-backports-staging main universe

je test le remove de mozilla et je te dis ca !
EDIT : il me demande si je veux supprimer les pkg mozilla-firefox + locales et aussi ubuntu-desktop ou un truc dans le genre , je continu ? et ensuite si j'ai bien compris j'installe la 1.0 ? mais par contre pour les prochaine mise a jour de firefox (1.1) il y aura un problême ?

Dernière modification par PrEdAt0r (Le 02/02/2005, à 19:55)

Hors ligne

Haut de page ↑