Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 21/01/2005, à 14:02

gruike

Yet another nvidia glx problem

Salut,
j'ai linux-headers-2.6.10-2-k7, linux-image-2.6.10-2-k7, linux-restricted-modules-2.6.10-2-k7, nvidia-glx, nvidia-kernel-common et nvidia-settings installés. Mon serveur x est xorg.

Voici mon etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   md5sum /etc/X11/xorg.conf >/var/lib/xorg//etc/X11/xorg.conf.md5sum
#   dpkg-reconfigure xserver-xorg

Section "Files"
        FontPath        "unix/:7100"                    # local font server
        # if the local font server has problems, we can fall back on these
        FontPath        "/usr/lib/X11/fonts/misc"
        FontPath        "/usr/lib/X11/fonts/cyrillic"
        FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/lib/X11/fonts/Type1"
        FontPath        "/usr/lib/X11/fonts/CID"
        FontPath        "/usr/lib/X11/fonts/Speedo"
        FontPath        "/usr/lib/X11/fonts/100dpi"
        FontPath        "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
        #Load   "GLcore"
        Load    "bitmap"
        Load    "dbe"
        Load    "ddc"
        #Load   "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "record"
        Load    "speedo"
        Load    "type1"
        Load    "v4l"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "keyboard"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "fr"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
        Identifier      "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
        Driver          "nv"
        BusID           "PCI:1:0:0"
#       0ption          "RenderAccel"           "yes"
#       Option          "NoLogo"                "yes"
#       Option          "AllowGLXWithComposite" "yes"

EndSection

Section "Monitor"
        Identifier      "Q770"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
        Monitor         "Q770"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
EndSection

Section "DRI"
        Mode    0666
EndSection

/etc/modules contient "nvidia"

/etcmodutils/nvidia-kernel-nkc contient
alias char-major-195 nvidia

/etcmodprobe.d/nvidia-kernel-nkc contient
alias char-major-195* nvidia (notez la différence)

Il y a un fichier nvidia-glx dans /etc/init.d

Voilà. Mon problème est que au boot, au moment où X se lance, l'écran reste noir et ne bouge pas, je ne peux plus rien faire. Le clavier ne répond pas, donc impossible de passer dans un tty. Je suis obligé de rebooter à la mano. Par contre x démarre sans problème avec nv (mais lorsque je lance glxgears j'ai droit à Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.).
Pourtant je me souviens d'avoir pu lancer glxgears, je n'étais peut-être pas encore passé en hoary.

HELP !

Merci d'avance

ps: merci d'éviter les réponses de type "es-tu sûr d'avoir besoin de la 3d", etc...

#2 Le 21/01/2005, à 17:07

nikola

Re : Yet another nvidia glx problem

Es-tu sûr d'être sous Ubuntu ? tongue

Oui oui, je ->[]

Edit: Peut-être les méfaits du passage en Hoary, plus instable ?

Dernière modification par nikola (Le 21/01/2005, à 17:11)


Venez prendre un café :)

Hors ligne

#3 Le 24/01/2005, à 17:08

gart

Re : Yet another nvidia glx problem

Salut,
as-tu regardé les messages d'erreurs ("dmesg" ou dans les logs d'xorg) ?


Quidquid latine dictum sit, altum viditur

Hors ligne

#4 Le 27/01/2005, à 18:01

Xvince

Re : Yet another nvidia glx problem

La 3D n'est peut-être pas indispensable...

#5 Le 27/01/2005, à 18:21

coffee

Re : Yet another nvidia glx problem

as-tu vraiment besoin de hoarty? enfin de xorg?


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#6 Le 30/01/2005, à 19:53

Baptiste

Re : Yet another nvidia glx problem

Bonjour Gruike.

Dans l'optique de régler le problème il te faut désinstaller les pilotes installés via synaptic et installer ceux disponibles sur le site du constructeur.

En effet, il semblerait que ceux proposés par ubuntu soient les plus récents, c'est à dire ceux ne fonctionnant pas avec la tnt2. La version du pilote à installer serait donc la 6111 qui fonctionne assez bien. Il est à noter qu'il te faudra les sources et headers de ton noyau ( http://www.nvidia.com/object/linux_display_ia32_1.0-6111.html ).

Merci de ton attention.

Hors ligne

#7 Le 05/02/2005, à 15:24

O.

Re : Yet another nvidia glx problem

Le truc qui me frappe dans ton xorg.conf, c'est que c'est "nv" et non "nvidia" qui est mentionné dans le module d'affichage...


Erreur : pas de clavier détecté. Appuyer sur F1 pour continuer

Hors ligne

Haut de page ↑