Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 04/01/2009, à 23:21

Arznael

accent circonflexe et tréma qui délirent : ^e ¨e

Impossible de mettre un chapeau pointu sur un e, un i , un o ou quoi que ce soit ! Pas plus de tréma.
Je crois que ça date du changement de langue de firefox, mais je n'en suis pas s^ur (désolé !).
J'ai parcouru les forums et essayés quelques propositions. Pour l'instant sans succès, mais je ne suis pas toujours assez connaisseur pour les mettre en oeuvre.
Quelqu'un a-t-il ma solution et de bons talents de pédagogues ?

merci

#2 Le 05/01/2009, à 00:20

abelthorne

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Système -> Préférences -> Clavier, onglet Agencements : lequel est sélectionné par défaut ?

Est-ce que le problème arrive uniquement dans Firefox ou partout (en éditant un texte avec Gedit, par exemple) ?

Hors ligne

#3 Le 05/01/2009, à 18:18

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Salut,
par défaut c'est France autre et je n'ai d'ailleurs que celui-là qui appara^it.

Sinon, le problème se manifeste désormais dans toutes les applications, y compris Gedit.
CE n'était pas le cas il y a qqs temps. Cela ne se constatait que sous certaines (skype, amsn...)
J'ai eu le malheur de tenter de suivre des conseils sur différents forum et je crains d'avoir agravé la situation !
Seras-tu mon sauveur ?
merci.

#4 Le 05/01/2009, à 18:26

abelthorne

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Dans les propriétés du clavier, vérifie les "autres options" dans l'onglet Agencement (sachant que d'origine aucune option n'est cochée ou est "par défaut" selon les cas).

Il me semble qu'il y a une option quelque part qui parle de "prise en charge étendue du clavier" ou un truc dans le genre mais je suis incapable de la retrouver.

EDIT : tu pourrais donner le contenu de ton fichier /etc/X11/xorg.conf ?

Dernière modification par abelthorne (Le 05/01/2009, à 18:27)

Hors ligne

#5 Le 05/01/2009, à 18:32

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

J'ai fait un test sous ma virtualbox. Ca marche sous winlsd 3.5, mais ubuntu ne veux rien savoir.

le contenu de /etc/X11/xorg.conf ?
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr"
    Option        "XkbVariant"    "oss"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
EndSection

Section "InputDevice"
    Identifier    "Synaptics Touchpad"
    Driver        "synaptics"
    Option        "SendCoreEvents"    "true"
    Option        "Device"        "/dev/psaux"
    Option        "Protocol"        "auto-dev"
    Option        "HorizEdgeScroll"    "0"
EndSection

Section "Device"
    Identifier    "Configured Video Device"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Synaptics Touchpad"
EndSection

ça te parle ?

#6 Le 05/01/2009, à 18:39

abelthorne

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Pas de souci au niveau de xorg.conf. À la limite, tu peux tenter de commenter ce qui concerne le clavier dedans (toute la première section InputDevice, en mettant un dièse # devant chaque ligne ; il faut éditer le fichier en root pour pouvoir l'enregistrer : sudo gedit /etc/X11/xorg.conf), mais je ne pense pas que ça change quoi que ce soit. Une fois la modif faite, il faut bien sûr relancer X (déconnexion/reconnexion).

J'ai fait un test sous ma virtualbox. Ca marche sous winlsd 3.5, mais ubuntu ne veux rien savoir.

Tu veux dire qu'un système virtualisé lancé depuis Ubuntu a un clavier fonctionnel mais que le reste du système, non ?

Dernière modification par abelthorne (Le 05/01/2009, à 18:39)

Hors ligne

#7 Le 05/01/2009, à 18:48

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

oui, c'est bien ça. Dans le système virtualisé lancé depuis ubuntu, pas de soucis !

#8 Le 05/01/2009, à 19:19

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Mais bon, je ne vais quand m^eme pas retourné sous windows ?
A l'aiiiiide !
hmm

#9 Le 05/01/2009, à 19:22

abelthorne

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Si tu rajoutes un autre agencement de clavier ("France" en plus de "France autre", par exemple) et que tu le règles par défaut, le problème est toujours là ?

Hors ligne

#10 Le 05/01/2009, à 19:43

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

J'ai tenté, sans succès.

#11 Le 06/01/2009, à 09:27

Arznael

Re : accent circonflexe et tréma qui délirent : ^e ¨e

M^eme la nuit, ne m'a pas apporté de conseil éclairé.

Quelqu'un est-il en mesure de me dépanner ?
Merci

#12 Le 06/01/2009, à 15:21

Carroués

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Salut,

Si tu as l'habitude, comme moi, de faire tes accents avec le chapeau vers la fin de la ligne azerty suivi de la lettre concernée, sache qu'il existe aussi :

â = AltGr + z
ê = AltGr + r
î = AltGr + i
ô = AltGr + p
û = AltGr + u

Fonctionne idem avec les majuscules.

Voir : Système → Préférences → Clavier → Agencements → Choisir ton agencement (France autre) → Imprimer un schéma.

Je l'imprime Dans un fichier manière de conserver ça sous le coude sur le PC.

Sinon, comme le dit abelthorne, il faut voir si tu n'as pas des "Options" activées. Sinon, tente "Réinitialiser".

Cependant, il y a un cas semblable ici.

Hors ligne

#13 Le 18/01/2009, à 00:07

fnx

Re : accent circonflexe et tréma qui délirent : ^e ¨e

carroues a écrit :
â = AltGr + z
ê = AltGr + r
î = AltGr + i
ô = AltGr + p
û = AltGr + u

Pour info (je suis sous Kubuntu)

AltGr+r = ¶ (signe de paragraphe)
AltGr + i = → (carré sous Konqueror, flèche vers la droite sous Konsole)
AltGr + p = þ (p+b melés)
AltGr + u =↓ (carré sous Konqueror, flèche vers le bas sous Konsole )

Je suppose que j'ai encore des problèmes de locales ou de d'encodage sad
Sinon dans les dispositions claviers, il faut peut-être regardé dans les options (éviter les options "nodead keys" ou "sans touches mortes" qui ne prennent pas a priori en compte les caractères à composition comme les  ^ et " sur les disposition azerty)

Hors ligne

#14 Le 21/08/2009, à 00:39

Poukame

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Bonsoir,

Je remonte ce post car j'ai eu le même problème qu'Arznael pendant 1 an et avec 2 PC différents.
Aujourd'hui j'ai trouvé une solution qui marche (chez moi en tout cas) :

1. Dans "système" > "préférence" > "clavier" > "agencement" j'ai ajouté "France autre - latin 9 seulement"
2. Ensuite j'ai viré les autres agencements claviers que j'avais.
3. Après reboot mon trema et mon accent circonflexe marchaient nikel. J'avais juste un problème sur signe "€" qui n'était plus reconnu sur ma touche "E". Pour résoudre ça j'ai été dans les options d'agencements de "France autre - latin 9 seulement" > "Ajout du signe euro sur certaines touches" puis j'ai coché "E".

Après reboot tout marche parfaitement. J'espère que ça pourra dépanner les personnes qui ont le même problème que nous...en espérant que la cause soit la même tongue

Hors ligne

#15 Le 02/11/2009, à 15:26

I'm_an_ent

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Moi en changeant le clavier qui était en "éliminer les touches mortes" en "défaut" tout est ok !


Kubuntu 9.10 Karmic Koala
sur Acer Aspire 5520g
& Acer Aspire One D250

Hors ligne

#16 Le 04/11/2009, à 00:41

djiock

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Yep, le souci c'est qu'à l'install il propose le clavier sans touche morte par défaut, ennuyeux...

Launchpad est un bon endroit pour le signaler ou pas ?


La route est longue mais la voie est libre.
bloug

Hors ligne

#17 Le 28/11/2009, à 18:06

nandayo

Re : accent circonflexe et tréma qui délirent : ^e ¨e

C'est vraiment hallucinant qu'on soit autant à se payer un bug pareil sérieux -_-

Dernière modification par nandayo (Le 28/11/2009, à 18:13)


Plus de feedback dans le brainstorm et plus facilement ? --> http://brainstorm.ubuntu.com/idea/18056/

Hors ligne

#18 Le 26/06/2010, à 14:19

MartinN

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Bonjour,

J'ai le même problème avec les accents circonflexes !
En changeant la disposition de clavier "France Éliminer les touches morts" en "France" ou en ou en "France autre, latin-9 seulement" le circonflexe recommence à marcher (c'est pour cela que je peux écrire ê â î là) mais au démarrage suivant le problème est revenu... par contre à ce moment là en revenant sur "Éliminer les touches mortes" ça remarche !
En résumé quelque soit le changement que je fais dans l'agencement de clavier le circonflexe se met à marcher, mais au démarrage suivant il ne marche plus ! Les joies de l'informatique...
Comme c'est assez pénible de devoir faire la manipulation à chaque démarrage j'aimerais pouvoir régler ce problème, si possible sans avoir à bidouiller des trucs qui ne ferait qu'empirer la situation... Donc si quelqu'un a une idée, elle sera la bienvenue !
Merci !


La liberté, ça n'a pas de prix... manquerait plus qu'elle ait un coût !

Hors ligne

#19 Le 01/08/2010, à 15:50

MartinN

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Je me permet de faire un up, n'ayant toujours pas résolu le problème depuis.
Merci pour votre patience !


La liberté, ça n'a pas de prix... manquerait plus qu'elle ait un coût !

Hors ligne

#20 Le 10/08/2010, à 08:55

Kildrei

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Salut,
j'ai eu le même soucis. Comme tu peux le constater je l'ai résolus dans les préférence du clavier. J'ai simplement rajouté le français sans autres préférence et supprimé les autres claviers enregistrés.
Si cela peut t'aider...


Plus je regarde Unity plus j'aime Fedora....

Hors ligne

#21 Le 17/05/2011, à 03:11

R2D2Que

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Salut
Moi au passage à Ubuntu 11.04 je me retrouve avec ce problème d'accent circonflexe et tréma impossible à faire.
Je trouve peu de réponse en cherchant.

En ligne

#22 Le 22/06/2011, à 13:20

pawup

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Bonjour à tous,

j'ai lu votre discussion et je constate que j'ai également un soucis avec ma touche circonflexe-tréma puisque quand je l'utilise elle me met directement les deux accents circonflexe comme ceci : ^^ ou cela : ¨¨ . 
Je vous explique : j'ai windows 7 pour un hp pavillon. Je ne trouve pas l’emplacement agencement ou même "Éliminer les touches mortes"... Mon pc a eu un gros virus il y a peu et j'ai du réinstaller un windows 7 et depuis je n'ai que des petits problèmes du genre... donc si vous pouviez m'indiquer où trouver ces emplacements je vous serait très reconnaissante!

d'ailleurs j'ai un autre problème inexpliqué!
Lorsque j'écris des fois comme ça par magie le curseur du texte se déplace et la fin de ma phrase se retrouve en plein milieu et bref c'est le bazar dans mes textes... y a t'il un curieux fantôme dans mon clavier ?

bonne journée et merci du coup de main si quelqu'un à une réponse.

Hors ligne

#23 Le 22/06/2011, à 13:25

abelthorne

Re : accent circonflexe et tréma qui délirent : ^e ¨e

La réponse va être simple : ici, c'est un forum Ubuntu (une distribution Linux) et pas Windows...
Tout ce qui a pu être conseillé dans le présent sujet ne concerne pas le système que tu utilises (c'est donc normal que tu ne trouves pas les mêmes paramètres).

Au vu des problèmes, je dirais que soit tu as encore des saloperies qui traînent (surtout si après avoir réinstallé Windows tu as récupéré des logiciels ou des documents qui étaient peut-être vérolés de ta précédente installation), soit ton clavier déconne.

Tu peux toujours essayer de tester Ubuntu en LiveCD (démarrage et utilisation depuis un CD ou une clé USB, sans toucher au système installé), ça te permettra déjà de confirmer ou infirmer un problème de clavier.

Dernière modification par abelthorne (Le 22/06/2011, à 13:26)

Hors ligne

#24 Le 23/06/2011, à 22:41

Jean-M

Re : accent circonflexe et tréma qui délirent : ^e ¨e

Bonsoir,

Il semble y avoir un problème plus général dans la Gestion des préférences du clavier !
Entre autre, pas de mémorisation des changements après une relance du système cf. dans cette conversation ici
@+


Jean-M -- Ingénieur Développement Grands Systèmes IBM et Consultant Qualité / Qualification des logiciels
Équipement : Ubuntu 12.04 (sur fixe I5_750 8Go), Scientific Linux 6.2 (sur Portable Intel Core I7 8Go), Ubuntu Netbook Remix-9.04 (sur e-Café 900)

Hors ligne

#25 Le 23/07/2011, à 16:31

tichit

Re : accent circonflexe et tréma qui délirent : ^e ¨e

bonjour,
j'ai eu également le même problème en ce qui concerne le circonflexe
et le tréma hmm
j'ai trouvé la solution sur cette page:
en effet  en mettant France autre - latin 9 seulement ,
cela fonctionne(pas de souci avec €)
mais pour cela il faut que j'utilse la méthode de carroues:
â = AltGr + z
ê = AltGr + r
î = AltGr + i
ô = AltGr + p
û = AltGr + u
sinon c'est niet

Hors ligne

  • Accueil
  • » Forum
  • » Unity
  • » accent circonflexe et tréma qui délirent : ^e ¨e

Haut de page ↑