Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 04/01/2007, à 21:41

Neothor

[RÉSOLU] Le son flash ne sort pas au bon endroit...

Boujour,

J'ai un petit problème avec nspluginwrapper, quand du contenu flash apparaît dans le navigateur et qu'il y a du son, plus moyen d'entendre ce son su la sortie spdif de ma carte mère (ship son intégré Realtek AC'97) : il sort sur la prise jack des hauts-parleurs avant (et pas sur les autres, le son n'est même plus en 5.1)!!! lol:o:|:(

Une fois quitté la fenêtre contenant du flash, le son reste sur la sortie jack, il faut faire un "killall npviewer.bin" dans le terminal pour que le son sorte à nouveau au bon endroit... Mais ce n'est pas une solution, je veux que le flash sorte sur la sortie spdif.

La commande

lsof /dev/snd/*

me donne ça lorsqu'il y a du flash dans firefox:

COMMAND     PID    USER   FD   TYPE DEVICE SIZE NODE NAME
mixer_app 20352 neothor   17u   CHR  116,7      8081 /dev/snd/controlC0
npviewer. 22548 neothor  mem    CHR  116,5      8059 /dev/snd/pcmC0D0p
npviewer. 22548 neothor   55u   CHR  116,3      8045 /dev/snd/pcmC0D2p
npviewer. 22548 neothor   56u   CHR  116,5      8059 /dev/snd/pcmC0D0p

et ça quand tout va bien:

COMMAND     PID    USER   FD   TYPE DEVICE SIZE NODE NAME
mixer_app 20352 neothor   17u   CHR  116,7      8081 /dev/snd/controlC0

Je ne sait pas du tout interpréter ces données, quelqu'un peut-il m'aider?
Je continue à chercher...

Dernière modification par Neothor (Le 05/01/2007, à 02:49)

Hors ligne

#2 Le 05/01/2007, à 02:47

Neothor

Re : [RÉSOLU] Le son flash ne sort pas au bon endroit...

Bon ben voilà, c'est résolu... smile

En fait je pensait que le mixage directement dans alsa (dmixer) s'activait par défaut sous Edgy, une erreur d'interprétation du tuto suivant:
http://doc.ubuntu-fr.org/installation/son

donc j'ai modifié, dans le doute roll, mon asound.conf comme indiqué, avec juste une mofication pour indiquer ma sortie son IEC958...

Et bien sûr, ça marche, je peux faire une méga salade dans mes enceintes, trois vlc en même temps, deux vidéos sur youtube et cliquer partout dans gnome, le tout en 5.1 cool tongue( c'est mon ampli qui décode)

Bon j'exagère wink

Vive ubuntu et la communauté!!! smile:):)

See you

Hors ligne

#3 Le 22/02/2009, à 17:55

Jeff83

Re : [RÉSOLU] Le son flash ne sort pas au bon endroit...

bonjous
j'ai aussi le même probleme avecflash pas de sortie son en spdif. et la page http://doc.ubuntu-fr.org/installation/son n'existe plus!

pleas help

Hors ligne

#4 Le 20/05/2011, à 13:45

compte supprimé

Re : [RÉSOLU] Le son flash ne sort pas au bon endroit...

Salut,
Même problème pour moi (bon, le sujet date un peu mais le problème est toujours d'actualité).
@ Neothor : est-il possible d'avoir ton asound.conf de l'époque stp ?