Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 19/06/2005, à 11:59

fjeannet

[Résolu] Montage de partion windows

Bonjour,
depuis mon passage sur Hoary 5.04, je n'ai plus accès à ma partion windows qu'en lecture.
L'icône windows ne s'affiche plus sur mon bureau.
Avec la warty, tout marchait très bien. J'ai pourtant rajouter la même ligne à mon fstab :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda2       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hdb5	/windows	vfat	user,auto,exec,showexec,umask=0,codepage=850,iocharset=iso8859-1	0	0

Est-ce que qqun aurait une idée ?

Merci d'avance !

Hors ligne

#2 Le 19/06/2005, à 12:04

Express

Re : [Résolu] Montage de partion windows

Hors ligne

#3 Le 19/06/2005, à 12:28

moijbt

Re : [Résolu] Montage de partion windows

Puis tapes:

sudo chown -R fjeannet /windows/*

Ca devrait marcher normalement !

Hors ligne

#4 Le 19/06/2005, à 14:49

fjeannet

Re : [Résolu] Montage de partion windows

J'ai fait la commande, mais ça n'a pas du tout l'air de marcher...
voilà un morceau du résultat :

chown: changement de propriétaire pour `/windows/documents/docs/guide/jpda/jdi/com/sun/jdi/request/ClassPrepareRequest.html': Opération non permise
chown: changement de propriétaire pour `/windows/documents/docs/guide/jpda/jdi/com/sun/jdi/request/ClassUnloadRequest.html': Opération non permise

j'ai interrompu l'opération... sad

Hors ligne

#5 Le 19/06/2005, à 15:02

LordFarquaad

Re : [Résolu] Montage de partion windows

moijbt a écrit :

Puis tapes:

sudo chown -R fjeannet /windows/*

Ca devrait marcher normalement !

Ça ne marcherait que si fat32 prenait en charge les permissions ;-)

-> fjeannet:
et si tu essayais avec simplement

/dev/hdb5    /windows    vfat    user,umask=000    0    0

à la place de

/dev/hdb5    /windows    vfat    user,auto,exec,showexec,umask=0,codepage=850,iocharset=iso8859-1    0    0

?

Hors ligne

#6 Le 19/06/2005, à 16:26

fjeannet

Re : [Résolu] Montage de partion windows

J'ai essayé, mais ca ne marche tjs pas.... sad

Hors ligne

#7 Le 19/06/2005, à 17:21

Ephack

Re : [Résolu] Montage de partion windows

Est-ce que tu n'as pas changé d'utilisateur en changeant de version? Essaie en enlevant le 'user', voir si ça marche. Ou en le remplaçant par 'users'. Si ça marche, c'est vraiment un problème d'appartenance. C'est bizarre que le chown ne fonctionne pas, même avec 'sudo'...

Hors ligne

#8 Le 19/06/2005, à 17:22

gabrieel

Re : [Résolu] Montage de partion windows

bon j'ai eu le même problème, voici comment je m'en suis sorti:

1. sur le /etc/fstab voici ce que j'ai ajouté pour la ligne windows:

/dev/hda1      /windows     vfat    user,auto,gid=100,umask=002   0    0

2. sur le /etc/group à la ligne user rajouter son nom (login)

sauvegareder et c'est bon normalement (trés important se rajouter dans la liste des groupes, apparement dans ubuntu c'est pas automatique)


@+

Gabrieel

Hors ligne

#9 Le 19/06/2005, à 20:00

fjeannet

Re : [Résolu] Montage de partion windows

Ca y est ! Ca marche !
Merci à tous pour votre participation !

Hors ligne

#10 Le 19/06/2005, à 20:17

fjeannet

Re : [Résolu] Montage de partion windows

Eh ben c'est halucinant, mais ça ne marche plus. J'ai réussi à faire une copie après avoir redemarré tout à l'heure et là, ça ne marche plus sad
Une idée ?

Hors ligne

#11 Le 19/06/2005, à 20:47

Wipe

Re : [Résolu] Montage de partion windows

Rajoute le parramètre "rw" dans la liste

donc :

/dev/hdb5    /windows    vfat    rw,user,auto,exec,showexec,umask=0,codepage=850,iocharset=iso8859-1    0    0


Linux c'est bien !
Mais avec Ubuntu, c'est encore mieux ! :)

Hors ligne

#12 Le 20/06/2005, à 22:13

EurkY

Re : [Résolu] Montage de partion windows

euh meme probleme, bon disons que mon /dev/hda1 c'est ma partition system fat32 de win2k, et mon /dev/hda2 c ma partition DATA fat32 toujours pour windows, mais en partition logique et non principale.

ainsi en ajoutant les deux meme ligne dans /etc/fstab puis en tapant :

sudo mount -a

j'obtiens ce message:

eurky@ubuntu:~$ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
       missing codepage or other error
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

si quelqu'un sais ce que je dois mettre apres /vfat:

/dev/hda2      /win_data     vfat    user,auto,gid=100,umask=002   0    0

merci d'avance

Hors ligne

#13 Le 21/06/2005, à 05:50

gabrieel

Re : [Résolu] Montage de partion windows

d'après le message le dossier est déja monter tu ne peux donc pas le monter une deuxième fois.
il y a aussi une chose que je ne capte pas: quel est ton disque windows? si je reprend ton post au début c'est le hdb5 et si je considère ton dernier post c'est le hda2 (qui selon ton premier post est une partition linux

tu peux vérifier ça?


@+

Gabrieel

Hors ligne

#14 Le 21/06/2005, à 07:41

cep

Re : [Résolu] Montage de partion windows

EurkY a écrit :

(aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

Fais un fdisk -l et publie le ici pour voir tes partitions

Hors ligne

#15 Le 21/06/2005, à 08:37

fjeannet

Re : [Résolu] Montage de partion windows

Bon ben j'ai essayé avec la ligne :

/dev/hdb5    /windows    vfat    rw,user,auto,exec,showexec,umask=0,codepage=850,iocharset=iso8859-1    0    0

et ça marche.
Je vous remercie tous !

Hors ligne

#16 Le 21/06/2005, à 08:46

fjeannet

Re : [Résolu] Montage de partion windows

Eh bien croyez moi si vous voulez, mais ça n'a encore marché qu'une fois. J'ai copié un fichier du bureau vers /windows et ça a marché. Ensuite j'ai essayé de déplacer ce même fichier et la il me dit :
Erreur du déplacement vers "/windows/monDossier", l'écriture dans ce dossier vous est interdite.
Derriere j'essaie de copier un autre fichier dans /windows et ça ne marche plus !
Si quelqun peut trouver une explication logique et surtout une solution viable à mon problème, je suis peneur ^^ !

merci !

Hors ligne

#17 Le 21/06/2005, à 15:17

EurkY

Re : [Résolu] Montage de partion windows

cep a écrit :
EurkY a écrit :

(aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

Fais un fdisk -l et publie le ici pour voir tes partitions

Vous allez rire, mais en bidouillant, je me suis apercu que j'étais total dans l'erreur:

1°) j'ai laissé dans /etc/fstab pour /dev/hda2 vfat => en auto
et au reboot, bah pas de reboot car bouclage de tentative de monter une partition inexistante, j'en ai eu des sueurs froides.

2°) au bout d'une heure, me suis dit bon tant pis y'a rien de bien important sur ma "/" donc je peux encore une fois rebooter avec le CD d'install. Mais pour changer sans formater les disques, uniquement pour utiliser l'utilitaire "partman".

3°) dans partman:
J'ai fait en sorte que les autres partition FAT32 soit pris en charge, au démarrage, sans formatage.

4°) apres le reboot:
je m'apercois qu'il a bien pris en charge la partition, d'ailleurs ci dessous mon fstab:

/dev/hda3       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda4       /home           ext3    defaults        0       2
/dev/hda5       /home/eurky/Desktop/win_data vfat    defaults        0       0
/dev/hda6       none            swap    sw              0       0

Ainsi, bah ct le hda5 lol suis vraiment nul

5°) Maintenant j'aimerais changer les droits sur en RWX sur cette partition monté afin de m'en servir de partition d'échange windows / linux, pourriez vous me dire quoi mettre à la place de "Defaults" et surtout m'expliquer la syntaxe. Car, j'y ai déjà passé 2h hier!
Malgré plusieurs

sudo chmod -R 777 /home/eurky/Desktop/win_data

il ne semble pas le prendre en compte


Enfin, je vous remercie pour la réactivité de ce forum wink

Hors ligne

#18 Le 21/06/2005, à 15:24

Ju.

Re : [Résolu] Montage de partion windows

Bien joué pour le reboot sur l'installeur !

Tu trouveras toutes les infos pour monter ta partition en écriture ici  :http://wiki.ubuntu-fr.org/installation/partitions_windows#pour_les_partitions_en_fat

(Tout est dans fstab , il y a un parametre pour dire qui peut ecrire gid=100)

[Résolu] dans le titre si ca marche...


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#19 Le 21/06/2005, à 15:26

EurkY

Re : [Résolu] Montage de partion windows

ah oui au fait j'ai lancer le fdisk -l et voila la réponse

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/hda1               1         677     5118088+   b  W95 FAT32
/dev/hda2             678        1403     5488560    f  W95 Etendu (LBA)
/dev/hda3            1404        2695     9767520   83  Linux
/dev/hda4            2696        5174    18741240   83  Linux
/dev/hda5   *         678        1354     5118088+   b  W95 FAT32
/dev/hda6            1355        1403      370408+  82  Linux swap / Solaris

Hors ligne

#20 Le 21/06/2005, à 15:41

cep

Re : [Résolu] Montage de partion windows

EurkY a écrit :

ah oui au fait j'ai lancer le fdisk -l et voila la réponse

Ben oui, comme te le disait le message d'erreur, tu lançais une partition étendue, c'est à dire la coquille des partitions logiques.
Mais tu as corrigé tout cela.

Bonne continuation.
Cep

Hors ligne

#21 Le 21/06/2005, à 17:31

gabrieel

Re : [Résolu] Montage de partion windows

hello,

sur ta fstab tu dois avoir ça comme option:

vfat    user,auto,gid=100,umask=002   0    0

en suite tu va dans /etc/group (sudo vi /etc/group)et vérifie bien que dans la ligne user il y a bien ton login. si c'est pas le cas rajoute ton login à la suite.

et ça marche normalement.


@+

Gabrieel

Hors ligne

#22 Le 21/06/2005, à 19:39

EurkY

Re : [Résolu] Montage de partion windows

wahou trop coool
ca marche ^^
merci a Ju gabrieel

et pour

fjeannet a écrit :

Eh bien croyez moi si vous voulez, mais ça n'a encore marché qu'une fois. J'ai copié un fichier du bureau vers /windows et ça a marché. Ensuite j'ai essayé de déplacer ce même fichier et la il me dit :
Erreur du déplacement vers "/windows/monDossier", l'écriture dans ce dossier vous est interdite.
Derriere j'essaie de copier un autre fichier dans /windows et ça ne marche plus !
Si quelqun peut trouver une explication logique et surtout une solution viable à mon problème, je suis peneur ^^ !
merci !

as tu essayer de:
1°) Virer la ligne dans /etc/fstab concernant ta partition voulu
sauvegarder

2°) Rebooter, des fois c mieux, surtout pour killer les processus pere/fils égaré.

3°) en redémarrant tu retapes ta ligne dans /etc/fstab concernant ta partition a monter avec les parametres

vfat    user,auto,gid=100,umask=002   0    0

et tu vas direct dans le fichier /etc/group afin de bien voir ton pseudo a droite de "users".

4°) bah tu lances la commande

sudo mount -a

Je sais pas pour toi, mais moi ca a marché

PS: pour ma part c résolu cool

Hors ligne

Haut de page ↑