Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 27/01/2005, à 05:16

fox-eye

[Résolu] Document Root+apache2

Bonjour à tous, amis de la communauté Ubuntu,

J'ai installé php4/mysql/phpmyadmin à partir d'apt et tout tourne mais un problème subsiste:

J'aimerais reconfigurer apache pour que le documentRoot ne soit pas /var/www mais ...
/home/www/

Seulement dans apache2.conf, pas une trace de la ligne documentRoot...

ou se trouve alors le fichier de configuration qui me permettra de faire le changement?

Hors ligne

#2 Le 27/01/2005, à 09:42

nikola

Re : [Résolu] Document Root+apache2

Il faut faire des vhost je crois. Et à chaque vhost tu peux assigner un document root. Enfin c'est ce que j'ai lyu, il y a peut-être une meilleure méthode.


Venez prendre un café :)

Hors ligne

#3 Le 27/01/2005, à 09:42

Globule

Re : [Résolu] Document Root+apache2

Bonjour !

Dans httpd.conf, non ?

Hors ligne

#4 Le 27/01/2005, à 09:49

nikola

Re : [Résolu] Document Root+apache2

httpd.conf, c'était dans apache 1.x je crois smile


Venez prendre un café :)

Hors ligne

#5 Le 27/01/2005, à 10:10

Globule

Re : [Résolu] Document Root+apache2

Désolé alors ....

Hors ligne

#6 Le 27/01/2005, à 10:43

Ju.

Re : [Résolu] Document Root+apache2

Si le paquet Ubuntu reprend le paquet Sarge jusque dans la conf, la definition propre aux sites est dans le fichier : /etc/apache2/sites-available/default

http://www.destination-linux.org/article30.html est assez bien fait et clair : juste une remarque, il ne faut pas faire de lien symbolique pour 'activer' un site mais un coup de a2ensite nom_du_vhost

Bon courage !


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#7 Le 27/01/2005, à 19:17

melyadon

Re : [Résolu] Document Root+apache2

tu peux aussi décommenter les lignes :

UserDir public_html
UserDir disabled root

c'est ce que j'ai fait pour accéder à mes fichiers via http://localhost/~login/ (~/public_html/). Mais si quelqu'un trouve comment changer la racine du serveur sans_se_prendre_la_tête, je suis aussi preneur... wink

Hors ligne

#8 Le 28/01/2005, à 01:56

fox-eye

Re : [Résolu] Document Root+apache2

J'ai résolu le problème tout seul avant de revenir lire les infos du forum.

Je vous explique ma démarche.

Comme dit très justement par JU, il faut aller dans /etc/apache2/sites-available et modifier le fichier DEFAULT  là ou il est indiqué "documentRoot". On y remplace /var/www par le chemin de son choix.

Ensuite on relance apache2: /etc/init.d/apache2 restart

et l'affaire est faite :-)

Dernière modification par fox-eye (Le 28/01/2005, à 01:57)

Hors ligne

#9 Le 28/01/2005, à 18:33

melyadon

Re : [Résolu] Document Root+apache2

Merci ! big_smile
Ce comportement est spécifique à Apache 2 ou à Ubuntu ?

Hors ligne

#10 Le 28/01/2005, à 18:55

coffee

Re : [Résolu] Document Root+apache2

apache2 sûr à 98%


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#11 Le 28/01/2005, à 22:17

melyadon

Re : [Résolu] Document Root+apache2

bizarre... Apache accepte /home/melyadon/public_html/ comme nouvelle racine des documents, mais pas /home/melyadon/www/ (access denied sur toutes les pages). J'ai cherché un certain temps avant de me rendre compte que le nom "www" posait problème.
pourtant il ne semble rien y avoir de particulier à propos de ce nom dans /etc/apache2/apache2.conf ou  /etc/apache2/sites-available/default.

Hors ligne

#12 Le 29/01/2005, à 05:55

fox-eye

Re : [Résolu] Document Root+apache2

melyadon a écrit :

J'ai cherché un certain temps avant de me rendre compte que le nom "www" posait problème.

C'est assez  curieux. Je suis arrivé sans problème à changer le documentRoot d'apache2 pour qu'il prenne /home/foxeye/www/ en compte...

Tout ça pour te dire que ça ne t'avancera peut-être pas beaucoup, mais que le problème est sans doute ailleurs...

Dernière modification par fox-eye (Le 29/01/2005, à 14:06)

Hors ligne

#13 Le 29/01/2005, à 10:33

yeKcim

Re : [Résolu] Document Root+apache2

fox-eye -> la citation c'est bien mais faut pas en abuser, citer tout le message précédent n'a aucune utilité et alourdi le topic. Merci de ne cité que des bouts de sujets ou des sujets plus haut.


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

#14 Le 07/02/2005, à 10:27

yeKcim

Re : [Résolu] Document Root+apache2

fox-eye, je marque [Résolu] dans le suje, j'espere que je ne me suis pas trompé


Participer à un projet libre est un jeu... Et toi, à quoi tu joues ?
http://yeknan.free.fr

Hors ligne

Haut de page ↑