Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 02/06/2011, à 23:40

hors_net

[Résolu] partition deletée...

Salut à tous,

J'ai eu un problème lors de l'installation de Natty en multiboot avec Vista et ubuntu 10.10 ...

Voici comment était partitionné mon disque au préalable.

/dev/sda1 => Recovery Vista
/dev/sda2 => Vista
/dev/sda3 => extended
/dev/sda5 => Ubuntu 10.10
/dev/sda6 => Swap
/dev/sda7 => Non Allouer (C'est la que je veux mettre 11.04)

Soit dit en passant GParted m'indique des espaces non alloué de quelque Mib avant et après certaines partitions... Est-ce normal?

En chipotant un peu dans l'utilitaire d’installation (étape allocation d'espace disque manuellement) parce que je n'arrive pas à allouer les points de montage que je veux pour Vista et 10.10 (un autre problème en fait... Mais j'ai cru comprendre qu'avec plusieurs systèmes linux ça n'est pas possible avec l'utilitaire d'installation et qu'il faut le faire direct dans fstab..? ) Je fais la bourde...

Alors que la partition de 10.10 est sélectionné, je dérape et clique sur "delete" plutôt que "change"... Trop tard il ne demande pas de confirmation tongue

Résigné à tout réinstaller (10.10) , je me rend compte (grâce au live-usb) que apparemment il a juste supprimer les données d'infos de la partitions, mais que les données sont encore là...

Ma question: Y a-t-il un moyen de récupérer la partition sans la réinstaller ... Je n'ai pas envie de devoir refaire toute ma config et réinstaller tout mes programmes (j'avais bien sur sauvé mes données perso et peux d'ailleurs toujours y accéder par live-usb)

En fait, que je veux le démarrer, il me dit :
files not found
Grub rescue >

Quelq'un sait-il m'aider? :-)

Merci d'avance

Dernière modification par hors_net (Le 07/06/2011, à 10:54)

Hors ligne

#2 Le 03/06/2011, à 08:52

malbo

Re : [Résolu] partition deletée...

Je te suggère de ne plus chercher à démarrer sur le disque dur mais à toujours démarrer sur un liveCD ou une clé liveUSB tant que tu n'as pas réparé ton installation. Dans l'immédiat, tu devrais poster dans cette discussion : http://forum.ubuntu-fr.org/viewtopic.php?id=447877
Attention : tu risques de faire de colossales conneries dans les heures ou jours qui viennent pour tenter de retrouver ton install de Ubuntu 10.10, parce que tu vas utiliser des outils puissants donc dangereux. J'ai lu que tu as sauvegardé tes doc mais ce qu'il faut sauvegardé dès à présent (depuis une session live de Ubuntu) c'est l'ensemble des doc précieux qui sont dans le PC, pas seulement les doc qui sont dans la partition deletée sda5 mais les doc précieux qui sont dans toutes les partitions. A sauvegarder sur disque dur externe.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#3 Le 03/06/2011, à 09:04

Nasman

Re : [Résolu] partition deletée...

Dans ce cas il y a plusieurs choses à faire :
1) Ne plus écrire sur le disque, donc utilisation exclusive du LiveCD (ou Liveusb)
2) Sauvegarder l'existant sur support externe (prévoir éventuellement l'achat d'un disque dur au moins aussi grand que le disque à problème).
3) Se renseigner avant de tenter n'importe quoi (comme des réinstallations...)
4) testdisk permet de reconstituer des tables de partitions - je pense que c'est l'outil à privilégier - mais il faut le maitriser et ne pas se lancer aveuglément dans des réécritures de tables des partitions sans être assuré que ce qui est proposé est correct. Testdisk peut retrouver d'anciennes partitions qui ont été détruites volontairement et dont la restauration (au détriment de ce que tu veux récupérer) est à proscrire.


PC fixe et portable avec Precise 64 bits

Hors ligne

#4 Le 03/06/2011, à 10:46

hors_net

Re : [Résolu] partition deletée...

Alors, c'est effectivement ce que je fait, là je suis en liveUSB  (normal ca ne marche pas en dd tongue )
Je vais effectivement poster dans le topic proposé et sauvegarder les rares docs important sous Windows.

Mais heu, vous avez tous les deux l'air de dire que le problème est plus large que simplement ma partition étendue et peut affecter sda2 ...?

Et donc si je formate simplement la partition étendue (avec sda5,6,7) et réinstalle ubuntu (embêtant mais pas dramatique), est ce que ne réglerais pas le problème et me permettrais à nouveau d'accéder à Windows et Ubuntu nouvellement réinstallé?

Dernière modification par hors_net (Le 03/06/2011, à 10:46)

Hors ligne

#5 Le 03/06/2011, à 10:59

malbo

Re : [Résolu] partition deletée...

hors_net a écrit :

Mais heu, vous avez tous les deux l'air de dire que le problème est plus large que simplement ma partition étendue et peut affecter sda2 ...?

Pour réparer, il va falloir modifier la table de partition. Quand on modifie la table de partition dans l'objectif de modifier ce qui concerne une seule partition, on court le risque de dégrader les infos d'autres partitions. C'est très clairement ce qui se passe avec Testdisk : à un moment donné, il te met le marché dans la main : voilà, j'ai trouvé ces partitions avec leurs indices de début et de fin, leur taille, etc...Et là, c'est toi qui prends la responsabilité (ce n'est pas Testdisk) si tu acceptes qu'il y ait réécriture de la table de partition. Parce que les coordonnées de toutes les partitions seront réécrites dans le MBR et pas seulement celles de la partition en question.

hors_net a écrit :

Et donc si je formate simplement la partition étendue (avec sda5,6,7) et réinstalle ubuntu (embêtant mais pas dramatique), est ce que ne réglerais pas le problème et me permettrais à nouveau d'accéder à Windows et Ubuntu nouvellement réinstallé?

C'est la bonne solution à mon avis. A condition de ne pas toucher du tout à la partition étendue (la laisser en l'état) mais seulement de modifier les partitions logiques qui sont à l'intérieur de la partition étendue (je pense que tu peux tout réaménager à ton goût à l'intérieur de la partition étendue avec Gparted)

Dernière modification par malbo (Le 03/06/2011, à 11:06)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#6 Le 03/06/2011, à 11:16

rmy

Re : [Résolu] partition deletée...

Hello. Bravo Nasman et malbo pour la réactivité wink. J'ai pas grand chose à ajouter.
Sauf qu'il me parait curieux que l'accès aux données puisse être encore possible si la partoche est deleted. Je pense donc à un autre problème plutôt.
On peut vérifier ça tout de même ?

mount
blkid
sudo sfdisk -luS

depuis ton live USB

Et une proposition alternative pour résoudre ton problème : Si la partition est vraiment "cassée" et que tu la retrouve avec testdisk, il sera possible de la monter avec un loopdevice sans modifier la table de partition. Du coup tu pourras rsync ton /home et récupérer la liste de tes softs installés, et repartir sur une install propre ensuite.

Perso, je préfère l'option : Sauvegarde intégrale de l'état initial vers disque externe plus gros, réparation de la table de partition avec testdisk, reboot, constat que tout est bon et que tu as accès à windows et ubuntu comme avant, et tu recommences ta migration.


récupération de données : vractopic uniquemon site pro : www.diskcard.fr
Je récupère et recycle volontiers tous vos disques durs HS (ou pas).
BLACKOUT

Hors ligne

#7 Le 03/06/2011, à 11:56

hors_net

Re : [Résolu] partition deletée...

Salut rmy,

Donc comme tu dis, j'ai fait les trois commandes  et voila les resultats:

mount me fait:

ubuntu@ubuntu:~$ mount
aufs on / type aufs (rw)
none on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
/dev/sdb1 on /cdrom type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/ubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ubuntu)

blkid ne fait rien du tout (n'affiche rien en tout cas)

et sudo sfdisk -luS me dit :

ubuntu@ubuntu:~$ sudo sfdisk -lus
unrecognized format - using sectors

Disk /dev/sda: 60801 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1   *        63  24579449   24579387   c  W95 FAT32 (LBA)
/dev/sda2      24580096 498363299  473783204   7  HPFS/NTFS
/dev/sda3     498368491 976771071  478402581   5  Extended
/dev/sda4             0         -          0   0  Empty
/dev/sda5     498368493 728451071  230082579  83  Linux
/dev/sda6     728453120 746686463   18233344  82  Linux swap / Solaris
/dev/sda7     746688512 976771071  230082560  83  Linux

Disk /dev/sdb: 1017 cylinders, 62 heads, 62 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdb1   *        62   3909347    3909286   c  W95 FAT32 (LBA)
/dev/sdb2             0         -          0   0  Empty
/dev/sdb3             0         -          0   0  Empty
/dev/sdb4             0         -          0   0  Empty

Et pour sauvegarder le disque... Vous dd et dd_rescue, c'est du pareil au même? (dd est peut être un peu plus simple non? il suffit juste de faire ca: dd if=/dev/sda of=/dev/sdc conv=notrunc,noerror)
Et quand tu dis, vers un disque plus grand... Tu veux plus grand que ce qui est "utilisé" chez moi? Par exemple, mon disque dur est de 500Gb, alors un autre externe de 500Gb est bon ou il m'en faut un de 600?

Mon disque externe doit-il être formaté d'une quelconque manière, partitionné? (entre autre enlever les utilitaires installés d'usine (que je n'utilise quand même jamais)) Là il a une partition /dev/sdc1 en ntfs.

Ok malbo, donc si je vois que ça me pose trop de problèmes je vais réinstaller (mais je n'étais même pas sur que ça soit possible avec mon problème d'où là question :-))... mais j'ai quand même envie de tenter la récup

Thanks à tous pour votre help :-)

Dernière modification par hors_net (Le 03/06/2011, à 11:56)

Hors ligne

#8 Le 03/06/2011, à 12:23

malbo

Re : [Résolu] partition deletée...

hors_net a écrit :

blkid ne fait rien du tout (n'affiche rien en tout cas)

Oui, en fait la bonne commande est celle-ci (il faut mettre sudo en tête) :

sudo blkid

MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#9 Le 03/06/2011, à 12:39

hors_net

Re : [Résolu] partition deletée...

Ah ok donc voila la réponse de sudo blkid :

ubuntu@ubuntu:~$ sudo blkid
/dev/loop0: TYPE="squashfs" 
/dev/loop1: UUID="b55665ed-2d7b-4d51-b0a7-ef8fe9d25067" TYPE="ext3" 
/dev/sda1: LABEL="RECOVERY" UUID="3C98-AC5D" TYPE="vfat" 
/dev/sda2: LABEL="VistaOS" UUID="E8686D52686D2114" TYPE="ntfs" 
/dev/sda5: LABEL="Ubuntu Karmic" UUID="daec1fd5-ebeb-4529-b2df-4ed6e84dd299" TYPE="ext4" 
/dev/sda6: UUID="ff802aca-0656-420c-9ccb-1e5ff01b56c4" TYPE="swap" 
/dev/sda7: LABEL="Ubuntu Natty" UUID="886fd985-0230-4267-90a3-308ccb8f442f" TYPE="ext4" 
/dev/sdb1: UUID="32F9-7B58" TYPE="vfat" 

Dernière modification par hors_net (Le 03/06/2011, à 12:41)

Hors ligne

#10 Le 03/06/2011, à 14:53

rmy

Re : [Résolu] partition deletée...

tes partitions ne sont pas "deletées", je suppose qu'il s'agit bien des partitions sdaX ?
Il me semble que la simple réinstallation de grub sur ce disque devrait suffire.


récupération de données : vractopic uniquemon site pro : www.diskcard.fr
Je récupère et recycle volontiers tous vos disques durs HS (ou pas).
BLACKOUT

Hors ligne

#11 Le 03/06/2011, à 15:10

malbo

Re : [Résolu] partition deletée...

hors_net,
Peux-tu démarrer ton PC sur le liveCD 11.04 (pas le liveCD 10.10)  et répondre à cette demande  ( bootinfoscript ) : http://forum.ubuntu-fr.org/viewtopic.php?pid=3534285
Le but étant de vérifier quelques points fondamentaux du démarrage.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#12 Le 03/06/2011, à 15:13

hors_net

Re : [Résolu] partition deletée...

Oui, il s'agit des sdaX, sdb1 étant le liveUSB.

Réinstaller grub,... Je fais ça avec le réparateur de démarrage à partir de ma session live?

Hors ligne

#13 Le 03/06/2011, à 15:18

hors_net

Re : [Résolu] partition deletée...

malbo, voila ce que le script me dit:

                  Boot Info Script 0.60    from 17 May 2011


============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos7)/boot/grub on this drive.
 => Syslinux MBR (3.61-4.03) is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Unknown
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /boot/bcd

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  Windows Vista
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sda3: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info:  

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:  
    Operating System:  Ubuntu 10.10
    Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda6: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info:  

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:  
    Operating System:  
    Boot files:        

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.01 debian-20100714 ...........>...r>..............0...~.k...~...f...M.f.f....f..8~....>2}
    Boot sector info:   Syslinux looks at sector 3471360 of /dev/sdb1 for its 
                       second stage. SYSLINUX is installed in the  directory. 
                       The integrity check of the ADV area failed. According 
                       to the info in the boot sector, sdb1 starts at sector 
                       0. But according to the info from fdisk, sdb1 starts 
                       at sector 62.
    Operating System:  
    Boot files:        /syslinux/syslinux.cfg /ldlinux.sys

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *             63    24,579,449    24,579,387   c W95 FAT32 (LBA)
/dev/sda2          24,580,096   498,363,299   473,783,204   7 NTFS / exFAT / HPFS
/dev/sda3         498,368,491   976,771,071   478,402,581   5 Extended
/dev/sda5         498,368,493   728,451,071   230,082,579  83 Linux
/dev/sda6         728,453,120   746,686,463    18,233,344  82 Linux swap / Solaris
/dev/sda7         746,688,512   976,771,071   230,082,560  83 Linux


Drive: sdb _____________________________________________________________________

Disk /dev/sdb: 2002 MB, 2002780160 bytes
62 heads, 62 sectors/track, 1017 cylinders, total 3911680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sdb1    *             62     3,909,347     3,909,286   c W95 FAT32 (LBA)


"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/loop1       b55665ed-2d7b-4d51-b0a7-ef8fe9d25067   ext3       
/dev/sda1        3C98-AC5D                              vfat       RECOVERY
/dev/sda2        E8686D52686D2114                       ntfs       VistaOS
/dev/sda5        daec1fd5-ebeb-4529-b2df-4ed6e84dd299   ext4       Ubuntu Karmic
/dev/sda6        ff802aca-0656-420c-9ccb-1e5ff01b56c4   swap       
/dev/sda7        886fd985-0230-4267-90a3-308ccb8f442f   ext4       Ubuntu Natty
/dev/sdb1        32F9-7B58                              vfat       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sdb1        /cdrom                   vfat       (rw,relatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)


=========================== sda5/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  load_video
  insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
set locale_dir=($root)/boot/grub/locale
set lang=fr
insmod gettext
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.35-28-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    linux    /boot/vmlinuz-2.6.35-28-generic-pae root=UUID=daec1fd5-ebeb-4529-b2df-4ed6e84dd299 ro   quiet splash
    initrd    /boot/initrd.img-2.6.35-28-generic-pae
}
menuentry 'Ubuntu, with Linux 2.6.35-28-generic-pae (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    echo    'Loading Linux 2.6.35-28-generic-pae ...'
    linux    /boot/vmlinuz-2.6.35-28-generic-pae root=UUID=daec1fd5-ebeb-4529-b2df-4ed6e84dd299 ro single 
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-2.6.35-28-generic-pae
}
menuentry 'Ubuntu, with Linux 2.6.35-27-generic-pae' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    linux    /boot/vmlinuz-2.6.35-27-generic-pae root=UUID=daec1fd5-ebeb-4529-b2df-4ed6e84dd299 ro   quiet splash
    initrd    /boot/initrd.img-2.6.35-27-generic-pae
}
menuentry 'Ubuntu, with Linux 2.6.35-27-generic-pae (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    echo    'Loading Linux 2.6.35-27-generic-pae ...'
    linux    /boot/vmlinuz-2.6.35-27-generic-pae root=UUID=daec1fd5-ebeb-4529-b2df-4ed6e84dd299 ro single 
    echo    'Loading initial ramdisk ...'
    initrd    /boot/initrd.img-2.6.35-27-generic-pae
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    linux16    /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos5)'
    search --no-floppy --fs-uuid --set daec1fd5-ebeb-4529-b2df-4ed6e84dd299
    linux16    /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows Vista (loader) (on /dev/sda1)" {
    insmod part_msdos
    insmod fat
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set 3c98-ac5d
    chainloader +1
}
menuentry "Windows Vista (loader) (on /dev/sda2)" {
    insmod part_msdos
    insmod ntfs
    set root='(hd0,msdos2)'
    search --no-floppy --fs-uuid --set e8686d52686d2114
    chainloader +1
}
menuentry "Ubuntu, with Linux 2.6.38-8-generic-pae (on /dev/sda7)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos7)'
    search --no-floppy --fs-uuid --set 189701a4-d76a-43f9-a42f-9e9f311e86c5
    linux /boot/vmlinuz-2.6.38-8-generic-pae root=UUID=189701a4-d76a-43f9-a42f-9e9f311e86c5 ro quiet splash vt.handoff=7
    initrd /boot/initrd.img-2.6.38-8-generic-pae
}
menuentry "Ubuntu, with Linux 2.6.38-8-generic-pae (recovery mode) (on /dev/sda7)" {
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos7)'
    search --no-floppy --fs-uuid --set 189701a4-d76a-43f9-a42f-9e9f311e86c5
    linux /boot/vmlinuz-2.6.38-8-generic-pae root=UUID=189701a4-d76a-43f9-a42f-9e9f311e86c5 ro single
    initrd /boot/initrd.img-2.6.38-8-generic-pae
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
--------------------------------------------------------------------------------

=============================== sda5/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=daec1fd5-ebeb-4529-b2df-4ed6e84dd299 /               ext4    errors=remount-ro 0       1
# /media/Vista_OS was on /dev/sda2 during installation
#UUID=E8686D52686D2114 /media/Vista_OS ntfs-3g    rw,user,auto,gid=46,uid=1000,nls=utf8,umask=002 0       0
# swap was on /dev/sda6 during installation
UUID=ff802aca-0656-420c-9ccb-1e5ff01b56c4 none            swap    sw              0       0
--------------------------------------------------------------------------------

=================== sda5: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

 249.780634403 = 268.199913984  boot/grub/core.img                             1
 240.617361546 = 258.360924672  boot/grub/grub.cfg                             1
 250.359365940 = 268.821322240  boot/initrd.img-2.6.35-27-generic-pae          2
 246.573965549 = 264.756779520  boot/initrd.img-2.6.35-28-generic-pae          2
 250.043177128 = 268.481817088  boot/vmlinuz-2.6.35-27-generic-pae             1
 251.687025547 = 270.246885888  boot/vmlinuz-2.6.35-28-generic-pae             1
 246.573965549 = 264.756779520  initrd.img                                     2
 250.359365940 = 268.821322240  initrd.img.old                                 2
 251.687025547 = 270.246885888  vmlinuz                                        1
 250.043177128 = 268.481817088  vmlinuz.old                                    1

========================= sdb1/syslinux/syslinux.cfg: ==========================

--------------------------------------------------------------------------------
# D-I config version 2.0
include menu.cfg
default vesamenu.c32
prompt 0
timeout 50
ui gfxboot bootlogo
--------------------------------------------------------------------------------

================= sdb1: Location of files loaded by Syslinux: ==================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             ldlinux.sys                                    1
            ?? = ??             syslinux/gfxboot.c32                           1
            ?? = ??             syslinux/syslinux.cfg                          1
            ?? = ??             syslinux/vesamenu.c32                          1

============== sdb1: Version of COM32(R) files used by Syslinux: ===============

 syslinux/gfxboot.c32               :  COM32R module (v4.xx)
 syslinux/vesamenu.c32              :  COM32R module (v4.xx)

======================== Unknown MBRs/Boot Sectors/etc: ========================

Unknown BootLoader on sda1

00000000  eb 58 90 4d 53 44 4f 53  35 2e 30 00 02 10 20 00  |.X.MSDOS5.0... .|
00000010  02 00 00 00 00 f8 00 00  3f 00 ff 00 3f 00 00 00  |........?...?...|
00000020  3b 0d 77 01 d6 2e 00 00  00 00 00 00 17 c1 00 00  |;.w.............|
00000030  01 00 06 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000040  80 00 29 5d ac 98 3c 4e  4f 20 4e 41 4d 45 20 20  |..)]..<NO NAME  |
00000050  20 20 46 41 54 33 32 20  20 20 33 c9 8e d1 bc f4  |  FAT32   3.....|
00000060  7b 8e c1 8e d9 bd 00 7c  88 4e 02 8a 56 40 b4 41  |{......|.N..V@.A|
00000070  bb aa 55 cd 13 72 10 81  fb 55 aa 75 0a f6 c1 01  |..U..r...U.u....|
00000080  74 05 fe 46 02 eb 2d 8a  56 40 b4 08 cd 13 73 05  |t..F..-.V@....s.|
00000090  b9 ff ff 8a f1 66 0f b6  c6 40 66 0f b6 d1 80 e2  |.....f...@f.....|
000000a0  3f f7 e2 86 cd c0 ed 06  41 66 0f b7 c9 66 f7 e1  |?.......Af...f..|
000000b0  66 89 46 f8 83 7e 16 00  75 38 83 7e 2a 00 77 32  |f.F..~..u8.~*.w2|
000000c0  66 8b 46 1c 66 83 c0 0c  bb 00 80 b9 01 00 e8 2b  |f.F.f..........+|
000000d0  00 e9 2c 03 a0 fa 7d b4  7d 8b f0 ac 84 c0 74 17  |..,...}.}.....t.|
000000e0  3c ff 74 09 b4 0e bb 07  00 cd 10 eb ee a0 fb 7d  |<.t............}|
000000f0  eb e5 a0 f9 7d eb e0 98  cd 16 cd 19 66 60 80 7e  |....}.......f`.~|
00000100  02 00 0f 84 20 00 66 6a  00 66 50 06 53 66 68 10  |.... .fj.fP.Sfh.|
00000110  00 01 00 b4 42 8a 56 40  8b f4 cd 13 66 58 66 58  |....B.V@....fXfX|
00000120  66 58 66 58 eb 33 66 3b  46 f8 72 03 f9 eb 2a 66  |fXfX.3f;F.r...*f|
00000130  33 d2 66 0f b7 4e 18 66  f7 f1 fe c2 8a ca 66 8b  |3.f..N.f......f.|
00000140  d0 66 c1 ea 10 f7 76 1a  86 d6 8a 56 40 8a e8 c0  |.f....v....V@...|
00000150  e4 06 0a cc b8 01 02 cd  13 66 61 0f 82 75 ff 81  |.........fa..u..|
00000160  c3 00 02 66 40 49 75 94  c3 42 4f 4f 54 4d 47 52  |...f@Iu..BOOTMGR|
00000170  20 20 20 20 00 00 00 00  00 00 00 00 00 00 00 00  |    ............|
00000180  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001a0  00 00 00 00 00 00 00 00  00 00 00 00 0d 0a 52 65  |..............Re|
000001b0  6d 6f 76 65 20 64 69 73  6b 73 20 6f 72 20 6f 74  |move disks or ot|
000001c0  68 65 72 20 6d 65 64 69  61 2e ff 0d 0a 44 69 73  |her media....Dis|
000001d0  6b 20 65 72 72 6f 72 ff  0d 0a 50 72 65 73 73 20  |k error...Press |
000001e0  61 6e 79 20 6b 65 79 20  74 6f 20 72 65 73 74 61  |any key to resta|
000001f0  72 74 0d 0a 00 00 00 00  00 ac cb d8 00 00 55 aa  |rt............U.|
00000200


=============================== StdErr Messages: ===============================

unlzma: Decoder error
/home/ubuntu/Downloads/boot_info_script.sh: line 1579: [: 2.73495e+09: integer expression expected

Hum, je vois que le grub est installé dans le MBR ce qui n'est apparemment pas a faire... Mais je ne saurais pas dire s'il a été mis là à l'achat de mon pc par le type qui me l'a préparé (dual-boot ubuntu/vista) il y a maintenant deux ans ou si c'est moi qui l'y ai mis lors d'une réinstallation antérieure d'ubuntu...
Je sais néanmoins que quand j'ai installé Natty avant de le supprimer pour le réinstaller (moment de la bourde :-)) (à cause de problèmes de système de fichiers et de montage de partitions dûs je crois à mes chipotages dans fstab) je n'ai vu a aucun moments lors de l’installation une possibilité quelconque de choix pour l’installation du grub. (Et je pense mais ne pourrais le jurer que je n'ai pas eu ce choix non plus lors de l'installation de Maverick)
Mais je n'ai jamais eu de problème au démarrage de vista...

Dernière modification par hors_net (Le 03/06/2011, à 15:31)

Hors ligne

#14 Le 03/06/2011, à 15:42

malbo

Re : [Résolu] partition deletée...

Bien que tu ne te sois rendu compte de rien, ce sournois d'installateur de Ubuntu a installé le Grub de Ubuntu 11.04 dans le MBR et évidemment, ce Grub contient des instructions pour démarrer sur la partition sda7, celle qui était sensée recevoir Ubuntu 11.04. ce que je te dis se voit là (la version v1.99 est la version du Grub de Ubuntu 11.04) :

============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos7)/boot/grub on this drive.

   
D'autre part, on peut voir dans ton résultat que Ubuntu 10.10 est toujours installé dans sda5. Comme tu peux voir là :

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:  
    Operating System:  Ubuntu 10.10
    Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

et que Ubuntu 11.04 n'est pas installé dans sda7. sda7 est vide :

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:  
    Operating System:  
    Boot files:        

Ma suggestion est que tu installes Ubuntu 11.04 dans la partition sda7. Tu vas utiliser le choix "autre chose" au moment du partitionnement afin de faire le travail en manuel. Tu auras juste à modifier la partition sda7 pour dire que tu la veux en format ext4 (oui, elle y est déjà mais tu confirmes), que son point de montage est / et tu ne modifies pas autre chose. Tu vérifies que Grub va s'installer dans /dev/sda (oui, il est déjà installé là, mais c'est important de confirmer que c'est là que tu le veux et pas ailleurs). Après installation au redémarrage, tout devrait être fonctionnel. C'est à dire que le menu Grub (proposé par Ubuntu 11.04) permettra le choix pour Windows, pour Ubuntu 10.10 (tu devrais avoir plusieurs lignes rien que pour Ubuntu 10.10) et pour Ubuntu 11.04.

Dernière modification par malbo (Le 03/06/2011, à 15:47)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

En ligne

#15 Le 03/06/2011, à 16:21

hors_net

Re : [Résolu] partition deletée...

Ok malbo, je vais donc tenter ça... Mais, pour être sur de ne pas le manquer parce que bon je l'avais pas vu avant alors que je le cherchais essayant de suivre ce tuto: http://doc.ubuntu-fr.org/tutoriel/multiboot_avance; c'est à quelle étape qu'on me demande où installer Grub? Après l'allocation d'espace disque? Après m'avoir proposé d'importer mes docs?

Et deux autres questions à propos de cette installation avant de la faire alors:

1) Si après je ne veux plus de 11.04 et décide de l'enlever et de travailler sur 10.10, ça ne sera pas possible alors puisque c'est le Grub de 11.04 qui gère tout et qu'il est dans le MBR. Il faut alors que après installation, je l'enlève de MBR pour la remettre dans la racine "/"? C'est possible ça? Même question (par anticipation tongue ) pour quand j'installerai 11.10 (à sa sortie) à la place de 11.04 ou même de 11.04+10.10 ... (ou même bêtement si j'ai un problème et dois/veux réinstaller)

2) Comment je fais pour gérer les point de montages des partitions (Vista et 10.10)? Parce que dans "allocation de l'espace disque" il n'y a pas (plus !) moyen de mettre ce qu'on veut (genre /media/VistaOS et /media/Maverick). Est ce du à la présence de deux installation linux? Faut-il alors juste éditer fstab après l'installation?

Thanks

Hors ligne

#16 Le 06/06/2011, à 10:26

hors_net

Re : [Résolu] partition deletée...

Ah ben tien j'ai trouvé où on choisit d'installer Grub... :-)

Des idées pou mes deux autres questions?

Thx

Hors ligne

#17 Le 06/06/2011, à 10:36

rmy

Re : [Résolu] partition deletée...

1/ grub n'est pas dépendant de la "version" qui l'a installé.
2/ pas compris ta question, mais fstab + uuid devrait résoudre ton souci

De manière générale, un post=un problème. Pour cette dernière question, tu es complètement hors-sujet tongue

Dernière modification par rmy (Le 06/06/2011, à 10:36)


récupération de données : vractopic uniquemon site pro : www.diskcard.fr
Je récupère et recycle volontiers tous vos disques durs HS (ou pas).
BLACKOUT

Hors ligne

#18 Le 06/06/2011, à 10:38

sinbad83

Re : [Résolu] partition deletée...

Salut,
pour les points de montage, utilise Disk-Manager (http://doc.ubuntu-fr.org/disk-manager) qui gérera pour toi le fichier fstab.
Pour le grub, il y a aussi un outil commode, Boot-Repair (http://doc.ubuntu-fr.org/boot-repair)

Dernière modification par sinbad83 (Le 06/06/2011, à 10:39)


La connaissance n'est pas une denrée rare, il faut la partager avec les autres.
Linux registered #484707
Site: http://coursinforev.org/dokuwiki/doku.php
Desktop Quad8800 Ubuntu 14.04, Cinnamon 14.04 et XP,  Samsung N150 U13.04 et Seven, HP Pavillon G6 U14.04 et Seven, Serveurs Ubuntu 12.04 et 14.04, Serveur virtualisation Proxmox

Hors ligne

#19 Le 06/06/2011, à 11:09

hors_net

Re : [Résolu] partition deletée...

De manière générale, un post=un problème. Pour cette dernière question, tu es complètement hors-sujet tongue

Oui bien sur :-) Mais je ne voulais pas faire la réinstallation nécessaire à la résolution de mon problème sans avoir de réponses pour ces deux questions... J'ai donc considéré que c'était le même "problème" :-)

Je vais essayer, et si ca marche je met en résolu :-)

Thx

Dernière modification par hors_net (Le 06/06/2011, à 11:21)

Hors ligne

Haut de page ↑